Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
xmltv requires a Date::Manip timezone of +0000 to work
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
FizzyWidget
Veteran
Veteran


Joined: 21 Nov 2008
Posts: 1116
Location: 127.0.0.1

PostPosted: Fri May 27, 2011 10:00 pm    Post subject: xmltv requires a Date::Manip timezone of +0000 to work Reply with quote

Anyone else getting this issue when trying to get listings using tv_grab_uk_rt?

I am using the latest stable versions of all packages

xmltv-0.5.55
DateManip-6.230.0
mythtv-0.23

The full error i get is

Code:
xmltv requires a Date::Manip timezone of +0000 to work properly
Current Date::Manip timezone is afric/lome.


which is totally incorrect, i did try updating to latest unstable release of xmltv, but that seems to have gotten rid of the rt grabber, should i mask all versions above 6.04 of date::manip as they say this is when it changed and caused the issue i am seeing, but then others have said to update xmltv, so kinda stuck
_________________
I know 43 ways to kill with a SKITTLE, so taste my rainbow bitch.
Back to top
View user's profile Send private message
Sonander
n00b
n00b


Joined: 26 Aug 2005
Posts: 18
Location: England

PostPosted: Thu Dec 13, 2012 9:30 pm    Post subject: Reply with quote

Yes, me!
I am surprised its just the two of us though. Here is a crude hack that I came up with to get it working again.
It installs xmltv version 0.5.57 which incorporates a fix to support the new output from Date::Manip

cd /usr/portage/media-tv/xmltv
cp xmltv-0.5.55.ebuild xmltv-0.5.57.ebuild
ebuild /usr/portage/media-tv/xmltv/xmltv-0.5.57.ebuild manifest
ACCEPT_KEYWORDS="~amd64" emerge xmltv

A manual hack in the portage tree like this isn't ideal because it will be wiped with the next emerge --sync, but by then you will have the new xmltv installed. So long as you don't let portage downgrade xmltv again you will be ok.

Perhaps no one else found this thread because you did a lot of research first, worked out what the problem was and asked for the solution to the specific problem rather than just post the error messages you saw at the beginning. So for Google, here we are:

You got this from mythfilldatabase
2012-12-13 20:14:38.830949 E FillData: xmltv returned error code 255
2012-12-13 20:14:38.832595 E Error in 1:1: unexpected end of file

Perhaps you then tried this to narrow it down
tv_grab_uk_rt --config-file /home/mythtv/.mythtv/Freeview.xmltv --output /tmp/some_file

and it croaked with
http://xmltv.radiotimes.com/xmltv/47.dat: bad delta 0:0:0:0:0:0:0 at /usr/lib64/perl5/vendor_perl/5.12.4/XMLTV/TZ.pm line 101.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum