Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
xorg-server - Bild größer als Bildschirm?
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
uhai
l33t
l33t


Joined: 23 Aug 2007
Posts: 872
Location: Eppingen, Germany

PostPosted: Mon Dec 10, 2012 6:42 am    Post subject: xorg-server - Bild größer als Bildschirm? Reply with quote

Hallo zusammen,

nach dem letzten KDE-Update vor zwei Tagen war der Anmeldebildschirm in übler Auflösung (800x600?) ohne Maus und Tastatur. Deshalb habe ich wie in der Doku beschrieben X-Server und nvidia-guide meinen X-Server neu aufgesetzt. Dabei habe ich festgestellt, das in meiner alten xorg.conf noch die Definitionen vom alten Monitor stehen. Also habe ich diese Datei umbenannt, mit nvidia-xconfig eine neue geschrieben und seitdem läuft der X-Server. Lediglich ein Problem habe ich:

Die Benutzeroberfläche ist größer als mein Monitor. Geht man mit der Maus nach rechts oder nach unten, wird der sichtbare Teil der Oberfläche verschoben und ich bekomme einen breiten schwarzen Rand. diesen Effekt bekomme ich nicht weg.... stört aber.

Der Monitor ist ein HP ZR2240w angeschlossen über DVI mit einer maximalen Auflösung von 1920 x 1080 bei 60 HZ.

Grafikkarte ist eine NVIDIA Corporation G98 [GeForce 8400 GS] (rev a1).

Treiber:
Code:


[I] media-video/nvidia-settings                                                                                   
     Available versions:  ~173.14.31 260.19.29 ~275.43 ~290.10 295.20 ~295.40 ~302.11 304.60 ~310.19 {{examples}}
     Installed versions:  304.60(22:48:25 06.12.2012)(-examples)
     Homepage:            http://www.nvidia.com/
     Description:         NVIDIA Linux X11 Settings Utility

[I] x11-drivers/nvidia-drivers
     Available versions:  96.43.20^s 96.43.23^s 173.14.35^s 173.14.36^s 295.71^s 295.75^s 304.60^s 304.64^s ~310.19^s {{+X acpi custom-cflags gtk kernel_FreeBSD kernel_linux multilib pax_kernel (+)tools}}
     Installed versions:  304.64^s(21:52:34 08.12.2012)(X acpi kernel_linux multilib tools -kernel_FreeBSD -pax_kernel)
     Homepage:            http://www.nvidia.com/
     Description:         NVIDIA X11 driver and GLX libraries


X-Server:
Code:

[b]eix -I xorg-server[/b]
[I] x11-base/xorg-server
     Available versions:  1.9.5-r1 1.10.6-r1 1.11.4-r1 1.12.2 ~1.12.3 1.12.4 ~1.13.0 1.13.0-r1 {{dmx doc ipv6 kdrive minimal nptl selinux static-libs tslib +udev xnest xorg xvfb}}
     Installed versions:  1.13.0-r1(13:10:44 09.12.2012)(doc ipv6 nptl udev xorg -dmx -kdrive -minimal -selinux -static-libs -tslib -xnest -xvfb)
     Homepage:            http://xorg.freedesktop.org/
     Description:         X.Org X servers

[b]
Code:
eix -I xorg-drivers[/b]
[I] x11-base/xorg-drivers
     Available versions:  1.9 1.10 1.11 1.12 1.13 {{input_devices_acecad input_devices_aiptek input_devices_elographics input_devices_evdev input_devices_fpit input_devices_hyperpen input_devices_joystick input_devices_keyboard input_devices_mouse input_devices_mutouch input_devices_penmount input_devices_synaptics input_devices_tslib input_devices_vmmouse input_devices_void input_devices_wacom video_cards_apm video_cards_ark video_cards_ast video_cards_chips video_cards_cirrus video_cards_dummy video_cards_epson video_cards_fbdev video_cards_fglrx video_cards_geode video_cards_glint video_cards_i128 video_cards_i740 video_cards_impact video_cards_intel video_cards_mach64 video_cards_mga video_cards_modesetting video_cards_neomagic video_cards_newport video_cards_nouveau video_cards_nv video_cards_nvidia video_cards_omap video_cards_omapfb video_cards_qxl video_cards_r128 video_cards_radeon video_cards_rendition video_cards_s3 video_cards_s3virge video_cards_savage video_cards_siliconmotion video_cards_sis video_cards_sisusb video_cards_sunbw2 video_cards_suncg14 video_cards_suncg3 video_cards_suncg6 video_cards_sunffb video_cards_sunleo video_cards_suntcx video_cards_tdfx video_cards_tga video_cards_trident video_cards_tseng video_cards_v4l video_cards_vesa video_cards_via video_cards_virtualbox video_cards_vmware video_cards_voodoo}}
     Installed versions:  1.13(13:25:42 09.12.2012)(input_devices_evdev input_devices_wacom video_cards_nvidia -input_devices_acecad -input_devices_aiptek -input_devices_elographics -input_devices_fpit -input_devices_hyperpen -input_devices_joystick -input_devices_keyboard -input_devices_mouse -input_devices_mutouch -input_devices_penmount -input_devices_synaptics -input_devices_tslib -input_devices_vmmouse -input_devices_void -video_cards_apm -video_cards_ark -video_cards_ast -video_cards_chips -video_cards_cirrus -video_cards_dummy -video_cards_epson -video_cards_fbdev -video_cards_fglrx -video_cards_geode -video_cards_glint -video_cards_i128 -video_cards_i740 -video_cards_intel -video_cards_mach64 -video_cards_mga -video_cards_modesetting -video_cards_neomagic -video_cards_newport -video_cards_nouveau -video_cards_nv -video_cards_omap -video_cards_omapfb -video_cards_qxl -video_cards_r128 -video_cards_radeon -video_cards_rendition -video_cards_s3 -video_cards_s3virge -video_cards_savage -video_cards_siliconmotion -video_cards_sis -video_cards_sisusb -video_cards_sunbw2 -video_cards_suncg14 -video_cards_suncg3 -video_cards_suncg6 -video_cards_sunffb -video_cards_sunleo -video_cards_suntcx -video_cards_tdfx -video_cards_tga -video_cards_trident -video_cards_tseng -video_cards_v4l -video_cards_vesa -video_cards_via -video_cards_virtualbox -video_cards_vmware -video_cards_voodoo)
     Homepage:            http://www.gentoo.org/
     Description:         Meta package containing deps on all xorg drivers


Kernel:
Code:
uname -a
Linux tux 3.5.7-gentoo #2 SMP Sun Dec 9 13:01:47 CET 2012 x86_64 AMD Phenom(tm) II X4 945 Processor AuthenticAMD GNU/Linux


xorg.conf:
Code:

cat /etc/X11/xorg.conf
# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 304.60  (root@tux)  Do 6. Dez 22:48:21 CET 2012

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 304.64  (buildmeister@swio-display-x86-rhel47-12)  Tue Oct 30 12:04:46 PDT 2012

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "InputDevice"

    # generated from data in "/etc/conf.d/gpm"
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol"
    Option         "Device" "/dev/input/mice"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "HP ZR2240w"
    HorizSync       24.0 - 94.0
    VertRefresh     50.0 - 76.0
    Option         "DPMS"
    Option         "ExactModeTimingsDVI" "TRUE"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce 8400 GS"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "ModeValidation" "NoEdidModes"
    Option         "Stereo" "0"
    Option         "metamodes" "nvidia-auto-select @1920x1080 +0+0; nvidia-auto-select +0+0"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection


Weitere Angaben kann ich gerne liefern...

Was kann ich machen?
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org


Last edited by uhai on Mon Dec 10, 2012 7:28 pm; edited 1 time in total
Back to top
View user's profile Send private message
Christian99
l33t
l33t


Joined: 28 May 2009
Posts: 991

PostPosted: Mon Dec 10, 2012 9:48 am    Post subject: Reply with quote

versuch mal eine leere xorg.conf. Inzwischen kann der so sachen anz gut selber erkennen.
Back to top
View user's profile Send private message
uhai
l33t
l33t


Joined: 23 Aug 2007
Posts: 872
Location: Eppingen, Germany

PostPosted: Mon Dec 10, 2012 5:04 pm    Post subject: Reply with quote

Das muss die Stromsparversion sein - der Bildschirm bleibt dann schwarz. :wink:

Kein Protokoll dazu...?

Bei mir wird Xinerama geladen - ich dachte, dass braucht man nur für zwei Bildschirme gleichzeitig? Dann könnte ich das hier ja entfernen, oder?

uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
Christian99
l33t
l33t


Joined: 28 May 2009
Posts: 991

PostPosted: Mon Dec 10, 2012 5:50 pm    Post subject: Reply with quote

ja, xinerama ist für zwei bildschirme, aber es schadet (eigentlich) auch nix wenns mit kompiliert ist.

und wenn du keine config datei hast, gibts keine log datei? wie startest du denn, über xdm init-skript oder mit startx?
Back to top
View user's profile Send private message
uhai
l33t
l33t


Joined: 23 Aug 2007
Posts: 872
Location: Eppingen, Germany

PostPosted: Mon Dec 10, 2012 7:27 pm    Post subject: Reply with quote

die Log-Datei gibt es schon, nur keine Eintrag für den Schwarzen Bildschirm. Sieht nach einem gelungenen Start aus....

Ich starte über .xinitrc mit
Code:
exec startkde
.

Bisher hat das geklappt...

uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
Christian99
l33t
l33t


Joined: 28 May 2009
Posts: 991

PostPosted: Mon Dec 10, 2012 11:08 pm    Post subject: Reply with quote

hm, bin jetzt kein experte auf dem gebiet, aber poste trotzdem das log, bitte.

aber wie startest du denn X selber?
Back to top
View user's profile Send private message
uhai
l33t
l33t


Joined: 23 Aug 2007
Posts: 872
Location: Eppingen, Germany

PostPosted: Tue Dec 11, 2012 10:03 pm    Post subject: Reply with quote

Code:
rc-update
xdm |      default


startet im default beim Boot...

Hier ist das log:

Code:
X.Org X Server 1.13.0
Release Date: 2012-09-05
[    27.619] X Protocol Version 11, Revision 0
[    27.619] Build Operating System: Linux 3.4.9-gentoo x86_64 Gentoo
[    27.619] Current Operating System: Linux tux 3.5.7-gentoo #3 SMP Mon Dec 10 09:07:17 CET 2012 x86_64
[    27.619] Kernel command line: root=/dev/sda3
[    27.619] Build Date: 09 December 2012  01:09:04PM
[    27.619] 
[    27.619] Current version of pixman: 0.28.0
[    27.619]    Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
[    27.619] Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    27.619] (==) Log file: "/var/log/Xorg.0.log", Time: Tue Dec 11 22:14:07 2012
[    27.716] (==) Using config file: "/etc/X11/xorg.conf"
[    27.716] (==) Using config directory: "/etc/X11/xorg.conf.d"
[    27.716] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[    27.841] (==) ServerLayout "Layout0"
[    27.841] (**) |-->Screen "Screen0" (0)
[    27.841] (**) |   |-->Monitor "Monitor0"
[    27.841] (**) |   |-->Device "Device0"
[    27.841] (**) |-->Input Device "Keyboard0"
[    27.841] (**) |-->Input Device "Mouse0"
[    27.841] (**) Option "Xinerama" "0"
[    27.841] (==) Automatically adding devices
[    27.841] (==) Automatically enabling devices
[    27.841] (==) Automatically adding GPU devices
[    27.899] (WW) The directory "/usr/share/fonts/OTF/" does not exist.
[    27.899]    Entry deleted from font path.
[    27.996] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/75dpi/".
[    27.996]    Entry deleted from font path.
[    27.996]    (Run 'mkfontdir' on "/usr/share/fonts/75dpi/").
[    27.996] (==) FontPath set to:
        /usr/share/fonts/misc/,
        /usr/share/fonts/TTF/,
        /usr/share/fonts/Type1/,
        /usr/share/fonts/100dpi/
[    27.996] (==) ModulePath set to "/usr/lib64/xorg/modules"
[    27.996] (WW) Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[    27.996] (WW) Disabling Keyboard0
[    27.996] (WW) Disabling Mouse0
[    28.015] (II) Loader magic: 0x815c00
[    28.015] (II) Module ABI versions:
[    28.015]    X.Org ANSI C Emulation: 0.4
[    28.015]    X.Org Video Driver: 13.0
[    28.015]    X.Org XInput driver : 18.0
[    28.015]    X.Org Server Extension : 7.0
[    28.016] (--) PCI:*(0:1:0:0) 10de:06e4:0000:0000 rev 161, Mem @ 0xfd000000/16777216, 0xd0000000/268435456, 0xfa000000/33554432, I/O @ 0x0000cc00/128, BIOS @ 0x????????/131072
[    28.016] (II) Open ACPI successful (/var/run/acpid.socket)
[    28.039] Initializing built-in extension Generic Event Extension
[    28.039] Initializing built-in extension SHAPE
[    28.039] Initializing built-in extension MIT-SHM
[    28.039] Initializing built-in extension XInputExtension
[    28.039] Initializing built-in extension XTEST
[    28.039] Initializing built-in extension BIG-REQUESTS
[    28.039] Initializing built-in extension SYNC
[    28.039] Initializing built-in extension XKEYBOARD
[    28.039] Initializing built-in extension XC-MISC
[    28.039] Initializing built-in extension XINERAMA
[    28.039] Initializing built-in extension XFIXES
[    28.039] Initializing built-in extension RENDER
[    28.039] Initializing built-in extension RANDR
[    28.039] Initializing built-in extension COMPOSITE
[    28.039] Initializing built-in extension DAMAGE
[    28.039] Initializing built-in extension MIT-SCREEN-SAVER
[    28.039] Initializing built-in extension DOUBLE-BUFFER
[    28.039] Initializing built-in extension RECORD
[    28.039] Initializing built-in extension DPMS
[    28.039] Initializing built-in extension X-Resource
[    28.039] Initializing built-in extension XVideo
[    28.039] Initializing built-in extension XVideo-MotionCompensation
[    28.039] Initializing built-in extension XFree86-VidModeExtension
[    28.039] Initializing built-in extension XFree86-DGA
[    28.039] Initializing built-in extension XFree86-DRI
[    28.039] Initializing built-in extension DRI2
[    28.039] (II) LoadModule: "glx"
[    28.098] (II) Loading /usr/lib64/xorg/modules/extensions/libglx.so
[    33.058] (II) Module glx: vendor="NVIDIA Corporation"
[    33.058]    compiled for 4.0.2, module version = 1.0.0
[    33.058]    Module class: X.Org Server Extension
[    33.058] (II) NVIDIA GLX Module  304.64  Tue Oct 30 11:18:32 PDT 2012
[    33.058] Loading extension GLX
[    33.058] (II) LoadModule: "nvidia"
[    33.164] (II) Loading /usr/lib64/xorg/modules/drivers/nvidia_drv.so
[    33.452] (II) Module nvidia: vendor="NVIDIA Corporation"
[    33.452]    compiled for 4.0.2, module version = 1.0.0
[    33.452]    Module class: X.Org Video Driver
[    33.492] (II) NVIDIA dlloader X Driver  304.64  Tue Oct 30 10:59:51 PDT 2012
[    33.492] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[    33.506] (++) using VT number 7

[    33.554] (II) Loading sub module "fb"
[    33.554] (II) LoadModule: "fb"
[    33.554] (II) Loading /usr/lib64/xorg/modules/libfb.so
[    33.566] (II) Module fb: vendor="X.Org Foundation"
[    33.566]    compiled for 1.13.0, module version = 1.0.0
[    33.566]    ABI class: X.Org ANSI C Emulation, version 0.4
[    33.566] (II) Loading sub module "wfb"
[    33.566] (II) LoadModule: "wfb"
[    33.566] (II) Loading /usr/lib64/xorg/modules/libwfb.so
[    33.636] (II) Module wfb: vendor="X.Org Foundation"
[    33.636]    compiled for 1.13.0, module version = 1.0.0
[    33.636]    ABI class: X.Org ANSI C Emulation, version 0.4
[    33.636] (II) Loading sub module "ramdac"
[    33.636] (II) LoadModule: "ramdac"
[    33.636] (II) Module "ramdac" already built-in
[    33.647] (**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
[    33.647] (==) NVIDIA(0): RGB weight 888
[    33.647] (==) NVIDIA(0): Default visual is TrueColor
[    33.647] (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
[    33.647] (**) NVIDIA(0): Option "Stereo" "0"
[    33.647] (**) NVIDIA(0): Option "ExactModeTimingsDVI" "TRUE"
[    33.647] (**) NVIDIA(0): Option "ModeValidation" "NoEdidModes"
[    33.647] (**) NVIDIA(0): Stereo disabled by request
[    33.647] (**) NVIDIA(0): Option "MetaModes" "nvidia-auto-select @1920x1080 +0+0; nvidia-auto-select +0+0"
[    33.647] (**) NVIDIA(0): Enabling 2D acceleration
[    34.582] (II) NVIDIA(GPU-0): Display (HP ZR2240w (DFP-0)) does not support NVIDIA 3D Vision
[    34.582] (II) NVIDIA(GPU-0):     stereo.
[    34.596] (II) NVIDIA(0): NVIDIA GPU GeForce 8400 GS (G98) at PCI:1:0:0 (GPU-0)
[    34.596] (--) NVIDIA(0): Memory: 524288 kBytes
[    34.596] (--) NVIDIA(0): VideoBIOS: 62.98.29.00.00
[    34.596] (II) NVIDIA(0): Detected PCI Express Link width: 16X
[    34.596] (--) NVIDIA(0): Interlaced video modes are supported on this GPU
[    34.748] (--) NVIDIA(0): Valid display device(s) on GeForce 8400 GS at PCI:1:0:0
[    34.748] (--) NVIDIA(0):     CRT-0
[    34.748] (--) NVIDIA(0):     CRT-1
[    34.748] (--) NVIDIA(0):     TV-0
[    34.748] (--) NVIDIA(0):     HP ZR2240w (DFP-0) (connected)
[    34.748] (--) NVIDIA(0): CRT-0: 400.0 MHz maximum pixel clock
[    34.748] (--) NVIDIA(0): CRT-1: 400.0 MHz maximum pixel clock
[    34.748] (--) NVIDIA(0): TV-0: 400.0 MHz maximum pixel clock
[    34.748] (--) NVIDIA(0): TV encoder: (null)
[    34.748] (--) NVIDIA(0): HP ZR2240w (DFP-0): 330.0 MHz maximum pixel clock
[    34.748] (--) NVIDIA(0): HP ZR2240w (DFP-0): Internal Dual Link TMDS
[    34.748] (**) NVIDIA(0): Using HorizSync/VertRefresh ranges from the EDID for display
[    34.748] (**) NVIDIA(0):     device HP ZR2240w (DFP-0) (Using EDID frequencies has been
[    34.748] (**) NVIDIA(0):     enabled on all display devices.)
[    34.748] (II) NVIDIA(0): Mode Validation Overrides for HP ZR2240w (DFP-0):
[    34.748] (II) NVIDIA(0):     NoEdidModes
[    34.757] (II) NVIDIA(0): Validated MetaModes:
[    34.757] (II) NVIDIA(0):     "nvidia-auto-select@1920x1080+0+0"
[    34.757] (II) NVIDIA(0):     "nvidia-auto-select+0+0"
[    34.757] (II) NVIDIA(0): Virtual screen size determined to be 1920 x 1080
[    34.783] (--) NVIDIA(0): DPI set to (54, 72); computed from "UseEdidDpi" X config
[    34.783] (--) NVIDIA(0):     option
[    34.783] (--) Depth 24 pixmap format is 32 bpp
[    34.783] (II) NVIDIA: Using 768.00 MB of virtual memory for indirect memory access.
[    34.790] (II) NVIDIA(0): Setting mode "nvidia-auto-select@1920x1080+0+0"
[    34.972] Loading extension NV-GLX
[    35.039] (==) NVIDIA(0): Disabling shared memory pixmaps
[    35.039] (==) NVIDIA(0): Backing store disabled
[    35.039] (==) NVIDIA(0): Silken mouse enabled
[    35.042] (**) NVIDIA(0): DPMS enabled
[    35.042] Loading extension NV-CONTROL
[    35.042] Loading extension XINERAMA
[    35.042] (II) Loading sub module "dri2"
[    35.042] (II) LoadModule: "dri2"
[    35.042] (II) Module "dri2" already built-in
[    35.042] (II) NVIDIA(0): [DRI2] Setup complete
[    35.042] (II) NVIDIA(0): [DRI2]   VDPAU driver: nvidia
[    35.042] (--) RandR disabled
[    35.076] (II) Initializing extension GLX
[    36.642] (II) config/udev: Adding input device Power Button (/dev/input/event1)
[    36.642] (**) Power Button: Applying InputClass "evdev keyboard catchall"
[    36.642] (II) LoadModule: "evdev"
[    36.642] (II) Loading /usr/lib64/xorg/modules/input/evdev_drv.so
[    36.763] (II) Module evdev: vendor="X.Org Foundation"
[    36.763]    compiled for 1.13.0, module version = 2.7.3
[    36.763]    Module class: X.Org XInput Driver
[    36.763]    ABI class: X.Org XInput driver, version 18.0
[    36.763] (II) Using input driver 'evdev' for 'Power Button'
[    36.763] (**) Power Button: always reports core events
[    36.763] (**) evdev: Power Button: Device: "/dev/input/event1"
[    36.764] (--) evdev: Power Button: Vendor 0 Product 0x1
[    36.764] (--) evdev: Power Button: Found keys
[    36.764] (II) evdev: Power Button: Configuring as keyboard
[    36.764] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXPWRBN:00/input/input1/event1"
[    36.764] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD, id 6)
[    36.764] (**) Option "xkb_rules" "evdev"
[    36.764] (**) Option "xkb_model" "evdev"
[    36.764] (**) Option "xkb_layout" "us"
[    36.785] (II) config/udev: Adding input device Power Button (/dev/input/event0)
[    36.785] (**) Power Button: Applying InputClass "evdev keyboard catchall"
[    36.785] (II) Using input driver 'evdev' for 'Power Button'
[    36.785] (**) Power Button: always reports core events
[    36.785] (**) evdev: Power Button: Device: "/dev/input/event0"
[    36.785] (--) evdev: Power Button: Vendor 0 Product 0x1
[    36.785] (--) evdev: Power Button: Found keys
[    36.785] (II) evdev: Power Button: Configuring as keyboard
[    36.785] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/device:00/PNP0C0C:00/input/input0/event0"
[    36.785] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD, id 7)
[    36.785] (**) Option "xkb_rules" "evdev"
[    36.785] (**) Option "xkb_model" "evdev"
[    36.785] (**) Option "xkb_layout" "us"
[    36.785] (II) config/udev: Adding input device 2.4GHz 2way RF Mouse Receiver (/dev/input/event3)
[    36.785] (**) 2.4GHz 2way RF Mouse Receiver: Applying InputClass "evdev pointer catchall"
[    36.785] (**) 2.4GHz 2way RF Mouse Receiver: Applying InputClass "evdev keyboard catchall"
[    36.785] (**) 2.4GHz 2way RF Mouse Receiver: Applying InputClass "Mouse"
[    36.785] (II) Using input driver 'evdev' for '2.4GHz 2way RF Mouse Receiver'
[    36.785] (**) 2.4GHz 2way RF Mouse Receiver: always reports core events
[    36.785] (**) evdev: 2.4GHz 2way RF Mouse Receiver: Device: "/dev/input/event3"
[    36.785] (--) evdev: 2.4GHz 2way RF Mouse Receiver: Vendor 0x1bcf Product 0x535
[    36.785] (--) evdev: 2.4GHz 2way RF Mouse Receiver: Found 12 mouse buttons
[    36.785] (--) evdev: 2.4GHz 2way RF Mouse Receiver: Found scroll wheel(s)
[    36.785] (--) evdev: 2.4GHz 2way RF Mouse Receiver: Found relative axes
[    36.785] (--) evdev: 2.4GHz 2way RF Mouse Receiver: Found x and y relative axes
[    36.785] (--) evdev: 2.4GHz 2way RF Mouse Receiver: Found absolute axes
[    36.785] (II) evdev: 2.4GHz 2way RF Mouse Receiver: Forcing absolute x/y axes to exist.
[    36.785] (--) evdev: 2.4GHz 2way RF Mouse Receiver: Found keys
[    36.785] (II) evdev: 2.4GHz 2way RF Mouse Receiver: Configuring as mouse
[    36.785] (II) evdev: 2.4GHz 2way RF Mouse Receiver: Configuring as keyboard
[    36.785] (II) evdev: 2.4GHz 2way RF Mouse Receiver: Adding scrollwheel support
[    36.785] (**) evdev: 2.4GHz 2way RF Mouse Receiver: YAxisMapping: buttons 4 and 5
[    36.785] (**) evdev: 2.4GHz 2way RF Mouse Receiver: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
[    36.785] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:12.0/usb3/3-2/3-2:1.0/input/input3/event3"
[    36.785] (II) XINPUT: Adding extended input device "2.4GHz 2way RF Mouse Receiver" (type: KEYBOARD, id 8)
[    36.785] (**) Option "xkb_rules" "evdev"
[    36.785] (**) Option "xkb_model" "evdev"
[    36.785] (**) Option "xkb_layout" "us"
[    36.786] (II) evdev: 2.4GHz 2way RF Mouse Receiver: initialized for relative axes.
[    36.786] (WW) evdev: 2.4GHz 2way RF Mouse Receiver: ignoring absolute axes.
[    36.786] (**) 2.4GHz 2way RF Mouse Receiver: (accel) keeping acceleration scheme 1
[    36.786] (**) 2.4GHz 2way RF Mouse Receiver: (accel) acceleration profile 0
[    36.786] (**) 2.4GHz 2way RF Mouse Receiver: (accel) acceleration factor: 2.000
[    36.786] (**) 2.4GHz 2way RF Mouse Receiver: (accel) acceleration threshold: 4
[    36.786] (II) config/udev: Adding input device 2.4GHz 2way RF Mouse Receiver (/dev/input/mouse0)
[    36.786] (II) No input driver specified, ignoring this device.
[    36.786] (II) This device may have been added with another device file.
[    36.786] (II) config/udev: Adding input device HDA ATI SB Line Out Surround (/dev/input/event10)
[    36.786] (II) No input driver specified, ignoring this device.
[    36.786] (II) This device may have been added with another device file.
[    36.786] (II) config/udev: Adding input device HDA ATI SB Line Out Front (/dev/input/event11)
[    36.786] (II) No input driver specified, ignoring this device.
[    36.786] (II) This device may have been added with another device file.
[    36.787] (II) config/udev: Adding input device HDA ATI SB Line (/dev/input/event4)
[    36.787] (II) No input driver specified, ignoring this device.
[    36.787] (II) This device may have been added with another device file.
[    36.787] (II) config/udev: Adding input device HDA ATI SB Front Mic (/dev/input/event5)
[    36.787] (II) No input driver specified, ignoring this device.
[    36.787] (II) This device may have been added with another device file.
[    36.787] (II) config/udev: Adding input device HDA ATI SB Rear Mic (/dev/input/event6)
[    36.787] (II) No input driver specified, ignoring this device.
[    36.787] (II) This device may have been added with another device file.
[    36.787] (II) config/udev: Adding input device HDA ATI SB Front Headphone (/dev/input/event7)
[    36.787] (II) No input driver specified, ignoring this device.
[    36.787] (II) This device may have been added with another device file.
[    36.787] (II) config/udev: Adding input device HDA ATI SB Line Out Side (/dev/input/event8)
[    36.787] (II) No input driver specified, ignoring this device.
[    36.787] (II) This device may have been added with another device file.
[    36.787] (II) config/udev: Adding input device HDA ATI SB Line Out CLFE (/dev/input/event9)
[    36.787] (II) No input driver specified, ignoring this device.
[    36.787] (II) This device may have been added with another device file.
[    36.787] (II) config/udev: Adding input device AT Translated Set 2 keyboard (/dev/input/event2)
[    36.787] (**) AT Translated Set 2 keyboard: Applying InputClass "evdev keyboard catchall"
[    36.787] (II) Using input driver 'evdev' for 'AT Translated Set 2 keyboard'
[    36.788] (**) AT Translated Set 2 keyboard: always reports core events
[    36.788] (**) evdev: AT Translated Set 2 keyboard: Device: "/dev/input/event2"
[    36.788] (--) evdev: AT Translated Set 2 keyboard: Vendor 0x1 Product 0x1
[    36.788] (--) evdev: AT Translated Set 2 keyboard: Found keys
[    36.788] (II) evdev: AT Translated Set 2 keyboard: Configuring as keyboard
[    36.788] (**) Option "config_info" "udev:/sys/devices/platform/i8042/serio0/input/input2/event2"
[    36.788] (II) XINPUT: Adding extended input device "AT Translated Set 2 keyboard" (type: KEYBOARD, id 9)
[    36.788] (**) Option "xkb_rules" "evdev"
[    36.788] (**) Option "xkb_model" "evdev"
[    36.788] (**) Option "xkb_layout" "us"
[   221.592] (II) NVIDIA(GPU-0): Display (HP ZR2240w (DFP-0)) does not support NVIDIA 3D Vision
[   221.592] (II) NVIDIA(GPU-0):     stereo.
[   221.592] (**) NVIDIA(0): Using HorizSync/VertRefresh ranges from the EDID for display
[   221.592] (**) NVIDIA(0):     device HP ZR2240w (DFP-0) (Using EDID frequencies has been
[   221.592] (**) NVIDIA(0):     enabled on all display devices.)
[   221.592] (II) NVIDIA(0): Mode Validation Overrides for HP ZR2240w (DFP-0):
[   221.592] (II) NVIDIA(0):     NoEdidModes


uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
Christian99
l33t
l33t


Joined: 28 May 2009
Posts: 991

PostPosted: Wed Dec 12, 2012 8:04 pm    Post subject: Reply with quote

hm, tja, sieht eigentlich tatsächlich gut aus, bis die letzten zeilen von wegen 3d, aber das sagt mir überhaupt nix...

Sorry, da kann ich dir auch nicht helfen.

du könntest höchstens mal noch probieren das xdm init-skript zu beenden, und dann einfach startx auszuführen. wenns dann klappt, dann liegts nicht am x11, sondern an deinem xdm. Ansonsten weiß ich auch nix mehr
Back to top
View user's profile Send private message
uhai
l33t
l33t


Joined: 23 Aug 2007
Posts: 872
Location: Eppingen, Germany

PostPosted: Fri Dec 14, 2012 7:59 pm    Post subject: Reply with quote

startx funktioniert genauso - gleiches Ergebnis...

gehe ich mit der Maus nach unten oder rechts verschiebt sich die angezeigte Oberfläche nach oben oder links..

uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 2281
Location: Germany

PostPosted: Tue Dec 25, 2012 10:34 am    Post subject: Reply with quote

Quote:
Hallo zusammen,

nach dem letzten KDE-Update vor zwei Tagen war der Anmeldebildschirm in übler Auflösung (800x600?) ohne Maus und Tastatur. Deshalb habe ich wie in der Doku beschrieben X-Server und nvidia-guide meinen X-Server neu aufgesetzt. Dabei habe ich festgestellt, das in meiner alten xorg.conf noch die Definitionen vom alten Monitor stehen. Also habe ich diese Datei umbenannt, mit nvidia-xconfig eine neue geschrieben und seitdem läuft der X-Server. Lediglich ein Problem habe ich:

Die Benutzeroberfläche ist größer als mein Monitor. Geht man mit der Maus nach rechts oder nach unten, wird der sichtbare Teil der Oberfläche verschoben und ich bekomme einen breiten schwarzen Rand. diesen Effekt bekomme ich nicht weg.... stört aber.

Der Monitor ist ein HP ZR2240w angeschlossen über DVI mit einer maximalen Auflösung von 1920 x 1080 bei 60 HZ.
....

Hallo uhai,
hm, ist ja ungewöhnlich..
Vermutlich ist das ganze nach dem wechseln vom 200er zum 300er nvidia-drivers aufgetreten? Wenn ja, beachte das sich zwischen diesen Treiber Versionen sehr viel geändert hat - sprich den neuen Treiber solltest du möglichst komplett neu einrichten.
Ein Schuss ins Blaue: Entferne doch (sofern vorhanden) auch mal die ~/.nvidia-settings-rc
eventuell sind dort noch zum neuen Treiber inkompatible Settings drin enthalten.
Back to top
View user's profile Send private message
wuesti
Apprentice
Apprentice


Joined: 07 Mar 2009
Posts: 163

PostPosted: Tue Dec 25, 2012 1:28 pm    Post subject: Reply with quote

Mir sieht das so aus, als hättest du im KDE einen größeren virtuellen Desktop eingestellt.
Schick mal die Ausgabe von xrandr!
Back to top
View user's profile Send private message
uhai
l33t
l33t


Joined: 23 Aug 2007
Posts: 872
Location: Eppingen, Germany

PostPosted: Thu Dec 27, 2012 11:32 am    Post subject: Reply with quote

@Josef.95:
Das habe ich bereits versucht ohne eine Verbesserung zu erzielen.

@wuesti:

Hier sind die Angaben:
Code:
xrandr
Screen 0: minimum 8 x 8, current 1920 x 1080, maximum 8192 x 8192
DVI-I-0 disconnected (normal left inverted right x axis y axis)
VGA-0 disconnected (normal left inverted right x axis y axis)
TV-0 disconnected (normal left inverted right x axis y axis)
DVI-I-1 connected 1024x768+0+0 (normal left inverted right x axis y axis) 480mm x 270mm
   1024x768       75.0*+   70.1     60.0 
   1600x1200      60.0 
   1400x1050      74.8     60.0 
   1280x1024      75.0     60.0 
   1280x960       60.0 
   1152x864       75.0 
   832x624        74.6 
   800x600        75.0     72.2     60.3     56.2 
   700x525       149.5    120.0 
   640x480        75.0     72.8     59.9 
   512x384       140.1    120.0 
   400x300       144.4 
   320x240       145.6    120.1 


Die Auflösung von 1920 x 1020 taucht hier gar nicht auf. Das scheint nur bei den settings der nvidia-Karte aufzutauchen...

uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
wuesti
Apprentice
Apprentice


Joined: 07 Mar 2009
Posts: 163

PostPosted: Thu Dec 27, 2012 12:17 pm    Post subject: Reply with quote

Code:
xrandr
Screen 0: minimum 8 x 8, current 1920 x 1080, maximum 8192 x 8192

Du hast also einen virtuellen Desktop von 1920x1080...
Code:
DVI-I-1 connected 1024x768+0+0 (normal left inverted right x axis y axis) 480mm x 270mm

... der auf eine Bildschirmauflösung von 1024x768 dargestellt wird.
Da deine x-Logdatei die richtige Auflösung meldet, gehe ich weiter davon dass KDE hier dazwischenfunkt und die X-Einstellungen ändert. Da kann ich dir leider nicht helfen (hab ich nicht), aber prüfe nochmal alle Bildschirmeinstellungen in KDE und auch im KDM.
Eventuell kannst du auch den KDM umgehen:
    STRG+ALT+F1
    als root anmelden
    /etc/init.d/xdm stop
    STRG+ALT+F2
    als user anmelden
    startx
Back to top
View user's profile Send private message
uhai
l33t
l33t


Joined: 23 Aug 2007
Posts: 872
Location: Eppingen, Germany

PostPosted: Fri Dec 28, 2012 1:10 pm    Post subject: Reply with quote

wuesti:

So ist es. in den Monitor-settings von kde steht 1024 x 768 und lässt sich dort nicht ändern.

nvidia-settings schent dadurch überschrieben zu werden....

uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
uhai
l33t
l33t


Joined: 23 Aug 2007
Posts: 872
Location: Eppingen, Germany

PostPosted: Sat Feb 09, 2013 12:36 pm    Post subject: Reply with quote

Scheint so, als ob nach dem KDE-Login die Bildschirmauflösung sich ändert...

Wo könnte denn in KDE die Auflösung definiert sein? Ich kann die Konfigurationsdatei nicht finden....

Hier läuft übrigens KDE-4.10
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum