Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
KDE dont`t start, new instalation on macbook pro
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
sasho23
Apprentice
Apprentice


Joined: 28 Dec 2005
Posts: 186
Location: Pamplona , Spain

PostPosted: Tue Dec 04, 2012 10:22 pm    Post subject: KDE dont`t start, new instalation on macbook pro Reply with quote

Hi all, I have Macbook pro 8,2 with refit, lilo, dualboot mac os and gentoo.
Startx is running well but when I start Kde it tells me
Quote:
Call to lnusertemp failed (temporary directories full?). Check your installation.


I enter in console mode and try
Code:
startkde

and it says
Quote:
$DISPLAY is not set or cannot connect to the X server.


I was "googleing" and tryed
Code:
chmod 1777 /tmp
 chmod 1777/var/tmp

but still the same. df -h / says that I have enoght space. I am using gentoo-sources-3.5.7 I'm not sure what else info you will need. Just ask me and please help...
Back to top
View user's profile Send private message
MacGyver031
Tux's lil' helper
Tux's lil' helper


Joined: 11 Jul 2004
Posts: 140
Location: Ilavalai, Sri Lanka

PostPosted: Thu Dec 06, 2012 9:25 am    Post subject: Reply with quote

Does this site help: http://www.jon.demon.co.uk/kde_xinitrc/ ?
_________________
Sincerely your
Joanand K.

MacBook Pro 5.1: 2.4GHz Core2 Duo, 4096MB, 500GB, NVidia 9400/9600 M GT
Gentoo, Kernel 3.4.9, XOrg, Fluxbox.
Back to top
View user's profile Send private message
LoTeK
Apprentice
Apprentice


Joined: 26 Jul 2012
Posts: 270

PostPosted: Thu Dec 06, 2012 10:30 am    Post subject: Reply with quote

look at:
http://forums.gentoo.org/viewtopic-t-840393.html
I had the same problem once with openbox (same error message) and the solution in this thread worked for me too, add
Code:
exec startkde

to xinitrc
Back to top
View user's profile Send private message
sasho23
Apprentice
Apprentice


Joined: 28 Dec 2005
Posts: 186
Location: Pamplona , Spain

PostPosted: Thu Dec 06, 2012 3:33 pm    Post subject: Reply with quote

Thanks a lot for yours answers.

Ok, I have just tried
Code:
echo "exec startkde" > ~/.xinitrc


and if I type "startx" in console mode it works. Oh, only for root. But when I reboot and try to login with my user, it gives me the same error. So, this is my fstab:
Quote:
/dev/sda3 / ext4 noauto,noatime 1 2
/dev/sda4 none swap sw 0 0
/dev/cdrom /mnt/cdrom auto noauto,user 0 0
/dev/sda5 /home/sasho23/ vfat rw,users 0 0

If I uncheck /dev/sda5 then I can login just fine... Any suggestions...
Back to top
View user's profile Send private message
LoTeK
Apprentice
Apprentice


Joined: 26 Jul 2012
Posts: 270

PostPosted: Thu Dec 06, 2012 4:48 pm    Post subject: Reply with quote

have you run
Code:
echo "exec startkde" > ~/.xinitrc

as root?

where is your .xinitrc and what are the permissions?
(it should be in /home/sasho23/.xinitrc with permissions sasho23 "your group")
Back to top
View user's profile Send private message
sasho23
Apprentice
Apprentice


Joined: 28 Dec 2005
Posts: 186
Location: Pamplona , Spain

PostPosted: Sun Dec 09, 2012 8:21 pm    Post subject: Reply with quote

Hi again
LoTeK wrote:
have you run
Code:
echo "exec startkde" > ~/.xinitrc

as root?


Yes I already did it and it still fail.

Quote:
where is your .xinitrc and what are the permissions?
(it should be in /home/sasho23/.xinitrc with permissions sasho23 "your group")


No, my xinitrc is not in my user dir and I don't know what to do with this.Here is my ls -la sasho23:
Code:
tux sasho23 # ls -la
total 84
drwxr-x--- 9 sasho23 users    4096 Dec  9 21:13 .
drwxr-xr-x 3 root    root     4096 Oct 22 23:51 ..
-rwxr-x--- 1 sasho23 sasho23   158 Dec  9 21:08 .Xauthority
-rwxr-x--- 1 sasho23 users      53 Dec  6 14:48 .bash_history
-rwxr-x--- 1 sasho23 users     127 Oct  6 16:57 .bash_logout
-rwxr-x--- 1 sasho23 users     193 Oct  6 16:57 .bash_profile
-rwxr-x--- 1 sasho23 users     551 Oct  6 16:57 .bashrc
drwxr-x--- 3 sasho23 users    4096 Dec  6 14:32 .config
drwxr-x--- 3 sasho23 users    4096 Dec  6 14:32 .dbus
-rwxr-x--- 1 sasho23 users      26 Dec  6 14:32 .dmrc
drwxr-x--- 2 sasho23 users    4096 Dec  6 14:32 .gstreamer-0.10
drwxr-x--- 4 sasho23 users    4096 Dec  6 14:32 .kde4
drwxr-x--- 3 sasho23 users    4096 Dec  6 14:32 .local
drwx------ 4 sasho23 sasho23  4096 Dec  9 21:13 .mozilla
drwxr-x--- 2 sasho23 users    4096 Jun 21 14:09 .ssh
-rw------- 1 sasho23 sasho23 17622 Dec  9 21:16 .xsession-errors
Back to top
View user's profile Send private message
The Doctor
Veteran
Veteran


Joined: 27 Jul 2010
Posts: 1265

PostPosted: Sun Dec 09, 2012 8:25 pm    Post subject: Reply with quote

Quote:
Quote:
have you run
Code:
echo "exec startkde" > ~/.xinitrc

as root?
Yes I already did it and it still fail.


No, you have to run it as a user. You should not play with X as root because you you will get burned. You have to run that as your user. In this case, ~ refereed to root's home directory, not yours.
_________________
First things first, but not necessarily in that order.
Back to top
View user's profile Send private message
LoTeK
Apprentice
Apprentice


Joined: 26 Jul 2012
Posts: 270

PostPosted: Sun Dec 09, 2012 8:31 pm    Post subject: Reply with quote

Yes thats what I meant... not that you should run it as root, I've just asked if you did run it as root :)
Now your .xinitrc is in /root, but like The Doctor said you have to run it as sasho23 and then it is in /home/sasho23 and you should be fine...


Last edited by LoTeK on Mon Dec 10, 2012 3:09 pm; edited 1 time in total
Back to top
View user's profile Send private message
sasho23
Apprentice
Apprentice


Joined: 28 Dec 2005
Posts: 186
Location: Pamplona , Spain

PostPosted: Sun Dec 09, 2012 8:50 pm    Post subject: Reply with quote

Hey, you are so quick answering to me, thanks a lot.

I will try it tomorow like a user and will report here :D .

I was looking around and find that I should not mount extended partition like primary. So, my /dev/sda5 is extended and it mounts fine at /home/sasho23. But maybe there is the problem and the system is getting confused ??? I'll search the way to change it in primary without loose the data on it and if it's not possible will have to make a backup. And maybe will have to work without a swap partition. See you soon and thanks again.
Back to top
View user's profile Send private message
sasho23
Apprentice
Apprentice


Joined: 28 Dec 2005
Posts: 186
Location: Pamplona , Spain

PostPosted: Mon Dec 10, 2012 2:39 pm    Post subject: Reply with quote

Nop, my dear friends, the problem is not solved yet. I did
Code:
echo "exec startkde" > ~/.xinitrc

like a user and it worked. But my /dev/sda5 was unchecked. So I set it again and then appear the same problem. And when I look for my xinitrc it wasn't there. I retype
Code:
echo "exec startkde" > ~/.xinitrc

and xinitrc is in my user dir again. Will have to change my partition table. Thanks to all for their help. I'll be back soon.
Back to top
View user's profile Send private message
LoTeK
Apprentice
Apprentice


Joined: 26 Jul 2012
Posts: 270

PostPosted: Mon Dec 10, 2012 3:08 pm    Post subject: Reply with quote

ok, I'm not quite sure, but in your fstab you have
Quote:
/dev/sda5 /home/sasho23/ vfat rw,users 0 0
maybe change it to
Quote:
/dev/sda5 /home vfat rw,users 0 0
Back to top
View user's profile Send private message
rabcor
Apprentice
Apprentice


Joined: 05 Apr 2012
Posts: 158

PostPosted: Wed Dec 12, 2012 5:17 pm    Post subject: Reply with quote

You might need to create a /etc/X11/xorg.conf file.

In my case i created it and it looks like this. (you're not "supposed to" need this file, but... i needed it.)


Code:
Section "Device"
  Identifier        "GeForce GTX 670"
  Driver            "nvidia"
EndSection

Section "Module"
  # Load  "dri"
  Load  "glx"
EndSection


Without this file i got a similar error to yours. i found it on the gentoo documentary on how to set up nvidia graphics cards on gentoo if i recall correctly.
_________________
This picture is the only reason i ever installed this OS...
Back to top
View user's profile Send private message
Deathwing00
Moderator
Moderator


Joined: 13 Jun 2003
Posts: 4078
Location: Barcelona, Spain

PostPosted: Fri Dec 21, 2012 12:52 am    Post subject: Reply with quote

Moved from Installing Gentoo to Desktop Environments.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum