Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] gtk applications in KDE 4.9. Rough graphics
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Tumanov
n00b
n00b


Joined: 24 Jul 2012
Posts: 14

PostPosted: Sat Dec 08, 2012 6:13 pm    Post subject: [solved] gtk applications in KDE 4.9. Rough graphics Reply with quote

Hi everyone! I use KDE 4.9.3. After update if the world, some graphics in gtk applications looks rough. Especially when I use firefox the buttons with round corners have extra pixels in corners. Checkboxes also look not nice - also have extra pixels.
Checkbox - example 1
Checkbox - example 2
Rough corners in edit box


Last edited by Tumanov on Tue Dec 11, 2012 7:11 am; edited 1 time in total
Back to top
View user's profile Send private message
giorgos
n00b
n00b


Joined: 06 Jul 2010
Posts: 3

PostPosted: Sat Dec 08, 2012 7:26 pm    Post subject: Re: gtk applications in KDE 4.9. Rough graphics Reply with quote

Tumanov wrote:
Hi everyone! I use KDE 4.9.3. After update if the world, some graphics in gtk applications looks rough. Especially when I use firefox the buttons with round corners have extra pixels in corners. Checkboxes also look not nice - also have extra pixels.
Checkbox - example 1
Checkbox - example 2
Rough corners in edit box

if you have Intel graphics, there was a bug with the video drivers concerning artifacts. If the driver was upgraded, try downgrading to your previous version.
Back to top
View user's profile Send private message
Tumanov
n00b
n00b


Joined: 24 Jul 2012
Posts: 14

PostPosted: Sat Dec 08, 2012 7:46 pm    Post subject: Reply with quote

Hi, Thank you for your reply! I do use Intel video driver, but the one integrated in 3.5.7 kernel, compiled in kernel (not as module). But it seams that everything is fine in KDE native graphics/ Problems only with all gtk themes.
Back to top
View user's profile Send private message
The Doctor
Veteran
Veteran


Joined: 27 Jul 2010
Posts: 1491

PostPosted: Sat Dec 08, 2012 9:14 pm    Post subject: Reply with quote

emerge x11-themes/oxygen-gtk. Also, check you picture links. They appear to be dead.
_________________
First things first, but not necessarily in that order.
Back to top
View user's profile Send private message
giorgos
n00b
n00b


Joined: 06 Jul 2010
Posts: 3

PostPosted: Sat Dec 08, 2012 9:41 pm    Post subject: Reply with quote

Tumanov wrote:
Hi, Thank you for your reply! I do use Intel video driver, but the one integrated in 3.5.7 kernel, compiled in kernel (not as module). But it seams that everything is fine in KDE native graphics/ Problems only with all gtk themes.

I was referring to this bug of xf86-video-intel-2.20.13 (which is marked stable)..
Back to top
View user's profile Send private message
Tumanov
n00b
n00b


Joined: 24 Jul 2012
Posts: 14

PostPosted: Sun Dec 09, 2012 8:46 am    Post subject: The problem was solved Reply with quote

Dear giorgos!
Thank you so much. You were right. I've installed newer xf86-video-intel-2.20.14 ~x86 and now everything looks great!
PS. I better recommend xf86-video-intel-2.20.15 as 2.20.14 has some bugs crashing X
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum