Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Weird auto-remount of root fs "/" like read only
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
Yczo
Tux's lil' helper
Tux's lil' helper


Joined: 09 Jul 2011
Posts: 145

PostPosted: Thu Dec 06, 2012 2:39 pm    Post subject: Weird auto-remount of root fs "/" like read only Reply with quote

Hello folks. After the last upgrade i'm suffering an strange auto-remount of the root fs "/", (remounts like read only) it's temporally fixed using fsck and rebooting. But a time later of reboot, i'm working, and suddenly the same error comes again. it's really disturbing, because force to reboot often.

It is not a physical error. I did not have problems with badblocks. Something creates logical errors, either the auto-remount did

Surely I have something bad on the kernel, and probably i have more things there than i must.


this is my fstab:

/dev/sda6 / ext4 noatime 0 1
/dev/sda3 /home ext3 noatime 0 2
/dev/sda5 none swap sw 0 0
/dev/sr0 /media/cdrom auto noauto,ro,user 0 0

#/dev/fd0 /media/floppy auto noauto 0 0 No hay unidad de disco flsexible


proc /proc proc defaults 0 0
shm /dev/shm tmpfs nodev,nosuid,noexec 0 0

And a summary of my dmesg report

[ 55.917194] EXT4-fs (sda6): re-mounted. Opts: commit=0
[10195.993335] nf_conntrack: automatic helper assignment is deprecated and it will be removed soon. Use the iptables CT target
to attach helpers instead.
[10229.239298] ata1.00: exception Emask 0x0 SAct 0xf SErr 0x0 action 0x0
[10229.239305] ata1.00: irq_stat 0x40000001
[10229.239318] ata1.00: cmd 60/80:00:a8:4d:6e/00:00:2d:00:00/40 tag 0 ncq 65536 in
[10229.239318] res 41/40:80:1e:4e:6e/00:00:2d:00:00/00 Emask 0x409 (media error) <F>
[10229.239330] ata1.00: cmd 60/20:08:b0:98:bb/00:00:07:00:00/40 tag 1 ncq 16384 in
[10229.239330] res 41/04:00:1e:4e:6e/00:00:2d:00:00/00 Emask 0x1 (device error)
[10229.239342] ata1.00: cmd 61/08:10:47:98:c0/00:00:37:00:00/40 tag 2 ncq 4096 out
[10229.239342] res 41/04:00:1e:4e:6e/00:00:2d:00:00/00 Emask 0x1 (device error)
[10229.239354] ata1.00: cmd 61/28:18:17:96:21/00:00:38:00:00/40 tag 3 ncq 20480 out
[10229.239354] res 41/04:00:1e:4e:6e/00:00:2d:00:00/00 Emask 0x1 (device error)
[10229.243923] ata1.00: configured for UDMA/133
[10229.243944] sd 0:0:0:0: [sda] Unhandled sense code
[10229.243948] sd 0:0:0:0: [sda]
[10229.243951] Result: hostbyte=0x00 driverbyte=0x08
[10229.243955] sd 0:0:0:0: [sda]
[10229.243957] Sense Key : 0x3 [current] [descriptor]
[10229.243963] Descriptor sense data with sense descriptors (in hex):
[10229.243966] 72 03 11 04 00 00 00 0c 00 0a 80 00 00 00 00 00
[10229.243980] 2d 6e 4e 1e
[10229.243988] sd 0:0:0:0: [sda]
[10229.243990] ASC=0x11 ASCQ=0x4
[10229.243995] sd 0:0:0:0: [sda] CDB:
[10229.243997] cdb[0]=0x28: 28 00 2d 6e 4d a8 00 00 80 00
[10229.244156] end_request: I/O error, dev sda, sector 935368775
[10229.244161] Buffer I/O error on device sda6, logical block 1336321
[10229.244164] lost page write due to I/O error on sda6
[10229.244177] sd 0:0:0:0: [sda]
[10229.244179] Result: hostbyte=0x00 driverbyte=0x08
[10229.244183] sd 0:0:0:0: [sda]
[10229.244185] Sense Key : 0xb [current] [descriptor]
[10229.244189] Descriptor sense data with sense descriptors (in hex):
[10229.244192] 72 0b 00 00 00 00 00 0c 00 0a 80 00 00 00 00 00
[10229.244206] 2d 6e 4e 1e
[10229.244213] sd 0:0:0:0: [sda]
[10229.244215] ASC=0x0 ASCQ=0x0
[10229.244219] sd 0:0:0:0: [sda] CDB:
[10229.244221] cdb[0]=0x2a: 2a 00 38 21 96 17 00 00 28 00
[10229.244233] end_request: I/O error, dev sda, sector 941725207
[10229.244251] ata1: EH complete
[10229.244268] JBD2: Detected IO errors while flushing file data on sda6-8
[10229.244281] Aborting journal on device sda6-8.
[10229.439264] EXT4-fs error (device sda6): ext4_journal_start_sb:348: Detected aborted journal
[10229.439272] EXT4-fs (sda6): Remounting filesystem read-only
[10232.111686] ata1.00: exception Emask 0x0 SAct 0x1 SErr 0x0 action 0x0
[10232.111692] ata1.00: irq_stat 0x40000008
[10232.111705] ata1.00: cmd 60/08:00:18:4e:6e/00:00:2d:00:00/40 tag 0 ncq 4096 in
[10232.111705] res 41/40:08:1e:4e:6e/00:00:2d:00:00/00 Emask 0x409 (media error) <F>
[10232.264635] ata1.00: configured for UDMA/133
[10232.264653] sd 0:0:0:0: [sda] Unhandled sense code
[10232.264657] sd 0:0:0:0: [sda]
[10232.264660] Result: hostbyte=0x00 driverbyte=0x08
[10232.264664] sd 0:0:0:0: [sda]
[10232.264666] Sense Key : 0x3 [current] [descriptor]
[10235.143085] Descriptor sense data with sense descriptors (in hex):
[10235.143088] 72 03 11 04 00 00 00 0c 00 0a 80 00 00 00 00 00
[10235.143103] 2d 6e 4e 1e
[10235.143110] sd 0:0:0:0: [sda]
[10235.143113] ASC=0x11 ASCQ=0x4
[10235.143117] sd 0:0:0:0: [sda] CDB:
[10235.143119] cdb[0]=0x28: 28 00 2d 6e 4e 18 00 00 08 00
[10235.143132] end_request: I/O error, dev sda, sector 762203678
[10235.143156] ata1: EH complete

Please, anybody could help me to undesrtand and solve this problem?
Is it a driver problem?

uname -r
3.6.5-gentoo , I tried too with the stable kernel 3.5.7 with the same result

Regards.


Last edited by Yczo on Fri Dec 07, 2012 11:09 am; edited 1 time in total
Back to top
View user's profile Send private message
Ant P.
Advocate
Advocate


Joined: 18 Apr 2009
Posts: 2507
Location: UK

PostPosted: Thu Dec 06, 2012 6:44 pm    Post subject: Reply with quote

Quote:
Code:

[10229.239318] res 41/40:80:1e:4e:6e/00:00:2d:00:00/00 Emask 0x409 (media error) <F>
[10229.239330] ata1.00: cmd 60/20:08:b0:98:bb/00:00:07:00:00/40 tag 1 ncq 16384 in
[10229.239330] res 41/04:00:1e:4e:6e/00:00:2d:00:00/00 Emask 0x1 (device error)
[10229.239342] ata1.00: cmd 61/08:10:47:98:c0/00:00:37:00:00/40 tag 2 ncq 4096 out
[10229.239342] res 41/04:00:1e:4e:6e/00:00:2d:00:00/00 Emask 0x1 (device error)
[10229.239354] ata1.00: cmd 61/28:18:17:96:21/00:00:38:00:00/40 tag 3 ncq 20480 out
[10229.239354] res 41/04:00:1e:4e:6e/00:00:2d:00:00/00 Emask 0x1 (device error)

Your hard disk has physical errors. Run a test using smartctl or gnome-disk-utility.
Back to top
View user's profile Send private message
Yczo
Tux's lil' helper
Tux's lil' helper


Joined: 09 Jul 2011
Posts: 145

PostPosted: Thu Dec 06, 2012 8:42 pm    Post subject: Reply with quote

Thank you for answer.

Ok, but when I used badblocks -nv, it did not report about problems. In the same way I could format the hdd.
I think that you're right but i'm not sure at all.
I will try with smartctl

Regards.
Back to top
View user's profile Send private message
Hu
Watchman
Watchman


Joined: 06 Mar 2007
Posts: 9117

PostPosted: Thu Dec 06, 2012 10:54 pm    Post subject: Reply with quote

In some cases, the drive may be fine, but the cable and/or motherboard controller for the drive has failed.
Back to top
View user's profile Send private message
krinn
Advocate
Advocate


Joined: 02 May 2003
Posts: 4399

PostPosted: Thu Dec 06, 2012 11:02 pm    Post subject: Reply with quote

Could happen if your bios was reset from "IDE controller running as AHCI" to "compatible mode". As it could alter lba and geometry report by the drive.
And changing disk may get some buggy bios lost and reset.
Back to top
View user's profile Send private message
Yczo
Tux's lil' helper
Tux's lil' helper


Joined: 09 Jul 2011
Posts: 145

PostPosted: Fri Dec 07, 2012 11:08 am    Post subject: Reply with quote

Thank you all.

Ok, I will review the cable state and later i'll do a hdd reset with a middle level format
Back to top
View user's profile Send private message
wcg
Guru
Guru


Joined: 06 Jan 2009
Posts: 588

PostPosted: Fri Dec 07, 2012 11:48 am    Post subject: Reply with quote

Code:

dumpe2fs -h /dev/sda6 | grep Errors

_________________
TIA
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum