Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Solved] Geary compile fail - Cannot find $EPATCH_SOURCE!
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
FrostyX
n00b
n00b


Joined: 13 Mar 2012
Posts: 56
Location: Czech Republic

PostPosted: Thu Dec 06, 2012 12:06 am    Post subject: [Solved] Geary compile fail - Cannot find $EPATCH_SOURCE! Reply with quote

Hi,
I am trying install mail client geary. I am using ebuild geary-0.2.2 from this site http://gpo.zugaina.org/mail-client/geary/. Also I have one missing dependence in portage so I am using sqlheavy-0.1.1 from same page. All dependences have been installed without problem, but geary not. Where is a problem please?

(I am using x86 architecture)

Code:
>>> Emerging (2 of 2) mail-client/geary-0.2.2 from overlay-frostyx
>>> Failed to emerge mail-client/geary-0.2.2, Log file:
>>>  '/var/tmp/portage/mail-client/geary-0.2.2/temp/build.log'
>>> Jobs: 1 of 2 complete, 1 failed                 Load avg: 3.59, 2.63, 2.40
 * Package:    mail-client/geary-0.2.2
 * Repository: overlay-frostyx
 * USE:        elibc_glibc kernel_linux userland_GNU x86
 * FEATURES:   sandbox
>>> Unpacking source...
>>> Unpacking geary-0.2.2.tar.xz to /var/tmp/portage/mail-client/geary-0.2.2/work
>>> Source unpacked in /var/tmp/portage/mail-client/geary-0.2.2/work
>>> Preparing source in /var/tmp/portage/mail-client/geary-0.2.2/work/geary-0.2.2 ...

 * Cannot find $EPATCH_SOURCE!  Value for $EPATCH_SOURCE is:
 *
 *   /usr/local/portage/mail-client/geary/files/fix-granite-0.1.1.patch
 *   ( fix-granite-0.1.1.patch )

 * ERROR: mail-client/geary-0.2.2 failed (prepare phase):
 *   Cannot find $EPATCH_SOURCE!
 *
 * Call stack:
 *     ebuild.sh, line   93:  Called src_prepare
 *   environment, line 3017:  Called epatch '/usr/local/portage/mail-client/geary/files/fix-granite-0.1.1.patch'
 *   environment, line 1311:  Called die
 * The specific snippet of code:
 *                   die "Cannot find \$EPATCH_SOURCE!";
 *
 * If you need support, post the output of `emerge --info '=mail-client/geary-0.2.2'`,
 * the complete build log and the output of `emerge -pqv '=mail-client/geary-0.2.2'`.
 * This ebuild is from an overlay named 'overlay-frostyx': '/usr/local/portage/'
 * The complete build log is located at '/var/tmp/portage/mail-client/geary-0.2.2/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/mail-client/geary-0.2.2/temp/environment'.
 * Working directory: '/var/tmp/portage/mail-client/geary-0.2.2/work/geary-0.2.2'
 * S: '/var/tmp/portage/mail-client/geary-0.2.2/work/geary-0.2.2'

 * Messages for package mail-client/geary-0.2.2:

 * Cannot find $EPATCH_SOURCE!  Value for $EPATCH_SOURCE is:
 *
 *   /usr/local/portage/mail-client/geary/files/fix-granite-0.1.1.patch
 *   ( fix-granite-0.1.1.patch )
 * ERROR: mail-client/geary-0.2.2 failed (prepare phase):
 *   Cannot find $EPATCH_SOURCE!
 *
 * Call stack:
 *     ebuild.sh, line   93:  Called src_prepare
 *   environment, line 3017:  Called epatch '/usr/local/portage/mail-client/geary/files/fix-granite-0.1.1.patch'
 *   environment, line 1311:  Called die
 * The specific snippet of code:
 *                   die "Cannot find \$EPATCH_SOURCE!";
 *
 * If you need support, post the output of `emerge --info '=mail-client/geary-0.2.2'`,
 * the complete build log and the output of `emerge -pqv '=mail-client/geary-0.2.2'`.
 * This ebuild is from an overlay named 'overlay-frostyx': '/usr/local/portage/'
 * The complete build log is located at '/var/tmp/portage/mail-client/geary-0.2.2/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/mail-client/geary-0.2.2/temp/environment'.
 * Working directory: '/var/tmp/portage/mail-client/geary-0.2.2/work/geary-0.2.2'
 * S: '/var/tmp/portage/mail-client/geary-0.2.2/work/geary-0.2.2'


Last edited by FrostyX on Thu Dec 06, 2012 5:14 pm; edited 2 times in total
Back to top
View user's profile Send private message
fturco
Apprentice
Apprentice


Joined: 08 Dec 2010
Posts: 273
Location: Italy

PostPosted: Thu Dec 06, 2012 10:49 am    Post subject: Reply with quote

Have you downloaded "fix-granite-0.1.1.patch" and put it in the "files" subdirectory?
Back to top
View user's profile Send private message
FrostyX
n00b
n00b


Joined: 13 Mar 2012
Posts: 56
Location: Czech Republic

PostPosted: Thu Dec 06, 2012 1:19 pm    Post subject: Reply with quote

No I haven't. I thought ebuild should do it. Where I can get this patch?
Back to top
View user's profile Send private message
tomk
Administrator
Administrator


Joined: 23 Sep 2003
Posts: 7219
Location: Sat in front of my computer

PostPosted: Thu Dec 06, 2012 1:44 pm    Post subject: Reply with quote

Moved from Desktop Environments to Unsupported Software. Ebuilds from overlays, etc. are not officially supported so questions about them should go to the Unsupported Software form.
_________________
Search | Read | Answer | Report | Strip
Back to top
View user's profile Send private message
comprookie2000
Developer
Developer


Joined: 25 Jul 2004
Posts: 900
Location: Pompano Beach, Florida

PostPosted: Thu Dec 06, 2012 2:56 pm    Post subject: Reply with quote

FrostyX wrote:
No I haven't. I thought ebuild should do it. Where I can get this patch?


Try this;
http://data.gpo.zugaina.org/elementary/mail-client/geary/
_________________
http://dev.gentoo.org/~dabbott/
Back to top
View user's profile Send private message
FrostyX
n00b
n00b


Joined: 13 Mar 2012
Posts: 56
Location: Czech Republic

PostPosted: Thu Dec 06, 2012 3:42 pm    Post subject: Reply with quote

Ok, thx. Now I got this
Code:
>>> Verifying ebuild manifests
>>> Emerging (1 of 1) mail-client/geary-0.2.2 from overlay-frostyx
>>> Failed to emerge mail-client/geary-0.2.2, Log file:
>>>  '/var/tmp/portage/mail-client/geary-0.2.2/temp/build.log'
>>> Jobs: 0 of 1 complete, 1 failed                 Load avg: 3.67, 2.52, 2.05
 * Package:    mail-client/geary-0.2.2
 * Repository: overlay-frostyx
 * USE:        elibc_glibc kernel_linux userland_GNU x86
 * FEATURES:   sandbox
>>> Unpacking source...
>>> Unpacking geary-0.2.2.tar.xz to /var/tmp/portage/mail-client/geary-0.2.2/work
>>> Source unpacked in /var/tmp/portage/mail-client/geary-0.2.2/work
>>> Preparing source in /var/tmp/portage/mail-client/geary-0.2.2/work/geary-0.2.2 ...
 * Applying fix-granite-0.1.1.patch ...
 [ ok ]
>>> Source prepared.
>>> Configuring source in /var/tmp/portage/mail-client/geary-0.2.2/work/geary-0.2.2 ...
>>> Working in BUILD_DIR: "/var/tmp/portage/mail-client/geary-0.2.2/work/geary-0.2.2_build"
cmake --no-warn-unused-cli -C /var/tmp/portage/mail-client/geary-0.2.2/work/geary-0.2.2_build/gentoo_common_config.cmake -G Unix Makefiles -DCMAKE_INSTALL_PREFIX=/usr -DDESKTOP_UPDATE=OFF -DGSETTINGS_COMPILE=OFF -DICON_UPDATE=OFF -DVALA_EXECUTABLE=/usr/bin/valac-0.18 -DCMAKE_BUILD_TYPE=Gentoo -DCMAKE_INSTALL_DO_STRIP=OFF -DCMAKE_USER_MAKE_RULES_OVERRIDE=/var/tmp/portage/mail-client/geary-0.2.2/work/geary-0.2.2_build/gentoo_rules.cmake  /var/tmp/portage/mail-client/geary-0.2.2/work/geary-0.2.2
Not searching for unused variables given on the command line.
loading initial cache file /var/tmp/portage/mail-client/geary-0.2.2/work/geary-0.2.2_build/gentoo_common_config.cmake
-- The C compiler identification is GNU 4.5.4
-- Check for working C compiler: /usr/bin/i686-pc-linux-gnu-gcc
-- Check for working C compiler: /usr/bin/i686-pc-linux-gnu-gcc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Found PkgConfig: /usr/bin/pkg-config (found version "0.27.1")
-- xgettext found
-- Found Vala: /usr/bin/valac-0.18 
-- checking for a minimum Vala version of 0.17.4
--   found Vala, version 0.18.0
-- Unity indicate support: OFF
-- Unity messaging menu support: OFF
-- Unity launcher support: OFF
-- Granite support: OFF
-- checking for modules 'gthread-2.0;glib-2.0>=2.32.0;gio-2.0>=2.28.0;gtk+-3.0>=3.4.0;gee-1.0>=0.6.0;unique-3.0>=3.0.0;libnotify>=0.7.5;libcanberra>=0.28;sqlite3>=3.7.4;gmime-2.6>=2.6.0;gnome-keyring-1>=3.2.2;webkitgtk-3.0>=1.8.0'
--   package 'gnome-keyring-1>=3.2.2' not found
CMake Error at /usr/share/cmake/Modules/FindPkgConfig.cmake:284 (message):
  A required package was not found
Call Stack (most recent call first):
  /usr/share/cmake/Modules/FindPkgConfig.cmake:338 (_pkg_check_modules_internal)
  src/CMakeLists.txt:358 (pkg_check_modules)


-- GSettings schemas will be compiled in-place.
-- GSettings schemas will be installed into /usr/share/glib-2.0/schemas/
Creating POT file
-- <<< Gentoo configuration >>>
Build type      Gentoo
Install path    /usr
Compiler flags:
C               -O2 -march=i686 -pipe
C++             
Linker flags:
Executable       -Wl,-O1 -Wl,--as-needed
Module           -Wl,-O1 -Wl,--as-needed
Shared           -Wl,-O1 -Wl,--as-needed

-- Configuring incomplete, errors occurred!
 * ERROR: mail-client/geary-0.2.2 failed (configure phase):
 *   cmake failed
 *
 * Call stack:
 *     ebuild.sh, line   93:  Called src_configure
 *   environment, line 3014:  Called cmake-utils_src_configure
 *   environment, line  697:  Called _execute_optionaly 'src_configure'
 *   environment, line  211:  Called enable_cmake-utils_src_configure
 *   environment, line 1009:  Called die
 * The specific snippet of code:
 *       "${CMAKE_BINARY}" "${cmakeargs[@]}" "${CMAKE_USE_DIR}" || die "cmake failed";
 *
 * If you need support, post the output of `emerge --info '=mail-client/geary-0.2.2'`,
 * the complete build log and the output of `emerge -pqv '=mail-client/geary-0.2.2'`.
 * This ebuild is from an overlay named 'overlay-frostyx': '/usr/local/portage/'
 * The complete build log is located at '/var/tmp/portage/mail-client/geary-0.2.2/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/mail-client/geary-0.2.2/temp/environment'.
 * Working directory: '/var/tmp/portage/mail-client/geary-0.2.2/work/geary-0.2.2_build'
 * S: '/var/tmp/portage/mail-client/geary-0.2.2/work/geary-0.2.2'

 * Messages for package mail-client/geary-0.2.2:

 * ERROR: mail-client/geary-0.2.2 failed (configure phase):
 *   cmake failed
 *
 * Call stack:
 *     ebuild.sh, line   93:  Called src_configure
 *   environment, line 3014:  Called cmake-utils_src_configure
 *   environment, line  697:  Called _execute_optionaly 'src_configure'
 *   environment, line  211:  Called enable_cmake-utils_src_configure
 *   environment, line 1009:  Called die
 * The specific snippet of code:
 *       "${CMAKE_BINARY}" "${cmakeargs[@]}" "${CMAKE_USE_DIR}" || die "cmake failed";
 *
 * If you need support, post the output of `emerge --info '=mail-client/geary-0.2.2'`,
 * the complete build log and the output of `emerge -pqv '=mail-client/geary-0.2.2'`.
 * This ebuild is from an overlay named 'overlay-frostyx': '/usr/local/portage/'
 * The complete build log is located at '/var/tmp/portage/mail-client/geary-0.2.2/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/mail-client/geary-0.2.2/temp/environment'.
 * Working directory: '/var/tmp/portage/mail-client/geary-0.2.2/work/geary-0.2.2_build'
 * S: '/var/tmp/portage/mail-client/geary-0.2.2/work/geary-0.2.2'


(Sorry for wrong category in forum)
Back to top
View user's profile Send private message
fturco
Apprentice
Apprentice


Joined: 08 Dec 2010
Posts: 273
Location: Italy

PostPosted: Thu Dec 06, 2012 4:19 pm    Post subject: Reply with quote

FrostyX wrote:
Code:
-- checking for modules 'gthread-2.0;glib-2.0>=2.32.0;gio-2.0>=2.28.0;gtk+-3.0>=3.4.0;gee-1.0>=0.6.0;unique-3.0>=3.0.0;libnotify>=0.7.5;libcanberra>=0.28;sqlite3>=3.7.4;gmime-2.6>=2.6.0;gnome-keyring-1>=3.2.2;webkitgtk-3.0>=1.8.0'
--   package 'gnome-keyring-1>=3.2.2' not found


It seems you should install the gnome-keyring package.
Back to top
View user's profile Send private message
FrostyX
n00b
n00b


Joined: 13 Mar 2012
Posts: 56
Location: Czech Republic

PostPosted: Thu Dec 06, 2012 5:13 pm    Post subject: Reply with quote

Okey, successfully installed. Thank you guys
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum