Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Gentoo - Instal Prob - Configuring the Compile Opt urgent
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
venkateshwaran07
n00b
n00b


Joined: 05 Dec 2012
Posts: 9
Location: India

PostPosted: Wed Dec 05, 2012 6:34 am    Post subject: Gentoo - Instal Prob - Configuring the Compile Opt urgent Reply with quote

Hi All,

I am new to Gentoo. I am trying to install gentoo in my PC to have the LAMP setup in it.

My PC details :

Processor: AMD Athlon™ Dual Core Processor 5200B 2.70GHz
RAM: 2.00 GB (1.75 GB Usable)
Hard-disk: 149 GB

I have followed the steps given in the Gentoo.org (http://www.gentoo.org/doc/en/handbook/handbook-amd64.xml?part=1&chap=6). I have done my installation till Installing the Gentoo Installation Files till Installing the Gentoo Installation Files.

I am not able to proceed from here Configuring the Compile Options:

nano -w /mnt/gentoo/etc/portage/make.conf

This is my notes:
# These settings were set by the catalyst build script that automatically
# built this stage.
# Please consult /usr/share/portage/config/make.conf.example for a more
# detailed example.
CFLAGS="-O2 -march=native -pipe -fomit-frame-pointer2"
CXXFLAGS="${CFLAGS}"
# WARNING: Changing your CHOST is not something that should be done lightly.
# Please consult http://www.gentoo.org/doc/en/change-chost.xml before changing.
CHOST="x86_64-pc-linux-gnu"
# These are the USE flags that were used in addition to what is provided by the
# profile used for building.
PHP_TARGETS="php5-3"

USE="mmx sse sse2 -X -qt -gtk -gnome -kde -cups curl bash-completion gd -snmp sockets threads latin1 -berkdb pvb -cli snmp perl apache2 mysql mysqli pdo php pam ssl sqlite3 xml xml2 berkdb innodb jpeg png pcre session unicode python3 zip ads ldap imap libwww maildir sasl ssl xmlwriter clamdtop"
MAKEOPTS="-j3"

Error :

livecd ~ # mirrorselect -i -o >> /mnt/gentoo/etc/portage/make.conf
Traceback (most recent call last):
File "/usr/lib64/python2.7/site.py", line 554, in <module>
main()
File "/usr/lib64/python2.7/site.py", line 536, in main
known_paths = addusersitepackages(known_paths)
File "/usr/lib64/python2.7/site.py", line 268, in addusersitepackages
user_site = getusersitepackages()
File "/usr/lib64/python2.7/site.py", line 243, in getusersitepackages
user_base = getuserbase() # this will also set USER_BASE
File "/usr/lib64/python2.7/site.py", line 233, in getuserbase
USER_BASE = get_config_var('userbase')
File "/usr/lib64/python2.7/sysconfig.py", line 535, in get_config_var
return get_config_vars().get(name)
File "/usr/lib64/python2.7/sysconfig.py", line 434, in get_config_vars
_init_posix(_CONFIG_VARS)
File "/usr/lib64/python2.7/sysconfig.py", line 298, in _init_posix
raise IOError(msg)
IOError: invalid Python installation: unable to open /usr/include/python2.7/pyconfig.h (No such file or directory)

Can some one tell me how to proceed from here ????
Back to top
View user's profile Send private message
tomk
Administrator
Administrator


Joined: 23 Sep 2003
Posts: 7219
Location: Sat in front of my computer

PostPosted: Wed Dec 05, 2012 9:40 am    Post subject: Reply with quote

Moved from Gentoo Chat to Duplicate Threads, please don't post the same question to different forums. If you want one of your topics moved please report it.
_________________
Search | Read | Answer | Report | Strip
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum