Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
ati-drivers won't install [somewhat solved]
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2  
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
oniichan
n00b
n00b


Joined: 15 Jun 2012
Posts: 29

PostPosted: Sun Dec 02, 2012 7:00 pm    Post subject: Reply with quote

hedmo wrote:
oniichan

remove x11-drivers/xf86-video-ati-7.0.0.it is not good to have them both(ati-drivers and xf86-video-ati).if you startx and it is black.hold ctrl+alt and hit f11 then alt+f1.this will take you to a login.is this correct?

regards hedmo

Removed that, and startx gives black at boot. Your key combination does nothing.
Back to top
View user's profile Send private message
hedmo
l33t
l33t


Joined: 29 Aug 2009
Posts: 840
Location: halmstad

PostPosted: Sun Dec 02, 2012 7:22 pm    Post subject: Reply with quote

oniichan

there is one thing i always have to do when i update ati-drivers and it is:

emerge -av xf86-input-mouse xf86-input-keyboard xf86-input-evdev

to get my mouse and keyboard to work in X.i dont know but it may be a shot for you to.

regards hedmo
Back to top
View user's profile Send private message
oniichan
n00b
n00b


Joined: 15 Jun 2012
Posts: 29

PostPosted: Sun Dec 02, 2012 7:38 pm    Post subject: Reply with quote

hedmo wrote:
oniichan

there is one thing i always have to do when i update ati-drivers and it is:

emerge -av xf86-input-mouse xf86-input-keyboard xf86-input-evdev

to get my mouse and keyboard to work in X.i dont know but it may be a shot for you to.

regards hedmo


Done, but no change.
Back to top
View user's profile Send private message
BillWho
Veteran
Veteran


Joined: 03 Mar 2012
Posts: 1600
Location: US

PostPosted: Sun Dec 02, 2012 7:44 pm    Post subject: Reply with quote

This should kiil X after 15 seconds and maybe leave an xorg log and .xsession-errors file - maybe :?

startx 2>&1 | tee start.log&; sleep 15 && killall X
_________________
Good luck :wink:

Since installing gentoo, my life has become one long emerge :)
Back to top
View user's profile Send private message
hedmo
l33t
l33t


Joined: 29 Aug 2009
Posts: 840
Location: halmstad

PostPosted: Sun Dec 02, 2012 7:51 pm    Post subject: Reply with quote

oniichan

the only fast thing i can come up with is to "emerge lxpanel",remove your lines in xinitrc if you have some and set a new line "exec lxpanel".try to startx.
Back to top
View user's profile Send private message
oniichan
n00b
n00b


Joined: 15 Jun 2012
Posts: 29

PostPosted: Sun Dec 02, 2012 8:19 pm    Post subject: Reply with quote

BillWho wrote:
This should kiil X after 15 seconds and maybe leave an xorg log and .xsession-errors file - maybe :?

startx 2>&1 | tee start.log&; sleep 15 && killall X

Syntax error near token ;
Deleted ; but nope, it didn't kill.
Really, I can't script at all in any language, so I can't see the problem.

hedmo wrote:
oniichan

the only fast thing i can come up with is to "emerge lxpanel",remove your lines in xinitrc if you have some and set a new line "exec lxpanel".try to startx.

No, it doesn't start, and neither does dwm or twm.
Back to top
View user's profile Send private message
BillWho
Veteran
Veteran


Joined: 03 Mar 2012
Posts: 1600
Location: US

PostPosted: Sun Dec 02, 2012 9:16 pm    Post subject: Reply with quote

According to http://forums.gentoo.org/viewtopic-p-7113858.html#7113858

You need to make sure that your kernel configurations does not have any DRI or KMS Graphics drivers options selected and the kernel is recompiled

I noticed you have CONFIG_DRM_RADEON_KMS=y and CONFIG_DRM_RADEON=y

Maybe :?
_________________
Good luck :wink:

Since installing gentoo, my life has become one long emerge :)
Back to top
View user's profile Send private message
oniichan
n00b
n00b


Joined: 15 Jun 2012
Posts: 29

PostPosted: Sun Dec 02, 2012 9:28 pm    Post subject: Reply with quote

BillWho wrote:
According to http://forums.gentoo.org/viewtopic-p-7113858.html#7113858

You need to make sure that your kernel configurations does not have any DRI or KMS Graphics drivers options selected and the kernel is recompiled

I noticed you have CONFIG_DRM_RADEON_KMS=y and CONFIG_DRM_RADEON=y

Maybe :?

I changed those to =n and recompiled, placed in /boot as correct name, but no. Still black screen on startx.
Back to top
View user's profile Send private message
oniichan
n00b
n00b


Joined: 15 Jun 2012
Posts: 29

PostPosted: Sun Dec 02, 2012 9:51 pm    Post subject: Reply with quote

Note: fglrxinfo returns
"Error: unable to open display (null)"
Back to top
View user's profile Send private message
BillWho
Veteran
Veteran


Joined: 03 Mar 2012
Posts: 1600
Location: US

PostPosted: Sun Dec 02, 2012 9:52 pm    Post subject: Reply with quote

oniichan,

Have you considered an attempt to get the radeon configuration going :?:

I think I've exhausted all options with the blob :oops: It's been quite some time since I ran the closed source driver and I can't recall with any degree of accuracy how it was setup.

Maybe just getting the graphics going with radeon, then saving the config and tweaking it for the blob would help :?
_________________
Good luck :wink:

Since installing gentoo, my life has become one long emerge :)
Back to top
View user's profile Send private message
hedmo
l33t
l33t


Joined: 29 Aug 2009
Posts: 840
Location: halmstad

PostPosted: Mon Dec 03, 2012 5:05 am    Post subject: Reply with quote

Oniichan

You dont need any thing but agpart in the kernel.pleace add the watermark,this is a way for me to know that you
have a working fglrx driver.post your xorg.conf file,lspci and if you have a xorg log file yet.

regards hedmo
Back to top
View user's profile Send private message
oniichan
n00b
n00b


Joined: 15 Jun 2012
Posts: 29

PostPosted: Mon Dec 03, 2012 3:36 pm    Post subject: Reply with quote

I can't even get my watermark back.
I'm reinstalling.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum