Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
fglrx, xorg.conf defaulting to CRT1 which doesn't exist
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Bennett000
n00b
n00b


Joined: 28 Nov 2012
Posts: 3
Location: Toronto

PostPosted: Thu Nov 29, 2012 7:13 pm    Post subject: fglrx, xorg.conf defaulting to CRT1 which doesn't exist Reply with quote

I can load X windows, I can hear KDE play its start chimes, however I cannot
see anything. The X log is showing no errors, and is informing me that it is
outputting to a connected "CRT1"

The funny thing is when I plug in either a VGA, or HDMI monitor to my laptop,
neither monitor displays anything. The X log does show that X is respecting
the modes I set in xorg.log. So it does not seem like I can use amdcccle to do
my configuration for me.

I have an 6600M/6700M ATI/AMD chip.

My World is updated, and reverse dependencies have been rebuilt.

I've tried a number of different xorg.confs both generated from the aticonfig
utility, and written by hand. I've tried two device options to attempt to force
LVDS, but the X log tells me it's ignoring these options. I forgot the options
at home, they were both Monitor related, that I found on other aticonfig
help sites.

I'm not completely opposed to running with the free software drivers, however
I was hoping to use ATI/AMDs drivers for their performance. Also I don't like
being bested by xorg configs.

One other solution that might work would be to use aticonfig's live options to
switch the monitor. Changing terminals works fine. The problem is I'm have
not yet been able to get aticonfig to recognize the running X session.
$DISPLAY is not set.

Somehow I think I'm missing something really obvious. Any help would be
appreciated, thanks.

I've included fglrx related dmesg output, xorg.conf, and the X log

Here's the dmesg output filtered for fglrx:
Code:
[  114.422608] fglrx: module license 'Proprietary. (C) 2002 - ATI Technologies, Starnberg, GERMANY' taints kernel.
[  114.506881] [fglrx] Maximum main memory to use for locked dma buffers: 5523 MBytes.
[  114.507356] [fglrx]   vendor: 1002 device: 6741 count: 1
[  114.507958] [fglrx] ioport: bar 4, base 0x3000, size: 0x100
[  114.508184] [fglrx] Kernel PAT support is enabled
[  114.508207] [fglrx] module loaded - fglrx 9.1.11 [Oct 18 2012] with 1 minors
[  174.373185] [fglrx] Firegl kernel thread PID: 2560
[  174.373369] [fglrx] Firegl kernel thread PID: 2561
[  174.373529] [fglrx] Firegl kernel thread PID: 2562
[  174.373740] [fglrx] IRQ 51 Enabled
[  174.428517] [fglrx] Gart USWC size:1280 M.
[  174.428520] [fglrx] Gart cacheable size:508 M.
[  174.428526] [fglrx] Reserved FB block: Shared offset:0, size:1000000
[  174.428529] [fglrx] Reserved FB block: Unshared offset:f8fc000, size:404000
[  174.428532] [fglrx] Reserved FB block: Unshared offset:3fff4000, size:c000
[  174.523930] [fglrx] ATIF platform detected with notification ID: 0x81


Here's the basic aticonfig initial xorg.conf:

Code:
Section "ServerLayout"
   Identifier     "aticonfig Layout"
   Screen      0  "aticonfig-Screen[0]-0" 0 0
EndSection

Section "Module"
EndSection

Section "Monitor"
   Identifier   "aticonfig-Monitor[0]-0"
   Option       "VendorName" "ATI Proprietary Driver"
   Option       "ModelName" "Generic Autodetecting Monitor"
   Option       "DPMS" "true"
EndSection

Section "Device"
   Identifier  "aticonfig-Device[0]-0"
   Driver      "fglrx"
   Option       "DesktopSetup" "clone"
   BusID       "PCI:2:0:0"
EndSection

Section "Screen"
   Identifier "aticonfig-Screen[0]-0"
   Device     "aticonfig-Device[0]-0"
   Monitor    "aticonfig-Monitor[0]-0"
   DefaultDepth     24
   SubSection "Display"
      Viewport   0 0
      Depth     24
   EndSubSection
EndSection


And finally, here's the X log:

Code:
[  6598.554]
X.Org X Server 1.13.0
Release Date: 2012-09-05
[  6598.554] X Protocol Version 11, Revision 0
[  6598.554] Build Operating System: Linux 3.0.17-tuxonice-r1 x86_64 Gentoo
[  6598.554] Current Operating System: Linux virtuosity 3.0.35-tuxonice #1 SMP PREEMPT Tue Nov 27 17:12:26 EST 2012 x86_64
[  6598.554] Kernel command line: root=/dev/sda5
[  6598.554] Build Date: 25 November 2012  08:40:11PM
[  6598.554] 
[  6598.554] Current version of pixman: 0.28.0
[  6598.554]    Before reporting problems, check http://wiki.x.org
   to make sure that you have the latest version.
[  6598.554] Markers: (--) probed, (**) from config file, (==) default setting,
   (++) from command line, (!!) notice, (II) informational,
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[  6598.554] (==) Log file: "/var/log/Xorg.0.log", Time: Tue Nov 27 20:42:49 2012
[  6598.554] (==) Using config file: "/etc/X11/xorg.conf"
[  6598.554] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[  6598.555] (==) ServerLayout "aticonfig Layout"
[  6598.555] (**) |-->Screen "aticonfig-Screen[0]-0" (0)
[  6598.555] (**) |   |-->Monitor "aticonfig-Monitor[0]-0"
[  6598.555] (**) |   |-->Device "aticonfig-Device[0]-0"
[  6598.555] (==) Automatically adding devices
[  6598.555] (==) Automatically enabling devices
[  6598.555] (==) Automatically adding GPU devices
[  6598.555] (WW) The directory "/usr/share/fonts/TTF/" does not exist.
[  6598.555]    Entry deleted from font path.
[  6598.555] (WW) The directory "/usr/share/fonts/OTF/" does not exist.
[  6598.555]    Entry deleted from font path.
[  6598.555] (WW) The directory "/usr/share/fonts/Type1/" does not exist.
[  6598.555]    Entry deleted from font path.
[  6598.555] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/100dpi/".
[  6598.555]    Entry deleted from font path.
[  6598.555]    (Run 'mkfontdir' on "/usr/share/fonts/100dpi/").
[  6598.555] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/75dpi/".
[  6598.555]    Entry deleted from font path.
[  6598.555]    (Run 'mkfontdir' on "/usr/share/fonts/75dpi/").
[  6598.555] (==) FontPath set to:
   /usr/share/fonts/misc/
[  6598.555] (==) ModulePath set to "/usr/lib64/xorg/modules"
[  6598.555] (II) The server relies on udev to provide the list of input devices.
   If no devices become available, reconfigure udev or disable AutoAddDevices.
[  6598.555] (II) Loader magic: 0x815c00
[  6598.555] (II) Module ABI versions:
[  6598.555]    X.Org ANSI C Emulation: 0.4
[  6598.555]    X.Org Video Driver: 13.0
[  6598.555]    X.Org XInput driver : 18.0
[  6598.555]    X.Org Server Extension : 7.0
[  6598.557] (--) PCI:*(0:1:5:0) 1002:9712:103c:164b rev 0, Mem @ 0xd0000000/268435456, 0xf0600000/65536, 0xf0500000/1048576, I/O @ 0x00004000/256
[  6598.557] (--) PCI: (0:2:0:0) 1002:6741:103c:164b rev 0, Mem @ 0xe0000000/268435456, 0xf0400000/131072, I/O @ 0x00003000/256, BIOS @ 0x????????/131072
[  6598.557] (II) Open ACPI successful (/var/run/acpid.socket)
[  6598.557] Initializing built-in extension Generic Event Extension
[  6598.557] Initializing built-in extension SHAPE
[  6598.557] Initializing built-in extension MIT-SHM
[  6598.557] Initializing built-in extension XInputExtension
[  6598.557] Initializing built-in extension XTEST
[  6598.557] Initializing built-in extension BIG-REQUESTS
[  6598.557] Initializing built-in extension SYNC
[  6598.558] Initializing built-in extension XKEYBOARD
[  6598.558] Initializing built-in extension XC-MISC
[  6598.558] Initializing built-in extension XINERAMA
[  6598.558] Initializing built-in extension XFIXES
[  6598.558] Initializing built-in extension RENDER
[  6598.558] Initializing built-in extension RANDR
[  6598.558] Initializing built-in extension COMPOSITE
[  6598.558] Initializing built-in extension DAMAGE
[  6598.558] Initializing built-in extension MIT-SCREEN-SAVER
[  6598.558] Initializing built-in extension DOUBLE-BUFFER
[  6598.558] Initializing built-in extension RECORD
[  6598.558] Initializing built-in extension DPMS
[  6598.558] Initializing built-in extension X-Resource
[  6598.558] Initializing built-in extension XVideo
[  6598.558] Initializing built-in extension XVideo-MotionCompensation
[  6598.558] Initializing built-in extension XFree86-VidModeExtension
[  6598.558] Initializing built-in extension XFree86-DGA
[  6598.558] Initializing built-in extension XFree86-DRI
[  6598.558] Initializing built-in extension DRI2
[  6598.558] (II) "glx" will be loaded by default.
[  6598.558] (II) LoadModule: "glx"
[  6598.559] (II) Loading /usr/lib64/xorg/modules/extensions/libglx.so
[  6598.559] (II) Module glx: vendor="Advanced Micro Devices, Inc."
[  6598.559]    compiled for 6.9.0, module version = 1.0.0
[  6598.559] Loading extension GLX
[  6598.559] (II) LoadModule: "fglrx"
[  6598.559] (II) Loading /usr/lib64/xorg/modules/drivers/fglrx_drv.so
[  6598.580] (II) Module fglrx: vendor="FireGL - AMD Technologies Inc."
[  6598.580]    compiled for 1.4.99.906, module version = 9.1.11
[  6598.580]    Module class: X.Org Video Driver
[  6598.580] (II) Loading sub module "fglrxdrm"
[  6598.580] (II) LoadModule: "fglrxdrm"
[  6598.580] (II) Loading /usr/lib64/xorg/modules/linux/libfglrxdrm.so
[  6598.581] (II) Module fglrxdrm: vendor="FireGL - AMD Technologies Inc."
[  6598.581]    compiled for 1.4.99.906, module version = 9.1.11
[  6598.581] (II) AMD Proprietary Linux Driver Version Identifier:9.01.11
[  6598.581] (II) AMD Proprietary Linux Driver Release Identifier: UNSUPPORTED-9.01                     
[  6598.581] (II) AMD Proprietary Linux Driver Build Date: Oct 18 2012 21:13:01
[  6598.581] (--) using VT number 7

[  6598.582] (WW) Falling back to old probe method for fglrx
[  6598.589] (II) Loading PCS database from /etc/ati/amdpcsdb /etc/ati/amdpcsdb.default
[  6598.591] ukiDynamicMajor: found major device number 250
[  6598.591] ukiDynamicMajor: found major device number 250
[  6598.592] ukiOpenByBusid: Searching for BusID PCI:2:0:0
[  6598.592] ukiOpenDevice: node name is /dev/ati/card0
[  6598.592] ukiOpenDevice: open result is 10, (OK)
[  6598.592] ukiOpenByBusid: ukiOpenMinor returns 10
[  6598.592] ukiOpenByBusid: ukiGetBusid reports PCI:2:0:0
[  6598.593] (WW) fglrx: No matching Device section for instance (BusID PCI:0@1:5:0) found
[  6598.593] (--) Chipset Supported AMD Graphics Processor (0x6741) found
[  6598.593] (WW) fglrx: No matching Device section for instance (BusID PCI:0@0:17:0) found
[  6598.593] (WW) fglrx: No matching Device section for instance (BusID PCI:0@0:18:0) found
[  6598.593] (WW) fglrx: No matching Device section for instance (BusID PCI:0@0:18:2) found
[  6598.593] (WW) fglrx: No matching Device section for instance (BusID PCI:0@0:19:0) found
[  6598.593] (WW) fglrx: No matching Device section for instance (BusID PCI:0@0:19:2) found
[  6598.594] (WW) fglrx: No matching Device section for instance (BusID PCI:0@0:20:0) found
[  6598.594] (WW) fglrx: No matching Device section for instance (BusID PCI:0@0:20:2) found
[  6598.594] (WW) fglrx: No matching Device section for instance (BusID PCI:0@0:20:3) found
[  6598.594] (WW) fglrx: No matching Device section for instance (BusID PCI:0@0:20:4) found
[  6598.594] (WW) fglrx: No matching Device section for instance (BusID PCI:0@0:22:0) found
[  6598.594] (WW) fglrx: No matching Device section for instance (BusID PCI:0@0:22:2) found
[  6598.594] (WW) fglrx: No matching Device section for instance (BusID PCI:0@1:5:0) found
[  6598.594] (WW) fglrx: No matching Device section for instance (BusID PCI:0@1:5:1) found
[  6598.594] (II) AMD Video driver is running on a device belonging to a group targeted for this release
[  6598.594] (II) AMD Video driver is unsigned
[  6598.594] (II) fglrx(0): pEnt->device->identifier=0x20ee5e0
[  6598.594] (II) fglrx(0): === [xdl_xs113_atiddxPreInit] === begin
[  6598.594] Requested Entity already in use!
[  6598.594] (**) fglrx(0): Depth 24, (--) framebuffer bpp 32
[  6598.594] (II) fglrx(0): Pixel depth = 24 bits stored in 4 bytes (32 bpp pixmaps)
[  6598.594] (==) fglrx(0): Default visual is TrueColor
[  6598.594] (**) fglrx(0): Option "DesktopSetup" "clone"
[  6598.594] (**) fglrx(0): Option "DPMS" "true"
[  6598.594] (==) fglrx(0): RGB weight 888
[  6598.594] (II) fglrx(0): Using 8 bits per RGB
[  6598.594] (==) fglrx(0): Buffer Tiling is ON
[  6598.594] (II) Loading sub module "fglrxdrm"
[  6598.594] (II) LoadModule: "fglrxdrm"
[  6598.595] (II) Loading /usr/lib64/xorg/modules/linux/libfglrxdrm.so
[  6598.595] (II) Module fglrxdrm: vendor="FireGL - AMD Technologies Inc."
[  6598.595]    compiled for 1.4.99.906, module version = 9.1.11
[  6598.597] ukiDynamicMajor: found major device number 250
[  6598.597] ukiDynamicMajor: found major device number 250
[  6598.597] ukiOpenByBusid: Searching for BusID PCI:2:0:0
[  6598.597] ukiOpenDevice: node name is /dev/ati/card0
[  6598.597] ukiOpenDevice: open result is 13, (OK)
[  6598.597] ukiOpenByBusid: ukiOpenMinor returns 13
[  6598.597] ukiOpenByBusid: ukiGetBusid reports PCI:2:0:0
[  6598.597] (**) fglrx(0): NoAccel = NO
[  6598.597] (**) fglrx(0): AMD 2D Acceleration Architecture enabled
[  6598.597] (--) fglrx(0): Chipset: "AMD Radeon 6600M and 6700M Series" (Chipset = 0x6741)
[  6598.597] (--) fglrx(0): (PciSubVendor = 0x103c, PciSubDevice = 0x164b)
[  6598.597] (==) fglrx(0): board vendor info: third party graphics adapter - NOT original AMD
[  6598.597] (--) fglrx(0): Linear framebuffer (phys) at 0xe0000000
[  6598.597] (--) fglrx(0): MMIO registers at 0xf0400000
[  6598.597] (--) fglrx(0): I/O port at 0x00003000
[  6598.597] (==) fglrx(0): ROM-BIOS at 0x000c0000
[  6598.604] (II) fglrx(0): ATIF platform detected
[  6598.606] (II) fglrx(0): AC Adapter is used
[  6598.606] (II) fglrx(0): AMD Video BIOS revision 9 or later detected
[  6598.606] (--) fglrx(0): Video RAM: 1048576 kByte, Type: DDR3
[  6598.606] (II) fglrx(0): PCIE card detected
[  6598.606] (--) fglrx(0): Using per-process page tables (PPPT) as GART.
[  6598.606] (WW) fglrx(0): board is an unknown third party board, chipset is supported
[  6598.912] (II) fglrx(0): PowerXpress is enabled for AMD platform.
[  6598.912] (II) fglrx(0): [FB] MC range(MCFBBase = 0xf00000000, MCFBSize = 0x40000000)
[  6598.912] (II) fglrx(0): RandR 1.2 support is enabled!
[  6598.912] (II) fglrx(0): RandR 1.2 rotation support is enabled!
[  6598.912] (==) fglrx(0): Center Mode is disabled
[  6598.912] (II) Loading sub module "fb"
[  6598.912] (II) LoadModule: "fb"
[  6598.912] (II) Loading /usr/lib64/xorg/modules/libfb.so
[  6598.912] (II) Module fb: vendor="X.Org Foundation"
[  6598.912]    compiled for 1.13.0, module version = 1.0.0
[  6598.913]    ABI class: X.Org ANSI C Emulation, version 0.4
[  6598.913] (II) Loading sub module "ddc"
[  6598.913] (II) LoadModule: "ddc"
[  6598.913] (II) Module "ddc" already built-in
[  6598.926] (II) fglrx(0): Output CRT1 using monitor section aticonfig-Monitor[0]-0
[  6598.926] (II) Loading sub module "ddc"
[  6598.926] (II) LoadModule: "ddc"
[  6598.926] (II) Module "ddc" already built-in
[  6598.926] (II) fglrx(0): Printing probed modes for output CRT1
[  6598.926] (II) fglrx(0): Modeline "1600x1200"x60.0  162.00  1600 1664 1856 2160  1200 1201 1204 1250 +hsync +vsync (75.0 kHz eP)
[  6598.926] (II) fglrx(0): Modeline "1400x1050"x60.0  122.61  1400 1488 1640 1880  1050 1051 1054 1087 -hsync +vsync (65.2 kHz e)
[  6598.926] (II) fglrx(0): Modeline "1600x900"x60.0  108.00  1600 1624 1704 1800  900 901 904 1000 +hsync +vsync (60.0 kHz e)
[  6598.926] (II) fglrx(0): Modeline "1280x1024"x60.0  108.00  1280 1328 1440 1688  1024 1025 1028 1066 +hsync +vsync (64.0 kHz e)
[  6598.926] (II) fglrx(0): Modeline "1440x900"x60.0  106.50  1440 1520 1672 1904  900 903 909 934 -hsync +vsync (55.9 kHz e)
[  6598.926] (II) fglrx(0): Modeline "1280x960"x60.0  102.10  1280 1360 1496 1712  960 961 964 994 -hsync +vsync (59.6 kHz e)
[  6598.927] (II) fglrx(0): Modeline "1366x768"x60.0   85.50  1366 1436 1579 1792  768 771 774 798 +hsync +vsync (47.7 kHz e)
[  6598.927] (II) fglrx(0): Modeline "1360x768"x60.0   85.50  1360 1424 1536 1792  768 771 777 795 +hsync +vsync (47.7 kHz e)
[  6598.927] (II) fglrx(0): Modeline "1280x800"x60.0   83.50  1280 1352 1480 1680  800 803 809 831 -hsync +vsync (49.7 kHz e)
[  6598.927] (II) fglrx(0): Modeline "1152x864"x60.0   81.62  1152 1216 1336 1520  864 865 868 895 -hsync +vsync (53.7 kHz e)
[  6598.927] (II) fglrx(0): Modeline "1280x768"x60.0   79.50  1280 1344 1472 1664  768 771 778 798 -hsync +vsync (47.8 kHz e)
[  6598.927] (II) fglrx(0): Modeline "1280x720"x60.0   74.25  1280 1390 1430 1650  720 725 730 750 +hsync +vsync (45.0 kHz e)
[  6598.927] (II) fglrx(0): Modeline "1024x768"x60.0   65.00  1024 1048 1184 1344  768 771 777 806 -hsync -vsync (48.4 kHz e)
[  6598.927] (II) fglrx(0): Modeline "1024x600"x60.0   48.96  1024 1064 1168 1312  600 601 604 622 -hsync +vsync (37.3 kHz e)
[  6598.927] (II) fglrx(0): Modeline "800x600"x60.0   40.00  800 840 968 1056  600 601 605 628 +hsync +vsync (37.9 kHz e)
[  6598.927] (II) fglrx(0): Modeline "800x480"x60.0   29.58  800 816 896 992  480 481 484 497 -hsync +vsync (29.8 kHz e)
[  6598.927] (II) fglrx(0): Modeline "720x480"x60.0   27.03  720 736 798 858  480 489 495 525 -hsync -vsync (31.5 kHz e)
[  6598.927] (II) fglrx(0): Modeline "640x480"x60.0   25.18  640 656 752 800  480 490 492 525 -hsync -vsync (31.5 kHz e)
[  6598.927] (II) fglrx(0): Output CRT1 connected
[  6598.927] (II) fglrx(0): Using exact sizes for initial modes
[  6598.927] (II) fglrx(0): Output CRT1 using initial mode 1600x1200
[  6598.927] (II) fglrx(0): Using default gamma of (1.0, 1.0, 1.0) unless otherwise stated.
[  6598.927] (II) fglrx(0): DPI set to (96, 96)
[  6598.927] (II) fglrx(0): Eyefinity capable adapter detected.
[  6598.927] (II) fglrx(0): Adapter AMD Radeon 6600M and 6700M Series has 6 configurable heads and 0 displays connected.
[  6598.927] (WW) fglrx(0): Big Desktop related functionalities are replaced by RandR 1.2!
[  6598.927] (==) fglrx(0):  PseudoColor visuals disabled
[  6598.927] (II) Loading sub module "ramdac"
[  6598.927] (II) LoadModule: "ramdac"
[  6598.927] (II) Module "ramdac" already built-in
[  6598.927] (==) fglrx(0): NoDRI = NO
[  6598.927] (==) fglrx(0): Capabilities: 0x00000000
[  6598.927] (==) fglrx(0): CapabilitiesEx: 0x00000000
[  6598.927] (==) fglrx(0): OpenGL ClientDriverName: "fglrx_dri.so"
[  6598.927] (==) fglrx(0): UseFastTLS=0
[  6598.927] (II) fglrx(0): TearFreeDesktop is not supported on PowerXpress systems currently.
[  6598.927] (--) Depth 24 pixmap format is 32 bpp
[  6598.927] Loading extension ATIFGLRXDRI
[  6598.927] (II) fglrx(0): doing swlDriScreenInit
[  6598.927] (II) fglrx(0): swlDriScreenInit for fglrx driver
[  6598.927] ukiDynamicMajor: found major device number 250
[  6598.927] ukiDynamicMajor: found major device number 250
[  6598.927] ukiDynamicMajor: found major device number 250
[  6598.927] ukiOpenByBusid: Searching for BusID PCI:2:0:0
[  6598.927] ukiOpenDevice: node name is /dev/ati/card0
[  6598.927] ukiOpenDevice: open result is 14, (OK)
[  6598.927] ukiOpenByBusid: ukiOpenMinor returns 14
[  6598.927] ukiOpenByBusid: ukiGetBusid reports PCI:2:0:0
[  6598.927] (II) fglrx(0): [uki] DRM interface version 1.0
[  6598.928] (II) fglrx(0): [uki] created "fglrx" driver at busid "PCI:2:0:0"
[  6598.928] (II) fglrx(0): [uki] added 8192 byte SAREA at 0x9f1000
[  6598.928] (II) fglrx(0): [uki] mapped SAREA 0x9f1000 to 0x7f8e15baf000
[  6598.928] (II) fglrx(0): [uki] framebuffer handle = 0x9f2000
[  6598.928] (II) fglrx(0): [uki] added 1 reserved context for kernel
[  6598.928] (II) fglrx(0): swlDriScreenInit done
[  6598.928] (II) fglrx(0): Kernel Module Version Information:
[  6598.928] (II) fglrx(0):     Name: fglrx
[  6598.928] (II) fglrx(0):     Version: 9.1.11
[  6598.928] (II) fglrx(0):     Date: Oct 18 2012
[  6598.928] (II) fglrx(0):     Desc: AMD FireGL DRM kernel module
[  6598.928] (II) fglrx(0): Kernel Module version matches driver.
[  6598.928] (II) fglrx(0): Kernel Module Build Time Information:
[  6598.928] (II) fglrx(0):     Build-Kernel UTS_RELEASE:        3.0.35-tuxonice
[  6598.928] (II) fglrx(0):     Build-Kernel MODVERSIONS:        no
[  6598.928] (II) fglrx(0):     Build-Kernel __SMP__:            yes
[  6598.928] (II) fglrx(0):     Build-Kernel PAGE_SIZE:          0x1000
[  6598.928] (II) fglrx(0): [uki] register handle = 0x009f3000
[  6598.943] (II) fglrx(0): Static shadow buffer initialized.
[  6598.943] (II) fglrx(0): DRI initialization successfull
[  6598.943] (II) fglrx(0): FBADPhys: 0xf00000000 FBMappedSize: 0x01004000
[  6598.944] (==) fglrx(0): Backing store disabled
[  6598.944] Loading extension FGLRXEXTENSION
[  6598.944] (**) fglrx(0): DPMS enabled
[  6598.944] (II) fglrx(0): Initialized in-driver Xinerama extension
[  6598.944] (**) fglrx(0): Textured Video is enabled.
[  6598.944] (II) LoadModule: "glesx"
[  6598.945] (II) Loading /usr/lib64/xorg/modules/glesx.so
[  6598.945] (II) Module glesx: vendor="X.Org Foundation"
[  6598.945]    compiled for 1.4.99.906, module version = 1.0.0
[  6598.945] Loading extension GLESX
[  6598.945] (II) fglrx(0): GLESX enableFlags = 848
[  6598.945] (II) fglrx(0): GLESX is enabled
[  6598.945] (II) LoadModule: "amdxmm"
[  6598.945] (II) Loading /usr/lib64/xorg/modules/amdxmm.so
[  6598.946] (II) Module amdxmm: vendor="X.Org Foundation"
[  6598.946]    compiled for 1.4.99.906, module version = 2.0.0
[  6598.946] Loading extension AMDXVOPL
[  6598.946] Loading extension AMDXVBA
[  6598.948] (II) fglrx(0): UVD feature is enabled(II) fglrx(0):
[  6598.951] (II) fglrx(0): Enable composite support successfully
[  6598.951] (WW) fglrx(0): Option "VendorName" is not used
[  6598.951] (WW) fglrx(0): Option "ModelName" is not used
[  6598.951] (II) fglrx(0): X context handle = 0x14
[  6598.951] (II) fglrx(0): [DRI] installation complete
[  6598.951] (==) fglrx(0): Silken mouse enabled
[  6598.951] (==) fglrx(0): Using HW cursor of display infrastructure!
[  6598.952] (II) fglrx(0): RandR 1.2 enabled, ignore the following RandR disabled message.
[  6599.010] (--) RandR disabled
[  6599.019] ukiDynamicMajor: found major device number 250
[  6599.019] ukiDynamicMajor: found major device number 250
[  6599.019] ukiOpenByBusid: Searching for BusID PCI:2:0:0
[  6599.019] ukiOpenDevice: node name is /dev/ati/card0
[  6599.019] ukiOpenDevice: open result is 15, (OK)
[  6599.019] ukiOpenByBusid: ukiOpenMinor returns 15
[  6599.019] ukiOpenByBusid: ukiGetBusid reports PCI:2:0:0
[  6599.135] (II) AIGLX: Loaded and initialized OpenGL driver(II) GLX: Initialized DRI GL provider for screen 0
[  6599.152] (II) fglrx(0): Setting screen physical size to 423 x 317
[  6599.211] (II) config/udev: Adding input device Power Button (/dev/input/event2)
[  6599.211] (**) Power Button: Applying InputClass "evdev keyboard catchall"
[  6599.211] (II) LoadModule: "evdev"
[  6599.211] (II) Loading /usr/lib64/xorg/modules/input/evdev_drv.so
[  6599.211] (II) Module evdev: vendor="X.Org Foundation"
[  6599.211]    compiled for 1.13.0, module version = 2.7.3
[  6599.211]    Module class: X.Org XInput Driver
[  6599.212]    ABI class: X.Org XInput driver, version 18.0
[  6599.212] (II) Using input driver 'evdev' for 'Power Button'
[  6599.212] (**) Power Button: always reports core events
[  6599.212] (**) evdev: Power Button: Device: "/dev/input/event2"
[  6599.212] (--) evdev: Power Button: Vendor 0 Product 0x1
[  6599.212] (--) evdev: Power Button: Found keys
[  6599.212] (II) evdev: Power Button: Configuring as keyboard
[  6599.212] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXPWRBN:00/input/input2/event2"
[  6599.212] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD, id 6)
[  6599.212] (**) Option "xkb_rules" "evdev"
[  6599.212] (**) Option "xkb_model" "evdev"
[  6599.212] (**) Option "xkb_layout" "us"
[  6599.260] (II) config/udev: Adding input device Video Bus (/dev/input/event3)
[  6599.260] (**) Video Bus: Applying InputClass "evdev keyboard catchall"
[  6599.260] (II) Using input driver 'evdev' for 'Video Bus'
[  6599.260] (**) Video Bus: always reports core events
[  6599.260] (**) evdev: Video Bus: Device: "/dev/input/event3"
[  6599.260] (--) evdev: Video Bus: Vendor 0 Product 0x6
[  6599.260] (--) evdev: Video Bus: Found keys
[  6599.260] (II) evdev: Video Bus: Configuring as keyboard
[  6599.260] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/device:00/PNP0A08:00/device:02/LNXVIDEO:00/input/input3/event3"
[  6599.260] (II) XINPUT: Adding extended input device "Video Bus" (type: KEYBOARD, id 7)
[  6599.260] (**) Option "xkb_rules" "evdev"
[  6599.260] (**) Option "xkb_model" "evdev"
[  6599.260] (**) Option "xkb_layout" "us"
[  6599.260] (II) config/udev: Adding input device Video Bus (/dev/input/event4)
[  6599.260] (**) Video Bus: Applying InputClass "evdev keyboard catchall"
[  6599.260] (II) Using input driver 'evdev' for 'Video Bus'
[  6599.260] (**) Video Bus: always reports core events
[  6599.260] (**) evdev: Video Bus: Device: "/dev/input/event4"
[  6599.261] (--) evdev: Video Bus: Vendor 0 Product 0x6
[  6599.261] (--) evdev: Video Bus: Found keys
[  6599.261] (II) evdev: Video Bus: Configuring as keyboard
[  6599.261] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/device:00/PNP0A08:00/device:09/LNXVIDEO:02/input/input4/event4"
[  6599.261] (II) XINPUT: Adding extended input device "Video Bus" (type: KEYBOARD, id 8)
[  6599.261] (**) Option "xkb_rules" "evdev"
[  6599.261] (**) Option "xkb_model" "evdev"
[  6599.261] (**) Option "xkb_layout" "us"
[  6599.261] (II) config/udev: Adding input device Power Button (/dev/input/event0)
[  6599.261] (**) Power Button: Applying InputClass "evdev keyboard catchall"
[  6599.261] (II) Using input driver 'evdev' for 'Power Button'
[  6599.261] (**) Power Button: always reports core events
[  6599.261] (**) evdev: Power Button: Device: "/dev/input/event0"
[  6599.261] (--) evdev: Power Button: Vendor 0 Product 0x1
[  6599.261] (--) evdev: Power Button: Found keys
[  6599.261] (II) evdev: Power Button: Configuring as keyboard
[  6599.261] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/device:00/PNP0C0C:00/input/input0/event0"
[  6599.261] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD, id 9)
[  6599.261] (**) Option "xkb_rules" "evdev"
[  6599.261] (**) Option "xkb_model" "evdev"
[  6599.261] (**) Option "xkb_layout" "us"
[  6599.262] (II) config/udev: Adding input device Lid Switch (/dev/input/event1)
[  6599.262] (II) No input driver specified, ignoring this device.
[  6599.262] (II) This device may have been added with another device file.
[  6599.262] (II) config/udev: Adding input device HDA Digital PCBeep (/dev/input/event7)
[  6599.262] (II) No input driver specified, ignoring this device.
[  6599.262] (II) This device may have been added with another device file.
[  6599.262] (II) config/udev: Adding input device HDA ATI SB Mic at Ext Front Jack (/dev/input/event8)
[  6599.262] (II) No input driver specified, ignoring this device.
[  6599.262] (II) This device may have been added with another device file.
[  6599.262] (II) config/udev: Adding input device HDA ATI SB HP Out at Ext Front Jack (/dev/input/event9)
[  6599.262] (II) No input driver specified, ignoring this device.
[  6599.262] (II) This device may have been added with another device file.
[  6599.263] (II) config/udev: Adding input device AT Translated Set 2 keyboard (/dev/input/event5)
[  6599.263] (**) AT Translated Set 2 keyboard: Applying InputClass "evdev keyboard catchall"
[  6599.263] (II) Using input driver 'evdev' for 'AT Translated Set 2 keyboard'
[  6599.263] (**) AT Translated Set 2 keyboard: always reports core events
[  6599.263] (**) evdev: AT Translated Set 2 keyboard: Device: "/dev/input/event5"
[  6599.263] (--) evdev: AT Translated Set 2 keyboard: Vendor 0x1 Product 0x1
[  6599.263] (--) evdev: AT Translated Set 2 keyboard: Found keys
[  6599.263] (II) evdev: AT Translated Set 2 keyboard: Configuring as keyboard
[  6599.263] (**) Option "config_info" "udev:/sys/devices/platform/i8042/serio0/input/input5/event5"
[  6599.263] (II) XINPUT: Adding extended input device "AT Translated Set 2 keyboard" (type: KEYBOARD, id 10)
[  6599.263] (**) Option "xkb_rules" "evdev"
[  6599.263] (**) Option "xkb_model" "evdev"
[  6599.263] (**) Option "xkb_layout" "us"
[  6599.263] (II) config/udev: Adding input device SynPS/2 Synaptics TouchPad (/dev/input/event6)
[  6599.263] (**) SynPS/2 Synaptics TouchPad: Applying InputClass "evdev touchpad catchall"
[  6599.263] (II) Using input driver 'evdev' for 'SynPS/2 Synaptics TouchPad'
[  6599.263] (**) SynPS/2 Synaptics TouchPad: always reports core events
[  6599.263] (**) evdev: SynPS/2 Synaptics TouchPad: Device: "/dev/input/event6"
[  6599.264] (--) evdev: SynPS/2 Synaptics TouchPad: Vendor 0x2 Product 0x7
[  6599.264] (--) evdev: SynPS/2 Synaptics TouchPad: Found 3 mouse buttons
[  6599.264] (--) evdev: SynPS/2 Synaptics TouchPad: Found absolute axes
[  6599.264] (--) evdev: SynPS/2 Synaptics TouchPad: Found absolute multitouch axes
[  6599.264] (--) evdev: SynPS/2 Synaptics TouchPad: Found x and y absolute axes
[  6599.264] (--) evdev: SynPS/2 Synaptics TouchPad: Found absolute touchpad.
[  6599.264] (II) evdev: SynPS/2 Synaptics TouchPad: Configuring as touchpad
[  6599.264] (**) evdev: SynPS/2 Synaptics TouchPad: YAxisMapping: buttons 4 and 5
[  6599.264] (**) evdev: SynPS/2 Synaptics TouchPad: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
[  6599.264] (**) Option "config_info" "udev:/sys/devices/platform/i8042/serio1/input/input6/event6"
[  6599.264] (II) XINPUT: Adding extended input device "SynPS/2 Synaptics TouchPad" (type: TOUCHPAD, id 11)
[  6599.264] (II) evdev: SynPS/2 Synaptics TouchPad: initialized for absolute axes.
[  6599.264] (**) SynPS/2 Synaptics TouchPad: (accel) keeping acceleration scheme 1
[  6599.264] (**) SynPS/2 Synaptics TouchPad: (accel) acceleration profile 0
[  6599.264] (**) SynPS/2 Synaptics TouchPad: (accel) acceleration factor: 2.000
[  6599.264] (**) SynPS/2 Synaptics TouchPad: (accel) acceleration threshold: 4
[  6599.264] (II) config/udev: Adding input device SynPS/2 Synaptics TouchPad (/dev/input/mouse0)
[  6599.264] (II) No input driver specified, ignoring this device.
[  6599.264] (II) This device may have been added with another device file.
[  6599.275] (II) fglrx(0): Restoring Recent Mode via PCS is not supported in RANDR 1.2 capable environments
[  6609.386] (II) AIGLX: Suspending AIGLX clients for VT switch
[  6609.386] (II) fglrx(0): Backup framebuffer data.
[  6609.389] (II) fglrx(0): Backup complete.
[  6609.389] (II) fglrx(0): Backup framebuffer data.
[  6609.392] (II) fglrx(0): Backup complete.
Back to top
View user's profile Send private message
LoTeK
Apprentice
Apprentice


Joined: 26 Jul 2012
Posts: 270

PostPosted: Thu Nov 29, 2012 7:50 pm    Post subject: Reply with quote

plz post your make.conf..
Back to top
View user's profile Send private message
Bennett000
n00b
n00b


Joined: 28 Nov 2012
Posts: 3
Location: Toronto

PostPosted: Fri Nov 30, 2012 6:16 am    Post subject: Reply with quote

Here is my make.conf

Code:
CFLAGS="-march=barcelona -O2 -pipe"
CXXFLAGS="${CFLAGS}"

# WARNING: Changing your CHOST is not something that should be done lightly.
# Please consult http://www.gentoo.org/doc/en/change-chost.xml before changing.
CHOST="x86_64-pc-linux-gnu"

MAKEOPTS="-j3"
# These are the USE flags that were used in addition to what is provided by the
# profile used for building.
USE="mmx sse sse2 -gtk -gnome qt4 kde dvd alsa cdr dvdr X consolekit dbus policykit udev irmc bluetooth unicode cjk jpeg nls pam png ppds samba slp ssl tiff alsa midi acpi scsi ipv6 icu"
PORTAGE_NICENESS=30
VIDEO_CARDS="fglrx"
Back to top
View user's profile Send private message
LoTeK
Apprentice
Apprentice


Joined: 26 Jul 2012
Posts: 270

PostPosted: Sun Dec 02, 2012 5:08 pm    Post subject: Reply with quote

sorry for the late reply, it's because I don't know how to help you... I had a similar problem and the fault was in make.conf, but your make.conf seems to be ok.
you can post dmesg, and your kernel-config (/usr/src/linux/.config) then maybe someone else can help...
Back to top
View user's profile Send private message
hedmo
l33t
l33t


Joined: 29 Aug 2009
Posts: 840
Location: halmstad

PostPosted: Sun Dec 02, 2012 6:23 pm    Post subject: Reply with quote

Bennett000

how about this:


PreInitDAL failed

This can happen if multiple monitors were detected, even though you don't have multiple monitors. To fix it, use aticonfig --enable-monitor and /opt/bin/aticonfig --force-monitor to specify which monitors you use. Example, if you have a VGA + DVI card, but only use your VGA connection:
# aticonfig --enable-monitor=crt1 --force-monitor=crt1,notmds1

taken from http://en.gentoo-wiki.com/wiki/Fglrx

regards hedmo
Back to top
View user's profile Send private message
Bennett000
n00b
n00b


Joined: 28 Nov 2012
Posts: 3
Location: Toronto

PostPosted: Mon Dec 03, 2012 4:32 am    Post subject: aticonfig cannot detect session Reply with quote

I've been playing with aticonfig a lot, but i haven't been able to get
it to detect my running X session

Code:
ati_dm: X Windows is not running or $DISPLAY is not set.


setting $DISPLAY manually has not yet worked for me, yet. I'm assuming
it's supposed to be :0, or myhostname.domain:0
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum