Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Xorg doesn't work after emerge -vauND world
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
jwackito
n00b
n00b


Joined: 31 Jan 2007
Posts: 27

PostPosted: Sat Dec 01, 2012 3:02 am    Post subject: Xorg doesn't work after emerge -vauND world Reply with quote

After full system upgrade, Xorg freezes my video. It is possible to access it via ssh but all sorts of magic I read in tutorials have failed miserably.
For example, here is the log from X -configure
Code:

 # X -configure

X.Org X Server 1.13.0
Release Date: 2012-09-05
X Protocol Version 11, Revision 0
Build Operating System: Linux 3.5.7-gentoogiskard i686 Gentoo
Current Operating System: Linux giskard 3.5.7-gentoogiskard #3 SMP PREEMPT Thu Nov 29 15:42:03 ART 2012 i686
Kernel command line: root=/dev/sda3 vga=0x317
Build Date: 29 November 2012  11:47:51AM
 
Current version of pixman: 0.28.0
        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Fri Nov 30 23:51:16 2012
List of video drivers:
        v4l
        nvidia
        fbdev
        vesa
(++) Using config file: "/root/xorg.conf.new"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
Number of created screens does not match number of detected devices.
  Configuration failed.
Server terminated with error (2). Closing log file.


I'm using stable packages only so I suspect misconfigured use flags or another obscure problem.

Any help here will be welcome. If you need more data like emerge --info, please just ask.
Regards...
_________________
--
Jwackito
Back to top
View user's profile Send private message
BillWho
Veteran
Veteran


Joined: 03 Mar 2012
Posts: 1600
Location: US

PostPosted: Sat Dec 01, 2012 5:04 am    Post subject: Reply with quote

jwackito,

Try
Code:
emerge -av1 $(qlist -IC x11-drivers)


Also, if you're using the open source driver, move /etc/X11/xorg.conf to /etc/X11/xorg.save since xorg shouldn't require any config file.
_________________
Good luck :wink:

Since installing gentoo, my life has become one long emerge :)
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 5526

PostPosted: Sat Dec 01, 2012 10:48 am    Post subject: Reply with quote

Usually, 'X -configure' is rather useless these days.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum