Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Problem with bootsplash (splashutils)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo
View previous topic :: View next topic  
Author Message
Martux
Veteran
Veteran


Joined: 04 Feb 2005
Posts: 1744
Location: Mannheim, Germany

PostPosted: Sat Aug 04, 2012 3:26 am    Post subject: Problem with bootsplash (splashutils) Reply with quote

Hi folks!
I recently decided to install fbcondecor and bootsplash stuff on my system.
Neat, looks good.
My problem is only in "silent" mode: the image fades out and then, instead of booting into KDE, drops me off at tty1. This doesn't happen with the same bootsplash in "verbose" mode.

I am still using grub-0.97 and these are my parameter, relevant for the image:
Code:

kernel /boot/vmlinuz root=/dev/sda6 quiet vga=0x0361 splash=verbose,theme:sabayon console=tty1
initrd (hd0,5)/boot/initramfs-bootsplash

Any idea why it only works verbose?
_________________
"Coincidence is God's way of remaining anonymous."
Albert Einstein
"The road to success is always under construction"
Back to top
View user's profile Send private message
Martux
Veteran
Veteran


Joined: 04 Feb 2005
Posts: 1744
Location: Mannheim, Germany

PostPosted: Tue Aug 07, 2012 8:31 am    Post subject: Reply with quote

Even if I set tty=7 it does not work. Problem seems to be the switching from tty1 to tty7 where KDE starts.I use an entry in /etc/local.d/ to start up kdm.
_________________
"Coincidence is God's way of remaining anonymous."
Albert Einstein
"The road to success is always under construction"
Back to top
View user's profile Send private message
johnlu
Apprentice
Apprentice


Joined: 22 Aug 2004
Posts: 241
Location: Córdoba, España

PostPosted: Fri Nov 30, 2012 2:39 am    Post subject: Reply with quote

Did you get any success? I'm facing this same problem.
_________________
http://www.juanluperez.com
Back to top
View user's profile Send private message
Martux
Veteran
Veteran


Joined: 04 Feb 2005
Posts: 1744
Location: Mannheim, Germany

PostPosted: Sat Dec 01, 2012 12:52 pm    Post subject: Reply with quote

Oh, that's interesting, I am not the only one. No, I have had no success so far. Even with Grub2, I face the exact same issue. I am stuck with "verbose" bootscreen ever since.
_________________
"Coincidence is God's way of remaining anonymous."
Albert Einstein
"The road to success is always under construction"
Back to top
View user's profile Send private message
johnlu
Apprentice
Apprentice


Joined: 22 Aug 2004
Posts: 241
Location: Córdoba, España

PostPosted: Wed Dec 12, 2012 12:17 am    Post subject: Reply with quote

bootsplash in Gentoo is really tricky, it depends a lot on which hardware you have.
_________________
http://www.juanluperez.com
Back to top
View user's profile Send private message
Logicien
l33t
l33t


Joined: 16 Sep 2005
Posts: 851
Location: Montréal

PostPosted: Wed Dec 12, 2012 3:38 am    Post subject: Reply with quote

Hello there,
Martux, you can try to start Kdm by enabling the xdm daemon with rc-update, then choose kdm as the display manager in /etc/conf.d/xdm. kdm is not installed in my present Gentoo. If there's a specific kdm daemon it should work to. I do not think start kdm from /etc/local.d is the way to do.
_________________
Paul
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum