Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
xen 4.2 with gentoo
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
vacula
n00b
n00b


Joined: 17 Oct 2007
Posts: 32
Location: Lviv. Ukraine

PostPosted: Sun Sep 23, 2012 10:59 am    Post subject: xen 4.2 with gentoo Reply with quote

Has anybody tried xen/xen-tools 4.2 or 9999 ?

I'm not able to compile xen-tools neither -4.2 nor -9999 with both gcc 4.6/4.7.
I've tried overlays: from xen and from virtualization, and both times I filed to compile tools: from virtualization the problem is coming from ipxe.

Is anyone interested in that stuff? Any success stories?
Back to top
View user's profile Send private message
sandymac
n00b
n00b


Joined: 10 Dec 2003
Posts: 2
Location: Florida, USA

PostPosted: Tue Sep 25, 2012 2:20 pm    Post subject: Reply with quote

Fails for me too when I try to install Xen Tools 4.2.0 from the xen virtualization overlay. The problem is that gentoo wants to (rightly) manage the download of ipxe itself instead of letting the make file do it but the ebuild it must download the wrong version.

If you edit /var/lib/layman/virtualization/app-emulation/xen-tools/xen-tools-4.2.0.ebuild and remove all references to ipxe in the ebuild and then insert a "unset CFLAGS" just before the emake line inside the src_compile() function you can `ebuild xen-tools-4.2.0.ebuild merge` just fine. I don't make any claims on how well Xen will work after you do this though and this will mean that Xen Tools cannot be compiled unless you are connected to the internet.

To recap:
[list=]
[*]cd /var/lib/layman/virtualization/app-emulation/xen-tools/
[*]edit xen-tools-4.2.0.ebuild to remove references to ipxe
[*]insert "unset CFLAGS" just before the call to emake in src_compile()
[*]run `ebuild xen-tools-4.2.0.ebuild merge`
[/list]


Links:
Helped me figure out the ipxe download issue:
http://lists.xen.org/archives/html/xen-devel/2012-01/msg00269.html

Helped me figure out I needed to unset CFLAGS:
http://lists.xen.org/archives/html/xen-devel/2012-08/msg02137.html
Back to top
View user's profile Send private message
hydrapolic
Tux's lil' helper
Tux's lil' helper


Joined: 07 Feb 2008
Posts: 112

PostPosted: Tue Nov 27, 2012 2:15 pm    Post subject: Reply with quote

Works fine on Gentoo 3.5.7 :)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum