Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Solved] atmarpd.pid': No such file or directory
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
Kollin
Veteran
Veteran


Joined: 25 Feb 2006
Posts: 1103
Location: Sofia/Bulgaria

PostPosted: Sun Nov 11, 2012 9:55 am    Post subject: [Solved] atmarpd.pid': No such file or directory Reply with quote

Since few days back when i'm bringing down my system i'm getting those messages:

Code:
ov 11 02:30:02 [/etc/init.d/net.wlan0] start-stop-daemon: fopen `/var/run/atmarpd.pid': No such file or directory
Nov 11 02:30:02 [/etc/init.d/net.wlan0] start-stop-daemon: fopen `/var/run/atmarpd.pid': No such file or directory
Nov 11 02:30:03 [/etc/init.d/net.eth1] start-stop-daemon: fopen `/var/run/atmarpd.pid': No such file or directory
                - Last output repeated twice -
Nov 11 02:30:03 [kernel] [19040.345950] device eth1 left promiscuous mode
Nov 11 02:30:03 [kernel] [19040.346100] br0: port 2(eth1) entered disabled state
Nov 11 02:30:03 [/etc/init.d/net.eth0] start-stop-daemon: fopen `/var/run/atmarpd.pid': No such file or directory
                - Last output repeated twice -
Nov 11 02:30:03 [kernel] [19040.535261] device eth0 left promiscuous mode
Nov 11 02:30:03 [kernel] [19040.535388] br0: port 1(eth0) entered disabled state
Nov 11 02:30:03 [dhcpcd] br0: carrier lost
Nov 11 02:30:03 [/etc/init.d/net.br0] start-stop-daemon: fopen `/var/run/atmarpd.pid': No such file or directory
Nov 11 02:30:03 [dhcpcd] received SIGTERM, stopping
Nov 11 02:30:03 [dhcpcd] br0: removing interface
Nov 11 02:30:03 [/etc/init.d/net.br0] start-stop-daemon: fopen `/var/run/atmarpd.pid': No such file or directory
Nov 11 02:30:03 [/etc/init.d/net.lo] start-stop-daemon: fopen `/var/run/atmarpd.pid': No such file or directory



I think it's openrc related because i never configured or used atmarpd.
It's something harmless because my network setup works fine.
My question is: What can i do to get rid of those messages or i just have to wait for the next openrc update? :D
_________________
"Dear Enemy: may the Lord hate you and all your kind, may you be turned orange in hue, and may your head fall off at an awkward moment."
"Linux is like a wigwam - no windows, no gates, apache inside..."


Last edited by Kollin on Mon Dec 10, 2012 3:49 pm; edited 1 time in total
Back to top
View user's profile Send private message
tamjan
n00b
n00b


Joined: 11 May 2012
Posts: 8
Location: Luleå, Sweden

PostPosted: Sat Nov 24, 2012 2:28 pm    Post subject: Reply with quote

I have the same errors at shutdown. Appeared with the upgrade to openrc 0.11.5. :)
Back to top
View user's profile Send private message
Kollin
Veteran
Veteran


Joined: 25 Feb 2006
Posts: 1103
Location: Sofia/Bulgaria

PostPosted: Sat Nov 24, 2012 8:49 pm    Post subject: Reply with quote

tamjan wrote:
I have the same errors at shutdown. Appeared with the upgrade to openrc 0.11.5. :)


Yea, but how to get rid of them ? :wink:
_________________
"Dear Enemy: may the Lord hate you and all your kind, may you be turned orange in hue, and may your head fall off at an awkward moment."
"Linux is like a wigwam - no windows, no gates, apache inside..."
Back to top
View user's profile Send private message
aCOSwt
Moderator
Moderator


Joined: 19 Oct 2007
Posts: 2537
Location: Hilbert space

PostPosted: Sun Nov 25, 2012 3:14 pm    Post subject: Reply with quote

I can confirm. :evil:

I have not had enough time/will to investigate yet.
The only thing I believe is that the track to the culprit starts with /lib64/rc/net/clip.sh which is actually responsible for issuing the
Code:
start-stop-daemon --quiet --test --stop --pidfile /var/run/atmarpd.pid


I can't tell much more about this and don't think I will. Please move forward from there.
I am getting just fed up by the increasingly disgraceful way I am regularly told by my own system that I should no longer start / stop my processes as I want.

BTW, I appreciate how much a --quiet option obviously no longer means what... it used to mean... (to me) :roll:
_________________
Back to top
View user's profile Send private message
Kollin
Veteran
Veteran


Joined: 25 Feb 2006
Posts: 1103
Location: Sofia/Bulgaria

PostPosted: Sun Nov 25, 2012 9:51 pm    Post subject: Reply with quote

Openrc is definitely acting up recently :(
_________________
"Dear Enemy: may the Lord hate you and all your kind, may you be turned orange in hue, and may your head fall off at an awkward moment."
"Linux is like a wigwam - no windows, no gates, apache inside..."
Back to top
View user's profile Send private message
Robert S
Guru
Guru


Joined: 15 Aug 2004
Posts: 415
Location: Canberra Australia

PostPosted: Sun Nov 25, 2012 9:59 pm    Post subject: Reply with quote

I have had similar problems. Permissions on a number of subdirectories of /var/run now change on reboot and various daemons quietly fail (eg. sendmail - didn't get any email over the weekend until I discovered this).

Is there a plan to fix this?
Back to top
View user's profile Send private message
piccolo
n00b
n00b


Joined: 30 Dec 2011
Posts: 16

PostPosted: Mon Nov 26, 2012 2:22 pm    Post subject: Reply with quote

Hi,
same problem here.
Somebody found a fix for it?

Greetings,
piccolo
Back to top
View user's profile Send private message
Ant P.
Advocate
Advocate


Joined: 18 Apr 2009
Posts: 2365
Location: UK

PostPosted: Mon Nov 26, 2012 3:10 pm    Post subject: Reply with quote

I'm also having this problem with app-misc/uptimed, net-irc/inspircd, sys-process/atop, games-server/minecraft-server::java-overlay, net-im/prosody, and there's probably more stuff that's silently broken and I haven't noticed yet. These are just the ones that show up as crashed in rc-status that I've had to hack into a working state manually.

The OpenRC devs really need the concept of don't &$%@ing break working systems beating into their heads with a heavy stone.
Back to top
View user's profile Send private message
Kollin
Veteran
Veteran


Joined: 25 Feb 2006
Posts: 1103
Location: Sofia/Bulgaria

PostPosted: Mon Dec 03, 2012 8:22 am    Post subject: Reply with quote

Sadly sys-apps/openrc-0.11.6 does not solve the issue :?
_________________
"Dear Enemy: may the Lord hate you and all your kind, may you be turned orange in hue, and may your head fall off at an awkward moment."
"Linux is like a wigwam - no windows, no gates, apache inside..."
Back to top
View user's profile Send private message
murdock
n00b
n00b


Joined: 25 Jun 2003
Posts: 3

PostPosted: Fri Dec 07, 2012 10:08 pm    Post subject: Reply with quote

Just disable the 'atm' USE flag and unmerge the package 'linux-atm'.
Back to top
View user's profile Send private message
Kollin
Veteran
Veteran


Joined: 25 Feb 2006
Posts: 1103
Location: Sofia/Bulgaria

PostPosted: Mon Dec 10, 2012 3:49 pm    Post subject: Reply with quote

murdock wrote:
Just disable the 'atm' USE flag and unmerge the package 'linux-atm'.


That worked for me, thanx! :D
_________________
"Dear Enemy: may the Lord hate you and all your kind, may you be turned orange in hue, and may your head fall off at an awkward moment."
"Linux is like a wigwam - no windows, no gates, apache inside..."
Back to top
View user's profile Send private message
lost-distance
n00b
n00b


Joined: 10 Apr 2003
Posts: 65

PostPosted: Tue Dec 25, 2012 12:00 pm    Post subject: Reply with quote

With respect, I don't consider removing linux-atm to be the solution to this problem.

I keep net-dialup/ppp and net-dialup/linux-atm installed on my system as a fallback in case my wireless router dies: I could then configure PPP/ATM to use an old ADSL modem instead.

In the meantime I do not start PPP/ATM. However I too am now seeing these "atmarpd.pid" warnings.

As far as I can tell the problem is that OpenRC is now trying to stop a service which it did not start. If that is the case then this is a real bug in OpenRC.
Back to top
View user's profile Send private message
Kollin
Veteran
Veteran


Joined: 25 Feb 2006
Posts: 1103
Location: Sofia/Bulgaria

PostPosted: Tue Dec 25, 2012 6:49 pm    Post subject: Reply with quote

lost-distance wrote:
With respect, I don't consider removing linux-atm to be the solution to this problem.

I keep net-dialup/ppp and net-dialup/linux-atm installed on my system as a fallback in case my wireless router dies: I could then configure PPP/ATM to use an old ADSL modem instead.

In the meantime I do not start PPP/ATM. However I too am now seeing these "atmarpd.pid" warnings.

As far as I can tell the problem is that OpenRC is now trying to stop a service which it did not start. If that is the case then this is a real bug in OpenRC.


You are correct, may be you should consider opening a bug about this problem in bugs.gentoo.org :D
_________________
"Dear Enemy: may the Lord hate you and all your kind, may you be turned orange in hue, and may your head fall off at an awkward moment."
"Linux is like a wigwam - no windows, no gates, apache inside..."
Back to top
View user's profile Send private message
Nikoli
n00b
n00b


Joined: 13 Nov 2007
Posts: 35

PostPosted: Fri Mar 08, 2013 8:02 am    Post subject: Reply with quote

https://bugs.gentoo.org/show_bug.cgi?id=460756

Same problem here.
Back to top
View user's profile Send private message
ph03
n00b
n00b


Joined: 14 Jan 2005
Posts: 39

PostPosted: Thu Jun 06, 2013 3:18 pm    Post subject: Reply with quote

Is there a solution for this annoying problem yet?
Back to top
View user's profile Send private message
F1r31c3r
Tux's lil' helper
Tux's lil' helper


Joined: 31 Aug 2007
Posts: 80
Location: UK

PostPosted: Sun Aug 25, 2013 12:47 pm    Post subject: Reply with quote

ph03 wrote:
Is there a solution for this annoying problem yet?


Ploblem? lol

The reason for this error is because the
Quote:
atmarpd
is not actually running.

When you ren a program in linux the kernel sets a unique pid(Program ID) atmarpd of course has one and this is what should be contained in the pid file. if you run atmarpd and then
Quote:
ps aux | grep atmarpd
then you will see its pid number.

Entering that pid number into the atmarpd.pid file would allow it to run but then you find a dependancy
Quote:
ilmid
needs to be running too.

basically i dont think many people need ATM support so just uninstall it.

http://www.linuxcommand.org/man_pages/atmarpd8.html

The above link explains more about it, its not just a damon you can starup with init.d and it does its thing. you need configure ATM networking over IP to use it.

That is what i can gather about it anyway. I just removed tho atm use flag and updated world. Then emerge --depclean removed linux-atm package. At present i dont see any personal use for this networking technology, feel free to play though lol.
_________________
When i look In-between white and black i see a rainbow of colours
Back to top
View user's profile Send private message
Logicien
l33t
l33t


Joined: 16 Sep 2005
Posts: 838
Location: Montréal

PostPosted: Sun Aug 25, 2013 11:32 pm    Post subject: Reply with quote

I had set the atm USE flag only for iproute2 package in /etc/portage/package.use and not globally in /etc/portage/make.conf. I had the same messages mentionned above when my net.wlo1 wireless script was shutting down. The atm USE flag is not activated by default. I remove it and the messages disappear. Of course, emerge --depclean remove the atmarpd daemon after that.

I think the messages come from the iproute2 utilities when they are execute with atm support. According to euse, it's the only other package than the ppp one who can use this USE flag.
_________________
Paul
Back to top
View user's profile Send private message
F1r31c3r
Tux's lil' helper
Tux's lil' helper


Joined: 31 Aug 2007
Posts: 80
Location: UK

PostPosted: Mon Aug 26, 2013 1:05 am    Post subject: Reply with quote

Well its a IBM input, by input i mean its IBM contributing the technology to the open source community by looks of it.

I am not sure what advantage or use this technology benefits the end user.

M$ speak about its benefits here so maybe figuring out how it actually works and how IBM have programed it to be implamented etc then use it.

http://technet.microsoft.com/en-us/library/cc740081%28v=ws.10%29.aspx

As far as surfing the web i dont think it will benefit much. If you are connecting to a network that can optimise this technology then it is well worth getting it working. Just seting it up without using it could result in security issues in my opinion even if they have not been discovered yet.

If i actually had the time i would dig into this protocol deeper and see what i can find that uses it but life is short so ill put it on backburner. Feel free to hack it if you wish though, dont let me put you off :-p

Either way the reason you get this error is because the relevant programs required for ATM are not running. If someone out there actually has ATM runing feel free to share the info, saves us having to hack it lol.
More googling on ATM setup on linux might be a good place to start in getting it working.

I may revisit this thread again in a while depends if i get board after work and fancy hacking it me self at which point ill let you all know how to get it working of course.

You never know upstream might refine the code so it all starts and works semless in the near futur without having to hack it. Some would say that takes the fun out of it all but hey :-)
_________________
When i look In-between white and black i see a rainbow of colours
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum