Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
xorg: dead keys sind weg
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
musv
Advocate
Advocate


Joined: 01 Dec 2002
Posts: 2688
Location: de

PostPosted: Fri Nov 23, 2012 11:46 am    Post subject: xorg: dead keys sind weg Reply with quote

Hi, weiß nicht, seit wann das der Fall ist. Aber vor kurzem ist mir aufgefallen, dass die Dead-Keys in meinem xorg nicht mehr funktionieren. Das ist ärgerlich. Ab und zu brauch ich die doch mal.

Weiß da jemand mehr drüber? Die Konfiguration hatte ich schon vor längerer Zeit umgestellt, also xorg.conf.d -> 10-evdev.conf
Back to top
View user's profile Send private message
Christian99
Veteran
Veteran


Joined: 28 May 2009
Posts: 1016

PostPosted: Fri Nov 23, 2012 2:54 pm    Post subject: Reply with quote

wie sieht denn die evdef-conf aus? du kannst auch mal ins xorg log schauen, da steht drin welche optionen für welche dvices angewendet werden
Back to top
View user's profile Send private message
musv
Advocate
Advocate


Joined: 01 Dec 2002
Posts: 2688
Location: de

PostPosted: Sat Nov 24, 2012 5:03 pm    Post subject: Reply with quote

Als ich das Posting schrieb, war ich grad auf Arbeit. Von daher:

/etc/X11/xorg.conf.d/10-evdev.conf:
Section "InputClass"
        Identifier "Keyboard"
        MatchIsKeyboard "on"
        MatchDevicePath "/dev/input/event*"
        Driver "evdev"
        Option "AutoRepeat"    "500 30"
        Option "XkbRules"   "xorg"
        Option "XkbModel"   "pc105"
        Option "XkbLayout"  "de"
       Option "XkbVariant" ",winkeys"
       Option "CoreKeyboard"
EndSection


/var/log/Xorg.0.log:
[    12.227] (**) Option "CoreKeyboard"
[    12.227] (**) Power Button: always reports core events
[    12.227] (**) evdev: Power Button: Device: "/dev/input/event0"
[    12.227] (--) evdev: Power Button: Vendor 0 Product 0x1
[    12.227] (--) evdev: Power Button: Found keys
[    12.227] (II) evdev: Power Button: Configuring as keyboard
[    12.227] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/device:00/PNP0C0C:00/input/input0/event0"
[    12.227] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD, id 7)
[    12.227] (**) Option "xkb_rules" "evdev"
[    12.227] (**) Option "xkb_model" "pc105"
[    12.227] (**) Option "xkb_layout" "de"
[    12.227] (**) Option "xkb_variant" ",winkeys"
Back to top
View user's profile Send private message
Christian99
Veteran
Veteran


Joined: 28 May 2009
Posts: 1016

PostPosted: Sun Nov 25, 2012 12:14 am    Post subject: Reply with quote

da taucht ja nichts in richtung "nodeadkeys" auf, also scheint das von der seite zu passen, Soweit ich weiß kanns dann nur per setxkbmap umgestellt werden. manche DEs machen das auf wunsch, zb KDE. Was verwendest du denn?
Back to top
View user's profile Send private message
musv
Advocate
Advocate


Joined: 01 Dec 2002
Posts: 2688
Location: de

PostPosted: Sun Nov 25, 2012 6:38 pm    Post subject: Reply with quote

e16

D.h. das Desktop Environment greift nicht in meine Konfiguration ein. Die Konfiguration der Schriftarten erfolgt nur über X.

Ach ja, installierte xorg-server-Version ist 1.13.0
Code:
eix xorg-server
[I] x11-base/xorg-server
     Available versions:  1.9.5-r1 1.10.6-r1 1.11.4-r1 1.12.2 (~)1.12.3 (~)1.12.4 (~)1.13.0 {{dmx doc ipv6 kdrive minimal nptl selinux static-libs tslib +udev xnest xorg xvfb}}
     Installed versions:  1.13.0(22:13:11 24.09.2012)(doc nptl udev xorg -dmx -ipv6 -kdrive -minimal -selinux -static-libs -tslib -xnest -xvfb)
     Homepage:            http://xorg.freedesktop.org/
     Description:         X.Org X servers
Back to top
View user's profile Send private message
Christian99
Veteran
Veteran


Joined: 28 May 2009
Posts: 1016

PostPosted: Sun Nov 25, 2012 7:06 pm    Post subject: Reply with quote

hm, du kannst ja mal per hand versuchen das umzustellen mit "setxkbmap". Ich weiß aber nicht genau wie das funktioniert, weiß nur dass es das gibt.
Viel Erfolg!
Back to top
View user's profile Send private message
musv
Advocate
Advocate


Joined: 01 Dec 2002
Posts: 2688
Location: de

PostPosted: Sun Nov 25, 2012 7:55 pm    Post subject: Reply with quote

Im Debian-Forum soll es angeblich mit:
Code:
setxkbmap -variant "basic"

funktionieren. Tat es bei mir leider nicht.

Update:
http://www.mail-archive.com/gentoo-user@lists.gentoo.org/msg133035.html
Demnach scheint wohl xkbmap irgendwie kaputt zu sein.

Update2:
https://bugs.freedesktop.org/show_bug.cgi?id=9752
Quote:
Jon TURNEY 2012-07-23 12:55:25 UTC
(In reply to comment #12)
> Sorry, you are right. Anyone would have any objections?

I also have a german end-user requesting that tilde not be a dead key in the german keyboard layout, (see [1] and following, and excuse my xkeyboard-config ignorance), so changing the default so tilde is not a deadkey, or adding an option for that, seems like a good idea.

[1] http://cygwin.com/ml/cygwin-xfree/2011-08/msg00040.html
Comment 14
Sergey V. Udaltsov 2012-08-05 18:54:47 UTC
Ok, committed that fix. Please check

*Grmpf!*
Denken die Leute auch mal etwas nach?


Last edited by musv on Mon Nov 26, 2012 3:55 pm; edited 1 time in total
Back to top
View user's profile Send private message
Christian99
Veteran
Veteran


Joined: 28 May 2009
Posts: 1016

PostPosted: Sun Nov 25, 2012 8:47 pm    Post subject: Reply with quote

wenn ich das richtig verstehe, ist das problem, dass die tilde kein deadkey im deutschen Layout ist. Gehn denn die anderen deadkeys?
Back to top
View user's profile Send private message
schmidicom
Veteran
Veteran


Joined: 09 Mar 2006
Posts: 1051
Location: Schweiz

PostPosted: Mon Nov 26, 2012 10:19 am    Post subject: Reply with quote

Nur so aus neugier, gibt es in der deutschen Sprache überhaupt einen Buchstaben der mit einem Tilde kombiniert werden muss/kann?

Auf Wikipedia habe ich das hier gefunden:
Quelle: http://de.wikipedia.org/wiki/Tottaste
Quote:
Auf deutschen Tastaturen ist noch der Zirkumflex (»^«) und die Tilde (»~«) oft als Tottaste ausgeführt. Allerdings stirbt die Tilde als Tottaste auf deutschen Tastaturen aus, da kaum noch ein Tastaturtreiber sie als Tottaste aufführt.

_________________
Mich braucht jeder. Zumindest behaupten viele, ich hätte gerade noch gefehlt. ;)
GPG: 0x54A19454 - Download | (0x5E2B12A0 ist veraltet)
Back to top
View user's profile Send private message
musv
Advocate
Advocate


Joined: 01 Dec 2002
Posts: 2688
Location: de

PostPosted: Mon Nov 26, 2012 11:06 am    Post subject: Reply with quote

Christian99 wrote:
wenn ich das richtig verstehe, ist das problem, dass die tilde kein deadkey im deutschen Layout ist. Gehn denn die anderen deadkeys?

Ja, die anderen gehen noch. Das ^ hab ich nicht probiert (bin grad wieder auf Arbeit).

schmidicom wrote:
Nur so aus neugier, gibt es in der deutschen Sprache überhaupt einen Buchstaben der mit einem Tilde kombiniert werden muss/kann?

Einer der größten Vorteile unter Linux ist für mich, dass ich nicht jedes Mal die Tastatur umschalten muss, wenn ich ein paar Sonderzeichen tippen will. Auch die dämlichen Alt+xxx-Codes aus Windows kann und will ich mir nicht merken. Für mich war das bisherige Verhalten des Dead Keys eigentlich perfekt. Die Änderung betrachte ich als Bug.
Back to top
View user's profile Send private message
Christian99
Veteran
Veteran


Joined: 28 May 2009
Posts: 1016

PostPosted: Mon Nov 26, 2012 12:21 pm    Post subject: Reply with quote

Hm, also ich persönlcih brauche die tilde häufiger als nodeadkey, wie vermutlich viele nutzer des deutschen tastaturlayouts. um sowas wie sonderzeichen einfach tippen zu können gibts ja sowas wie tastaturlayouts. Nicht böse sein, aber meiner meinung nach ist tilde als nondeadkey besser...
Back to top
View user's profile Send private message
musv
Advocate
Advocate


Joined: 01 Dec 2002
Posts: 2688
Location: de

PostPosted: Mon Nov 26, 2012 4:01 pm    Post subject: Reply with quote

Christian99 wrote:
Hm, also ich persönlcih brauche die tilde häufiger als nodeadkey, wie vermutlich viele nutzer des deutschen tastaturlayouts. um sowas wie sonderzeichen einfach tippen zu können gibts ja sowas wie tastaturlayouts. Nicht böse sein, aber meiner meinung nach ist tilde als nondeadkey besser...

Mag sein. Du hast auch Recht aus Deiner Sicht. Aber ~ zu tippen, war bisher ebenfalls möglich. Eine leichte Verbesserung für viele wurde sich durch eine starke Verschlechterung für wenige erkauft. Und das No-Deadkey-Layout gab es auch schon bisher.

Situation vorher:
~: benötigte 2 Tastaturanschläge, da Deadkey
ñ: benötigte ebenfalls 2 Tastaturanschläge

Situation jetzt:
~: bekommst du mit einem Tastendruck hin.
ñ: kopier ich mir jetzt aus irgendwelchen Zeichentabellen raus. 8O

Anmerkung:
Ich hab mal die Bug-ID oben von xorg korrigiert. Fehlte eine 2 am Ende.
Back to top
View user's profile Send private message
Christian99
Veteran
Veteran


Joined: 28 May 2009
Posts: 1016

PostPosted: Tue Nov 27, 2012 8:57 pm    Post subject: Reply with quote

ja, ok da hast du auch wieder recht.wenn es extra eine deadkey und nodeadkey variante gibt,dann sollte die deadkey variante auch so funktionieren...

aber du schreibst, dass es momentan gar nicht geht. ich kenn mich jetzt zwar net damit aus, weil ich es nicht verwende, abergibts nicht sowas wie einen Composekey, mit dem man sowas macht?
Back to top
View user's profile Send private message
schmidicom
Veteran
Veteran


Joined: 09 Mar 2006
Posts: 1051
Location: Schweiz

PostPosted: Wed Nov 28, 2012 6:47 am    Post subject: Reply with quote

Christian99 wrote:
Ich kenn mich jetzt zwar net damit aus, weil ich es nicht verwende, aber gibts nicht sowas wie einen Composekey, mit dem man sowas macht?

Bei den aktuellen Tastaturen gibt es keine Composetaste mehr weswegen sie mit SHIFT + AltGr simuliert wird, doch da das Tilde nur mit AltGr ohne SHIFT erreichbar ist dürfte das eine interessante Fingerakrobatik werden. ;)
_________________
Mich braucht jeder. Zumindest behaupten viele, ich hätte gerade noch gefehlt. ;)
GPG: 0x54A19454 - Download | (0x5E2B12A0 ist veraltet)
Back to top
View user's profile Send private message
Yamakuzure
Veteran
Veteran


Joined: 21 Jun 2006
Posts: 1447
Location: Bardowick, Germany

PostPosted: Wed Nov 28, 2012 12:02 pm    Post subject: Reply with quote

Man kann die Compose-Taste auch einstellen. Bei mir ist es die linke Windows Taste, und so ergibt LWin+AltGr+~, dann 'n' nun 'ñ'.

Aus meiner /etc/X11/xorg.conf:
Code:
Section "InputClass"
    Identifier  "keyboard-all_de"
    Driver      "evdev"
    Option      "XkbLayout"  "de"
    Option      "XkbOptions" "compose:lwin"
    MatchIsKeyboard "on"
EndSection

_________________
systemd - The biggest fallacies
Back to top
View user's profile Send private message
musv
Advocate
Advocate


Joined: 01 Dec 2002
Posts: 2688
Location: de

PostPosted: Thu Nov 29, 2012 7:25 am    Post subject: Reply with quote

Danke für die Info. Die Lösung werd ich mir im Hinterkopf behalten.

Der Thread bei bugs.freedesktop.org hat sich in die Richtung entwickelt. dass sich wohl die Befürworter der Tilde-Nicht-Deadkey-Variante durchsetzen, da es eher der Din-Norm für die deutsche Tastatur entspricht.

Dumm ist dann nur, dass in der Konsole außerhalb von X in der Defaultvariante die Tilde wie gewohnt ein Deadkey ist. Das ergibt dann das Potential für ein unterschiedliches Verhalten bei so hübschen Ausdrücken wie:

Tilde als Deadkey - Konsole:
rm -rf ~/irgendwas


und

Tilde als Nodeadkey - X:
rm -rf ~ /irgendwas

Ich hab's für mich erst mal insofern gelöst, dass ich:
Code:
[I] x11-misc/xkeyboard-config
     Available versions:  2.1 2.2.1-r1 2.3 2.4.1-r2 2.4.1-r3 (~)2.5 (~)2.5.1 2.6 [m](~)2.7
     Installed versions:  2.6(23:38:52 28.11.2012)
     Homepage:            http://www.freedesktop.org/wiki/Software/XKeyboardConfig
     Description:         X keyboard configuration database

in Version 2.7 maskiert hab.
Back to top
View user's profile Send private message
Max Steel
Veteran
Veteran


Joined: 12 Feb 2007
Posts: 1953
Location: My own world! I and Gentoo!

PostPosted: Thu Nov 29, 2012 8:18 am    Post subject: Reply with quote

musv wrote:
Danke für die Info. Die Lösung werd ich mir im Hinterkopf behalten.

Der Thread bei bugs.freedesktop.org hat sich in die Richtung entwickelt. dass sich wohl die Befürworter der Tilde-Nicht-Deadkey-Variante durchsetzen, da es eher der Din-Norm für die deutsche Tastatur entspricht.

Dumm ist dann nur, dass in der Konsole außerhalb von X in der Defaultvariante die Tilde wie gewohnt ein Deadkey ist. Das ergibt dann das Potential für ein unterschiedliches Verhalten bei so hübschen Ausdrücken wie


In der Konsole gibt es auch beide Varianten. das eine Keymap heißt de, das andere keymap de-latin1
_________________
mfg
Steel
___________________
Big sorry for my bad English.

Heim-PC: AMD Phenom II X4 3,2GHz, 16GB RAM, gentoo-sources-3.10.7, NV GTX 780
Laptop: Intel Celeron 1,7GHz, 512MB Ram, tuxonice-sources-3.7.1, SIS Graphic

Version 0.4
Back to top
View user's profile Send private message
musv
Advocate
Advocate


Joined: 01 Dec 2002
Posts: 2688
Location: de

PostPosted: Thu Nov 29, 2012 10:05 pm    Post subject: Reply with quote

Max Steel wrote:
In der Konsole gibt es auch beide Varianten. das eine Keymap heißt de, das andere keymap de-latin1

Schon klar. Bei der einen Variante in der Konsole ist die Tilde ein Deadkey. Im X ist das nicht mehr der Fall, egal welche Variante du wählst.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum