Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Kernel] VFS Cannot open root device (yet an other) [Solved]
View unanswered posts
View posts from last 24 hours

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
Mickael
Advocate
Advocate


Joined: 05 Sep 2005
Posts: 2383
Location: ~Belfort! - France - EU

PostPosted: Wed Nov 21, 2012 11:34 am    Post subject: [Kernel] VFS Cannot open root device (yet an other) [Solved] Reply with quote

Bonjour,

suite à une grosse mise à jour, passage à la famille 3* des noyaux je rencontre un soucis, un tout petit, petit, soucis : un bon vieux kernel panic.

je vous donne l'erreur :
Quote:
VFS : Cannot open root device "(NULL)" or unknown block (0,0): error -6
Please append a correct "root=" boot option;
...
etc la table de partition du portable
...
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0) <-- vous voyez je ne vous ai pas menti :)!!
Pid: 1, comm: swapper/0 Not tainted 3.4.11-tuxonice #3
Call Trace:
etcetc


Je suis sur mon portable DELL inspiron 6400 avec gentoo installé dessus depuis des lustres. Qu'ai-je fais, j'étais sur un noyau 2.6, passage au 3.4.11-tuxonice à la mano comme j'avais l'habitude de le faire. J'ai fait un old config, j'avais pris soins de rajouter les deux options pour udev, j'étais déjà pour le 2.6 en SATA (vous vous souvenez la migration de pata à sata, et bien tout fonctionnait très bien pour moi dès le début). C'est pourquoi je reste perplexe et à force de lire et relire et bien je ne parviens plus à prendre du recul....

je suis avec attention depuis le début les deux threads de augustin2 :


mais en vain je sèche.

la sortie de lspci -k :
Code:

00:00.0 Host bridge: Intel Corporation Mobile 945GM/PM/GMS, 943/940GML and 945GT Express Memory Controller Hub (rev 03)
   Subsystem: Dell Device 01bd
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03)
   Subsystem: Dell Device 01bd
00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller (rev 03)
   Subsystem: Dell Device 01bd
00:1b.0 Audio device: Intel Corporation NM10/ICH7 Family High Definition Audio Controller (rev 01)
   Subsystem: Dell Device 01bd
   Kernel driver in use: snd_hda_intel
00:1c.0 PCI bridge: Intel Corporation NM10/ICH7 Family PCI Express Port 1 (rev 01)
   Kernel driver in use: pcieport
00:1c.3 PCI bridge: Intel Corporation NM10/ICH7 Family PCI Express Port 4 (rev 01)
   Kernel driver in use: pcieport
00:1d.0 USB controller: Intel Corporation NM10/ICH7 Family USB UHCI Controller #1 (rev 01)
   Subsystem: Dell Device 01bd
   Kernel driver in use: uhci_hcd
00:1d.1 USB controller: Intel Corporation NM10/ICH7 Family USB UHCI Controller #2 (rev 01)
   Subsystem: Dell Device 01bd
   Kernel driver in use: uhci_hcd
00:1d.2 USB controller: Intel Corporation NM10/ICH7 Family USB UHCI Controller #3 (rev 01)
   Subsystem: Dell Device 01bd
   Kernel driver in use: uhci_hcd
00:1d.3 USB controller: Intel Corporation NM10/ICH7 Family USB UHCI Controller #4 (rev 01)
   Subsystem: Dell Device 01bd
   Kernel driver in use: uhci_hcd
00:1d.7 USB controller: Intel Corporation NM10/ICH7 Family USB2 EHCI Controller (rev 01)
   Subsystem: Dell Device 01bd
   Kernel driver in use: ehci_hcd
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev e1)
00:1f.0 ISA bridge: Intel Corporation 82801GBM (ICH7-M) LPC Interface Bridge (rev 01)
   Subsystem: Dell Device 01bd
00:1f.2 IDE interface: Intel Corporation 82801GBM/GHM (ICH7-M Family) SATA Controller [IDE mode] (rev 01)
   Subsystem: Dell Device 01bd
   Kernel driver in use: ata_piix
00:1f.3 SMBus: Intel Corporation NM10/ICH7 Family SMBus Controller (rev 01)
   Subsystem: Dell Device 01bd
03:00.0 Ethernet controller: Broadcom Corporation BCM4401-B0 100Base-TX (rev 02)
   Subsystem: Dell Inspiron 6400
   Kernel driver in use: b44
03:01.0 FireWire (IEEE 1394): Ricoh Co Ltd R5C832 IEEE 1394 Controller
   Subsystem: Dell Device 01bd
03:01.1 SD Host controller: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter (rev 19)
   Subsystem: Dell Device 01bd
   Kernel driver in use: sdhci-pci
03:01.2 System peripheral: Ricoh Co Ltd R5C843 MMC Host Controller (rev 01)
   Subsystem: Dell Device 01bd
   Kernel driver in use: sdhci-pci
03:01.3 System peripheral: Ricoh Co Ltd R5C592 Memory Stick Bus Host Adapter (rev 0a)
   Subsystem: Dell Device 01bd
03:01.4 System peripheral: Ricoh Co Ltd xD-Picture Card Controller (rev 05)
   Subsystem: Dell Device 01bd
0b:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG [Golan] Network Connection (rev 02)
   Subsystem: Intel Corporation Device 1021
   Kernel driver in use: iwl3945


la sortie de lspci -k :
Code:

00:00.0 0600: 8086:27a0 (rev 03)
00:02.0 0300: 8086:27a2 (rev 03)
00:02.1 0380: 8086:27a6 (rev 03)
00:1b.0 0403: 8086:27d8 (rev 01)
00:1c.0 0604: 8086:27d0 (rev 01)
00:1c.3 0604: 8086:27d6 (rev 01)
00:1d.0 0c03: 8086:27c8 (rev 01)
00:1d.1 0c03: 8086:27c9 (rev 01)
00:1d.2 0c03: 8086:27ca (rev 01)
00:1d.3 0c03: 8086:27cb (rev 01)
00:1d.7 0c03: 8086:27cc (rev 01)
00:1e.0 0604: 8086:2448 (rev e1)
00:1f.0 0601: 8086:27b9 (rev 01)
00:1f.2 0101: 8086:27c4 (rev 01)
00:1f.3 0c05: 8086:27da (rev 01)
03:00.0 0200: 14e4:170c (rev 02)
03:01.0 0c00: 1180:0832
03:01.1 0805: 1180:0822 (rev 19)
03:01.2 0880: 1180:0843 (rev 01)
03:01.3 0880: 1180:0592 (rev 0a)
03:01.4 0880: 1180:0852 (rev 05)
0b:00.0 0280: 8086:4222 (rev 02)


le grub.conf :
Code:

default 0
timeout 30

title 3.4.11-tuxonice
root (hd0,4)
kernel /boot/vmlinuz-3.4.11-tuxonice real_root=/dev/sda7 resume2=swap:/dev/sda6

title 2.6.36-tuxonice-r4
root (hd0,4)
kernel /boot/vmlinuz-2.6.36-tuxonice-r4 real_root=/dev/sda7 resume2=swap:/dev/sda6

title WindowsMediaCenter
rootnoverify (hd0,1)
makeactive
chainloader +1


le fstab :
Code:

# /etc/fstab: static file system information.
#
# noatime turns off atimes for increased performance (atimes normally aren't
# needed; notail increases performance of ReiserFS (at the expense of storage
# efficiency).  It's safe to drop the noatime options if you want and to
# switch between notail / tail freely.
#
# The root filesystem should have a pass number of either 0 or 1.
# All other filesystems should have a pass number of 0 or greater than 1.
#
# See the manpage fstab(5) for more information.
#

# <fs>         <mountpoint>   <type>      <opts>      <dump/pass>

# NOTE: If your BOOT partition is ReiserFS, add the notail option to opts.
/dev/sda5      /boot      ext2      defaults,noatime   1 2
/dev/sda7      /      ext3      noatime      0 1
/dev/sda6      none      swap      sw      0 0
#/dev/cdroms/cdrom0   /mnt/cdrom   iso9660      noauto,ro   0 0
#/dev/fd0      /mnt/floppy   auto      noauto      0 0

# NOTE: The next line is critical for boot!
proc         /proc      proc      defaults   0 0

# glibc 2.2 and above expects tmpfs to be mounted at /dev/shm for
# POSIX shared memory (shm_open, shm_unlink).
# (tmpfs is a dynamically expandable/shrinkable ramdisk, and will
#  use almost no memory if not populated with files)
shm         /dev/shm   tmpfs      nodev,nosuid,noexec   0 0

#/dev/sda8      /media/DATA   vfat      auto,rw,user,exec,uid=1000,gid=456   0 0
#/dev/sda8              /media/DATA     vfat            auto,rw,user,exec,uid=1000     0 0
/dev/sda8              /mnt/DATA     vfat            auto,rw,user,exec,uid=1000     0 0
#UUID=7e0753db-8f87-41fc-aff2-4b7d2928652c  /media/SysRescue ext3 auto,rw,user,exec     0 0

#firefox /home/mickael/.mozilla/firefox/4xhl677a.default tmpfs size=64M,noauto,user,exec,uid=1000,gid=100 0 0


Pour info le liveCD Gentoo charge ata_piix.
Comme un c** j'ai copier ma config du noyau et pensant faire un grep dessus par la suite sur le pc de ma compagne, mais elle sous windows7 quel con, je chroot et je me tiens près à tous les zgre et grep -i que vous voulez voir.

EDIT 1 :
Le site Debian HCL ne m'aide pas beaucoup :
Quote:
808627c4 Oui Intel Corporation 82801GBM/GHM (ICH7-M Family) SATA Controller [IDE mode] ata_piix v2.6.25
il me donne l'infi pour la famille 2.6 des noyaux... grrrrrr
_________________
À LIRE : COMMENT POSTER ET OBTENIR DE L'AIDE ?
Qui suis-je ? Bon j'ai relu, comme d'habitude, je suis bon a rien le vendredi
Qui suis-je ? Je ne serai jamais modo


Last edited by Mickael on Sat Dec 01, 2012 2:06 pm; edited 1 time in total
Back to top
View user's profile Send private message
kopp
Advocate
Advocate


Joined: 09 Apr 2004
Posts: 2869
Location: Grenoble, France

PostPosted: Wed Nov 21, 2012 11:51 am    Post subject: Reply with quote

Salut,

j'ai une machine très similaire (640m) avec a priori les mêmes contrôleurs, et j'utilise ata_piix et ça marche.

Je sais, ça n'aide pas beaucoup mais bon. Si tu as d'autres questions sur la config que j'ai pour que ça fonctionne, n'hésite pas (je suis aussi en 3.4.11)

Après, si ça vient de grub, je ne sais pas !

Sinon, je ne crois pas que le message soit comme ça lorsque le noyau ne supporte pas le système de fichier, mais as tu vérifié que ça n'avait pas bougé et que tu as bien tout ?
Back to top
View user's profile Send private message
El_Goretto
Advocate
Advocate


Joined: 29 May 2004
Posts: 2881
Location: Paris

PostPosted: Wed Nov 21, 2012 12:25 pm    Post subject: Reply with quote

Yep, je vote un rattage du make oldconfig, car de mémoire ya un "sous-arbre" qui a du apparaître au cours du temps dans la partie SATA (ATA SFF support), conditionnant "l'apparition" des drivers usuels (dont ata_piix).
_________________
-PC: 2500K/P8Z68V, 8Go, R9-290, ARC1220+5xWD500RE3, M4 256Go
-Home servers (hardened): µ-serv N40L, 2Go ECC ; NF9D-2700, 4Go ; DS61, i3 2100T, 16Go
-Réseau: ERL-3 + 3x switches GS108Tv2
-NAS: RN312
http://boycottsystemd.org/
Back to top
View user's profile Send private message
Mickael
Advocate
Advocate


Joined: 05 Sep 2005
Posts: 2383
Location: ~Belfort! - France - EU

PostPosted: Wed Nov 21, 2012 1:10 pm    Post subject: Reply with quote

Salut vous deux,

@Kopp : c'est bien le problème : ai je bien tout :)
@El_Goretto : ok mais je vous file quoi comme info?

aller je viens d'installer sous winwin windowsgrep (pas dy cyguin, pas du gnuwin32) je fais au plus pressé :)

un windowsgrep avec SATA sur la config du noyau 3 :
Quote:


01164: CONFIG_SATA_PMP=y
01169: CONFIG_SATA_AHCI=y
01170: CONFIG_SATA_AHCI_PLATFORM=y
01171: # CONFIG_SATA_INIC162X is not set
01172: CONFIG_SATA_ACARD_AHCI=y
01173: # CONFIG_SATA_SIL24 is not set
01180: # CONFIG_SATA_QSTOR is not set
01181: # CONFIG_SATA_SX4 is not set
01185: # SATA SFF controllers with BMDMA
01188: # CONFIG_SATA_MV is not set
01189: # CONFIG_SATA_NV is not set
01190: # CONFIG_SATA_PROMISE is not set
01191: # CONFIG_SATA_SIL is not set
01192: # CONFIG_SATA_SIS is not set
01193: CONFIG_SATA_SVW=y
01194: # CONFIG_SATA_ULI is not set
01195: # CONFIG_SATA_VIA is not set
01196: # CONFIG_SATA_VITESSE is not set


toujours avec windowsgrep PIIX me dit :
Quote:


01187: CONFIG_ATA_PIIX=y
01225: CONFIG_PATA_OLDPIIX=y
01245: CONFIG_PATA_MPIIX=y
01702: # CONFIG_I2C_PIIX4 is not set



EDIT 1 :

de ce que je peux voir depuis mon portable sous gentoo, en faisant make menuconfig :
/piix wrote:

01187: CONFIG_ATA_PIIX=y : je confirme ATA_PIIX [=y]avec l'arborescence Device Drivers>Serial ATA [y]> ATA SFF [y]> ATA DMDMA [y]



EDIT 2 :

je me demande si dans le résultat windowsgrep PIIX
les deux dernières lignes ne seraient pas à l'origine d'un conflit et le noyau n'utilise pas ATA_PIIX :
Quote:


01187: CONFIG_ATA_PIIX=y
01225: CONFIG_PATA_OLDPIIX=y
01245: CONFIG_PATA_MPIIX=y

01702: # CONFIG_I2C_PIIX4 is not set



EDIT 3 :
@Boozo : oui mais tu sais comme on est, avec nos vieilles habitudes :) sinon pour ta proposition mon p'tit problème est bien je check check et je recheck encore et encore :)

et en plus je vous fais des réponses avec du texte en gras, en couleur à la Word c'est pas ti mignon tout ça ?
_________________
À LIRE : COMMENT POSTER ET OBTENIR DE L'AIDE ?
Qui suis-je ? Bon j'ai relu, comme d'habitude, je suis bon a rien le vendredi
Qui suis-je ? Je ne serai jamais modo


Last edited by Mickael on Wed Nov 21, 2012 1:33 pm; edited 5 times in total
Back to top
View user's profile Send private message
boozo
Advocate
Advocate


Joined: 01 Jul 2004
Posts: 3141

PostPosted: Wed Nov 21, 2012 1:28 pm    Post subject: Reply with quote

El_Goretto wrote:
Yep, je vote un rattage du make oldconfig, car de mémoire ya un "sous-arbre" qui a du apparaître au cours du temps dans la partie SATA (ATA SFF support), conditionnant "l'apparition" des drivers usuels (dont ata_piix).

+1.
Les arborescences et les options ont pas mal changé depuis ton dernier 2.6 (->3.0->3.2->3.4->...) amha, tu pousses un chouilla de lui demander de faire un tel saut d'un coup au oldconfig.

Tout rechecker à la main en menuconfig (20,30min) et pis c'est tout ! :twisted:

Edit: Sur ce segment, je crois que tu dois avoir uniquement :
Code:
CONFIG_ATA_SFF=y
CONFIG_ATA_BMDMA=y
CONFIG_ATA_PIIX=y

_________________
" Un psychotique, c'est quelqu'un qui croit dur comme fer que 2 et 2 font 5, et qui en est pleinement satisfait.
Un névrosé, c'est quelqu'un qui sait pertinemment que 2 et 2 font 4, et ça le rend malade ! "
Back to top
View user's profile Send private message
Mickael
Advocate
Advocate


Joined: 05 Sep 2005
Posts: 2383
Location: ~Belfort! - France - EU

PostPosted: Wed Nov 21, 2012 1:40 pm    Post subject: Reply with quote

Boozo :

j'ai pour le SFF :
Quote:


01167: # Controllers with non-SFF native interface
01174: CONFIG_ATA_SFF=y
01177: # SFF controllers with custom DMA interface
01185: # SATA SFF controllers with BMDMA
01199: # PATA SFF controllers with BMDMA
01242: # PIO-only SFF controllers
 

pour le BMDMA :
Quote:


01182: CONFIG_ATA_BMDMA=y
01185: # SATA SFF controllers with BMDMA
01199: # PATA SFF controllers with BMDMA
 


et pour le PIIX :
Quote:

voir ma réponse plus haut


EDIT :
Quote:

01187: CONFIG_ATA_PIIX=y
01225: CONFIG_PATA_OLDPIIX=y ne vont ils pas de paire, maintenant ces deux là PIIX et OLDPIIX LA réponse est non puisque chacun deux sont proposés dans le noyau, je vire le vieux donc.
01245: CONFIG_PATA_MPIIX=y et maintenant à no

01702: # CONFIG_I2C_PIIX4 is not set

_________________
À LIRE : COMMENT POSTER ET OBTENIR DE L'AIDE ?
Qui suis-je ? Bon j'ai relu, comme d'habitude, je suis bon a rien le vendredi
Qui suis-je ? Je ne serai jamais modo


Last edited by Mickael on Wed Nov 21, 2012 2:17 pm; edited 1 time in total
Back to top
View user's profile Send private message
boozo
Advocate
Advocate


Joined: 01 Jul 2004
Posts: 3141

PostPosted: Wed Nov 21, 2012 2:02 pm    Post subject: Reply with quote

Oui comme tu le disais, je te confirme que je n'ai que ces 3 lignes (+ l'APCI mais c'est pas le soucis).
Le conflit majeur doit venir de tes 2 lignes CONFIG_PATA_
Edit: pour résumer donc
Code:
CONFIG_ATA=y
CONFIG_ATA_ACPI=y
CONFIG_ATA_SFF=y
CONFIG_ATA_BMDMA=y
CONFIG_ATA_PIIX=y


Edit: çà va que j'ai l'habitude de relire les posts :P Oué c'est p.e. normal de ne plus la retrouver dans l'arborescence si la structure du fichier est bancale - sinon voila ce que je lis
Quote:
│ Symbol: PATA_OLDPIIX [=n] │
│ Type : tristate │
│ Prompt: Intel PATA old PIIX support │
│ Defined at drivers/ata/Kconfig:565 │
│ Depends on: ATA [=y] && ATA_SFF [=y] && ATA_BMDMA [=y] && PCI [=y] │
│ Location: │
│ -> Device Drivers │
│ -> Serial ATA and Parallel ATA drivers (ATA [=y]) │
│ -> ATA SFF support (ATA_SFF [=y]) │
│ -> ATA BMDMA support (ATA_BMDMA [=y])

_________________
" Un psychotique, c'est quelqu'un qui croit dur comme fer que 2 et 2 font 5, et qui en est pleinement satisfait.
Un névrosé, c'est quelqu'un qui sait pertinemment que 2 et 2 font 4, et ça le rend malade ! "
Back to top
View user's profile Send private message
El_Goretto
Advocate
Advocate


Joined: 29 May 2004
Posts: 2881
Location: Paris

PostPosted: Wed Nov 21, 2012 2:28 pm    Post subject: Reply with quote

Argh, bon, je te laisse entre de bonnes mains, je peux pas lutter, j'ai les yeux qui bifurquent avec tous ces edit ;)
En tout cas oui, c'est de ces options dont je parlais.
_________________
-PC: 2500K/P8Z68V, 8Go, R9-290, ARC1220+5xWD500RE3, M4 256Go
-Home servers (hardened): µ-serv N40L, 2Go ECC ; NF9D-2700, 4Go ; DS61, i3 2100T, 16Go
-Réseau: ERL-3 + 3x switches GS108Tv2
-NAS: RN312
http://boycottsystemd.org/
Back to top
View user's profile Send private message
Mickael
Advocate
Advocate


Joined: 05 Sep 2005
Posts: 2383
Location: ~Belfort! - France - EU

PostPosted: Wed Nov 21, 2012 2:30 pm    Post subject: Reply with quote

boozo wrote:
Oui comme tu le disais, je te confirme que je n'ai que ces 3 lignes (+ l'APCI mais c'est pas le soucis).
Le conflit majeur doit venir de tes 2 lignes CONFIG_PATA_
Edit: pour résumer donc
Code:
CONFIG_ATA=y
CONFIG_ATA_ACPI=y
CONFIG_ATA_SFF=y
CONFIG_ATA_BMDMA=y
CONFIG_ATA_PIIX=y


Edit: çà va que j'ai l'habitude de relire les posts :P Oué c'est p.e. normal de ne plus la retrouver dans l'arborescence si la structure du fichier est bancale - sinon voila ce que je lis
Quote:
│ Symbol: PATA_OLDPIIX [=n] │
│ Type : tristate │
│ Prompt: Intel PATA old PIIX support │
│ Defined at drivers/ata/Kconfig:565 │
│ Depends on: ATA [=y] && ATA_SFF [=y] && ATA_BMDMA [=y] && PCI [=y] │
│ Location: │
│ -> Device Drivers │
│ -> Serial ATA and Parallel ATA drivers (ATA [=y]) │
│ -> ATA SFF support (ATA_SFF [=y]) │
│ -> ATA BMDMA support (ATA_BMDMA [=y])


je l'avais retrouvé merci :) j'ai recompilé et rebooté et rechrooté ===> toujours pareil kernel panic :/
et je confirme que seul ATA_PIIX est en dure dans le noyau.... tssssss
_________________
À LIRE : COMMENT POSTER ET OBTENIR DE L'AIDE ?
Qui suis-je ? Bon j'ai relu, comme d'habitude, je suis bon a rien le vendredi
Qui suis-je ? Je ne serai jamais modo
Back to top
View user's profile Send private message
boozo
Advocate
Advocate


Joined: 01 Jul 2004
Posts: 3141

PostPosted: Wed Nov 21, 2012 2:44 pm    Post subject: Reply with quote

Ben oui mais après y'a peut-être d'autres m***** qui traines c'est pourquoi je te disais de repartir from scratch au début :lol:
Si tu veux mon avis : split l'écran ouvre toi 2 menuconfig et passe en revue toutes les options one-by-one c'est encore le plus rapide et le plus sûr à mon sens. Mais après si tu veux tenter le hold-up
Les supports de FS sont ok ? notamment en plus de ext2,3, etc
Code:
CONFIG_PROC_FS=y
CONFIG_SYSFS=y
CONFIG_TMPFS=y
CONFIG_TMPFS_POSIX_ACL=y
CONFIG_TMPFS_XATTR=y


ps:/ Au fait juste au cas où : tu la copie bien à chaque fois avec /boot monté la quenelle ? et avec le bon nom dans grub.conf... ^^

Edit: ah ? même kopp à du mal à suivre les edit croisés dynamiques :mrgreen:
_________________
" Un psychotique, c'est quelqu'un qui croit dur comme fer que 2 et 2 font 5, et qui en est pleinement satisfait.
Un névrosé, c'est quelqu'un qui sait pertinemment que 2 et 2 font 4, et ça le rend malade ! "


Last edited by boozo on Wed Nov 21, 2012 2:53 pm; edited 1 time in total
Back to top
View user's profile Send private message
kopp
Advocate
Advocate


Joined: 09 Apr 2004
Posts: 2869
Location: Grenoble, France

PostPosted: Wed Nov 21, 2012 2:46 pm    Post subject: Reply with quote

perso, le PATA, c'est en deprecated et tout est off ! (le ATA/ATAPI/... est sur N)
Code:

zgrep ATA /proc/config.gz | grep "=y"
CONFIG_ATA=y
CONFIG_ATA_VERBOSE_ERROR=y
CONFIG_ATA_ACPI=y
CONFIG_ATA_SFF=y
CONFIG_ATA_BMDMA=y
CONFIG_ATA_PIIX=y
CONFIG_DEBUG_RODATA=y
Back to top
View user's profile Send private message
Mickael
Advocate
Advocate


Joined: 05 Sep 2005
Posts: 2383
Location: ~Belfort! - France - EU

PostPosted: Wed Nov 21, 2012 4:13 pm    Post subject: Reply with quote

j'arrête les EDIT croisés dynamiques :) promis

Koop j'ai bel et bien virés tout ce qui était en PATA cad les deux options en trop que j'avais (cf les edit croisés dynamiques), pour ce qui est de la branche Device Drivers > ATA/ATAPI/MFM/RLL support (DEPRECATED) c'est bien à off aussi (j'ai sous les yeux mon make menuconfig ouvert sur ma gentoo)
_________________
À LIRE : COMMENT POSTER ET OBTENIR DE L'AIDE ?
Qui suis-je ? Bon j'ai relu, comme d'habitude, je suis bon a rien le vendredi
Qui suis-je ? Je ne serai jamais modo
Back to top
View user's profile Send private message
Mickael
Advocate
Advocate


Joined: 05 Sep 2005
Posts: 2383
Location: ~Belfort! - France - EU

PostPosted: Wed Nov 21, 2012 5:02 pm    Post subject: Reply with quote

Boozo,

je viens de vérifier la liste pour les fs directement sur la machine concernée, et oui ce que tu me proposes et bel et bien dans le noyau, avec en plus ext2/3 etcetcetc. Pour le grub, ben je l'ai donné au dessus, et pour moi y'a pas d'erreur; la ligne pour le kernel 2.6 fonctionnait et à toujours fonctionnée. Maintenant si il y a une erreur je ne la vois pas. Je compile avec make && make modules_install && make install, ma partition boot est montée (pour rappel je chroot en ce moment : mount /dev/sad5 /mnt/gentoo/boot) et lorsque tout va bien elle est montée au démarrage du pc (voir fstab).

Maintenant si le suchi est avec grub quel est il? grub lui même? étrange, le code erreur qui correspond au kernel panic est envoyée par le kernel, donc pourquoi grub serait en cause à ce moment? JE POSE LA QUESTION avec la plus grande HUMILITE. Même si lors de la mise à jour, grub2 fut installé, jamais de n'ai fait de update to grub2 :: serait-ce là un problème? dois-je mettre grub-legacy explicitement? Je dis cela car emerge ne voit pas mon vieux grub0.97-r10 mais eix oui (update eix fait).

Une autre question pour chrooter je fais :
Code:

mount /dev/sda7 /mnt/gentoo
mount /dev/sda5 /mnt/gentoo/boot
mount -t proc none /mnt/gentoo/proc
mount --rbind /sys /mnt/gentoo/sys
mount --rbind /dev /mnt/gentoo/dev
chroot /mnt/gentoo /bin/bash
env-update
source /etc/profile
export PS1="(chroot) $PS1"


si je vais ensuite dans /usr/src/linux puis, make menuconfig, puis /piix par exemple j'ai comme réponse un seul [y] pour ATA_PIIX. Maintenant si je fais zgrep PIIX /proc/config.gz j'obtiens une réponse qui me gêne : CONFIG_ATA_PIIX=m CONFIG_ATA_MPIIX=m. Et je n'aime pas cette réponse. De là vous pouvez me dire que je n'ai pas choisi General setup --->[*] Kernel .config support[*] Enable access to .config through /proc/config.gz mais voilà je l'ai et en dur en plus :/ c'est étrange............ serais-je en train de lire le proc du liveCD (ceci peut être une énorme connerie je vous préviens soyez sympa). ou alors config.gz est écrite une fois que j'ai booté pour la première fois, avec mon nouveau noyau. Pour faire simple je suis complètement largué .......... :evil:
_________________
À LIRE : COMMENT POSTER ET OBTENIR DE L'AIDE ?
Qui suis-je ? Bon j'ai relu, comme d'habitude, je suis bon a rien le vendredi
Qui suis-je ? Je ne serai jamais modo
Back to top
View user's profile Send private message
boozo
Advocate
Advocate


Joined: 01 Jul 2004
Posts: 3141

PostPosted: Wed Nov 21, 2012 5:28 pm    Post subject: Reply with quote

hébé çà fume ! :lol:

Bon fs ok donc.
Pour grub.conf je parlais de juste de la correspondance avec le nom du bzImage dans /boot mais si c'est bon ok (des fois on se plante comme on oubli de copier le dernier noyau re-(re-)recompilé :wink:

Par contre le /proc/config.gz te renvois la conf embarquée dans le noyau en cours d'utilisation donc ras c'est le livecd et pas ton /usr/src/linux/.config dans le chroot.

Sinon là tout de suite, je ne sais pas trop vers quoi d'autre t'orienter comme option à vérifier ; et qui soit susceptible de causer ce kernel panic... /me réfléchis

Edit: J'y pense donc je le note en attendant, perso je virerais ce qui ne sert à rien pour l'instant et pourrait parasiter i.e. l'option "resume2=swap:/dev/sda6" dans la ligne de boot
_________________
" Un psychotique, c'est quelqu'un qui croit dur comme fer que 2 et 2 font 5, et qui en est pleinement satisfait.
Un névrosé, c'est quelqu'un qui sait pertinemment que 2 et 2 font 4, et ça le rend malade ! "
Back to top
View user's profile Send private message
Mickael
Advocate
Advocate


Joined: 05 Sep 2005
Posts: 2383
Location: ~Belfort! - France - EU

PostPosted: Wed Nov 21, 2012 5:59 pm    Post subject: Reply with quote

boozo wrote:
hébé çà fume ! :lol:

Edit: J'y pense donc je le note en attendant, perso je virerais ce qui ne sert à rien pour l'instant et pourrait parasiter i.e. l'option "resume2=swap:/dev/sda6" dans la ligne de boot


oui ça brule même ^^
sinon en editant grub au démarrage, en virant l'option resume2 ben le résultat est le même: kernel panic.

Kopp tu peux me filer ton .config stp.
_________________
À LIRE : COMMENT POSTER ET OBTENIR DE L'AIDE ?
Qui suis-je ? Bon j'ai relu, comme d'habitude, je suis bon a rien le vendredi
Qui suis-je ? Je ne serai jamais modo
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 5611
Location: ~Brussels - Belgique

PostPosted: Wed Nov 21, 2012 6:23 pm    Post subject: Reply with quote

Hello,

Je te conseille de repartir d'un "Kernel Seed" de Pappy + les infos de Debian HCL.
Tu perdras vachement moins de temps à chipoter ;)
_________________
Xavier Miller
(FR) Merci de respecter les règles du forum.
http://www.xaviermiller.be
Back to top
View user's profile Send private message
Mickael
Advocate
Advocate


Joined: 05 Sep 2005
Posts: 2383
Location: ~Belfort! - France - EU

PostPosted: Wed Nov 21, 2012 6:27 pm    Post subject: Reply with quote

XavierMiller wrote:
Hello,

Je te conseille de repartir d'un "Kernel Seed" de Pappy + les infos de Debian HCL.
Tu perdras vachement moins de temps à chipoter ;)


DEBIAN HCL ne sert à rien mis à part pour les noyaux 2.6 ce qui n'est pas le cas ici. Et je ne chipote pas je veux savoir pourquoi le noyau ne peut pas accèder au disque dur.
_________________
À LIRE : COMMENT POSTER ET OBTENIR DE L'AIDE ?
Qui suis-je ? Bon j'ai relu, comme d'habitude, je suis bon a rien le vendredi
Qui suis-je ? Je ne serai jamais modo
Back to top
View user's profile Send private message
boozo
Advocate
Advocate


Joined: 01 Jul 2004
Posts: 3141

PostPosted: Wed Nov 21, 2012 7:52 pm    Post subject: Reply with quote

Même après apport en protéines, j'ai pas plus de piste dsl
M'enfin en attendant que kopp passe un tête, tu peux peut-être nous coller un pastbin du .config ; sait-on jamais qu'une illumination intempestive se manifeste :P

Btw, l'option de prendre une config Seed en attendant c'est pas mal aussi
_________________
" Un psychotique, c'est quelqu'un qui croit dur comme fer que 2 et 2 font 5, et qui en est pleinement satisfait.
Un névrosé, c'est quelqu'un qui sait pertinemment que 2 et 2 font 4, et ça le rend malade ! "
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 5611
Location: ~Brussels - Belgique

PostPosted: Thu Nov 22, 2012 7:03 am    Post subject: Reply with quote

Mickael wrote:
XavierMiller wrote:
Hello,

Je te conseille de repartir d'un "Kernel Seed" de Pappy + les infos de Debian HCL.
Tu perdras vachement moins de temps à chipoter ;)


DEBIAN HCL ne sert à rien mis à part pour les noyaux 2.6 ce qui n'est pas le cas ici. Et je ne chipote pas je veux savoir pourquoi le noyau ne peut pas accèder au disque dur.


Mais bien sûr que oui ! Le noyau 3.x est un 2.6.4x ;)
_________________
Xavier Miller
(FR) Merci de respecter les règles du forum.
http://www.xaviermiller.be
Back to top
View user's profile Send private message
Mickael
Advocate
Advocate


Joined: 05 Sep 2005
Posts: 2383
Location: ~Belfort! - France - EU

PostPosted: Thu Nov 22, 2012 7:15 am    Post subject: Reply with quote

XavierMiller wrote:
Mickael wrote:
XavierMiller wrote:
Hello,

Je te conseille de repartir d'un "Kernel Seed" de Pappy + les infos de Debian HCL.
Tu perdras vachement moins de temps à chipoter ;)


DEBIAN HCL ne sert à rien mis à part pour les noyaux 2.6 ce qui n'est pas le cas ici. Et je ne chipote pas je veux savoir pourquoi le noyau ne peut pas accèder au disque dur.


Mais bien sûr que oui ! Le noyau 3.x est un 2.6.4x ;)


ce qui au final ne servira à rien puisque les modules sont les mêmes, que debian hcl me les donnes pour un 2.6.25 qui sont les mêmes que pour un 2.6.4x que pour les 3* etc etc etc donc a rien cf voir mon premier post c'est écrit. :/

pour le .config je vous le colle dans la journée, et sinon ce soir je passerai sur un config seed ou kopp (préférence pour le second le hdd controller est déjà configuré)
_________________
À LIRE : COMMENT POSTER ET OBTENIR DE L'AIDE ?
Qui suis-je ? Bon j'ai relu, comme d'habitude, je suis bon a rien le vendredi
Qui suis-je ? Je ne serai jamais modo
Back to top
View user's profile Send private message
boozo
Advocate
Advocate


Joined: 01 Jul 2004
Posts: 3141

PostPosted: Thu Nov 22, 2012 7:46 am    Post subject: Reply with quote

D'ici là, si tu veux faire un check de tes options, tu peux voir ce lien (section Recommended Linux Kernel Configurations) qui détaille/décrit un peu les indispensables :wink:
_________________
" Un psychotique, c'est quelqu'un qui croit dur comme fer que 2 et 2 font 5, et qui en est pleinement satisfait.
Un névrosé, c'est quelqu'un qui sait pertinemment que 2 et 2 font 4, et ça le rend malade ! "
Back to top
View user's profile Send private message
El_Goretto
Advocate
Advocate


Joined: 29 May 2004
Posts: 2881
Location: Paris

PostPosted: Thu Nov 22, 2012 12:02 pm    Post subject: Reply with quote

Et c'est sûr çà que l'ebuild grub2 n'installe pas toute seule le biniou dans le MBR? Sûr de sûr? Un chti coup de reinstall de grub1 sur le disque au cas où? (c'est une ânerie si tu arrives à booter un autre noyau, hein, mais j'ai lu en diagonal ;)).
Parce que c'est bizarre quand même, que les ID soient (0,0) dans le message d'erreur, alors que bon, c'est pas les options qui sont passées à la quenelle d'après la conf.

Autre chose, mais un peu off: vos précos entre root= et real_root=? Avantages? Inconvénients?
_________________
-PC: 2500K/P8Z68V, 8Go, R9-290, ARC1220+5xWD500RE3, M4 256Go
-Home servers (hardened): µ-serv N40L, 2Go ECC ; NF9D-2700, 4Go ; DS61, i3 2100T, 16Go
-Réseau: ERL-3 + 3x switches GS108Tv2
-NAS: RN312
http://boycottsystemd.org/
Back to top
View user's profile Send private message
kopp
Advocate
Advocate


Joined: 09 Apr 2004
Posts: 2869
Location: Grenoble, France

PostPosted: Fri Nov 23, 2012 9:06 am    Post subject: Reply with quote

Bon voilà, je me réveille. Je t'ai envoyé ça !
Back to top
View user's profile Send private message
Mickael
Advocate
Advocate


Joined: 05 Sep 2005
Posts: 2383
Location: ~Belfort! - France - EU

PostPosted: Fri Nov 23, 2012 4:34 pm    Post subject: Reply with quote

Bonjour tout le monde et merci pour vos réponses.

Alors je viens de tenter un boot avec la config de Kopp. Ben voilà kernel panic again :/ Donc làa chui mal :) Mais je viens de noter qqchose au boot :
Quote:

TuxOnIce : Unable to find a signature. Could you have moved a swap file?
TuxOnIce : Block I/O: No signature found at /dev/sda5

registrered taskstats version 1
un truc sur ALSA sui va bien
puis les lignes du kernel panic données au premier posts avec une différence en rouge :
VFS : Cannot open root device "(NULL)" or unknown block (0,0): error -6
Please append a correct "root=" boot option;
...
etc la table de partition du portable
...
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0) <-- vous voyez je ne vous ai pas menti !!
Pid: 1, comm: swapper/0 Not tainted 3.4.11-tuxonice #3 maintenant c'est 12
Call Trace:
etcetc

_________________
À LIRE : COMMENT POSTER ET OBTENIR DE L'AIDE ?
Qui suis-je ? Bon j'ai relu, comme d'habitude, je suis bon a rien le vendredi
Qui suis-je ? Je ne serai jamais modo
Back to top
View user's profile Send private message
kopp
Advocate
Advocate


Joined: 09 Apr 2004
Posts: 2869
Location: Grenoble, France

PostPosted: Fri Nov 23, 2012 6:15 pm    Post subject: Reply with quote

Tu as viré de ta conf grub resume2=swap:/dev/sda6 comme le suggérait boozo ?
Et si tu as utilisé ma config, tu as changé ce qu'il fallait pour que ça corresponde à ta config ?

Edit : a priori non, toi ta partition de resume, c'est sda6, moi c'est sda5 ... donc ...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum