Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Solved] Sound recording
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
FrostyX
n00b
n00b


Joined: 13 Mar 2012
Posts: 48
Location: Czech Republic

PostPosted: Fri Nov 16, 2012 8:14 pm    Post subject: [Solved] Sound recording Reply with quote

I have problem with sound recording in gentoo. Can you please help me?
(I am trying sound recording but real purpose is voice call in skype)

I have played with alsamixer - everything is scrolled up and unmuted.
Probably i cant post here screenshot with alsamixer so I attach output of amixer
Code:
$[FrostyX  ~]-> amixer
Simple mixer control 'Master',0
  Capabilities: pvolume pvolume-joined pswitch pswitch-joined penum
  Playback channels: Mono
  Limits: Playback 0 - 64
  Mono: Playback 39 [61%] [-25.00dB] [on]
Simple mixer control 'Headphone',0
  Capabilities: pvolume pswitch penum
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 64
  Mono:
  Front Left: Playback 64 [100%] [1.00dB] [on]
  Front Right: Playback 64 [100%] [1.00dB] [on]
Simple mixer control 'Speaker',0
  Capabilities: pvolume pswitch penum
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 64
  Mono:
  Front Left: Playback 64 [100%] [1.00dB] [on]
  Front Right: Playback 64 [100%] [1.00dB] [on]
Simple mixer control 'PCM',0
  Capabilities: pvolume penum
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 255
  Mono:
  Front Left: Playback 255 [100%] [0.00dB]
  Front Right: Playback 255 [100%] [0.00dB]
Simple mixer control 'Mic',0
  Capabilities: pvolume pswitch penum
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Mono:
  Front Left: Playback 31 [100%] [12.00dB] [on]
  Front Right: Playback 31 [100%] [12.00dB] [on]
Simple mixer control 'Mic Boost',0
  Capabilities: volume penum
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: 0 - 3
  Front Left: 2 [67%] [20.00dB]
  Front Right: 2 [67%] [20.00dB]
Simple mixer control 'IEC958',0
  Capabilities: pswitch pswitch-joined penum
  Playback channels: Mono
  Mono: Playback [on]
Simple mixer control 'Capture',0
  Capabilities: cvolume cswitch penum
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 46
  Front Left: Capture 46 [100%] [29.00dB] [on]
  Front Right: Capture 46 [100%] [29.00dB] [on]
Simple mixer control 'Auto-Mute Mode',0
  Capabilities: enum
  Items: 'Disabled' 'Enabled'
  Item0: 'Enabled'
Simple mixer control 'Digital',0
  Capabilities: cvolume penum
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 120
  Front Left: Capture 120 [100%] [30.00dB]
  Front Right: Capture 120 [100%] [30.00dB]


I try record sound using gnome-sound-recorder (from gnome-extra/gnome-media package) in which I have tried every of offered channels. Nothing work. After I stop recording and click on play, it prints me "Stram contains no media"

Hardware:
- laptop ThinkPad SL510
- I have tried internal mic and also external from headphones

If you are interested about something else, please tell me.


Last edited by FrostyX on Wed Nov 21, 2012 1:28 pm; edited 1 time in total
Back to top
View user's profile Send private message
doom555
n00b
n00b


Joined: 29 Oct 2012
Posts: 57

PostPosted: Fri Nov 16, 2012 8:40 pm    Post subject: Reply with quote

Probably you are using Pulseaudio, in this case you should use media-sound/pavucontrol
Back to top
View user's profile Send private message
FrostyX
n00b
n00b


Joined: 13 Mar 2012
Posts: 48
Location: Czech Republic

PostPosted: Fri Nov 16, 2012 8:47 pm    Post subject: Reply with quote

Probably I am not :-)
Code:

*  media-sound/pulseaudio
      Latest version available: 1.1-r1
      Latest version installed: [ Not Installed ]
      Size of files: 1,275 kB
      Homepage:      http://www.pulseaudio.org/
      Description:   A networked sound server with an advanced plugin system
      License:       !gdbm? ( LGPL-2.1 ) gdbm? ( GPL-2 )

Do I have to ?
Back to top
View user's profile Send private message
doom555
n00b
n00b


Joined: 29 Oct 2012
Posts: 57

PostPosted: Fri Nov 16, 2012 11:29 pm    Post subject: Reply with quote

No, you don't need, but if you use pulseaudio you need to control it with pavucontrol.
But, if you are using Gnome enviroinment is strange that you aren't using pulsaudio :!: :?:
Back to top
View user's profile Send private message
FrostyX
n00b
n00b


Joined: 13 Mar 2012
Posts: 48
Location: Czech Republic

PostPosted: Sat Nov 17, 2012 12:07 am    Post subject: Reply with quote

I am not using whole gnome desktop environment. I am using XMonad with few gnome apps :wink:
Back to top
View user's profile Send private message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 5186

PostPosted: Sat Nov 17, 2012 1:09 am    Post subject: Reply with quote

First, let's make sure we have the correct drivers for your hardware. Please post the output of

Code:

lspci


and

Code:

lspci -n

_________________
Gentoo Studio: http://gentoostudio.org
Facebook: http://www.facebook.com/gentoostudio
G+: https://plus.google.com/113947758237122861689/posts
Pappy's Kernel Seeds: http://kernel-seeds.gentoostudio.org
Back to top
View user's profile Send private message
FrostyX
n00b
n00b


Joined: 13 Mar 2012
Posts: 48
Location: Czech Republic

PostPosted: Sat Nov 17, 2012 1:13 am    Post subject: Reply with quote

There is lspci
Code:

$[FrostyX  ~]-> sudo lspci
00:00.0 Host bridge: Intel Corporation Mobile 4 Series Chipset Memory Controller Hub (rev 07)
00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
00:02.1 Display controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
00:1a.0 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #4 (rev 03)
00:1a.1 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #5 (rev 03)
00:1a.2 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #6 (rev 03)
00:1a.7 USB controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #2 (rev 03)
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 1 (rev 03)
00:1c.1 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 2 (rev 03)
00:1c.2 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 3 (rev 03)
00:1c.3 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 4 (rev 03)
00:1c.4 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 5 (rev 03)
00:1c.5 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 6 (rev 03)
00:1d.0 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #1 (rev 03)
00:1d.1 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #2 (rev 03)
00:1d.2 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #3 (rev 03)
00:1d.7 USB controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #1 (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev 93)
00:1f.0 ISA bridge: Intel Corporation ICH9M LPC Interface Controller (rev 03)
00:1f.2 SATA controller: Intel Corporation 82801IBM/IEM (ICH9M/ICH9M-E) 4 port SATA Controller [AHCI mode] (rev 03)
00:1f.3 SMBus: Intel Corporation 82801I (ICH9 Family) SMBus Controller (rev 03)
02:00.0 System peripheral: JMicron Technology Corp. SD/MMC Host Controller
02:00.2 SD Host controller: JMicron Technology Corp. Standard SD Host Controller
02:00.3 System peripheral: JMicron Technology Corp. MS Host Controller
02:00.4 System peripheral: JMicron Technology Corp. xD Host Controller
03:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG [Golan] Network Connection (rev 02)
08:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 03)
and there lspci -n
Code:

$[FrostyX  ~]-> sudo lspci -n
00:00.0 0600: 8086:2a40 (rev 07)
00:02.0 0300: 8086:2a42 (rev 07)
00:02.1 0380: 8086:2a43 (rev 07)
00:1a.0 0c03: 8086:2937 (rev 03)
00:1a.1 0c03: 8086:2938 (rev 03)
00:1a.2 0c03: 8086:2939 (rev 03)
00:1a.7 0c03: 8086:293c (rev 03)
00:1b.0 0403: 8086:293e (rev 03)
00:1c.0 0604: 8086:2940 (rev 03)
00:1c.1 0604: 8086:2942 (rev 03)
00:1c.2 0604: 8086:2944 (rev 03)
00:1c.3 0604: 8086:2946 (rev 03)
00:1c.4 0604: 8086:2948 (rev 03)
00:1c.5 0604: 8086:294a (rev 03)
00:1d.0 0c03: 8086:2934 (rev 03)
00:1d.1 0c03: 8086:2935 (rev 03)
00:1d.2 0c03: 8086:2936 (rev 03)
00:1d.7 0c03: 8086:293a (rev 03)
00:1e.0 0604: 8086:2448 (rev 93)
00:1f.0 0601: 8086:2919 (rev 03)
00:1f.2 0106: 8086:2929 (rev 03)
00:1f.3 0c05: 8086:2930 (rev 03)
02:00.0 0880: 197b:2382
02:00.2 0805: 197b:2381
02:00.3 0880: 197b:2383
02:00.4 0880: 197b:2384
03:00.0 0280: 8086:4222 (rev 02)
08:00.0 0200: 10ec:8168 (rev 03)
Back to top
View user's profile Send private message
Ant P.
Advocate
Advocate


Joined: 18 Apr 2009
Posts: 2204
Location: UK

PostPosted: Sat Nov 17, 2012 6:43 pm    Post subject: Reply with quote

You have a HDA audio chip, which doesn't have hardware loopback due to DRM excuses. You'll either need to route all your audio through Pulseaudio, or use `alsaloop` with a loopback sound card.
Back to top
View user's profile Send private message
FrostyX
n00b
n00b


Joined: 13 Mar 2012
Posts: 48
Location: Czech Republic

PostPosted: Sat Nov 17, 2012 9:23 pm    Post subject: Reply with quote

I rather want no pulseaudio. Is it hard to solve it by alsaloop? Can you please tell me how can I do it using this alsaloop ? I will be very grateful ;-)
Back to top
View user's profile Send private message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 5186

PostPosted: Mon Nov 19, 2012 2:41 pm    Post subject: Reply with quote

Sorry for the delay. Had some weekend home improvement stuff I wanted to work on.

First, I don't know that you need any kind of loop, pulseaudio or ALSA. Intel HD Audio should just work straight up. I've used it often. So put that back on the table for now.

Second, in your kernel config, do you have snd-hda-intel enabled? You should have this:

Code:

Device Drivers --->
   Sound card support  --->
      <M> Advanced Linux Sound Architecture --->
         [*] PCI sound devices --->
            <M> Intel HD Audio --->


Leave all of the default settings under Intel HD Audio. If you didn't have this, select the modules as shown above. If you had them compiled-in, changed them to modules. There is no performance or stability difference, but having modules will make it easier to troubleshoot (you can unload/reload modules, as opposed to having to make kernel changes and rebooting).

Once you're at that point, let me know and we'll go from there.
_________________
Gentoo Studio: http://gentoostudio.org
Facebook: http://www.facebook.com/gentoostudio
G+: https://plus.google.com/113947758237122861689/posts
Pappy's Kernel Seeds: http://kernel-seeds.gentoostudio.org
Back to top
View user's profile Send private message
FrostyX
n00b
n00b


Joined: 13 Mar 2012
Posts: 48
Location: Czech Republic

PostPosted: Mon Nov 19, 2012 5:32 pm    Post subject: Reply with quote

Quote:
Sorry for the delay. Had some weekend home improvement stuff I wanted to work on.

No problem. I am glad you are interested about it at all.

I had only one difference in kernel. Instead of
Code:
<M> Advanced Linux Sound Architecture --->
I had
Code:
<*> Advanced Linux Sound Architecture --->
so I changed it to module and rebooted.
Back to top
View user's profile Send private message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 5186

PostPosted: Mon Nov 19, 2012 8:17 pm    Post subject: Reply with quote

OK. You've put the module in /etc/conf.d/modules, right?
_________________
Gentoo Studio: http://gentoostudio.org
Facebook: http://www.facebook.com/gentoostudio
G+: https://plus.google.com/113947758237122861689/posts
Pappy's Kernel Seeds: http://kernel-seeds.gentoostudio.org
Back to top
View user's profile Send private message
FrostyX
n00b
n00b


Joined: 13 Mar 2012
Posts: 48
Location: Czech Republic

PostPosted: Mon Nov 19, 2012 8:38 pm    Post subject: Reply with quote

You didnt say anything about /etc/conf.d/modules so I havent. I have had it as * not as M cause I dont know what modules I should add into this /etc/conf.d/modules
Back to top
View user's profile Send private message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 5186

PostPosted: Mon Nov 19, 2012 10:55 pm    Post subject: Reply with quote

When you change it to a module (* to M), you exit out of make menuconfig and do

Code:

make && make modules_install


When it's done, you'll see a list of modules ending with .ko. Copy all of those, open /etc/conf.d/modules, delete everything in there, paste into /etc/conf.d/modules, and strip away the .ko and everything before the module name. You should see something like this:

/etc/conf.d/modules example:

Code:

modules="
snd-page-alloc
snd-pcm
snd-timer
snd
snd-hda-codec-analog
snd-hda-codec-ca0110
snd-hda-codec-ca0132
snd-hda-codec-cirrus
snd-hda-codec-cmedia
snd-hda-codec-conexant
snd-hda-codec-hdmi
snd-hda-codec-idt
snd-hda-codec-realtek
snd-hda-codec-si3054
snd-hda-codec-via
snd-hda-codec
snd-hda-intel
soundcore
"


Once that's done, reboot. You should now have ALSA configured, with modules, for your sound card.

When that's done, the next thing you'll want to do is make sure you have alsa-utils installed. If you don't, run emerge alsa-utils. When that's done, run alsamixer as root. If you see all of the components of your sound card, then you have everything in place. Make sure everything is up and un-muted, then do

Code:

/etc/init.d/alsasound start
rc-update add alsasound default


Then we'll be in a position to tackle any recording issues you might still have.
_________________
Gentoo Studio: http://gentoostudio.org
Facebook: http://www.facebook.com/gentoostudio
G+: https://plus.google.com/113947758237122861689/posts
Pappy's Kernel Seeds: http://kernel-seeds.gentoostudio.org
Back to top
View user's profile Send private message
FrostyX
n00b
n00b


Joined: 13 Mar 2012
Posts: 48
Location: Czech Republic

PostPosted: Wed Nov 21, 2012 1:27 pm    Post subject: Reply with quote

audiodef's posts above, solved the problem.

I just did
Code:
make && make modules_install


edited /etc/conf.d/modules to
Code:
modules="
vboxdrv
snd-mixer-oss
snd-pcm-oss
oss/snd-seq-oss
snd-seq-device
snd-seq-dummy
snd-seq-midi-event
snd-seq
snd-hrtimer
snd-hwdep
snd-page-alloc
snd-pcm
snd-timer
snd
snd-hda-codec-analog
snd-hda-codec-ca0110
snd-hda-codec-ca0132
snd-hda-codec-cirrus
snd-hda-codec-cmedia
snd-hda-codec-conexant
snd-hda-codec-hdmi
snd-hda-codec-idt
snd-hda-codec-realtek
snd-hda-codec-si3054
snd-hda-codec-via
snd-hda-codec
snd-hda-intel
"

and rebooted. Sound recording worked great (on channel "capture") and skype also works.
Thank you very much. I am changing topic name to [Solved]
Back to top
View user's profile Send private message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 5186

PostPosted: Wed Nov 21, 2012 1:43 pm    Post subject: Reply with quote

Glad I could help. :)
_________________
Gentoo Studio: http://gentoostudio.org
Facebook: http://www.facebook.com/gentoostudio
G+: https://plus.google.com/113947758237122861689/posts
Pappy's Kernel Seeds: http://kernel-seeds.gentoostudio.org
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum