Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Native Steam client and source game engine
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3, 4, 5, 6 ... 10, 11, 12  Next  
Reply to topic    Gentoo Forums Forum Index Gamers & Players
View previous topic :: View next topic  
Author Message
Chiitoo
l33t
l33t


Joined: 28 Feb 2010
Posts: 852
Location: Here and Away Again

PostPosted: Thu Nov 15, 2012 6:40 am    Post subject: ><)))°€ Reply with quote

Mhm, I've had it on Mint (maya), but not on Gentoo.

After seeing spacelike's post I tried removing the libappindicator1 package, and indeed would not get the icon. I also tried removing libappindicator3-1, but this did not have the effect (but probably broke a lot of other stuff, heh).
_________________
Kind Regards,
~ The Noob Unlimited ~

Sore wa sore, kore wa kore.
Back to top
View user's profile Send private message
spacelike
n00b
n00b


Joined: 15 Sep 2011
Posts: 57

PostPosted: Fri Nov 16, 2012 3:46 am    Post subject: Reply with quote

Based on the fact that it requires libappindicator can anyone think of a way that might make it possible to see the icon within a tint2 panel?
(or any panel really... just not the unity panel please!)
Back to top
View user's profile Send private message
Auwesome
n00b
n00b


Joined: 16 Nov 2012
Posts: 4

PostPosted: Fri Nov 16, 2012 3:25 pm    Post subject: Reply with quote

Hello,

I try to make World of goo demo working, but I have this issue about ld.so :

Code:
ERROR: ld.so: object '/root/.steam/bin/gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.
An X Error occurred
X Error of failed request:  BadWindow (invalid Window parameter)


There is no so much help about this over the net. I'm running ~amd64, KDE on dualscreen with nvidia 304 driver.

Someone idea ?
Back to top
View user's profile Send private message
Spidey
Apprentice
Apprentice


Joined: 07 Sep 2006
Posts: 264

PostPosted: Fri Nov 16, 2012 3:50 pm    Post subject: Reply with quote

It seems that you are running Steam as root? See how the error complains about not finding something on /root? This is the root user home directory.
Back to top
View user's profile Send private message
Auwesome
n00b
n00b


Joined: 16 Nov 2012
Posts: 4

PostPosted: Sat Nov 17, 2012 9:46 pm    Post subject: Reply with quote

Running as root or not, I have the same error.

I've found on steam forums that adding in steam.sh "export LC_NUMERIC=C" just after bin/bash line, would resolve the problem.

But when I modify the file, Steam always updates and removes my modification. So I try to put the file on read only mode, but this time Steam complains about not reaching the internet..

At least, I've resolved the X error. I didn't have xorg.conf file so just doing an /opt/bin/nvidia-xconfig has remove this error.
Back to top
View user's profile Send private message
spacelike
n00b
n00b


Joined: 15 Sep 2011
Posts: 57

PostPosted: Sat Nov 17, 2012 10:09 pm    Post subject: Reply with quote

But your .steam/bin folder should be in a users home folder.

I think you should remove steam from your system and re-run the installation as a non-root user. Remove the files:
/root/.steam
/root/Steam
/root/.steampath
/root/.steampid


and then do the installation again as non-root.
In the end you should have a folder in /home/<user>/Steam instead of /root/Steam
Back to top
View user's profile Send private message
Auwesome
n00b
n00b


Joined: 16 Nov 2012
Posts: 4

PostPosted: Sat Nov 17, 2012 10:12 pm    Post subject: Reply with quote

I already done this. My first try was into the root directory just for a quick test.

But even as a user, it doesn't work.
Back to top
View user's profile Send private message
Auwesome
n00b
n00b


Joined: 16 Nov 2012
Posts: 4

PostPosted: Mon Nov 19, 2012 1:26 pm    Post subject: Reply with quote

I finally manage to launch the game even with the

Code:
ERROR: ld.so: object '/home/blablabla/.steam/bin/gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.


It's because of iptables blocking some needed ports... So I've to found which one.
Back to top
View user's profile Send private message
darklegion
Guru
Guru


Joined: 14 Nov 2004
Posts: 466

PostPosted: Wed Nov 21, 2012 2:23 am    Post subject: Reply with quote

This needs pulseaudio right? I got TF2 working, but I have no sound. I'm on AMD64 so is it available in the compat libs, and if so, do I also need 64bit pulseaudio installed?

I'm not too fussed either way, plenty of other games still to play :)
Back to top
View user's profile Send private message
hasufell
Developer
Developer


Joined: 29 Oct 2011
Posts: 224

PostPosted: Wed Nov 21, 2012 10:51 am    Post subject: Reply with quote

I haven't played TF2 yet, so cannot confirm on that, but in general pulseaudio (64bit version) is not a dependency.

However steamclient.so is linked against 32bit pulseaudio which is bad coding. Alsa should work fine.

Those are side effects of steam being shipped for ubuntu, not for linux in general.
Back to top
View user's profile Send private message
spacelike
n00b
n00b


Joined: 15 Sep 2011
Posts: 57

PostPosted: Wed Nov 21, 2012 5:03 pm    Post subject: Reply with quote

darklegion wrote:
This needs pulseaudio right? I got TF2 working, but I have no sound. I'm on AMD64 so is it available in the compat libs, and if so, do I also need 64bit pulseaudio installed?

I'm not too fussed either way, plenty of other games still to play :)


I have TF2 working with sound on ALSA no pulse.

I simply do:
export SDL_AUDIODRIVER=alsa
and then start steam, then lauch TF2 from the library and it has audio.

====================================================

I'm trying to start steam on my x86 gentoo laptop and after going through all of the dependencies with the correct versions where needed from the wiki (and I do have the correct kernel options with /dev/shm mounted) it won't launch.

It is giving me the same errors that people posted here before:
Code:

      2503:   /usr/lib/libGL.so.1: error: symbol lookup error: undefined symbol: glXCopySubBufferMESA (fatal)
      2503:   /usr/lib/libGL.so.1: error: symbol lookup error: undefined symbol: glXBindTexImageEXT (fatal)
      2503:   /usr/lib/libGL.so.1: error: symbol lookup error: undefined symbol: glXReleaseTexImageEXT (fatal)
      2503:   /usr/lib/libGL.so.1: error: symbol lookup error: undefined symbol: glXSwapIntervalEXT (fatal)
      2503:   /usr/lib/libGL.so.1: error: symbol lookup error: undefined symbol: glXCreateContextAttribsARB (fatal)


The solution was to install emul-linux-x86-sdl.

But that is for a 64-bit system, my laptop is 32-bit and I have libsdl installed which should be the equivalent right? and installing emul-linux-x86-sdl on my x86 machine won't do anything right?

What am I missing?
Back to top
View user's profile Send private message
anyc
Tux's lil' helper
Tux's lil' helper


Joined: 31 May 2004
Posts: 119

PostPosted: Wed Nov 21, 2012 10:42 pm    Post subject: Reply with quote

Just a try: Do you use the latest binary drivers from nvidia or amd? If you use open source drivers, did you install >=mesa-9?
Back to top
View user's profile Send private message
spacelike
n00b
n00b


Joined: 15 Sep 2011
Posts: 57

PostPosted: Thu Nov 22, 2012 5:01 am    Post subject: Reply with quote

empanyc wrote:
Just a try: Do you use the latest binary drivers from nvidia or amd? If you use open source drivers, did you install >=mesa-9?


I have a laptop with integrated intel graphics, and I have x11-drivers/xf86-video-intel installed and also media-libs/mesa-9.0.
Back to top
View user's profile Send private message
Tieren
n00b
n00b


Joined: 22 Nov 2012
Posts: 7

PostPosted: Thu Nov 22, 2012 11:38 am    Post subject: Reply with quote

I've updated to GCC 4.6.3. In fact, at this point:

Code:
tieren@fenrir ~ $ gcc-config -l
 [1] x86_64-pc-linux-gnu-4.6.3 *
tieren@fenrir ~ $


However LD_DEBUG="libs" /usr/bin/steam 2>&1 eventually spits out:

Code:
/home/tieren/Steam/ubuntu12_32/steam: error while loading shared libraries: libstdc++.so.6: cannot open shared object file: No such file or directory

Full Text

Prior to this I was getting some errors listing the path to the now-uninstalled GCC 4.5.3's libstdc++.so.6 (I was kind of hoping more things would squawk after removing it, but nothing else on my system seems to have an issue using 4.6.3...). Any thoughts on what's happening? I'm kind of going down the path of "something I have installed is still trying to link back to GCC 4.5.3", but I'm somewhat at a loss as to where to go from here.
Back to top
View user's profile Send private message
DaggyStyle
Advocate
Advocate


Joined: 22 Mar 2006
Posts: 4924

PostPosted: Thu Nov 22, 2012 12:37 pm    Post subject: Reply with quote

Tieren wrote:
I've updated to GCC 4.6.3. In fact, at this point:

Code:
tieren@fenrir ~ $ gcc-config -l
 [1] x86_64-pc-linux-gnu-4.6.3 *
tieren@fenrir ~ $


However LD_DEBUG="libs" /usr/bin/steam 2>&1 eventually spits out:

Code:
/home/tieren/Steam/ubuntu12_32/steam: error while loading shared libraries: libstdc++.so.6: cannot open shared object file: No such file or directory

Full Text

Prior to this I was getting some errors listing the path to the now-uninstalled GCC 4.5.3's libstdc++.so.6 (I was kind of hoping more things would squawk after removing it, but nothing else on my system seems to have an issue using 4.6.3...). Any thoughts on what's happening? I'm kind of going down the path of "something I have installed is still trying to link back to GCC 4.5.3", but I'm somewhat at a loss as to where to go from here.


try running revdep-rebuild
_________________
Only two things are infinite, the universe and human stupidity and I'm not sure about the former - Albert Einstein
ProjectFootball
Back to top
View user's profile Send private message
Tieren
n00b
n00b


Joined: 22 Nov 2012
Posts: 7

PostPosted: Thu Nov 22, 2012 1:28 pm    Post subject: Reply with quote

DaggyStyle wrote:


try running revdep-rebuild


Sadly I'd already done so at that point. Some very badly mangled imagemagick stuff, but nothing else showed up. I've also remerged/rebuilt any of the packaged listed in this thread as possible dependencies for Steam post-gcc-update.
Back to top
View user's profile Send private message
DaggyStyle
Advocate
Advocate


Joined: 22 Mar 2006
Posts: 4924

PostPosted: Thu Nov 22, 2012 2:18 pm    Post subject: Reply with quote

Tieren wrote:
DaggyStyle wrote:


try running revdep-rebuild


Sadly I'd already done so at that point. Some very badly mangled imagemagick stuff, but nothing else showed up. I've also remerged/rebuilt any of the packaged listed in this thread as possible dependencies for Steam post-gcc-update.


have you reinstalled steam post gcc upgrade?
_________________
Only two things are infinite, the universe and human stupidity and I'm not sure about the former - Albert Einstein
ProjectFootball
Back to top
View user's profile Send private message
Tieren
n00b
n00b


Joined: 22 Nov 2012
Posts: 7

PostPosted: Thu Nov 22, 2012 4:12 pm    Post subject: Reply with quote

DaggyStyle wrote:
have you reinstalled steam post gcc upgrade?


Yep! I actually updated GCC and had everything (except the recommended fonts) configured prior to installing steam the first time. I tried to do homework before installing, ran into some font issues after install, added the bitstream-vera font and started receiving the same GCC error as skaveria in this post.

Since that seemed odd (as GCC was already set to use 4.6.3 and I had rebooted since then as a lazy way to get new binary nvidia drivers in place) I unmerged 4.5.3, remerged the various emul-linux and other dependency packaged, and finished with a revdep-rebuild.

Got away from skaveria's error, so now instead of complaining about the 4.5.3 libraries it's unable to find the 4.6.3 libraries. 8O [/url]

Edit - I've also tried blowing away all of steam and its created directories a couple times. It gets as far as creating some directories and files, then errors.
Back to top
View user's profile Send private message
hasufell
Developer
Developer


Joined: 29 Oct 2011
Posts: 224

PostPosted: Thu Nov 22, 2012 4:19 pm    Post subject: Reply with quote

Tieren wrote:
I've updated to GCC 4.6.3. In fact, at this point:

Code:
tieren@fenrir ~ $ gcc-config -l
 [1] x86_64-pc-linux-gnu-4.6.3 *
tieren@fenrir ~ $


However LD_DEBUG="libs" /usr/bin/steam 2>&1 eventually spits out:

Code:
/home/tieren/Steam/ubuntu12_32/steam: error while loading shared libraries: libstdc++.so.6: cannot open shared object file: No such file or directory

Full Text

Prior to this I was getting some errors listing the path to the now-uninstalled GCC 4.5.3's libstdc++.so.6 (I was kind of hoping more things would squawk after removing it, but nothing else on my system seems to have an issue using 4.6.3...). Any thoughts on what's happening? I'm kind of going down the path of "something I have installed is still trying to link back to GCC 4.5.3", but I'm somewhat at a loss as to where to go from here.

That was wrong. Don't just remove a gcc version.

It totally does not matter which version is selected via gcc-config. You don't compile _anything_ here. You just have to satisfy the linkage.

It sounds like you are about to kill your toolchain with some unfinished gcc-switching.

read http://www.gentoo.org/doc/en/gcc-upgrading.xml
and either choose 4.5.4 or 4.6.3 now. On top of that I would do a complete remerge of @system


Last edited by hasufell on Thu Nov 22, 2012 4:22 pm; edited 1 time in total
Back to top
View user's profile Send private message
spacelike
n00b
n00b


Joined: 15 Sep 2011
Posts: 57

PostPosted: Thu Nov 22, 2012 4:19 pm    Post subject: Reply with quote

I'm starting to think my problem is due to a missing USE flag in one of the dependencies, would someone who has it working on x86 be so kind as to paste a list of their use flags for all of the dependencies?
Back to top
View user's profile Send private message
Tieren
n00b
n00b


Joined: 22 Nov 2012
Posts: 7

PostPosted: Thu Nov 22, 2012 4:24 pm    Post subject: Reply with quote

Ah, no. To be more clear, after merging 4.6.3 I used gcc-config to set it as the active gcc version and rebuilt libtool. I was actually following the exact guide you linked, hasufell. 4.5.3 got unmerged later that evening after several successful compiles using 4.6.3.
Back to top
View user's profile Send private message
hasufell
Developer
Developer


Joined: 29 Oct 2011
Posts: 224

PostPosted: Thu Nov 22, 2012 4:25 pm    Post subject: Reply with quote

Tieren wrote:
Ah, no. To be more clear, after merging 4.6.3 I used gcc-config to set it as the active gcc version and rebuilt libtool. I was actually following the exact guide you linked, hasufell. 4.5.3 got unmerged later that evening after several successful compiles using 4.6.3.

And that step was unnecessary. Anyway, 4.6.3 is fairly safe to use, so no need to downgrade.
Back to top
View user's profile Send private message
Tieren
n00b
n00b


Joined: 22 Nov 2012
Posts: 7

PostPosted: Thu Nov 22, 2012 4:43 pm    Post subject: Reply with quote

hasufell wrote:
Tieren wrote:
Ah, no. To be more clear, after merging 4.6.3 I used gcc-config to set it as the active gcc version and rebuilt libtool. I was actually following the exact guide you linked, hasufell. 4.5.3 got unmerged later that evening after several successful compiles using 4.6.3.

And that step was unnecessary. Anyway, 4.6.3 is fairly safe to use, so no need to downgrade.


I appreciate the information, thank you. :)
Back to top
View user's profile Send private message
piedar
Tux's lil' helper
Tux's lil' helper


Joined: 09 Aug 2010
Posts: 80

PostPosted: Thu Nov 22, 2012 5:47 pm    Post subject: Reply with quote

I had gcc-4.5.4 and gcc-4.6.3. steam first failed after initial update due to wrong version of GLIBCXX. It was trying to load libstdlibc++ from gcc-4.5.4 even though gcc-4.6.3 was selected with gcc-config. I pulled the trigger on removing gcc-4.5.4 (meaning to anyway), after which steam failed again on loading libstdc++ and libgcc_s.so.1. My quick and dirty workaround was
Code:
ln -s /usr/lib/gcc/x86_64-pc-linux-gnu/4.6.3/32/libstdc++.so.6 ~/Steam/ubuntu12_32/
ln -s /usr/lib/gcc/x86_64-pc-linux-gnu/4.6.3/32/libgcc_s.so.1 ~/Steam/ubuntu12_32/


I also fixed an error in steam.sh. It was using a nonexistent variable in pidof, triggering the script to exit before launching the binary. I changed
ALREADYRUNNINGPID=`pidof "${STEAMROOT}"/${PLATFORM}/${STEAMEXE}`
to
ALREADYRUNNINGPID=`pidof "${STEAMPATH}"`


It seems to work fine now. Now to try TF2.

Edit: TF2 runs really well! I get around 100 FPS with maxed out settings with GeForce GTX 550. World of Goo works too.


Last edited by piedar on Sun Nov 25, 2012 12:43 am; edited 2 times in total
Back to top
View user's profile Send private message
hasufell
Developer
Developer


Joined: 29 Oct 2011
Posts: 224

PostPosted: Thu Nov 22, 2012 6:08 pm    Post subject: Reply with quote

are you sure you did "env-update && source /etc/profile" after messing with gcc?

see http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?part=2&chap=5

Quote:
Note: The above command only updates the variables in your current terminal, new consoles, and their children. Thus, if you are working in X11, you will need to either type source /etc/profile in every new terminal you open or restart X so that all new terminals source the new variables. If you use a login manager, become root and type /etc/init.d/xdm restart. If not, you will need to logout and log back in for X to spawn children with the new variable values.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gamers & Players All times are GMT
Goto page Previous  1, 2, 3, 4, 5, 6 ... 10, 11, 12  Next
Page 5 of 12

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum