Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] xorg-server 1.13.0 fails with existing xorg.conf
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
dmpogo
Advocate
Advocate


Joined: 02 Sep 2004
Posts: 2276
Location: Canada

PostPosted: Sun Nov 18, 2012 5:22 pm    Post subject: [SOLVED] xorg-server 1.13.0 fails with existing xorg.conf Reply with quote

I'll pull this problem to the new thread from http://forums.gentoo.org/viewtopic-t-942726-highlight-.html
since I am not sure this issue is the same

Just updated and xorg-server and it fails to start with my old xorg.conf

X starts if I remove xorg.conf, but fails if xorg.conf is present either in /etc/X11 or in /etc/X11/xorg.conf.d
From the log I see that xorg.conf is loaded OK, goes through the loading of extensions, but then X bails out

Code:


[  9541.215]
X.Org X Server 1.13.0
Release Date: 2012-09-05
[  9541.223] X Protocol Version 11, Revision 0
[  9541.224] Build Operating System: Linux 3.4.9-gentoo x86_64 Gentoo
[  9541.226] Current Operating System: Linux pizzly 3.4.9-gentoo #2 SMP PREEMPT Wed Sep 19 08:36:32 MDT 2012 x86_64
[  9541.226] Kernel command line: root=/dev/sda2 resume=/dev/sda6
[  9541.229] Build Date: 17 November 2012  03:38:17PM
[  9541.231]
[  9541.233] Current version of pixman: 0.28.0
[  9541.236]    Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
[  9541.236] Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[  9541.243] (==) Log file: "/var/log/Xorg.0.log", Time: Sat Nov 17 17:12:43 2012
[  9541.245] (==) Using config file: "/etc/X11/xorg.conf"
[  9541.247] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[  9541.247] (==) ServerLayout "Main Layout"
[  9541.247] (**) |-->Screen "Screen 0" (0)
[  9541.247] (**) |   |-->Monitor "Lenovo LCD Screen"
[  9541.247] (**) |   |-->Device "Intel965G"
[  9541.247] (**) |-->Input Device "all-keyboards"
[  9541.248] (**) |-->Input Device "Trackpoint"
[  9541.248] (**) |-->Input Device "Touchpad"
[  9541.248] (**) Option "BlankTime" "10"
[  9541.248] (**) Option "StandbyTime" "20"
[  9541.248] (**) Option "SuspendTime" "30"
[  9541.248] (**) Option "OffTime" "60"
[  9541.248] (**) Option "AutoAddDevices" "False"
[  9541.248] (**) Not automatically adding devices
[  9541.248] (==) Automatically enabling devices
[  9541.248] (==) Automatically adding GPU devices
[  9541.248] (WW) The directory "/usr/share/local/fonts/ttf" does not exist.
[  9541.248]    Entry deleted from font path.
[  9541.248] (WW) The directory "/usr/share/fonts/OTF/" does not exist.
[  9541.248]    Entry deleted from font path.
[  9541.248] (WW) The directory "/usr/share/fonts/75dpi/" does not exist.
[  9541.248]    Entry deleted from font path.
[  9541.248] (**) FontPath set to:
        /usr/share/fonts/cyrillic,
        /usr/share/fonts/corefonts,
        /usr/share/fonts/default/ghostscript,
        /usr/share/fonts/misc,
        /usr/share/fonts/Type1,
        /usr/share/fonts/TTF,
        /usr/share/fonts/100dpi,
        /usr/share/fonts/misc/,
        /usr/share/fonts/TTF/,
        /usr/share/fonts/Type1/,
        /usr/share/fonts/100dpi/
[  9541.248] (==) ModulePath set to "/usr/lib64/xorg/modules"
[  9541.248] (II) Loader magic: 0x80bbe0
[  9541.248] (II) Module ABI versions:
[  9541.248]    X.Org ANSI C Emulation: 0.4
[  9541.248]    X.Org Video Driver: 13.0
[  9541.248]    X.Org XInput driver : 18.0
[  9541.248]    X.Org Server Extension : 7.0
[  9541.249] (II) config/udev: Adding drm device (/dev/dri/card0)
[  9541.250] (--) PCI:*(0:0:2:0) 8086:2a02:17aa:20b5 rev 12, Mem @ 0xfa000000/1048576, 0xe0000000/268435456, I/O @ 0x00001800/8
[  9541.250] (--) PCI: (0:0:2:1) 8086:2a03:17aa:20b5 rev 12, Mem @ 0xfa100000/1048576
[  9541.250] (II) Open ACPI successful (/var/run/acpid.socket)
[  9541.252] Initializing built-in extension Generic Event Extension
[  9541.254] Initializing built-in extension SHAPE
[  9541.255] Initializing built-in extension MIT-SHM
[  9541.257] Initializing built-in extension XInputExtension
[  9541.259] Initializing built-in extension XTEST
[  9541.260] Initializing built-in extension BIG-REQUESTS
[  9541.262] Initializing built-in extension SYNC
[  9541.264] Initializing built-in extension XKEYBOARD
[  9541.265] Initializing built-in extension XC-MISC
[  9541.267] Initializing built-in extension XINERAMA
[  9541.268] Initializing built-in extension XFIXES
[  9541.270] Initializing built-in extension RENDER
[  9541.271] Initializing built-in extension RANDR
[  9541.273] Initializing built-in extension COMPOSITE
[  9541.274] Initializing built-in extension DAMAGE
[  9541.276] Initializing built-in extension MIT-SCREEN-SAVER
[  9541.277] Initializing built-in extension DOUBLE-BUFFER
[  9541.278] Initializing built-in extension RECORD
[  9541.280] Initializing built-in extension DPMS
[  9541.281] Initializing built-in extension X-Resource
[  9541.282] Initializing built-in extension XVideo
[  9541.284] Initializing built-in extension XVideo-MotionCompensation
[  9541.285] Initializing built-in extension XFree86-VidModeExtension
[  9541.286] Initializing built-in extension XFree86-DGA
[  9541.287] Initializing built-in extension XFree86-DRI
[  9541.288] Initializing built-in extension DRI2
[  9541.288] (II) "glx" will be loaded. This was enabled by default and also specified in the config file.
[  9541.288] (II) LoadModule: "dbe"
[  9541.289] (II) Module "dbe" already built-in
[  9541.289] (II) LoadModule: "extmod"
[  9541.289] (II) Module "extmod" already built-in
[  9541.289] (II) LoadModule: "glx"
[  9541.289] (II) Loading /usr/lib64/xorg/modules/extensions/libglx.so
[  9541.289] (II) Module glx: vendor="X.Org Foundation"
[  9541.289]    compiled for 1.13.0, module version = 1.0.0
[  9541.289]    ABI class: X.Org Server Extension, version 7.0
[  9541.289] (==) AIGLX enabled
[  9541.290] Loading extension GLX
[  9541.290] (II) LoadModule: "dri"
[  9541.290] (II) Module "dri" already built-in
[  9541.290] (II) LoadModule: "intel"
[  9541.290] (II) Loading /usr/lib64/xorg/modules/drivers/intel_drv.so
[  9541.290] (II) Module intel: vendor="X.Org Foundation"
[  9541.290]    compiled for 1.13.0, module version = 2.20.13
[  9541.290]    Module class: X.Org Video Driver
[  9541.290]    ABI class: X.Org Video Driver, version 13.0
[  9541.291] (II) LoadModule: "evdev"
[  9541.291] (II) Loading /usr/lib64/xorg/modules/input/evdev_drv.so
[  9541.291] (II) Module evdev: vendor="X.Org Foundation"
[  9541.291]    compiled for 1.13.0, module version = 2.7.3
[  9541.291]    Module class: X.Org XInput Driver
[  9541.291]    ABI class: X.Org XInput driver, version 18.0
[  9541.291] (II) LoadModule: "synaptics"
[  9541.291] (II) Loading /usr/lib64/xorg/modules/input/synaptics_drv.so
[  9541.291] (II) Module synaptics: vendor="X.Org Foundation"
[  9541.291]    compiled for 1.13.0, module version = 1.6.2
[  9541.291]    Module class: X.Org XInput Driver
[  9541.291]    ABI class: X.Org XInput driver, version 18.0
[  9541.291] (II) intel: Driver for Intel Integrated Graphics Chipsets: i810,
        i810-dc100, i810e, i815, i830M, 845G, 854, 852GM/855GM, 865G, 915G,
        E7221 (i915), 915GM, 945G, 945GM, 945GME, Pineview GM, Pineview G,
        965G, G35, 965Q, 946GZ, 965GM, 965GME/GLE, G33, Q35, Q33, GM45,
        4 Series, G45/G43, Q45/Q43, G41, B43, B43, Clarkdale, Arrandale,
        Sandybridge Desktop (GT1), Sandybridge Desktop (GT2),
        Sandybridge Desktop (GT2+), Sandybridge Mobile (GT1),
        Sandybridge Mobile (GT2), Sandybridge Mobile (GT2+),
        Sandybridge Server, Ivybridge Mobile (GT1), Ivybridge Mobile (GT2),
        Ivybridge Desktop (GT1), Ivybridge Desktop (GT2), Ivybridge Server,
        Ivybridge Server (GT2), Haswell Desktop (GT1), Haswell Desktop (GT2),
        Haswell Desktop (GT2+), Haswell Mobile (GT1), Haswell Mobile (GT2),
        Haswell Mobile (GT2+), Haswell Server (GT1), Haswell Server (GT2),
        Haswell Server (GT2+), Haswell SDV Desktop (GT1),
        Haswell SDV Desktop (GT2), Haswell SDV Desktop (GT2+),
        Haswell SDV Mobile (GT1), Haswell SDV Mobile (GT2),
        Haswell SDV Mobile (GT2+), Haswell SDV Server (GT1),
        Haswell SDV Server (GT2), Haswell SDV Server (GT2+),
        Haswell ULT Desktop (GT1), Haswell ULT Desktop (GT2),
        Haswell ULT Desktop (GT2+), Haswell ULT Mobile (GT1),
        Haswell ULT Mobile (GT2), Haswell ULT Mobile (GT2+),
        Haswell ULT Server (GT1), Haswell ULT Server (GT2),
        Haswell ULT Server (GT2+), Haswell CRW Desktop (GT1),
        Haswell CRW Desktop (GT2), Haswell CRW Desktop (GT2+),
        Haswell CRW Mobile (GT1), Haswell CRW Mobile (GT2),
        Haswell CRW Mobile (GT2+), Haswell CRW Server (GT1),
        Haswell CRW Server (GT2), Haswell CRW Server (GT2+),
        ValleyView PO board
[  9541.291] (--) using VT number 7

[  9541.297] (II) intel(0): using device path '/dev/dri/card0'
[  9541.297] (II) intel(1): using device path '/dev/dri/card0'
[  9541.297] (II) intel(G0): using device path '/dev/dri/card0'
[  9541.298] (II) intel(G1): using device path '/dev/dri/card0'
[  9541.298] (EE) Screen 0 deleted because of no matching config section.
[  9541.298] (II) UnloadModule: "intel"
[  9541.298] (EE) Screen 0 deleted because of no matching config section.
[  9541.298] (II) UnloadModule: "intel"
[  9541.298] (EE) Screen 0 deleted because of no matching config section.
[  9541.298] (II) UnloadModule: "intel"
[  9541.298] (EE) Device(s) detected, but none match those in the config file.
[  9541.298]
Fatal server error:
[  9541.298] no screens found
[  9541.298] (EE)
Please consult the The X.Org Foundation support
         at http://wiki.x.org
 for help.
[  9541.298] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[  9541.298] (EE)
[  9541.310] Server terminated with error (1). Closing log file.


it happens both with startx and xdm (which is kdm in my case). Seems something has changed in how X parses xorg.conf,
but what ?

My xorg.conf is (I have deleted some comments)
Code:

# $XdotOrg$
#
# Copyright (c) 1994-1998 by The XFree86 Project, Inc.
#

# **********************************************************************
# Files section.  This allows default font and rgb paths to be set
# **********************************************************************

Section "Files"

# Multiple FontPath entries are allowed (which are concatenated together),
# as well as specifying multiple comma-separated entries in one FontPath
# command (or a combination of both methods)

    FontPath    "/usr/share/fonts/cyrillic"
    FontPath    "/usr/share/fonts/corefonts"
    FontPath    "/usr/share/fonts/default/ghostscript"
    FontPath    "/usr/share/fonts/misc"
    FontPath    "/usr/share/fonts/Type1"
    FontPath    "/usr/share/fonts/TTF"
    FontPath    "/usr/share/fonts/100dpi"
    FontPath    "/usr/share/local/fonts/ttf"
#    Fontpath    "/usr/local/Wolfram/Mathematica/7.0/SystemFiles/Fonts/Type1"
#    Fontpath    "/usr/local/Wolfram/Mathematica/7.0/SystemFiles/Fonts/BDF"

# The default path is shown here.

EndSection

# **********************************************************************
# Module section -- this is an optional section which is used to specify
# which run-time loadable modules to load when the X server starts up.
# **********************************************************************

Section "Module"

# This loads the DBE extension module.

    Load        "dbe"

# This loads the miscellaneous extensions module, and disables
# initialisation of the XFree86-DGA extension within that module.

    SubSection  "extmod"
        Option  "omit xfree86-dga"
    EndSubSection

# This loads 3D modules
    Load        "glx"
    Load        "dri"
   
EndSection

Section "Extensions"
    # Option "Composite" "true"
EndSection

# **********************************************************************
# Server flags section.  This contains various server-wide Options.
# **********************************************************************

Section "ServerFlags"

# Uncomment this to disable dynamically modifying the input device
# (mouse and keyboard) settings.

#    Option     "DisableModInDev"
#     Option    "AllowEmptyInput"       "False"
     Option     "AutoAddDevices"        "False"

# Uncomment this to enable the use of a non-local client to
# change the keyboard or mouse settings (currently only xset).

#    Option     "AllowNonLocalModInDev"

# Set the basic blanking screen saver timeout.

    Option      "blank time"    "10"    # 10 minutes

# Set the DPMS timeouts.  These are set here because they are global
# rather than screen-specific.  These settings alone don't enable DPMS.
# It is enabled per-screen (or per-monitor), and even then only when
# the driver supports it.

    Option      "standby time"  "20"
    Option      "suspend time"  "30"
    Option      "off time"      "60"

# On some platform the server needs to estimate the sizes of PCI
# memory and pio ranges. This is done by assuming that PCI ranges
# don't overlap. Some broken BIOSes tend to set ranges of inactive
# devices wrong. Here one can adjust how aggressive the assumptions
# should be. Default is 0.

# Option   "EstimateSizesAggresively" "0"

EndSection

# **********************************************************************
# Input devices
# **********************************************************************

# **********************************************************************
# Core keyboard's InputDevice section
# **********************************************************************

Section "InputDevice"

    Identifier  "all-keyboards"
    Driver      "evdev"
    Option      "Device"        "/dev/input/event4"

# Set the keyboard auto repeat parameters.  Not all platforms implement
# this.

    Option      "AutoRepeat"    "500 30"

# Specifiy which keyboard LEDs can be user-controlled (eg, with xset(1)).

#    Option     "Xleds" "1 2 3"

# To disable the XKEYBOARD extension, uncomment XkbDisable.

#    Option     "XkbDisable"

# These are the XKB settings for xorg
#
    Option      "XkbRules"      "evdev"
    Option      "XkbModel"      "thinkpad60"
    Option      "XkbLayout"     "us,ru"
    Option      "XkbVariant"    ",phonetic"
    Option      "XkbOptions"    "grp:caps_toggle"

#    MatchProduct       "AT"
#    MatchIsKeyboard     "true"
EndSection


# **********************************************************************
# Core Pointer's InputDevice section
# **********************************************************************


Section "InputDevice"

    Identifier  "Trackpoint"
    Driver      "evdev"
    Option      "Device"        "/dev/input/event5"

    Option      "Emulate3Buttons"     "false"
    Option      "Emulate3Timeout"     "50"
    Option      "EmulateWheel"        "true"
    Option      "EmulateWheelTimeOut" "200"
    Option      "EmulateWheelButton"  "2"
    Option      "XAxisMapping"        "6 7"
    Option      "YAxisMapping"        "4 5"

#    MatchProduct       "Stick"
#    MatchIsPointer     "true"
EndSection

Section "InputDevice"

# Identifier and driver

    Identifier  "Touchpad"
    Driver      "synaptics"

    Option      "SHMConfig"             "true"

#    Option "GuestMouseOff" "true"
    Option "LeftEdge" "128"
    Option "RightEdge" "896"
    Option "TopEdge" "128"
    Option "BottomEdge" "640"
    Option "FingerLow" "5"
    Option "FingerHigh" "20"
    Option "TapButton1" "1"
    Option "MaxTapTime" "300"
    Option "MaxTapMove" "200"
    Option "EmulateMidButtonTime" "75"
    Option "CoastingSpeed"      "10"
    Option "CornerCoasting"     "true"
    Option "VertScrollDelta"  "20"
    Option "HorizScrollDelta" "20"
    Option "MinSpeed" "0.60"
    Option "MaxSpeed" "1.10"
    Option "AccelFactor" "0.030"
    Option "EdgeMotionMinSpeed" "200"
    Option "EdgeMotionMaxSpeed" "200"
    Option "CircularScrolling" "1"
    Option "CircScrollDelta" "0.1"
    Option "CircScrollTrigger" "2"
    Option "GrabEventDevice" "off"

#    MatchIsTouchPad "on"
EndSection

# **********************************************************************
# Monitor section
# **********************************************************************

# Any number of monitor sections may be present

Section "Monitor"
    Identifier  "Lenovo LCD Screen"
    Option      "DPMS"
    DisplaySize 305 190
EndSection

Section "Monitor"
    Identifier  "External VGA monitor"
    Option      "DPMS"
    Option      "Ignore" "false"
#    Modeline    "1440x900"  102.00  1440 1488 1520 1836  900 903 909 926 -hsync -vsync
EndSection

# **********************************************************************
# Graphics device section
# **********************************************************************

# Any number of graphics device sections may be present

Section "Device"

    Identifier  "Intel965G"
    Driver      "intel"
    BusID       "PCI:0:2:0"

    Option      "FramebufferCompression" "false"
    Option      "Legacy3D" "false"
    Option      "AccelMethod"           "UXA"
#    Option     "Tiling" "Off"

    Option      "Monitor-LVDS1" "Lenovo LCD Screen"
    Option      "Monitor-VGA" "External VGA monitor"

EndSection

# **********************************************************************
# Screen sections.
# **********************************************************************

# Any number of screen sections may be present.  Each describes
# the configuration of a single screen.  A single specific screen section
# may be specified from the X server command line with the "-screen"
# option.

Section "Screen"

# The Identifier, Device and Monitor lines must be present

    Identifier  "LCD"
    Device      "Intel965G"
    Monitor     "Lenovo LCD Screen"

# The favoured Depth and/or Bpp may be specified here

    DefaultDepth 24

    SubSection "Display"
        Depth           24
        Modes           "1440x900" "1920x1080"
        Virtual         1920 2100
#        Virtual                2880 900
    EndSubSection
EndSection


# **********************************************************************
# ServerLayout sections.
# **********************************************************************

# Any number of ServerLayout sections may be present.  Each describes
# the way multiple screens are organised.  A specific ServerLayout
# section may be specified from the X server command line with the
# "-layout" option.  In the absence of this, the first section is used.
# When now ServerLayout section is present, the first Screen section
# is used alone.

Section "ServerLayout"

# The Identifier line must be present

    Identifier  "Main Layout"

# Each Screen line specifies a Screen section name, and optionally
# the relative position of other screens.  The four names after
# primary screen name are the screens to the top, bottom, left and right
# of the primary screen.  In this example, screen 2 is located to the
# right of screen 1.

    Screen      "LCD"

# Each InputDevice line specifies an InputDevice section name and
# optionally some options to specify the way the device is to be
# used.  Those options include "CorePointer", "CoreKeyboard" and
# "SendCoreEvents".  In this example, "Mouse1" is the core pointer,
# and "Mouse2" is an extended input device that also generates core
# pointer events (i.e., both mice will move the standard pointer).

    InputDevice         "all-keyboards"  "CoreKeyboard"
    InputDevice         "Trackpoint" "CorePointer"
    InputDevice         "Touchpad"   "SendCoreEvents"
#    InputDevice                "USBMouse"   "SendCoreEvents"

EndSection

Section "DRI"
#    Mode 0666
EndSection


Last edited by dmpogo on Sun Nov 18, 2012 10:20 pm; edited 1 time in total
Back to top
View user's profile Send private message
BasketCase
n00b
n00b


Joined: 02 Sep 2003
Posts: 65
Location: Orlando, FL

PostPosted: Sun Nov 18, 2012 7:12 pm    Post subject: Reply with quote

Same problem here. Also on a netbook with an Intel GPU.
Back to top
View user's profile Send private message
BasketCase
n00b
n00b


Joined: 02 Sep 2003
Posts: 65
Location: Orlando, FL

PostPosted: Sun Nov 18, 2012 7:38 pm    Post subject: Reply with quote

Try commenting the following line:
Code:
    Option      "AccelMethod"           "UXA"


That got me into X. Now working on my missing mouse problem.
Back to top
View user's profile Send private message
dmpogo
Advocate
Advocate


Joined: 02 Sep 2004
Posts: 2276
Location: Canada

PostPosted: Sun Nov 18, 2012 9:23 pm    Post subject: Reply with quote

BasketCase wrote:
Try commenting the following line:
Code:
    Option      "AccelMethod"           "UXA"


That got me into X. Now working on my missing mouse problem.


Good catch ! This get's me into X as well. I'll try to find out if that option is really depreciated before marking thread as resolved.
Back to top
View user's profile Send private message
genstorm
Advocate
Advocate


Joined: 05 Apr 2007
Posts: 2350
Location: Austria

PostPosted: Sun Nov 18, 2012 9:34 pm    Post subject: Reply with quote

Code:
equery u xf86-video-intel

_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
BasketCase
n00b
n00b


Joined: 02 Sep 2003
Posts: 65
Location: Orlando, FL

PostPosted: Sun Nov 18, 2012 9:50 pm    Post subject: Reply with quote

genstorm wrote:
Code:
equery u xf86-video-intel

lol, due to the complete absence of a sensible error message from X I hadn't thought to look for changes in the USE flag choices.
Back to top
View user's profile Send private message
Jaglover
Advocate
Advocate


Joined: 29 May 2005
Posts: 4560
Location: Saint Amant, Acadiana

PostPosted: Sun Nov 18, 2012 9:53 pm    Post subject: Reply with quote

dmpogo wrote:
BasketCase wrote:
Try commenting the following line:
Code:
    Option      "AccelMethod"           "UXA"


That got me into X. Now working on my missing mouse problem.


Good catch ! This get's me into X as well. I'll try to find out if that option is really depreciated before marking thread as resolved.


In fact, the whole xorg.conf is depreciated, at least the way you are using it. Nowadays there is normally no xorg.conf, and if you have to create one then you put in there only the options you want to override.
_________________
Please learn how to denote units correctly!
Back to top
View user's profile Send private message
genstorm
Advocate
Advocate


Joined: 05 Apr 2007
Posts: 2350
Location: Austria

PostPosted: Sun Nov 18, 2012 9:54 pm    Post subject: Reply with quote

Well, these days you aren't supposed to keep such massive xorg.conf files. Some of those lines are ancient and simply obsolete.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
dmpogo
Advocate
Advocate


Joined: 02 Sep 2004
Posts: 2276
Location: Canada

PostPosted: Sun Nov 18, 2012 9:57 pm    Post subject: Reply with quote

genstorm wrote:
Code:
equery u xf86-video-intel


Wow, to go through silent crash of X-server is quite an indirect way to learn about new USE flag :)

Since we are at it - is UXA being superseeded by SNA ?
Back to top
View user's profile Send private message
genstorm
Advocate
Advocate


Joined: 05 Apr 2007
Posts: 2350
Location: Austria

PostPosted: Sun Nov 18, 2012 10:08 pm    Post subject: Reply with quote

Seems to be. SNA is clearly better cared for these days. I've seen no regressions after switching from UXA.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
dmpogo
Advocate
Advocate


Joined: 02 Sep 2004
Posts: 2276
Location: Canada

PostPosted: Sun Nov 18, 2012 10:23 pm    Post subject: Reply with quote

Jaglover wrote:
dmpogo wrote:
BasketCase wrote:
Try commenting the following line:
Code:
    Option      "AccelMethod"           "UXA"


That got me into X. Now working on my missing mouse problem.


Good catch ! This get's me into X as well. I'll try to find out if that option is really depreciated before marking thread as resolved.


In fact, the whole xorg.conf is depreciated, at least the way you are using it. Nowadays there is normally no xorg.conf, and if you have to create one then you put in there only the options you want to override.


Yeah-yeah, I hear that for years :) I have couple of options that need not be defined anymore (mostly fonts and modules) but the rest is exactly what I like to have.
And I find it much easier to be in a single file.
Back to top
View user's profile Send private message
dmpogo
Advocate
Advocate


Joined: 02 Sep 2004
Posts: 2276
Location: Canada

PostPosted: Sun Nov 18, 2012 10:42 pm    Post subject: Reply with quote

genstorm wrote:
Well, these days you aren't supposed to keep such massive xorg.conf files. Some of those lines are ancient and simply obsolete.


Not that many, I took this opportunity and cleared few (mostly modules) and the rest I like as they are in one file. I prefer my X not trying to connect power button as a keyboard :) if it just cost me 10 minutes 3 years ago to tell it what exactly to do
Back to top
View user's profile Send private message
sl70
Guru
Guru


Joined: 18 Jun 2002
Posts: 336
Location: Chicago, USA

PostPosted: Mon Nov 19, 2012 5:54 pm    Post subject: Reply with quote

Jaglover wrote:
dmpogo wrote:
BasketCase wrote:
Try commenting the following line:
Code:
    Option      "AccelMethod"           "UXA"


That got me into X. Now working on my missing mouse problem.


Good catch ! This get's me into X as well. I'll try to find out if that option is really depreciated before marking thread as resolved.


In fact, the whole xorg.conf is depreciated, at least the way you are using it. Nowadays there is normally no xorg.conf, and if you have to create one then you put in there only the options you want to override.


I just had big problems with X after upgrading to 1.13. (Dell Latitude with i915.) The image in my left monitor was all distorted and shakey; looked like a sync problem. I changed the resolution down using xrandr and it was OK. Then I put it back to where it was, and it's running OK. I'm sure it's going to go all kablooey on me when I log out and log back in again.

I need these lines in my xorg.conf:
Code:
Section "Screen"
   Identifier "Screen0"
   Device     "Card0"
   Monitor    "Monitor0"
    SubSection "Display"
      Viewport   0 0
      Depth     24
      Virtual 2944 1280
   EndSubSection
EndSection


I use xrandr in /etc/X11/xdm/Xsetup to handle the two monitors like this:
Code:

xrandr --output HDMI2 --mode 1920x1200 --output HDMI3 --mode 1280x1024 --rotate left --right-of HDMI2


So, are you saying that I should take everything out of xorg.conf except for the lines above?

Thanks.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum