Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED]: Upgrading udev fails
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
ONEEYEMAN
Advocate
Advocate


Joined: 01 Mar 2005
Posts: 2069

PostPosted: Sun Nov 18, 2012 4:30 am    Post subject: [SOLVED]: Upgrading udev fails Reply with quote

Hi, ALL,
I'm trying to upgrade udev.

Code:

emerge -pv --update =udev-171-r8
[ebuild     U  ] [color=green]sys-fs/udev-171-r8[/color] [color=blue][171-r6][/color] USE="[color=red]gudev hwdb keymap rule-generator[/color] [color=blue]-action_modeswitch -build -debug -edd[/color] (-[color=green]extras[/color]*) [color=blue]-floppy -introspection[/color] ([color=blue]-selinux[/color]) {[color=blue]-test[/color]}"

Total: 1 package (1 upgrade), Size of download

!!! MUltiple package instances within a singl package slot have been pulled
!!! into the dependancy graph, resulting in a slot conflict:

sys-fs/udev:0

    (sys-fs/udev-171-r6:gentoo, installed) pulled in by
      >=sys-fs/udev-145[extras] required by (gnome-base/gvfs-1.6.7:gentoo, installed)

    (sys-fs/udev-171-r8:gentoo, ebuild scheduled for merge) pulled in by
      =dev-171-r8

It might be possible to solve this slot collision
by applying all of the following changes:
  -sys-fs/udev-171-r8 (Change USE: +extras)


However, whatever I do, either using "USE="extras" emerge -pv --update =udev-171-r8" or put the flag in the /etc/portage/package.use
I still see this message.

Is there any possibility to fix this?

Thank you.


Last edited by ONEEYEMAN on Mon Nov 19, 2012 7:55 am; edited 1 time in total
Back to top
View user's profile Send private message
ssuominen
Developer
Developer


Joined: 30 Sep 2005
Posts: 2128
Location: Finland

PostPosted: Sun Nov 18, 2012 10:00 am    Post subject: Reply with quote

It says...

Quote:

>=sys-fs/udev-145[extras] required by (gnome-base/gvfs-1.6.7:gentoo, installed)


And the current gnome-base/gvfs in tree has this dependency:

Code:

|| ( >=sys-fs/udev-171[gudev] >=sys-fs/udev-164-r2[extras] ) )


So as you can see, USE=gudev enabled is enough for gvfs, so time to upgrade the gvfs package into something new:

Code:

# emerge -v1 gvfs
Back to top
View user's profile Send private message
ONEEYEMAN
Advocate
Advocate


Joined: 01 Mar 2005
Posts: 2069

PostPosted: Mon Nov 19, 2012 7:55 am    Post subject: Reply with quote

Thank you. That did it.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum