Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] portage now needs "--backtrack=30"
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
toralf
Advocate
Advocate


Joined: 01 Feb 2004
Posts: 2614
Location: Hamburg/Germany

PostPosted: Sat Nov 10, 2012 8:59 am    Post subject: [solved] portage now needs "--backtrack=30" Reply with quote

to solve a slot conflict - never saw that option before.
Does this indicates that the portage tree becomes too complex ?


Last edited by toralf on Fri Nov 16, 2012 3:54 pm; edited 1 time in total
Back to top
View user's profile Send private message
Hu
Watchman
Watchman


Joined: 06 Mar 2007
Posts: 8595

PostPosted: Sat Nov 10, 2012 3:50 pm    Post subject: Reply with quote

Could you share the relevant emerge command and its output, both with and without adequate backtracking?
Back to top
View user's profile Send private message
toralf
Advocate
Advocate


Joined: 01 Feb 2004
Posts: 2614
Location: Hamburg/Germany

PostPosted: Sat Nov 10, 2012 5:30 pm    Post subject: Reply with quote

Code:
n22 ~ # emerge --update @world --ask                                                                           
                                                                                                               
These are the packages that would be merged, in reverse order:                                                 
                                                                                                               
Calculating dependencies  .. .. ...... ......... ...... done!                                                   
[nomerge       ] kde-base/system-config-printer-kde-4.9.3                                                       
[nomerge       ]  kde-base/pykde4-4.9.3                                                                         
[ebuild     UD ]   dev-python/sip-4.13.3 [4.14]                                                                 
[nomerge       ] x11-base/xorg-server-1.13.0                                                                   
[ebuild     UD ]  x11-libs/pixman-0.26.0 [0.27.4]                                                               
                                                                                                               
!!! Multiple package instances within a single package slot have been pulled                                   
!!! into the dependency graph, resulting in a slot conflict:

x11-libs/pixman:0

  (x11-libs/pixman-0.27.4::gentoo, installed) pulled in by
    >=x11-libs/pixman-0.27.1 required by (x11-drivers/xf86-video-intel-2.20.12::gentoo, installed)

  (x11-libs/pixman-0.26.0::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

dev-python/sip:0

  (dev-python/sip-4.14::gentoo, installed) pulled in by
    >=dev-python/sip-4.14 required by (dev-python/PyQt4-4.9.5::gentoo, installed)

  (dev-python/sip-4.13.3::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.
versus
Code:
n22 ~ # emerge --update @world --ask --backtrack=30

These are the packages that would be merged, in reverse order:

Calculating dependencies  . ... .... ...... .. ... done!

Nothing to merge; would you like to auto-clean packages? [Yes/No]
>>> Jobs: 0 of 0 complete                           Load avg: 5.38, 4.92, 4.54
>>> Auto-cleaning packages...

>>> No outdated packages were found on your system.
and fwiw
Code:
n22 ~ # grep -e sip -e pix /etc/portage/package.accept_keywords/misc
~dev-python/sip-4.14.1
~x11-libs/pixman-0.28
Back to top
View user's profile Send private message
toralf
Advocate
Advocate


Joined: 01 Feb 2004
Posts: 2614
Location: Hamburg/Germany

PostPosted: Fri Nov 16, 2012 3:54 pm    Post subject: Reply with quote

seems to be solved with portage 2.1.11.31
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum