Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[overlay] Pro audio production applications, Part 2
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... 15, 16, 17  
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 5282

PostPosted: Fri Nov 09, 2012 7:20 pm    Post subject: updated amidimap ebuild Reply with quote

Updated working ebuild for amidimap: http://forums.gentoo.org/viewtopic-p-7184622.html#7184622
_________________
Gentoo Studio: http://gentoostudio.org
Facebook: http://www.facebook.com/gentoostudio
G+: https://plus.google.com/113947758237122861689/posts
Pappy's Kernel Seeds: http://kernel-seeds.org


Last edited by audiodef on Thu Nov 15, 2012 2:16 pm; edited 1 time in total
Back to top
View user's profile Send private message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 5282

PostPosted: Fri Nov 09, 2012 9:42 pm    Post subject: Reply with quote

If anyone has trouble compiling Ardour-2.9999 because it "cannot find -lintl", change your use flag for Ardour to -nls.
_________________
Gentoo Studio: http://gentoostudio.org
Facebook: http://www.facebook.com/gentoostudio
G+: https://plus.google.com/113947758237122861689/posts
Pappy's Kernel Seeds: http://kernel-seeds.org
Back to top
View user's profile Send private message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 5282

PostPosted: Thu Nov 15, 2012 2:14 pm    Post subject: Reply with quote

A fix to get Openoctave working from a working ebuild: http://forums.gentoo.org/viewtopic-p-7184614.html#7184614
_________________
Gentoo Studio: http://gentoostudio.org
Facebook: http://www.facebook.com/gentoostudio
G+: https://plus.google.com/113947758237122861689/posts
Pappy's Kernel Seeds: http://kernel-seeds.org


Last edited by audiodef on Fri Nov 16, 2012 2:36 am; edited 1 time in total
Back to top
View user's profile Send private message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 5282

PostPosted: Fri Nov 16, 2012 2:36 am    Post subject: Reply with quote

New ebuild for latest stable SuperCollder: http://forums.gentoo.org/viewtopic-p-7185024.html#7185024
_________________
Gentoo Studio: http://gentoostudio.org
Facebook: http://www.facebook.com/gentoostudio
G+: https://plus.google.com/113947758237122861689/posts
Pappy's Kernel Seeds: http://kernel-seeds.org
Back to top
View user's profile Send private message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 5282

PostPosted: Fri Nov 16, 2012 3:21 pm    Post subject: Reply with quote

Updated init script for Liquidsoap: http://forums.gentoo.org/viewtopic-p-7185290.html#7185290
_________________
Gentoo Studio: http://gentoostudio.org
Facebook: http://www.facebook.com/gentoostudio
G+: https://plus.google.com/113947758237122861689/posts
Pappy's Kernel Seeds: http://kernel-seeds.org
Back to top
View user's profile Send private message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 5282

PostPosted: Mon Nov 19, 2012 8:16 pm    Post subject: Reply with quote

Rakarrack-9999 missing patch file: http://forums.gentoo.org/viewtopic-p-7187348.html#7187348
_________________
Gentoo Studio: http://gentoostudio.org
Facebook: http://www.facebook.com/gentoostudio
G+: https://plus.google.com/113947758237122861689/posts
Pappy's Kernel Seeds: http://kernel-seeds.org
Back to top
View user's profile Send private message
tek0
n00b
n00b


Joined: 09 Oct 2005
Posts: 43

PostPosted: Thu Feb 21, 2013 3:19 pm    Post subject: Reply with quote

Could someone please fix the invalid keyword '**' in tutka-9999?
Back to top
View user's profile Send private message
nitm
n00b
n00b


Joined: 27 Dec 2004
Posts: 37

PostPosted: Sat Jul 27, 2013 8:13 pm    Post subject: Reply with quote

Can someone fix the dependencies of guitarix2.
Here is a patch:
Code:
Index: media-sound/guitarix2/guitarix2-0.28.1.ebuild
===================================================================
--- media-sound/guitarix2/guitarix2-0.28.1.ebuild       (revision 2766)
+++ media-sound/guitarix2/guitarix2-0.28.1.ebuild       (working copy)
@@ -22,8 +22,8 @@
 IUSE="avahi +capture custom-cflags +convolver debug faust ladspa lv2 +meterbridge nls"

 RDEPEND="
-       >=dev-cpp/glibmm-2.24.0
-       >=dev-cpp/gtkmm-2.20.0
+       >=dev-cpp/glibmm-2.24.0:2
+       >=dev-cpp/gtkmm-2.20.0:2.4
        >=dev-libs/boost-1.38
        dev-libs/glib
        media-libs/liblrdf


Thank you in advance...
Back to top
View user's profile Send private message
yngwin
Developer
Developer


Joined: 19 Dec 2002
Posts: 4416
Location: Suzhou, China

PostPosted: Sat Jul 27, 2013 9:46 pm    Post subject: Reply with quote

The overlay needs a metadata/layout.conf with at least the following:
Code:
masters = gentoo
cache-formats = md5-dict


Currently it fails with portage >=2.2.0_alpha189
_________________
"Those who deny freedom to others deserve it not for themselves." - Abraham Lincoln
Free Culture | Defective by Design | EFF
Back to top
View user's profile Send private message
lilrc
n00b
n00b


Joined: 23 Sep 2012
Posts: 11
Location: Sweden

PostPosted: Sat Jul 27, 2013 10:39 pm    Post subject: Reply with quote

nitm wrote:
Can someone fix the dependencies of guitarix2.
Here is a patch:
Code:
Index: media-sound/guitarix2/guitarix2-0.28.1.ebuild
===================================================================
--- media-sound/guitarix2/guitarix2-0.28.1.ebuild       (revision 2766)
+++ media-sound/guitarix2/guitarix2-0.28.1.ebuild       (working copy)
@@ -22,8 +22,8 @@
 IUSE="avahi +capture custom-cflags +convolver debug faust ladspa lv2 +meterbridge nls"

 RDEPEND="
-       >=dev-cpp/glibmm-2.24.0
-       >=dev-cpp/gtkmm-2.20.0
+       >=dev-cpp/glibmm-2.24.0:2
+       >=dev-cpp/gtkmm-2.20.0:2.4
        >=dev-libs/boost-1.38
        dev-libs/glib
        media-libs/liblrdf

Thank you in advance...

Committed! Thanks!
Back to top
View user's profile Send private message
lilrc
n00b
n00b


Joined: 23 Sep 2012
Posts: 11
Location: Sweden

PostPosted: Sat Jul 27, 2013 11:05 pm    Post subject: Reply with quote

yngwin wrote:
The overlay needs a metadata/layout.conf with at least the following:
Code:
masters = gentoo
cache-formats = md5-dict


Currently it fails with portage >=2.2.0_alpha189

Committed as rev2768! Thank you!
Back to top
View user's profile Send private message
defer-
Tux's lil' helper
Tux's lil' helper


Joined: 11 Jun 2007
Posts: 140
Location: Finland

PostPosted: Mon Aug 19, 2013 11:01 pm    Post subject: Reply with quote

I created ebuilds for renoise tracker style DAW. It has very nice linux support. The demo version is almost full featured, just no rendering to wav!

https://github.com/defer-/my-projects/blob/master/renoise-2.8.1.ebuild
https://github.com/defer-/my-projects/blob/master/renoise-demo-2.8.1.ebuild

Btw, i didnt get verification e-mail from pro-audio bugtracker.
_________________
https://github.com/defer-
Back to top
View user's profile Send private message
GNULeslie
n00b
n00b


Joined: 23 Feb 2013
Posts: 1

PostPosted: Mon Aug 26, 2013 4:33 pm    Post subject: Reply with quote

Hi all,

I am going to ask a very newbie question, but I am a newbie with gentoo...

I am very interested in Mixxx (I am mixing myself), and I wanted to install mixxx 1.11, which is supposed to be available through the pro-audio overlay. I followed the install guide on the wiki with layman, but mixxx 1.11 is not available... What did I do wrong ?

Code:

[leslie:~] $ sudo layman -S

 * Fetching remote list,...
 * Remote list already up to date: http://www.gentoo.org/proj/en/overlays/repositories.xml
 * Last-modified: Fri, 23 Aug 2013 04:50:03 GMT
 * Fetch Ok

 * Syncing selected overlays,...
 * Running Subversion... # /usr/bin/svn up /var/lib/layman/pro-audio
Updating '/var/lib/layman/pro-audio':
At revision 2789.
 * Running Git... # ( cd /var/lib/layman/steam  && /usr/bin/git pull )
Already up-to-date.
 *
 * Succeeded:
 * ------
 * Successfully synchronized overlay "pro-audio".
 * Successfully synchronized overlay "steam".
 *

[leslie:~] $ emerge -s mixxx
Searching...   
[ Results for search key : mixxx ]
[ Applications found : 1 ]

*  media-sound/mixxx
      Latest version available: 1.10.1
      Latest version installed: 1.10.1
      Size of files: 15,575 kB
      Homepage:      http://mixxx.sourceforge.net
      Description:   A Qt based Digital DJ tool
      License:       GPL-2

_________________
GNU/Chick
Back to top
View user's profile Send private message
defer-
Tux's lil' helper
Tux's lil' helper


Joined: 11 Jun 2007
Posts: 140
Location: Finland

PostPosted: Wed Aug 28, 2013 8:52 pm    Post subject: Reply with quote

GNULeslie wrote:
Hi all,

I am going to ask a very newbie question, but I am a newbie with gentoo...

I am very interested in Mixxx (I am mixing myself), and I wanted to install mixxx 1.11, which is supposed to be available through the pro-audio overlay. I followed the install guide on the wiki with layman, but mixxx 1.11 is not available... What did I do wrong ?


You can find mixxx 1.11 from my overlay. Its not yet added to layman.

https://github.com/defer-/deferlay
_________________
https://github.com/defer-
Back to top
View user's profile Send private message
darkbasic
Tux's lil' helper
Tux's lil' helper


Joined: 06 Sep 2006
Posts: 124

PostPosted: Thu Nov 07, 2013 5:06 pm    Post subject: Reply with quote

libffado-9999-no-jackd-version.patch does not apply anymore (media-libs/libffado-9999-r1)
_________________
Computers are like air conditioners:
they stop working properly when you open Windows...

Coltiva Linux, Windows si pianta da solo.


http://www.linuxsystems.it/
Back to top
View user's profile Send private message
adsicks
n00b
n00b


Joined: 08 Sep 2012
Posts: 9
Location: Oklahoma, USA

PostPosted: Fri Mar 14, 2014 7:40 am    Post subject: Jackd/jackdbus/gladish Reply with quote

I tried to install gladish from the proaudio overlay, yet the ladish.org website referred to in the ebuild is offline. Since I had the dependencies installed already, I went ahead and pull the latest from the git repos and built it from scratch.

https://github.com/LADI/ladish

However, this package used the dbus flag and hosed my jack installation.

I did some digging around and found that at one time the jack-audio-connection-kit in the overlay at one time had a classic flag so the dbus and jackd versions could coexist. However, that appears to be gone. equeries of all the 1.x and 2.x versions showed no classic USE flag.

I am not really sure why I cannot get jack to run on the messagebus. I am in the messagebus group. I could not get jack to start with jack_control from the root account. It is the timeout, bad permission, or no socket error (I reinstalled jackd for now and forgot to copy the verbose error, if you are unfamiliar with this error and can help me, I will re-emerge jack w/ the dbus USE flag and post it. I have seen this type of error before and last time it was a problem with the service file).

Am I missing something?

EDIT:

I was. I found this on the Arch wiki and it fixed my problem:

Quote:

jack2-dbus and qjackctl errors
Still having the "Cannot allocate memory" and/or "Cannot connect to server socket err = No such file or directory" error(s) when pressing qjackctl's start button (assuming that you have package jack2-dbus installed) ?
Please delete ~/.jackdrc, ~/.config/jack/conf.xml, ~/.config/rncbc.org/QjackCtl.conf. Kill jackdbus and restart from scratch :) (Thanks to nedko)
Back to top
View user's profile Send private message
spectromas
n00b
n00b


Joined: 13 Jul 2014
Posts: 20

PostPosted: Wed Jul 23, 2014 2:43 pm    Post subject: Reply with quote

Is there any chance that amsynth could be updated and/or have a git version available? The version in this overlay is pretty old and there has been quite a lot of features added to it since. Unforunately the latest stable release crashes Renoise so that is why I am looking for the latest git version.
Back to top
View user's profile Send private message
Ancipital
Bodhisattva
Bodhisattva


Joined: 21 Jul 2002
Posts: 260
Location: Grnn

PostPosted: Sat Jul 26, 2014 12:28 pm    Post subject: Reply with quote

Hi everyone,

I wanted to share my own experience, thanks to the pro-audio overlay I could jump start my own project, the scope of which is mostly limited to using Liquidsoap, which will stream to an icecast server.

I am using Funtoo myself, but like Gentoo, it supports overlays just fine.

Anyway, what got me started was my desire to use Liquidsoap 1.1.1, which is a newer version than in the pro-audio overlay, and thus I had to update some ebuilds. Long story short; after a lot of trial and error I finally got it to work. But not in the "standard" way.. I got it to work from inside a Funtoo hardened Docker container. In other words, I can now use Liquidsoap from a clean, re-deployable, environment, dedicated to Liquidsoap. Pretty awesome.

I would like to know whether this is of interest to others. Also, I'm considering to fork the Liquidsoap-specific elements into a new git repository. So, comments and thoughts would be much appreciated.

Cheers
Ancipital
_________________
Diplomacy is the art of letting the other party have things your way.
-- Daniele Vare
Back to top
View user's profile Send private message
nitm
n00b
n00b


Joined: 27 Dec 2004
Posts: 37

PostPosted: Sat Nov 22, 2014 7:48 am    Post subject: Reply with quote

Code:
>>> Emerging (16 of 20) media-sound/jack-audio-connection-kit-1.9.9.5-r1::proaudio
>>> Downloading 'https://dl.dropbox.com/u/28869550/jack-1.9.9.5.tar.bz2'
--2014-11-22 05:10:39--  https://dl.dropbox.com/u/28869550/jack-1.9.9.5.tar.bz2
Resolving dl.dropbox.com... 23.23.253.177
Connecting to dl.dropbox.com|23.23.253.177|:443... connected.
HTTP request sent, awaiting response... 302 FOUND
Location: https://dl.dropboxusercontent.com/u/28869550/jack-1.9.9.5.tar.bz2 [following]
--2014-11-22 05:10:39--  https://dl.dropboxusercontent.com/u/28869550/jack-1.9.9.5.tar.bz2
Resolving dl.dropboxusercontent.com... 54.243.148.68, 54.235.173.181, 54.235.101.248, ...
Connecting to dl.dropboxusercontent.com|54.243.148.68|:443... connected.
HTTP request sent, awaiting response... 404 Not Found
2014-11-22 05:10:40 ERROR 404: Not Found.
!!! Couldn't download 'jack-1.9.9.5.tar.bz2'. Aborting.
 * Fetch failed for 'media-sound/jack-audio-connection-kit-1.9.9.5-r1', Log file:
 *  '/var/tmp/portage/media-sound/jack-audio-connection-kit-1.9.9.5-r1/temp/build.log'


Anyone else having this problem?
Back to top
View user's profile Send private message
tclover
Guru
Guru


Joined: 10 Apr 2011
Posts: 328

PostPosted: Sun Nov 30, 2014 12:02 am    Post subject: What was that... again? Reply with quote

I tried to post this several times in the mailing list... Lets post it here and forget definitely about it.

---
Hello,

Could you please unsubscribe from proaudio mailing? I tried at least twice
in the past and I'm still recieving emails without being able to post anything
in the mailing.

Thanks.

And could you please post the following (first part of the title) in the mailing
list for me?

It's not much.. well almost a quarter, in sheer number, of proaudio packages.
---
Hello fellow pro-audio users,

I've updated and cleaned up my overlay (https://github.com/tokiclover/bar-overlay)
which took too much time than I have expected. I had too learn a few things here
and there e.g. waf eclass which I did not ever used directly.

I am sending this email after a short deliberation. Well, I don't use use pro-audio overlay
anymore because I eventually get enough of not being able to sync to it without making
a fresh clone and others (minor) annoyances. And I don't neither have write access.

And maybe my adventures could eventually benefit pro-audio users.
Package list (optional are inside `()'):
--
dev-libs/serd
dev-libs/sord
dev-util/lv2-c++-tools
media-libs/aubio
media-libs/libffado
media-libs/lilv
media-libs/lv2
media-libs/sratom
media-libs/suil
media-libs/zita-alsa-pcmi
media-libs/zita-resampler
media-plugins/calf
(media-plugins/deadbeef-plugins-jack)
media-plugins/ll-plugins
media-plugins/tap-plugins
media-sound/a2jmidid
media-sound/ardour
(media-sound/deadbeef)
media-sound/fluidsynth
media-sound/hydrogen
media-sound/jack-audio-connection-kit
media-sound/jack_mixer
media-sound/ladish
media-sound/laditools
media-sound/oss
media-sound/patchage
media-sound/rezound
media-sound/rosegarden
media-sound/seq24
media-sound/yoshimi
media-sound/zita-ajbridge
media-sound/zynaddsubfx
media-video/ffmpeg
sys-libs/libfreebob
virtual/liblash
x11-libs/ganv
--
Major differences with pro-audio tree are:

* every ebuild has a header (I'd like to have date/author for various reasons,
this can be obviously trimmed out);
* full multilib support, so not app-emul cruft left overs;
* even the patches were cleaned up!
* renamed jacksession USE flag to jack-session for consistency (the hyphen makes sense, although reverting is easy). (I've just stumbled on jacksession vs. jack-session? Another inconsistency, annoyance.)

When I was updating/cleaningh up media-plugins/ll-plugins, I was suprised by the makefile patch. And then, I bumped into an issue related to headers files not properly included.
What the hell! Actually upstream does not include properly dev-util/lv2-c++-tools headers
files which should be something like `#include <lv2-c++-tools/header-file>' but instead
use `#include <header-file>' directly without having any dev-util/lv2-c++-tools pkg-config lines whatsoever in the makefile to ensure that the C/LDFLAGS are properly included.

God, this is one of those things that makes you lost to much time on a package,
because you have to dig around in the source files to fix the headers files
(to add lv2-tools directory) to be sure to compile fine and have functionning plugins
without proper CFLAGS. Hower, proper CLFLAGS+="$(pkg-config --cflags lv2-tools)" would
be surely better. But wait, you have to do everything here! morever upstream have numerous comments in the source files saying "enough of lv2-tools and its unreliable headers files!".
Common, you should properly write preprocessor `#include' directive to be sure to be fine.
And then double finish it all with proper C/LDFLAGS. But it's not the case.

God, I don't want to waste hours debugging those kind of easy fixes which make you waste
too much time to dig them out.

Anyway, I'm writting this so other users won't waste unecessary time to debug
already fixed ebuilds.

Cheers.
---
_________________
mkinitramfs-ll:topic 879125::(bar-)overlay
Back to top
View user's profile Send private message
steveL
Advocate
Advocate


Joined: 13 Sep 2006
Posts: 3055
Location: The Peanut Gallery

PostPosted: Wed Dec 03, 2014 2:41 pm    Post subject: Reply with quote

Ancipital wrote:
I wanted to share my own experience, thanks to the pro-audio overlay I could jump start my own project, the scope of which is mostly limited to using Liquidsoap, which will stream to an icecast server.

I am using Funtoo myself, but like Gentoo, it supports overlays just fine.

Anyway, what got me started was my desire to use Liquidsoap 1.1.1, which is a newer version than in the pro-audio overlay, and thus I had to update some ebuilds. Long story short; after a lot of trial and error I finally got it to work. But not in the "standard" way.. I got it to work from inside a Funtoo hardened Docker container. In other words, I can now use Liquidsoap from a clean, re-deployable, environment, dedicated to Liquidsoap. Pretty awesome.

I would like to know whether this is of interest to others. Also, I'm considering to fork the Liquidsoap-specific elements into a new git repository. So, comments and thoughts would be much appreciated.

Sure it would be of interest, but only if we can use it on Gentoo OOB (and funtoo is the next phase.) As I don't want any overlays full of stuff about funtoo profiles: make it work on Gentoo first, and by all means downstream it to the downstream project.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2, 3 ... 15, 16, 17
Page 17 of 17

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum