Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Se me pudrió el rancho, libstdc++ y gcc rotos
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Spanish
View previous topic :: View next topic  
Author Message
gbobr
n00b
n00b


Joined: 10 Apr 2012
Posts: 10

PostPosted: Wed Nov 07, 2012 10:39 pm    Post subject: Se me pudrió el rancho, libstdc++ y gcc rotos Reply with quote

Todo comenzó esta mañana,
Estuve instalando algunos plasmoids que encontré en kde-look, y resulta que fallaron... Nada raro, estoy usando la versión del overlay del KDE 4.9, así que estoy acostumbrado a que algunas cosas no funcionen como debería.

Luego tranquila y pacíficamente fui a compilar del git la versión de mplayer que soporta vaapi.
Resulta que la compilación falló porque no encontró una .h
No le di importancia, era código bajado de un git, podía llegar a fallar.

Parecía un día normal, hasta que de pronto, una de las aplicaciones que intenté levantar me dijo por consola:

Quote:
error while loading shared libraries: libstdc++.so.6: cannot open shared object file: No such file or directory


Que raro dije, reinicié la notebook y no levantó el kdm, miro el log y veo:
Quote:
/usr/lib64/kde4/libexec/kdm_greet: error while loading shared libraries: libstdc++.so.6: cannot open shared object file: No such file or directory
Server terminated successfully (0). Closing log file.


Ah, te haces la viva netbook, ok voy a reinstalar la libstdc++

Quote:

# emerge libstdc++
[...]
/usr/lib/../x86_64-pc-linux-gnu/bin/ld: cannot find crtbegin.o: No such file or directory
/usr/lib/../x86_64-pc-linux-gnu/bin/ld: cannot find -lgcc
/usr/lib/../x86_64-pc-linux-gnu/bin/ld: cannot find -lgcc_s
collect2: ld devolvió el estado de salida 1
*** The command 'gcc -o conftest -O2 -pipe -Wl,-O1 -Wl,--as-needed conftest.c' failed.
*** You must set the environment variable CC to a working compiler.
* ERROR: sys-libs/libstdc++-v3-3.3.6 failed (compile phase):
* econf failed
*
* Call stack:
* ebuild.sh, line 85: Called src_compile
* environment, line 2770: Called econf '--enable-shared' '--with-system-zlib' '--enable-languages=c++' '--enable-threads=posix' '--enable-long-long' '--disable-checking' '--enable-cstdio=stdio' '--enable-__cxa_atexit' '--enable-multilib' '--enable-nls' '--without-included-gettext'
* phase-helpers.sh, line 467: Called die
* The specific snippet of code:
* die "econf failed"
*
* If you need support, post the output of `emerge --info '=sys-libs/libstdc++-v3-3.3.6'`,
* the complete build log and the output of `emerge -pqv '=sys-libs/libstdc++-v3-3.3.6'`.
* The complete build log is located at '/var/tmp/portage/sys-libs/libstdc++-v3-3.3.6/temp/build.log'.
* The ebuild environment file is located at '/var/tmp/portage/sys-libs/libstdc++-v3-3.3.6/temp/environment'.
* Working directory: '/var/tmp/portage/sys-libs/libstdc++-v3-3.3.6/work/build'
* S: '/var/tmp/portage/sys-libs/libstdc++-v3-3.3.6/work/gcc-3.3.6'

>>> Failed to emerge sys-libs/libstdc++-v3-3.3.6


En ese momento me di cuenta de que ya no podía compilar absolutamente nada.
Tengo roto el gcc

Otra pista:

Quote:
# gcc-config -l
* gcc-config: Profile does not exist or invalid setting for /etc/env.d/gcc/x86_64-pc-linux-gnu-4.5.4
[1] x86_64-pc-linux-gnu-4.5.4 *


El contenido de ese archivo es:
Quote:
LDPATH="/usr/lib/gcc/x86_64-pc-linux-gnu/4.5.4:/usr/lib/gcc/x86_64-pc-linux-gnu/4.5.4/32"
MANPATH="/usr/share/gcc-data/x86_64-pc-linux-gnu/4.5.4/man"
INFOPATH="/usr/share/gcc-data/x86_64-pc-linux-gnu/4.5.4/info"
STDCXX_INCDIR="g++-v4"
GCC_PATH="/usr/x86_64-pc-linux-gnu/gcc-bin/4.5.4"


¿Alguna idea de que puedo hacer?
Aparentemente faltan archivos, carpetas, cosas del gcc, no entiendo como pasó... probablemente alguno de los scripts de plasma que bajé estaba hecho para alguna maldad o algo así.

Estaba pensando en descomprimir un stage sobre mi instalación para recuperar el GCC andando
¿Alguna opinion a ese respecto? ¿Voy a romper todo peor?

Saludos


Last edited by gbobr on Wed Nov 07, 2012 10:51 pm; edited 1 time in total
Back to top
View user's profile Send private message
cameta
l33t
l33t


Joined: 04 Aug 2004
Posts: 696

PostPosted: Wed Nov 07, 2012 10:51 pm    Post subject: Reply with quote

Salva los datos importantes en otro disco duro y haz una instalación limpia.
Tardarás menos que intentando arreglar este desaguisado.
_________________
Si algo falla LEE el jodido manual, Si sigue fallando LEE BIEN el jodido manual.
Back to top
View user's profile Send private message
gbobr
n00b
n00b


Joined: 10 Apr 2012
Posts: 10

PostPosted: Wed Nov 07, 2012 11:01 pm    Post subject: Reply with quote

cameta wrote:
Salva los datos importantes en otro disco duro y haz una instalación limpia.
Tardarás menos que intentando arreglar este desaguisado.


Agradezco el consejo, pero no quiero reinstalar! tiene que haber alguna otra forma :S
Back to top
View user's profile Send private message
cameta
l33t
l33t


Joined: 04 Aug 2004
Posts: 696

PostPosted: Wed Nov 07, 2012 11:17 pm    Post subject: Reply with quote

El problema es que no sabes que has metido en el sistema.
_________________
Si algo falla LEE el jodido manual, Si sigue fallando LEE BIEN el jodido manual.
Back to top
View user's profile Send private message
miguel_senso
n00b
n00b


Joined: 11 Nov 2009
Posts: 68
Location: Guatemala, Guatemala C.A.

PostPosted: Sat Nov 10, 2012 1:30 am    Post subject: Reply with quote

Hola a todos, gbobr si aún no has resuelto tu problema recuerdo haber visto algo similar en este post http://forums.gentoo.org/viewtopic-t-900814-start-0.html y le pondría especial atención a la solucion propuesta por agdg que hasta un post realizó en su blog :D , espero te sirva de algo.
Back to top
View user's profile Send private message
cameta
l33t
l33t


Joined: 04 Aug 2004
Posts: 696

PostPosted: Sat Nov 10, 2012 9:41 am    Post subject: Reply with quote

http://www.makeinstall.es/2011/03/reparar-el-compilador-gcc-en-gentoo.html

Es esto, prueba a ver si tienes suerte.
_________________
Si algo falla LEE el jodido manual, Si sigue fallando LEE BIEN el jodido manual.
Back to top
View user's profile Send private message
quilosaq
l33t
l33t


Joined: 22 Dec 2009
Posts: 896

PostPosted: Sun Nov 11, 2012 8:08 pm    Post subject: Reply with quote

Mira si te queda algo de gcc instalado.
Code:
ls -l /usr/x86_64-pc-linux-gnu/gcc-bin/
Back to top
View user's profile Send private message
Arctic
Apprentice
Apprentice


Joined: 04 Jul 2011
Posts: 178

PostPosted: Sun Nov 11, 2012 11:50 pm    Post subject: Reply with quote

Prueba esto:

Code:
revdep-rebuild


Como tengas roto el gcc, vas a tener un quebradero de cabeza.................. lo unico que se me ocurre es una inconsistencia del sistema de ficheros ,porque si no has tocado a nada .............

Salu2
_________________
ln -s /user/artic /user/arctic
Back to top
View user's profile Send private message
Theasker
l33t
l33t


Joined: 18 Nov 2006
Posts: 636
Location: Zaragoza (Spain)

PostPosted: Mon Nov 12, 2012 8:53 pm    Post subject: Reply with quote

Prueba con fix_libtool_files.sh pertenece al gcc, yo hace poco lo arreglé con eso, suerte pero lo arreglarás con eso, no reinstales, q eso es lo "facil" :)
_________________
"Oigo y olvido. Veo y recuerdo. Hago y comprendo"
Back to top
View user's profile Send private message
cameta
l33t
l33t


Joined: 04 Aug 2004
Posts: 696

PostPosted: Mon Nov 12, 2012 10:29 pm    Post subject: Reply with quote

Bueno a reinstalar siempre hay tiempo. :wink:
_________________
Si algo falla LEE el jodido manual, Si sigue fallando LEE BIEN el jodido manual.
Back to top
View user's profile Send private message
JotaCE
l33t
l33t


Joined: 10 Jul 2007
Posts: 768
Location: SANTIAGO, CHILE!!!

PostPosted: Wed Nov 14, 2012 2:04 am    Post subject: Reply with quote

cameta wrote:
Bueno a reinstalar siempre hay tiempo. :wink:


De acuerdo contigo!
_________________
La derrota no es motivo de vergüenza si el espíritu sigue sin conquistar!
Back to top
View user's profile Send private message
gringo
Advocate
Advocate


Joined: 27 Apr 2003
Posts: 3748

PostPosted: Wed Nov 14, 2012 9:16 am    Post subject: Reply with quote

que tienes en /etc/env.d/gcc ?
igual se soluciona simplemente con hacer un gcc-config 1 para que se vuelva a regenerar el perfil.

saluetes
Back to top
View user's profile Send private message
SS3
n00b
n00b


Joined: 23 Oct 2010
Posts: 20

PostPosted: Tue Dec 04, 2012 2:03 am    Post subject: Reply with quote

No creo que sea motivo para reinstalar, antes de nada ejecuta la herramienta revdep-rebuild como te dicen más arriba.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Spanish All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum