Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
revdep-rebuild broken
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
jtaylor1126
n00b
n00b


Joined: 11 Jun 2012
Posts: 5

PostPosted: Wed Nov 14, 2012 1:46 am    Post subject: revdep-rebuild broken Reply with quote

I have uninstalled ruby on my server but now when I run revdep-rebuild I keep getting this error:

revdep-rebuild
* Configuring search environment for revdep-rebuild

* Checking reverse dependencies
* Packages containing binaries and libraries broken by a package update
* will be emerged.

* Collecting system binaries and libraries
* Found existing 1_files.rr
* Collecting complete LD_LIBRARY_PATH
* Found existing 2_ldpath.rr.
* Checking dynamic linking consistency
* Found existing 3_broken.rr.
* Assigning files to packages
* !!! /usr/local/lib64/ruby/gems/1.8/gems/eventmachine-1.0.0/ext/fastfilereader/fastfilereaderext.so not owned by any package is broken !!!
* /usr/local/lib64/ruby/gems/1.8/gems/eventmachine-1.0.0/ext/fastfilereader/fastfilereaderext.so -> (none)
* !!! /usr/local/lib64/ruby/gems/1.8/gems/eventmachine-1.0.0/ext/rubyeventmachine.so not owned by any package is broken !!!
* /usr/local/lib64/ruby/gems/1.8/gems/eventmachine-1.0.0/ext/rubyeventmachine.so -> (none)
* !!! /usr/local/lib64/ruby/gems/1.8/gems/eventmachine-1.0.0/lib/fastfilereaderext.so not owned by any package is broken !!!
* /usr/local/lib64/ruby/gems/1.8/gems/eventmachine-1.0.0/lib/fastfilereaderext.so -> (none)
* !!! /usr/local/lib64/ruby/gems/1.8/gems/eventmachine-1.0.0/lib/rubyeventmachine.so not owned by any package is broken !!!
* /usr/local/lib64/ruby/gems/1.8/gems/eventmachine-1.0.0/lib/rubyeventmachine.so -> (none)
* !!! /usr/local/lib64/ruby/gems/1.8/gems/json-1.7.5/ext/json/ext/generator/generator.so not owned by any package is broken !!!
* /usr/local/lib64/ruby/gems/1.8/gems/json-1.7.5/ext/json/ext/generator/generator.so -> (none)
* !!! /usr/local/lib64/ruby/gems/1.8/gems/json-1.7.5/ext/json/ext/parser/parser.so not owned by any package is broken !!!
* /usr/local/lib64/ruby/gems/1.8/gems/json-1.7.5/ext/json/ext/parser/parser.so -> (none)
* !!! /usr/local/lib64/ruby/gems/1.8/gems/json-1.7.5/lib/json/ext/generator.so not owned by any package is broken !!!
* /usr/local/lib64/ruby/gems/1.8/gems/json-1.7.5/lib/json/ext/generator.so -> (none)
* !!! /usr/local/lib64/ruby/gems/1.8/gems/json-1.7.5/lib/json/ext/parser.so not owned by any package is broken !!!
* /usr/local/lib64/ruby/gems/1.8/gems/json-1.7.5/lib/json/ext/parser.so -> (none)
* !!! /usr/local/lib64/ruby/gems/1.8/gems/mysql-2.8.2/ext/mysql_api/mysql_api.so not owned by any package is broken !!!
* /usr/local/lib64/ruby/gems/1.8/gems/mysql-2.8.2/ext/mysql_api/mysql_api.so -> (none)
* !!! /usr/local/lib64/ruby/gems/1.8/gems/mysql-2.8.2/lib/mysql/mysql_api.so not owned by any package is broken !!!
* /usr/local/lib64/ruby/gems/1.8/gems/mysql-2.8.2/lib/mysql/mysql_api.so -> (none)
* !!! /usr/local/lib64/ruby/gems/1.8/gems/racc-1.4.9/ext/racc/cparse.so not owned by any package is broken !!!
* /usr/local/lib64/ruby/gems/1.8/gems/racc-1.4.9/ext/racc/cparse.so -> (none)
* !!! /usr/local/lib64/ruby/gems/1.8/gems/racc-1.4.9/lib/racc/cparse.so not owned by any package is broken !!!
* /usr/local/lib64/ruby/gems/1.8/gems/racc-1.4.9/lib/racc/cparse.so -> (none)
* !!! /usr/local/lib64/ruby/gems/1.8/gems/thin-1.5.0/ext/thin_parser/thin_parser.so not owned by any package is broken !!!
* /usr/local/lib64/ruby/gems/1.8/gems/thin-1.5.0/ext/thin_parser/thin_parser.so -> (none)
* !!! /usr/local/lib64/ruby/gems/1.8/gems/thin-1.5.0/lib/thin_parser.so not owned by any package is broken !!!
* /usr/local/lib64/ruby/gems/1.8/gems/thin-1.5.0/lib/thin_parser.so -> (none)
* !!! /usr/local/lib64/ruby/gems/1.9.1/gems/ffi-1.1.5/ext/ffi_c/ffi_c.so not owned by any package is broken !!!
* /usr/local/lib64/ruby/gems/1.9.1/gems/ffi-1.1.5/ext/ffi_c/ffi_c.so -> (none)
* !!! /usr/local/lib64/ruby/gems/1.9.1/gems/ffi-1.1.5/lib/ffi_c.so not owned by any package is broken !!!
* /usr/local/lib64/ruby/gems/1.9.1/gems/ffi-1.1.5/lib/ffi_c.so -> (none)
* !!! /usr/local/lib64/ruby/gems/1.9.1/gems/json-1.7.5/ext/json/ext/generator/generator.so not owned by any package is broken !!!
* /usr/local/lib64/ruby/gems/1.9.1/gems/json-1.7.5/ext/json/ext/generator/generator.so -> (none)
* !!! /usr/local/lib64/ruby/gems/1.9.1/gems/json-1.7.5/ext/json/ext/parser/parser.so not owned by any package is broken !!!
* /usr/local/lib64/ruby/gems/1.9.1/gems/json-1.7.5/ext/json/ext/parser/parser.so -> (none)
* !!! /usr/local/lib64/ruby/gems/1.9.1/gems/json-1.7.5/lib/json/ext/generator.so not owned by any package is broken !!!
* /usr/local/lib64/ruby/gems/1.9.1/gems/json-1.7.5/lib/json/ext/generator.so -> (none)
* !!! /usr/local/lib64/ruby/gems/1.9.1/gems/json-1.7.5/lib/json/ext/parser.so not owned by any package is broken !!!
* /usr/local/lib64/ruby/gems/1.9.1/gems/json-1.7.5/lib/json/ext/parser.so -> (none)
* !!! /usr/local/lib64/ruby/gems/1.9.1/gems/kgio-2.7.4/ext/kgio/kgio_ext.so not owned by any package is broken !!!
* /usr/local/lib64/ruby/gems/1.9.1/gems/kgio-2.7.4/ext/kgio/kgio_ext.so -> (none)
* !!! /usr/local/lib64/ruby/gems/1.9.1/gems/kgio-2.7.4/lib/kgio_ext.so not owned by any package is broken !!!
* /usr/local/lib64/ruby/gems/1.9.1/gems/kgio-2.7.4/lib/kgio_ext.so -> (none)
* !!! /usr/local/lib64/ruby/gems/1.9.1/gems/mysql2-0.2.18/ext/mysql2/mysql2.so not owned by any package is broken !!!
* /usr/local/lib64/ruby/gems/1.9.1/gems/mysql2-0.2.18/ext/mysql2/mysql2.so -> (none)
* !!! /usr/local/lib64/ruby/gems/1.9.1/gems/mysql2-0.2.18/lib/mysql2/mysql2.so not owned by any package is broken !!!
* /usr/local/lib64/ruby/gems/1.9.1/gems/mysql2-0.2.18/lib/mysql2/mysql2.so -> (none)
* !!! /usr/local/lib64/ruby/gems/1.9.1/gems/mysql2-0.3.11/ext/mysql2/mysql2.so not owned by any package is broken !!!
* /usr/local/lib64/ruby/gems/1.9.1/gems/mysql2-0.3.11/ext/mysql2/mysql2.so -> (none)
* !!! /usr/local/lib64/ruby/gems/1.9.1/gems/mysql2-0.3.11/lib/mysql2/mysql2.so not owned by any package is broken !!!
* /usr/local/lib64/ruby/gems/1.9.1/gems/mysql2-0.3.11/lib/mysql2/mysql2.so -> (none)
* !!! /usr/local/lib64/ruby/gems/1.9.1/gems/nokogiri-1.5.5/ext/nokogiri/nokogiri.so not owned by any package is broken !!!
* /usr/local/lib64/ruby/gems/1.9.1/gems/nokogiri-1.5.5/ext/nokogiri/nokogiri.so -> (none)
* !!! /usr/local/lib64/ruby/gems/1.9.1/gems/nokogiri-1.5.5/lib/nokogiri/nokogiri.so not owned by any package is broken !!!
* /usr/local/lib64/ruby/gems/1.9.1/gems/nokogiri-1.5.5/lib/nokogiri/nokogiri.so -> (none)
* !!! /usr/local/lib64/ruby/gems/1.9.1/gems/raindrops-0.10.0/ext/raindrops/raindrops_ext.so not owned by any package is broken !!!
* /usr/local/lib64/ruby/gems/1.9.1/gems/raindrops-0.10.0/ext/raindrops/raindrops_ext.so -> (none)
* !!! /usr/local/lib64/ruby/gems/1.9.1/gems/raindrops-0.10.0/lib/raindrops_ext.so not owned by any package is broken !!!
* /usr/local/lib64/ruby/gems/1.9.1/gems/raindrops-0.10.0/lib/raindrops_ext.so -> (none)
* !!! /usr/local/lib64/ruby/gems/1.9.1/gems/unicorn-4.4.0/ext/unicorn_http/unicorn_http.so not owned by any package is broken !!!
* /usr/local/lib64/ruby/gems/1.9.1/gems/unicorn-4.4.0/ext/unicorn_http/unicorn_http.so -> (none)
* !!! /usr/local/lib64/ruby/gems/1.9.1/gems/unicorn-4.4.0/lib/unicorn_http.so not owned by any package is broken !!!
* /usr/local/lib64/ruby/gems/1.9.1/gems/unicorn-4.4.0/lib/unicorn_http.so -> (none)
* Generated new 4_raw.rr and 4_owners.rr
* Found some broken files, but none of them were associated with known packages
* Unable to proceed with automatic repairs.
* The broken files are listed in 4_owners.rr

When I look into those directories those files are not listed.

dev ~ # ll /usr/local/lib64
total 0
Back to top
View user's profile Send private message
Jaglover
Advocate
Advocate


Joined: 29 May 2005
Posts: 4667
Location: Saint Amant, Acadiana

PostPosted: Wed Nov 14, 2012 1:53 am    Post subject: Reply with quote

You should remove stale *.rr files and try again.
_________________
Please learn how to denote units correctly!
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 5586

PostPosted: Wed Nov 14, 2012 1:56 am    Post subject: Reply with quote

Well, revdep-rebuild seems to hate things installed in /usr/local/, therefore in this case it hates you.
Back to top
View user's profile Send private message
paulj
Guru
Guru


Joined: 30 Sep 2004
Posts: 342
Location: Wales, UK

PostPosted: Wed Nov 14, 2012 8:14 am    Post subject: Reply with quote

Have you installed ruby packages using gem separately from portage? If so, revdep-rebuild won't know how to re-emerge them if they refer to library files which have now been upgraded.
Back to top
View user's profile Send private message
khayyam
Advocate
Advocate


Joined: 07 Jun 2012
Posts: 2244

PostPosted: Wed Nov 14, 2012 8:54 am    Post subject: Reply with quote

jtaylor1126 ...

correction: "ruby is broken", anyhow see man revdep-rebuild, specifically SEARCH_DIRS_MASK.

best ... khay
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum