Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Hat jemand Sound/Sprachausgabe in Google Earth?
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
Randy Andy
Veteran
Veteran


Joined: 19 Jun 2007
Posts: 1047
Location: /dev/koelsch

PostPosted: Tue Jul 06, 2010 9:11 am    Post subject: Hat jemand Sound/Sprachausgabe in Google Earth? Reply with quote

Hallo Leute.

Ich kenne es garnicht anders, als dass mein Google-Earth Muxmäuschenstill ist.
Dachte immer das wäre noch ein Manko der Linux-Version, obwohl ich stets die neueste verwende, da ich im ~x86_64 Zweig mit KDE-4.4.5 arbeite und fast täglich update.

Bis mir kürzlich ein Kollege erzählte, dass bei ihm unter Suse 11.x mit Gnome, das prima funktioniert. Das geht aber man garnicht, oder!

Ich teste das in Google Earth immer mit der Guided Tour der Mond Erkundung, und möchte endlich mal die Stimme von Neil Armstrong und konsorten hören.

Ich hatte in früher Vergangenheit mal Pulseaudio unterstützung installiert, machte aber ein bisschen zicken unter KDE4 mit Phonon, weshalb ich das wieder entfernt hatte.

Also, nochmal den Alsa Guide geschnappt und durchgegangen, aber kann eigentlich in meinem System keine Fehler erkennen.
Sound funktioniert sonst eigentlich prima, d.h. mit Phonon und den Systemklängen - geht,
Alsa, Kmixer oder auch Flash-sound, geht, Amarok und diverse sounds abspielen - geht.

Habe allerdings keine Midi oder seqencer Unterstützung (timidiy) aktiviert, aber die brauch ich doch dafür wohl kaum, oder?

Woran kann es liegen?
Auf welches Sound-system greift Google-Earth zurück, und wo kann man das einstellen?

Wie geh ich bei der Diagnose vor, was braucht ihr für Infos um mir dabei zu helfen?

Fragen über Fragen...

Dank euch vorab,
Andy.
_________________
If you want to see a Distro done right, compile it yourself!


Last edited by Randy Andy on Fri Jul 09, 2010 7:01 am; edited 1 time in total
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 3924
Location: Irgendwo im Nirgendwo

PostPosted: Tue Jul 06, 2010 9:32 am    Post subject: Reply with quote

Welche Version von emul-linux-x86-qtlibs hast du installiert?
Welche Version von emul-linux-x86-soundlibs, und mit welchen USE-Flags?
Ich hab es selber noch nicht probiert mit dem Sound unter googleearth, kann also nix dazu sagen ;)
_________________
"der mac dennoch wesen geil"
Wolfram von Eschenbach, Parzival (Buch 1, Z. 7).
Ein frühes Statement gegen Windows.

My overlay
Back to top
View user's profile Send private message
Randy Andy
Veteran
Veteran


Joined: 19 Jun 2007
Posts: 1047
Location: /dev/koelsch

PostPosted: Tue Jul 06, 2010 10:29 am    Post subject: Reply with quote

Hi Franz,

werd's dir später durchkabeln, wenn ich wieder zu Hause an einem vernünftigen OS sitze, und vor dem heutigen User-Group Treffen noch die Zeit dazu finde.

Dank, Andy.
_________________
If you want to see a Distro done right, compile it yourself!
Back to top
View user's profile Send private message
Christian99
l33t
l33t


Joined: 28 May 2009
Posts: 991

PostPosted: Tue Jul 06, 2010 11:31 am    Post subject: Reply with quote

cool, ich wusste bisher auch nicht, dass es google-earth mit sound gibt, ganz zu schweigen von den mond touren. Da bei mir auch kein sound geht, klink ich mich einfach mal ein:
system: ~amd64
app-emulation/emul-linux-x86-soundlibs
Available versions: 20100220-r1!s 20100409-r1!s 20100611!s {alsa pulseaudio}
Installed versions: 20100611!s(21:15:35 27.06.2010)(alsa pulseaudio)

app-emulation/emul-linux-x86-qtlibs
Available versions: 20100220!s 20100409!s 20100611!s
Installed versions: 20100611!s(21:14:59 27.06.2010)

sci-geosciences/googleearth
Available versions: 5.1.3533.1731-r1!f!s 5.1.3535.3218-r1!m!s (~)5.2.1.1329_beta!m!s {mdns-bundled (+)qt-bundled}
Installed versions: 5.2.1.1329_beta!m!s(04:05:05 30.06.2010)(qt-bundled -mdns-bundled)

da googleearth mit qt-bundeld installiert ist, dürfte es doch eigentlich die system x86-qtlibs gar nicht verwenden, oder?

EDIT: Ich verwende pulseaudio, und überall sonst (sytemsounds, vlc, mpd, flash...) gehts auch ohne probleme.
Back to top
View user's profile Send private message
toralf
Advocate
Advocate


Joined: 01 Feb 2004
Posts: 2700
Location: Hamburg/Germany

PostPosted: Tue Jul 06, 2010 1:07 pm    Post subject: Reply with quote

Christian99 wrote:
cool, ich wusste bisher auch nicht, dass es google-earth mit sound gibt, ganz zu schweigen von den mond touren.
++
Und jetzt - wo ich das weiß, fehlt's mir auch ...
Back to top
View user's profile Send private message
Randy Andy
Veteran
Veteran


Joined: 19 Jun 2007
Posts: 1047
Location: /dev/koelsch

PostPosted: Tue Jul 06, 2010 3:21 pm    Post subject: Reply with quote

Ahh,

iss ja nett, dass ich doch nicht alleine bin, auf weiter Flur.

Also Franz und alle die etwas zur Lösung beisteuern können, bei mir schaut's wie folgt aus:

Code:
                                                                                         
[ebuild   R   ] app-emulation/emul-linux-x86-soundlibs-20100611  USE="alsa -pulseaudio" 0 kB                                   
                                                                                                                                                                                                                         
[ebuild   R   ] app-emulation/emul-linux-x86-qtlibs-20100611  0 kB                                                             
                                                                                                                               
[ebuild   R   ] sci-geosciences/googleearth-5.2.1.1329_beta  USE="qt-bundled -mdns-bundled" 0 kB


Und nu?
Ideen willkommen.
_________________
If you want to see a Distro done right, compile it yourself!
Back to top
View user's profile Send private message
Randy Andy
Veteran
Veteran


Joined: 19 Jun 2007
Posts: 1047
Location: /dev/koelsch

PostPosted: Fri Jul 09, 2010 6:59 am    Post subject: Reply with quote

Hallo Mitstreiter.

Mich würde am meisten interessieren ob es hier (Gentoo) überhaupt jemanden gibt, bei dem Sound bzw. die Sprachausgabe von GoogleEarth funktioniert?

Das würde vielleicht schon ein bisschen weiterhelfen die Sache einzugrenzen (z.B. nur auf 32bit kompatibiltät, oder sonstige Konstellationen).

Konnte bisher nichts dazu finden, weder in Bugzilla, noch bei Tante Google. Und Quellcode lesen gehört leider noch nicht zu meinen Fähigkeiten(*), aber da will ich noch hinkommen, spätestens wenn ich Rente gehe und mehr Zeit finde :wink:

Folgendes hab ich zwischenzeitlich noch ausprobiert.

Sämtliche USE Flags aktiviert, die irgendwas mit Codec-Unterstützung von Video-streaming / Audio-Streaming oder sonstigen audio/video codecs zu tun haben, obwohl das Paket googleearth ja nur Zwei Flags anzeigt, die dafür eigentlich keinen Zusammenhang erkenen lassen.
Aber wer weiß, vielleicht wird ja irgendwas als selbstvertändlich vorausgesetzt, was in dem ebuild nicht berücksichtigt wurde? Bin aber unsicher weil (*).

Dann hab ich erst mal mein /home /$user/.googleearth Verz. gelöscht, und musste feststellen das gespeicherte Touren trotzdem erhalten bleiben, da sie scheinbar im system (ich glaub es war /var/foo/whatever) gespeichert werden.
Daher hab ich das gesamte Paket mal deinstalliert / installiert - hat aber alles nix gebracht.

Wie geht's weiter?
Ein Bugreport macht aber erst Sinn, wenn es unter Gentoo keinen gibt bei dem's läuft- oder?
Hilfe in die Runde.

Andy.
_________________
If you want to see a Distro done right, compile it yourself!
Back to top
View user's profile Send private message
toralf
Advocate
Advocate


Joined: 01 Feb 2004
Posts: 2700
Location: Hamburg/Germany

PostPosted: Fri Jul 09, 2010 8:00 am    Post subject: Reply with quote

Randy Andy wrote:
Konnte bisher nichts dazu finden, weder in Bugzilla, noch bei Tante Google.
Hhm, also mein Google gibt bei diesem Fragesatz http://www.google.de/search?q=no+sound+in+google+earth+under+linux&ie=utf-8&oe=utf-8&aq=t&rls=org.gentoo:en-US:unofficial&client=firefox-a dies hier aus http://code.google.com/p/earth-issues/issues/detail?id=199
Back to top
View user's profile Send private message
Randy Andy
Veteran
Veteran


Joined: 19 Jun 2007
Posts: 1047
Location: /dev/koelsch

PostPosted: Fri Jul 09, 2010 9:07 am    Post subject: Reply with quote

Danke toralf,

ich meine natürlich nicht nichts, sondern nichst Zielführendes :wink:

Dein Link ist aber tatsächlich schon nah dran, leider haben die da aber auch keine Abhilfe finden können, oder Info's die wir nicht schon wüssten.
So wie duzende der Links von Google die ich schon zu dem Thema besucht habe, inklusive deren Earth-Hilfe/ Forum :cry:

Mal sehen wie's weiter geht....
_________________
If you want to see a Distro done right, compile it yourself!
Back to top
View user's profile Send private message
Randy Andy
Veteran
Veteran


Joined: 19 Jun 2007
Posts: 1047
Location: /dev/koelsch

PostPosted: Thu Aug 19, 2010 8:43 am    Post subject: Reply with quote

... anscheinend geht's nicht weiter, daher zur Auffrischung nochmal hochgeholt.
_________________
If you want to see a Distro done right, compile it yourself!
Back to top
View user's profile Send private message
Randy Andy
Veteran
Veteran


Joined: 19 Jun 2007
Posts: 1047
Location: /dev/koelsch

PostPosted: Tue Sep 21, 2010 10:25 am    Post subject: Reply with quote

Und, gibt's was Neues?

Auf welches Soundssystem setzt GoogleEarth eigentlich auf (Alsa, OSS, esd, Pulseaudio, Phonon, Gstreamer, xine, ?) um den Sound überhaupt ausgeben zu können?
Wo finden sich conf. dateien zum einstellen?
Wo gibt's information oder Dokumentation dazu?

Fragen über Fragen...
_________________
If you want to see a Distro done right, compile it yourself!
Back to top
View user's profile Send private message
Randy Andy
Veteran
Veteran


Joined: 19 Jun 2007
Posts: 1047
Location: /dev/koelsch

PostPosted: Fri Mar 02, 2012 6:46 pm    Post subject: Reply with quote

Wow Leute,

wie die Zeit vergeht.
Ist doch tatsächlich schon über ein Jahr her und anscheinend hat sich die Lage nicht wirklich geändert, oder funktioniert der Sound mittlerweile bei Euch?

Wollte die Gestern neu im Tree erschienene Version googleearth-6.2.1.6014 (01 Mar 2012) zum Anlass nehmen und mal bei mir testen ob's nun geht - doch nix is.
Weiß nicht ob dieses Feature nun neu hinzu gekommen ist, oder ob ich's nur nicht bemerkt hatte, jedenfalls gilt es nun wohl Zwei Szenarien, erreichbar per Menü
Ansicht/Erkunden/Mond/ Ebenen/Moon Gallery/ zu unterscheiden.

1.) Guided Tours z.B. Apollo 11 (speziell hier fehlt mir der Sound/ Voice von Anfang an).
und (für mich) neu.
2.) Apollo Missions (11-17, alle mit Play Symbol)
Hier handelt es sich wohl meist um Flash Filme die z.B. mit dem Adobe Flashplayer laufen sollten. Das dumme ist nur folgendes:
Obwohl er bei mir installiert ist und unterm Firefox prima läuft, z.B. auch bei YouTube, behauptet GoogleEarth er wär nicht installiert und will mir anbieten diesen zu installieren oder runterzuladen, was am Paketmanagement vorbei natürlich nicht funktionieren kann bzw. nicht gewollt ist.

Das hab ich doch schon mal irgendwo anders gehört... musste man da nicht eine ganz bestimmte Version installieren auf der das Programm besteht?

Habt ihr bezüglich 1. und 2. schon weiterführende Erkenntnisse bzw. mehr Erfolg.
Hat 1. unter Linux (egal welche Distro) denn schon mal mit Sound/Stimme bei Euch funktioniert?

Feedback stets willkommen.

Grooß, Andy.
_________________
If you want to see a Distro done right, compile it yourself!
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 2281
Location: Germany

PostPosted: Fri Mar 02, 2012 7:26 pm    Post subject: Reply with quote

Hallo

Nur eine Idee:
Zu googleearth kann ich nichts beitragen (nicht installiert)
Aber falls googleearth tatsächlich einen Flashplayer benötigt, und diesen unter Gentoo nicht findet könnte es eventuell daran liegen das im falschen Pfad gesucht wird?!
AFAIK suchen einige Binary-Blobs im firefox unter ~/.mozilla/plugins/ nach der libflashplayer.so Daher wäre es eventuell mal ein Versuch wert sich dort einen Symlink zur libflashplayer.so anzulegen, und zu testen.
Beim adobe-flash Player also zb einen Symlink wie
Code:
~/.mozilla/plugins/libflashplayer.so -> /opt/Adobe/flash-player/flash-plugin/libflashplayer.so

(Das ganze ist nur eine ungetestete Idee!)
Back to top
View user's profile Send private message
toralf
Advocate
Advocate


Joined: 01 Feb 2004
Posts: 2700
Location: Hamburg/Germany

PostPosted: Sat Mar 03, 2012 2:56 pm    Post subject: Reply with quote

Josef.95 wrote:
(Das ganze ist nur eine ungetestete Idee!)
und funktioniert auch nicht :-(
Back to top
View user's profile Send private message
Randy Andy
Veteran
Veteran


Joined: 19 Jun 2007
Posts: 1047
Location: /dev/koelsch

PostPosted: Sat Mar 03, 2012 6:35 pm    Post subject: Reply with quote

Danke Leute,

hab etwas länger gebraucht, da mich der Bug des Tages ziemlich ausgebremst hat...
Quote:


*mesa-8.0.1-r2 (03 Mar 2012)

03 Mar 2012; Luca Barbato <lu_zero@gentoo.org> mesa-8.0.1-r1.ebuild,
+mesa-8.0.1-r2.ebuild:
Revert header placement


Außerdem gab's Heute schon wieder eine neue Version von GoogleEarth, jedoch nur um Probleme mit Pfadangaben im Startmenüaufruf zu lösen, die ich zuvor schon händisch gefixt hatte.
Das mit dem symbolischen Link hab ich zwischenzeitlich auch mal probiert, hat aber leider auch hier nichts gebracht.

Aufgefallen ist mir, das es in dem Programm nun auch einen Anmelden Button gibt, doch wenn ich den an-klicke crasht das Programm komplett.
Ob sich dahinter wieder so ein "toller" Mehrwertdienst der Krake befindet damit Sie künftig wissen für welche Gegenden man sich interessiert, und welchen Standort man als Heimatstandort definiert hat,
natürlich gleich mit den präzisen GPS Koordinaten :roll:
Nun muss man den User nur noch dazu bekommen sich stets brav anzumelden - vielleicht indem er sonst die besagten Flash-Filmchen nicht gucken kann und schon wird'n Schuh draus :wink:

Aber bis dahin haben die ja noch ein paar Bugs zu fixen, gelle.

Grooß, Andy.
Nicht dass man die
_________________
If you want to see a Distro done right, compile it yourself!
Back to top
View user's profile Send private message
Randy Andy
Veteran
Veteran


Joined: 19 Jun 2007
Posts: 1047
Location: /dev/koelsch

PostPosted: Mon Nov 12, 2012 2:44 pm    Post subject: Reply with quote

Hallo Leute, liebe Paket-Mantainer.

Diese Meldung ist ja schon wieder 11 Tage her:
http://www.heise.de/newsticker/meldung/Virtuelle-Reiseerlebnisse-mit-Google-Earth-7-1741470.html

doch leider ist die neue Version noch nicht im Tree (und anscheinend auch in keinem Overlay), um mal zu testen ob das Problem mit dem fehlenden Sound vielleicht damit endlich gefixed sein wird :cry:

Deshalb hol ich den Thread mal wieder hoch, in der Hoffnung dass sich daran mehr Leute beteiligen bzw. darauf aufmerksam werden.

Gruß, Andy.
_________________
If you want to see a Distro done right, compile it yourself!
Back to top
View user's profile Send private message
Christian99
l33t
l33t


Joined: 28 May 2009
Posts: 991

PostPosted: Mon Nov 12, 2012 2:50 pm    Post subject: Reply with quote

viele maintainer werden das hier nicht lesen...
besser wäre es, ein version-bump request im bugzilla zu erstellen
Back to top
View user's profile Send private message
Randy Andy
Veteran
Veteran


Joined: 19 Jun 2007
Posts: 1047
Location: /dev/koelsch

PostPosted: Mon Nov 12, 2012 5:52 pm    Post subject: Reply with quote

Christian,
wo Du recht hast, hast Du recht.

Daher nun erledigt:
https://bugs.gentoo.org/show_bug.cgi?id=442884
_________________
If you want to see a Distro done right, compile it yourself!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum