Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
udev problems again :-(
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
DieterK
n00b
n00b


Joined: 28 Oct 2010
Posts: 68

PostPosted: Sun Nov 11, 2012 12:45 am    Post subject: udev problems again :-( Reply with quote

Hello,

after many many month i can't upgrade my system because of the latest udev/kde upgrade:
Code:
The following keyword changes are necessary to proceed:
#required by sys-fs/udev-195[openrc], required by app-admin/system-config-printer-common-1.3.12, required by kde-base/printer-applet-4.9.3, required by kde-base/kdeutils-meta-4.9.3[cups], required by kde-base/kde-meta-4.9.3, required by @selected, required by @world (argument)
=sys-fs/udev-init-scripts-17-r1 ~amd64
#required by sys-fs/udev-195, required by app-admin/system-config-printer-common-1.3.12, required by kde-base/printer-applet-4.9.3, required by kde-base/kdeutils-meta-4.9.3[cups], required by kde-base/kde-meta-4.9.3, required by @selected, required by @world (argument)
=sys-apps/kmod-11-r1 ~amd64

The following mask changes are necessary to proceed:
#required by sys-fs/udev-195[openrc], required by app-admin/system-config-printer-common-1.3.12, required by kde-base/printer-applet-4.9.3, required by kde-base/kdeutils-meta-4.9.3[cups], required by kde-base/kde-meta-4.9.3, required by @selected, required by @world (argument)
# /etc/portage/package.mask/udev:
=sys-fs/udev-init-scripts-17-r1
#required by sys-fs/udev-195, required by app-admin/system-config-printer-common-1.3.12, required by kde-base/printer-applet-4.9.3, required by kde-base/kdeutils-meta-4.9.3[cups], required by kde-base/kde-meta-4.9.3, required by @selected, required by @world (argument)
# /etc/portage/package.mask/udev:
=sys-apps/kmod-11-r1
#required by sys-fs/udev-init-scripts-17-r1
# /etc/portage/package.mask/udev:
=sys-fs/udev-195


Because of my seperated /usr/ partition i have this in my package.mask:
Code:

>=sys-fs/udev-181
>=sys-apps/kmod-6
>=sys-fs/udev-init-scripts-8


Is there any workaround for this problem? I don't want to change everything because of this :-(

Thank you
Back to top
View user's profile Send private message
chithanh
Developer
Developer


Joined: 05 Aug 2006
Posts: 1678
Location: Berlin, Germany

PostPosted: Sun Nov 11, 2012 12:56 am    Post subject: Reply with quote

Code:
required by kde-base/kdeutils-meta-4.9.3[cups]
If you don't require the KDE print queue display applet, then you can try disabling the cups flag for kdeutils-meta. Also use emerge --autounmask=n to make its output a bit more informative.
Back to top
View user's profile Send private message
DieterK
n00b
n00b


Joined: 28 Oct 2010
Posts: 68

PostPosted: Sun Nov 11, 2012 4:45 am    Post subject: Reply with quote

Thanks, i tried it again:

Code:
!!! All ebuilds that could satisfy ">=sys-fs/udev-172" have been masked.
!!! One of the following masked packages is required to complete your request:
- sys-fs/udev-9999::gentoo (masked by: package.mask, missing keyword)
- sys-fs/udev-195::gentoo (masked by: package.mask)
- sys-fs/udev-194::gentoo (masked by: package.mask)
- sys-fs/udev-193::gentoo (masked by: package.mask)
- sys-fs/udev-192::gentoo (masked by: package.mask)
- sys-fs/udev-191::gentoo (masked by: package.mask)
- sys-fs/udev-190::gentoo (masked by: package.mask)
- sys-fs/udev-189::gentoo (masked by: package.mask)

(dependency required by "app-admin/system-config-printer-common-1.3.12" [ebuild])
(dependency required by "kde-base/printer-applet-4.9.3" [ebuild])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.
Back to top
View user's profile Send private message
The Doctor
Veteran
Veteran


Joined: 27 Jul 2010
Posts: 1493

PostPosted: Sun Nov 11, 2012 4:53 am    Post subject: Reply with quote

I don't know if you heard, but there is a fork of udev that supports a separate /usr with a discussion thread here

Personally I have been using it for a while and the only issue I have is that I need to delete /lib/udev/rules.d/90-alsa-restore.rules to stop udev from trying to mess with alsa before /usr is mounted. This does not affect alsa in any other way since those rules only apply for hot plugging a sound card.
_________________
First things first, but not necessarily in that order.
Back to top
View user's profile Send private message
DaggyStyle
Advocate
Advocate


Joined: 22 Mar 2006
Posts: 4941

PostPosted: Sun Nov 11, 2012 6:14 am    Post subject: Reply with quote

just mask app-admin/system-config-printer-common-1.3.12
_________________
Only two things are infinite, the universe and human stupidity and I'm not sure about the former - Albert Einstein
ProjectFootball
Back to top
View user's profile Send private message
chithanh
Developer
Developer


Joined: 05 Aug 2006
Posts: 1678
Location: Berlin, Germany

PostPosted: Sun Nov 11, 2012 11:58 am    Post subject: Reply with quote

Code:
(dependency required by "app-admin/system-config-printer-common-1.3.12" [ebuild])
(dependency required by "kde-base/printer-applet-4.9.3" [ebuild])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])
It seems that you have kde-base/printer-applet in world. run emerge --deselect on that package and try again.
Back to top
View user's profile Send private message
DaggyStyle
Advocate
Advocate


Joined: 22 Mar 2006
Posts: 4941

PostPosted: Sun Nov 11, 2012 12:47 pm    Post subject: Reply with quote

chithanh wrote:
Code:
(dependency required by "app-admin/system-config-printer-common-1.3.12" [ebuild])
(dependency required by "kde-base/printer-applet-4.9.3" [ebuild])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])
It seems that you have kde-base/printer-applet in world. run emerge --deselect on that package and try again.


had the same issue, masked app-admin/system-config-printer-common-1.3.12 and all is working well. with the applet.
_________________
Only two things are infinite, the universe and human stupidity and I'm not sure about the former - Albert Einstein
ProjectFootball
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum