Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
x11-libs/libdrm slot conflict (nouveau driver)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
jpc22
Apprentice
Apprentice


Joined: 29 Jan 2012
Posts: 190

PostPosted: Sun Nov 11, 2012 3:25 am    Post subject: x11-libs/libdrm slot conflict (nouveau driver) Reply with quote

I am trying to install xf86-video-nouveau-1.0.4 on the latest stable hardened-sources (3.5.4-r1), but i get this output.

# emerge =xf86-video-nouveau-1.0.4
Calculating dependencies... done!
[ebuild U ~] x11-libs/libdrm-2.4.40 [2.4.33] VIDEO_CARDS="(-exynos)"
[ebuild N ~] x11-drivers/xf86-video-nouveau-1.0.4

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

x11-libs/libdrm:0

(x11-libs/libdrm-2.4.40::gentoo, ebuild scheduled for merge) pulled in by
>=x11-libs/libdrm-2.4.34[video_cards_nouveau] required by (x11-drivers/xf86-video-nouveau-1.0.4::gentoo, ebuild scheduled for merge)

(x11-libs/libdrm-2.4.33::gentoo, installed) pulled in by
<x11-libs/libdrm-2.4.34 required by (media-libs/mesa-8.0.4-r1::gentoo, installed)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously. If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.

#





Can anyone give me pointers on how to use package.mask to solve this. (i tried --backtrack=30, but it did not work.)
Back to top
View user's profile Send private message
eccerr0r
Advocate
Advocate


Joined: 01 Jul 2004
Posts: 4004
Location: USA

PostPosted: Sun Nov 11, 2012 4:36 am    Post subject: Reply with quote

It looks like nouveau 1.0.4 wants libdrm 2.4.40 and mesa does not.
Try unmasking a new version of mesa (mesa 9?) and emerging it.
Or perhaps a older version of nouveau would work too...
_________________
Intel Core i7 2700K@ 4.1GHz/HD3000 graphics/8GB DDR3/180GB SSD
What am I supposed to be advocating?
Back to top
View user's profile Send private message
chithanh
Developer
Developer


Joined: 05 Aug 2006
Posts: 1677
Location: Berlin, Germany

PostPosted: Sun Nov 11, 2012 1:22 pm    Post subject: Reply with quote

Indeed. You are trying to mix stable mesa with unstable libdrm, which can cause these problems. You will have to install at least unstable media-libs/mesa, media-libs/glu and virtual/glu.

Alternatively, build mesa with nouveau disabled.
Back to top
View user's profile Send private message
jpc22
Apprentice
Apprentice


Joined: 29 Jan 2012
Posts: 190

PostPosted: Sun Nov 11, 2012 11:56 pm    Post subject: Reply with quote

thanks guys emerging unstable packages did the trick.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum