Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
kdelibs-4.9.3 build error (SOLVED)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
andrewwalker27
Guru
Guru


Joined: 27 Jun 2005
Posts: 522

PostPosted: Fri Nov 09, 2012 11:02 am    Post subject: kdelibs-4.9.3 build error (SOLVED) Reply with quote

kdelibs-4.9.3 failing with the following
Code:
 
Linking CXX executable ../../bin/nepomuk-rcgen
cd /var/tmp/portage/kde-base/kdelibs-4.9.3/work/kdelibs-4.9.3_build/nepomuk/rcgen && /usr/bin/cmake -E cmake_link_script CMakeFiles/nepomuk-rcgen.dir/link.txt --verbose=1
/usr/bin/x86_64-pc-linux-gnu-g++   -O2 -pipe  -Wnon-virtual-dtor -Wno-long-long -Wundef -Wcast-align -Wchar-subscripts -Wall -W -Wpointer-arith -Wformat-security -fno-exceptions -DQT_NO_EXCEPTIONS -fno-check-new -fno-common -Woverloaded-virtual -fno-threadsafe-statics -fvisibility=hidden -fvisibility-inlines-hidden  -Wl,--enable-new-dtags  -Wl,-O1 -Wl,--as-needed CMakeFiles/nepomuk-rcgen.dir/nepomuk-rcgen_automoc.o CMakeFiles/nepomuk-rcgen.dir/codegenerator.o CMakeFiles/nepomuk-rcgen.dir/fastcode.o CMakeFiles/nepomuk-rcgen.dir/property.o CMakeFiles/nepomuk-rcgen.dir/rcgen.o CMakeFiles/nepomuk-rcgen.dir/resourceclass.o CMakeFiles/nepomuk-rcgen.dir/safecode.o CMakeFiles/nepomuk-rcgen.dir/ontologyparser.o CMakeFiles/nepomuk-rcgen.dir/qrc_templates.o  -o ../../bin/nepomuk-rcgen -rdynamic -L/usr/lib64/qt4 -L/var/tmp/portage/kde-base/kdelibs-4.9.3/work/kdelibs-4.9.3_build/lib /usr/lib64/qt4/libQtCore.so -lpthread /usr/lib64/qt4/libQtDBus.so -lsoprano ../../lib/libkdecore.so.5.9.3 ../../lib/libkdeui.so.5.9.3 ../../lib/libkdecore.so.5.9.3 /usr/lib64/qt4/libQtCore.so -lpthread /usr/lib64/qt4/libQtDBus.so /usr/lib64/qt4/libQtGui.so /usr/lib64/qt4/libQtSvg.so -Wl,-rpath,/usr/lib64/qt4:/var/tmp/portage/kde-base/kdelibs-4.9.3/work/kdelibs-4.9.3_build/lib:
cd /var/tmp/portage/kde-base/kdelibs-4.9.3/work/kdelibs-4.9.3_build/nepomuk/rcgen && /usr/bin/cmake -D_filename=/var/tmp/portage/kde-base/kdelibs-4.9.3/work/kdelibs-4.9.3_build/bin/nepomuk-rcgen.shell -D_library_path_variable=LD_LIBRARY_PATH -D_ld_library_path="/var/tmp/portage/kde-base/kdelibs-4.9.3/work/kdelibs-4.9.3_build/lib/./:/usr/lib64:/var/tmp/portage/kde-base/kdelibs-4.9.3/work/kdelibs-4.9.3_build/lib/.:/usr/lib64/qt4" -D_executable=/var/tmp/portage/kde-base/kdelibs-4.9.3/work/kdelibs-4.9.3_build/bin/nepomuk-rcgen -P /var/tmp/portage/kde-base/kdelibs-4.9.3/work/kdelibs-4.9.3/cmake/modules/kde4_exec_via_sh.cmake
make[2]: Leaving directory `/var/tmp/portage/kde-base/kdelibs-4.9.3/work/kdelibs-4.9.3_build'
/usr/bin/cmake -E cmake_progress_report /var/tmp/portage/kde-base/kdelibs-4.9.3/work/kdelibs-4.9.3_build/CMakeFiles  75
[ 49%] Built target nepomuk-rcgen
make[1]: Leaving directory `/var/tmp/portage/kde-base/kdelibs-4.9.3/work/kdelibs-4.9.3_build'
make: *** [all] Error 2
 * ERROR: kde-base/kdelibs-4.9.3 failed (compile phase):
 *   emake failed


It looks like nepomuk problems, anyone else get this or have any suggestions?


Think this could be the cause
Code:
 
[  1%] Generating servicecontrolinterface.cpp, servicecontrolinterface.h
cd /var/tmp/portage/kde-base/nepomuk-core-4.9.2-r1/work/nepomuk-core-4.9.2_build/server && /usr/bin/qdbusxml2cpp -m -p servicecontrolinterface /var/tmp/portage/kde-base/nepomuk-core-4.9.2-r1/work/nepomuk-core-4.9.2/interfaces/org.kde.nepomuk.ServiceControl.xml
Unable to load library icui18n "Cannot load library icui18n: (icui18n: cannot open shared object file: No such file or directory)"
Could not load plugin at  "/usr/lib64/soprano/libsoprano_raptorparser.so" .  "Cannot load library /usr/lib64/soprano/libsoprano_raptorparser.so: (libgnutls.so.26: cannot open shared object file: No such file or directory)"
Could not find parser plugin for encoding trig
make[2]: *** [libnepomukcore/ndo.h] Error 1
make[2]: Leaving directory `/var/tmp/portage/kde-base/nepomuk-core-4.9.2-r1/work/nepomuk-core-4.9.2_build'
make[1]: *** [libnepomukcore/CMakeFiles/nepomukcore.dir/all] Error 2
make[1]: *** Waiting for unfinished jobs....
/usr/bin/cmake -E cmake_progress_report /var/tmp/portage/kde-base/nepomuk-core-4.9.2-r1/work/nepomuk-core-4.9.2_build/CMakeFiles 12
[  2%] Generating nepomukserversettings.h, nepomukserversettings.cpp



Last edited by andrewwalker27 on Wed Nov 14, 2012 5:49 pm; edited 2 times in total
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 5414

PostPosted: Fri Nov 09, 2012 3:57 pm    Post subject: Reply with quote

The later snippet does seem to be the actual problem.
The error seems to suggest, that a revdep-rebuild is required (due to icu upgrade).
Back to top
View user's profile Send private message
andrewwalker27
Guru
Guru


Joined: 27 Jun 2005
Posts: 522

PostPosted: Fri Nov 09, 2012 10:35 pm    Post subject: Reply with quote

That was the first thing I tried but it made no difference. I also found that openldap wouldn't compile when I tried to re-build it.
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 5414

PostPosted: Sat Nov 10, 2012 3:27 am    Post subject: Reply with quote

andrewwalker27 wrote:
That was the first thing I tried but it made no difference. I also found that openldap wouldn't compile when I tried to re-build it.

Do elaborate - either you didn't do it right or /usr/lib64/soprano/libsoprano_raptorparser.so didn't get detected.
The later would suggest a bug in revdep-rebuild.
Well, there is a slight chance that that libs belongs to kde-base/kdelibs itself, then it would be a bug in that package, but I kinda doubt it.
Back to top
View user's profile Send private message
genstorm
Advocate
Advocate


Joined: 05 Apr 2007
Posts: 2444
Location: Austria

PostPosted: Sat Nov 10, 2012 9:06 am    Post subject: Reply with quote

Code:
$ equery b /usr/lib64/soprano/libsoprano_raptorparser.so
 * Searching for /usr/lib64/soprano/libsoprano_raptorparser.so ...
dev-libs/soprano-2.8.0 (/usr/lib64/soprano/libsoprano_raptorparser.so)


So, what versions of icu and gnutls do you have installed?
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
andrewwalker27
Guru
Guru


Joined: 27 Jun 2005
Posts: 522

PostPosted: Mon Nov 12, 2012 4:32 pm    Post subject: Reply with quote

Well it seems to find it ok.

Code:
 
equery b /usr/lib64/soprano/libsoprano_raptorparser.so
 * Searching for /usr/lib64/soprano/libsoprano_raptorparser.so ...
dev-libs/soprano-2.8.0 (/usr/lib64/soprano/libsoprano_raptorparser.so)


The icu and gnutls versions I have install are
dev-libs/icu-49.1.2 and net-libs/gnutls-3.1.4


I think the problem must be due to a previous upgrade to icu-50.1-r1 which suddenly got hard-masked and reverted to 49.1.2 but I don't know what effect this would have.
I tried revdep-rebuild but that failed at net-nds/openldap-2.4.33 Here is the error but I don't think it's the real problem.

Code:
 
ls /usr/lib64/libgcrypt.so -lgpg-error -lcrypt -lresolv
libtool: link: x86_64-pc-linux-gnu-gcc -O2 -pipe -D_GNU_SOURCE -Wl,-O1 -o .libs/apitest apitest.o  -Wl,--as-needed ./.libs/libldap.so /var/tmp/portage/net-nds/openldap-2.4.33/work/openldap-2.4.33/libraries/liblber/.libs/liblber.so ../../libraries/liblber/.libs/liblber.so ../../libraries/liblutil/liblutil.a -lgnutls /usr/lib64/libgcrypt.so -lgpg-error -lcrypt -lresolv
./.libs/libldap.so: undefined reference to `gnutls_certificate_get_x509_cas'
collect2: ld returned 1 exit status
make[2]: *** [apitest] Error 1
make[2]: *** Waiting for unfinished jobs....
./.libs/libldap.so: undefined reference to `gnutls_certificate_get_x509_cas'
collect2: ld returned 1 exit status
./.libs/libldap.so: undefined reference to `gnutls_certificate_get_x509_cas'
collect2: ld returned 1 exit status
make[2]: *** [ftest] Error 1
make[2]: *** [dntest] Error 1
make[2]: Leaving directory `/var/tmp/portage/net-nds/openldap-2.4.33/work/openldap-2.4.33/libraries/libldap'
make[1]: *** [all-common] Error 1
make[1]: Leaving directory `/var/tmp/portage/net-nds/openldap-2.4.33/work/openldap-2.4.33/libraries'
make: *** [all-common] Error 1
 * ERROR: net-nds/openldap-2.4.33 failed (compile phase):
 *   emake failed
 *
 * If you need support, post the output of `emerge --info '=net-nds/openldap-2.4.33'`,
 * the complete build log and the output of `emerge -pqv '=net-nds/openldap-2.4.33'`.
 * The complete build log is located at '/var/tmp/portage/net-nds/openldap-2.4.33/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/net-nds/openldap-2.4.33/temp/environment'.
 * Working directory: '/var/tmp/portage/net-nds/openldap-2.4.33/work/openldap-2.4.33'
 * S: '/var/tmp/portage/net-nds/openldap-2.4.33/work/openldap-2.4.33'

>>> Failed to emerge net-nds/openldap-2.4.33, Log file:

>>>  '/var/tmp/portage/net-nds/openldap-2.4.33/temp/build.log'


Numerous others fail to build such as apr-util-1.4.1 and tagpy-0.94.8-r1, apr-util understandably due to the openldap failure but tagpy fails with this
Code:
 
/usr/include/boost/python/class.hpp:266:11: note: template<class Fn, class A1, class A2, class A3> boost::python::class_<T, X1, X2, X3>::self& boost::python::class_::def(const char*, Fn, const A1&, const A2&, const A3&) [with Fn = Fn, A1 = A1, A2 = A2, A3 = A3, W = TagLib::ID3v2::Tag, X1 = boost::noncopyable_::noncopyable, X2 = boost::python::bases<TagLib::Tag>, X3 = boost::python::detail::not_specified, boost::python::class_<T, X1, X2, X3>::self = boost::python::class_<TagLib::ID3v2::Tag, boost::noncopyable_::noncopyable, boost::python::bases<TagLib::Tag> >]
error: command 'x86_64-pc-linux-gnu-g++' failed with exit status 1
 * ERROR: dev-python/tagpy-0.94.8-r1 failed (compile phase):
 *   Building failed with CPython 2.7 in distutils_building() function
 *



I've tried rebuilding gnutls and icu but I still get the same errors.


Last edited by andrewwalker27 on Wed Nov 14, 2012 5:50 pm; edited 1 time in total
Back to top
View user's profile Send private message
Hamlet
Tux's lil' helper
Tux's lil' helper


Joined: 15 Apr 2005
Posts: 119
Location: Turin (Italy)

PostPosted: Mon Nov 12, 2012 5:06 pm    Post subject: openldap and gnutls update Reply with quote

I have a similar situation:

andrewwalker27 wrote:
libtool: link: x86_64-pc-linux-gnu-gcc -O2 -pipe -D_GNU_SOURCE -Wl,-O1 -o .libs/apitest apitest.o -Wl,--as-needed ./.libs/libldap.so /var/tmp/portage/net-nds/openldap-2.4.33/work/openldap-2.4.33/libraries/liblber/.libs/liblber.so ../../libraries/liblber/.libs/liblber.so ../../libraries/liblutil/liblutil.a -lgnutls /usr/lib64/libgcrypt.so -lgpg-error -lcrypt -lresolv
./.libs/libldap.so: undefined reference to `gnutls_certificate_get_x509_cas'


after upgrading gnutls (upgrade which breaks a lot of packages, revdep-rebuild is very needed).
With the USE='-gnutls' flag, the issue is skipped (and I bet, no TLS support).
gnutls reports a lot of "undeclared symbols" when compiling, I wonder if that's related.

Edit: the related Gentoo bug is #421463
Back to top
View user's profile Send private message
andrewwalker27
Guru
Guru


Joined: 27 Jun 2005
Posts: 522

PostPosted: Wed Nov 14, 2012 2:48 pm    Post subject: Reply with quote

To be more precise, USE="-gnutls" with openldap cured it. It may also be the cause of samba not compiling as well.

Something is very wrong with gnutls.
Back to top
View user's profile Send private message
toralf
Advocate
Advocate


Joined: 01 Feb 2004
Posts: 2669
Location: Hamburg/Germany

PostPosted: Wed Nov 14, 2012 3:14 pm    Post subject: Reply with quote

Please, could you surround the konsole output with [code] and [/code] tags ?
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 5414

PostPosted: Wed Nov 14, 2012 5:40 pm    Post subject: Reply with quote

Actually, something seems to be wrong with openldap upstream - just read the gentoo bug.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum