Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Upgrade from Grub to Grub2
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
Budoka
Guru
Guru


Joined: 03 Jun 2012
Posts: 358
Location: Tokyo, Japan

PostPosted: Sun Oct 21, 2012 7:12 am    Post subject: Upgrade from Grub to Grub2 Reply with quote

I installed Grub2 using the following guide, http://dev.gentoo.org/~scarabeus/grub-2-guide.xml.

But now when I boot the Grub menu comes up first and then flashes and changes to the Grub2 menu. This clearly isn't a big problem but it is really annoying. Is this behavior normal or did I botch something?
Back to top
View user's profile Send private message
Fitzcarraldo
Guru
Guru


Joined: 30 Aug 2008
Posts: 511
Location: United Kingdom

PostPosted: Sun Oct 21, 2012 9:06 am    Post subject: Reply with quote

No, it's not normal. It sounds as if somehow you're chainloading GRUB 2 from GRUB Legacy.

Do you have GRUB Legacy install in the MBR or in a partition? If the former and assuming your HDD is sda, to install GRUB 2:

Code:
grub2-install /dev/sda
grub2-mkconfig -o /boot/grub2/grub.cfg

If the latter and assuming your boot partition is sda3:

Code:
mount /dev/sda3 /boot
grub2-install --force /dev/sda3
grub2-mkconfig -o /boot/grub2/grub.cfg

_________________
Fitzcarraldo's blog
Back to top
View user's profile Send private message
Budoka
Guru
Guru


Joined: 03 Jun 2012
Posts: 358
Location: Tokyo, Japan

PostPosted: Sun Oct 21, 2012 11:23 am    Post subject: Reply with quote

Fitzcarraldo wrote:
No, it's not normal. It sounds as if somehow you're chainloading GRUB 2 from GRUB Legacy.

Do you have GRUB Legacy install in the MBR or in a partition? If the former and assuming your HDD is sda, to install GRUB 2:

Code:
grub2-install /dev/sda
grub2-mkconfig -o /boot/grub2/grub.cfg

If the latter and assuming your boot partition is sda3:

Code:
mount /dev/sda3 /boot
grub2-install --force /dev/sda3
grub2-mkconfig -o /boot/grub2/grub.cfg


Thank you for the reply. I am a little confused.

My boot partition is on sda6 and my gentoo install is on sda7.

I used the Gentoo amd64 Guide and it had me install grub on sda so I don't think it is on another partition but I am not sure how to check.
Back to top
View user's profile Send private message
ulenrich
Veteran
Veteran


Joined: 10 Oct 2010
Posts: 1146

PostPosted: Sun Oct 21, 2012 11:41 am    Post subject: Reply with quote

With an extra boot partition you should symlink boot into itself!
Perhaps also link grub2 to grub.
_________________
fun2gen2
Back to top
View user's profile Send private message
Budoka
Guru
Guru


Joined: 03 Jun 2012
Posts: 358
Location: Tokyo, Japan

PostPosted: Sun Oct 21, 2012 11:55 am    Post subject: Reply with quote

ulenrich wrote:
With an extra boot partition you should symlink boot into itself!
Perhaps also link grub2 to grub.


Thanks. Could you tell me how to do that or point me to the appropriate documentation? This is my first Gentoo Install so still learning.
Back to top
View user's profile Send private message
ulenrich
Veteran
Veteran


Joined: 10 Oct 2010
Posts: 1146

PostPosted: Sun Oct 21, 2012 12:15 pm    Post subject: Reply with quote

mounted boot partition already - then:
cd /boot && ln -s . boot

As for grub2 I would also:
ln -s /boot/grub2 /boot/grub

Attention: remove leftovers from grub1 before! (/boot/grub)
_________________
fun2gen2


Last edited by ulenrich on Sun Oct 21, 2012 12:23 pm; edited 1 time in total
Back to top
View user's profile Send private message
Leo Laursen
n00b
n00b


Joined: 29 Mar 2012
Posts: 38

PostPosted: Sun Oct 21, 2012 12:18 pm    Post subject: Re: Upgrade from Grub to Grub2 Reply with quote

Budoka wrote:
I installed Grub2 using the following guide, http://dev.gentoo.org/~scarabeus/grub-2-guide.xml.
But now when I boot the Grub menu comes up first and then flashes and changes to the Grub2 menu. This clearly isn't a big problem but it is really annoying. Is this behavior normal or did I botch something?

I had the same experience, but since grub2 obviously worked fine, i just removed grub:0. I had expected to be able to choose grub2 from the old grub menu, otherwise what's the point of chainloading?
Back to top
View user's profile Send private message
Fitzcarraldo
Guru
Guru


Joined: 30 Aug 2008
Posts: 511
Location: United Kingdom

PostPosted: Sun Oct 21, 2012 12:23 pm    Post subject: Reply with quote

Budoka, I take it you're running the GRUB 2 version 2.00 commands from Gentoo, and not from another Linux distribution installed in another partition on the same HDD? If your /boot directory is on sda6 and your Gentoo root directory is on sda7, and you want to install GRUB 2 first stage software to the MBR (in order to overwrite GRUB Legacy Stage 1 software in the MBR), then the commands would be:

Code:
mount /dev/sda6 /boot
grub2-install /dev/sda
grub2-mkconfig -o /boot/grub2/grub.cfg

Doing the above will mean that, when the machine boots, it will run the first stage GRUB 2 software in the MBR which will then vector to /boot/grub2/i386/core.img in sda6.

Note that the first stage of GRUB 2 is installed in the MBR if you specify sda in the grub2-install command, whereas the first stage of GRUB 2 is installed in the boot sector of the partition instead of in the MBR if you specify a partition (e.g. sda3) in the grub2-install command. Based on what you wrote in your first post, to me you appear to have GRUB Legacy chainloading GRUB 2, so I think you still have GRUB Legacy Stage 1 code in the MBR. So the GRUB 2 commands I list above are tailored to overwrite the MBR and hence get rid of GRUB Legacy code.

Just for information, the boot loader code in the MBR on my main laptop is Windows Boot Manager. Windows Boot Manager chainloads GRUB 2 in a boot partition (my /boot directory is on sda3, my root directory is on sda6 and my /home directory is on sda7). So, in my case, the GRUB 2 commands I used were as follows, as I did not want GRUB 2 to touch the MBR:

Code:
mount /dev/sda3 /boot
grub2-install --force /dev/sda3
grub2-mkconfig -o /boot/grub2/grub.cfg

The "--force" was necessary in my case because GRUB 2 does not like installing GRUB 2 code in a partition boot sector instead of the MBR.
_________________
Fitzcarraldo's blog
Back to top
View user's profile Send private message
Budoka
Guru
Guru


Joined: 03 Jun 2012
Posts: 358
Location: Tokyo, Japan

PostPosted: Mon Oct 22, 2012 5:44 am    Post subject: Reply with quote

Fitzcarraldo wrote:
Budoka, I take it you're running the GRUB 2 version 2.00 commands from Gentoo, and not from another Linux distribution installed in another partition on the same HDD? If your /boot directory is on sda6 and your Gentoo root directory is on sda7, and you want to install GRUB 2 first stage software to the MBR (in order to overwrite GRUB Legacy Stage 1 software in the MBR), then the commands would be:

Code:
mount /dev/sda6 /boot
grub2-install /dev/sda
grub2-mkconfig -o /boot/grub2/grub.cfg

Doing the above will mean that, when the machine boots, it will run the first stage GRUB 2 software in the MBR which will then vector to /boot/grub2/i386/core.img in sda6.

Note that the first stage of GRUB 2 is installed in the MBR if you specify sda in the grub2-install command, whereas the first stage of GRUB 2 is installed in the boot sector of the partition instead of in the MBR if you specify a partition (e.g. sda3) in the grub2-install command. Based on what you wrote in your first post, to me you appear to have GRUB Legacy chainloading GRUB 2, so I think you still have GRUB Legacy Stage 1 code in the MBR. So the GRUB 2 commands I list above are tailored to overwrite the MBR and hence get rid of GRUB Legacy code.

Just for information, the boot loader code in the MBR on my main laptop is Windows Boot Manager. Windows Boot Manager chainloads GRUB 2 in a boot partition (my /boot directory is on sda3, my root directory is on sda6 and my /home directory is on sda7). So, in my case, the GRUB 2 commands I used were as follows, as I did not want GRUB 2 to touch the MBR:

Code:
mount /dev/sda3 /boot
grub2-install --force /dev/sda3
grub2-mkconfig -o /boot/grub2/grub.cfg


Thanks everyone for the replies and help.


The "--force" was necessary in my case because GRUB 2 does not like installing GRUB 2 code in a partition boot sector instead of the MBR.


I tried the above and it didn't fix the behavior. Also now when I boot the Windows Boot Manager appears first. If I select Windows it will boot into Windows. If I select Linux, it will bring me to the grub then flash into Grub2 menu. Any ideas?

Is there a way to just safely remove all of the grub stuff and start from scratch or is it better to try to sort it out.

Is it possible that this is related to this other problem I am having?

http://forums.gentoo.org/viewtopic-t-940244-highlight-.html
Back to top
View user's profile Send private message
Fitzcarraldo
Guru
Guru


Joined: 30 Aug 2008
Posts: 511
Location: United Kingdom

PostPosted: Mon Oct 22, 2012 12:36 pm    Post subject: Reply with quote

Budoka wrote:
I tried the above and it didn't fix the behavior. Also now when I boot the Windows Boot Manager appears first. If I select Windows it will boot into Windows. If I select Linux, it will bring me to the grub then flash into Grub2 menu. Any ideas?

You didn't mention before that you are dual booting with Windows. What I don't understand is why your PC is booting to the Windows Boot Manager if you used the command grub2-install /dev/sda. That grub2-install command will overwrite the Windows Boot Manager code in the MBR. What messages are displayed in your Konsole/Terminal window when you issue the three commands shown below?

Code:
mount /dev/sda6 /boot
grub2-install /dev/sda
grub2-mkconfig -o /boot/grub2/grub.cfg

Also, have you uninstalled earlier versions of sys-boot/grub so that you only have sys-boot/grub-2.00 installed? As you are using GRUB 2, you could also rm -rf /boot/grub/ (after mounting the /boot directory on sda6, of course) because GRUB 2 in Gentoo uses the directory /boot/grub2/ instead.
_________________
Fitzcarraldo's blog
Back to top
View user's profile Send private message
Budoka
Guru
Guru


Joined: 03 Jun 2012
Posts: 358
Location: Tokyo, Japan

PostPosted: Tue Oct 23, 2012 2:09 am    Post subject: Reply with quote

Fitzcarraldo wrote:
Budoka wrote:
I tried the above and it didn't fix the behavior. Also now when I boot the Windows Boot Manager appears first. If I select Windows it will boot into Windows. If I select Linux, it will bring me to the grub then flash into Grub2 menu. Any ideas?

You didn't mention before that you are dual booting with Windows. What I don't understand is why your PC is booting to the Windows Boot Manager if you used the command grub2-install /dev/sda. That grub2-install command will overwrite the Windows Boot Manager code in the MBR. What messages are displayed in your Konsole/Terminal window when you issue the three commands shown below?

Code:
mount /dev/sda6 /boot
grub2-install /dev/sda
grub2-mkconfig -o /boot/grub2/grub.cfg

Also, have you uninstalled earlier versions of sys-boot/grub so that you only have sys-boot/grub-2.00 installed? As you are using GRUB 2, you could also rm -rf /boot/grub/ (after mounting the /boot directory on sda6, of course) because GRUB 2 in Gentoo uses the directory /boot/grub2/ instead.


My apologies for not indicating it was a dual boot box. I have been really confused by the grub stuff and the confusion is compounded by the fact that in addition to this problem, I can't get it to boot my kernel. http://forums.gentoo.org/viewtopic-t-940244-highlight-.html

Anyway, I uninstalled the earlier version of the sys-boot/grub and rm'd the residual grub directory as you suggested.

When I ran the suggested commands. I received the following output:

Code:
(chroot) sysresccd boot # grub2-install /dev/sda
Installation finished. No error reported.
(chroot) sysresccd boot # grub2-mkconfig -o /boot/grub2/grub.cfg
Generating grub.cfg ...
Found linux image: /boot/kernel-genkernel-x86_64-3.4.9-gentoo
Found initrd image: /boot/initramfs-genkernel-x86_64-3.4.9-gentoo
“Adding Windows”
done


My sda6 is mounted as boot:
Code:
mount /dev/sda6 /boot
and my directory looks cleaner in that none of the grub stuff is there anymore:
Quote:
(chroot) sysresccd / # ls -la boot/
total 11011
drwxr-xr-x 5 root root 1024 Oct 23 19:19 .
drwxr-xr-x 21 root root 4096 Oct 23 19:08 ..
lrwxrwxrwx 1 root root 1 Oct 10 23:18 boot -> .
drwxr-xr-x 6 root root 1024 Oct 23 19:26 grub2
drwxr-xr-x 3 root root 1024 Oct 19 00:00 grub_backup
-rw-r--r-- 1 root root 5791071 Oct 16 07:40 initramfs-genkernel-x86_64-3.4.9-gentoo
-rw-r--r-- 1 root root 0 Oct 23 19:18 .keep
-rw-r--r-- 1 root root 3456656 Oct 16 07:30 kernel-genkernel-x86_64-3.4.9-gentoo
drwx------ 2 root root 12288 Oct 10 01:12 lost+found
-rw-r--r-- 1 root root 1957831 Oct 16 07:30 System.map-genkernel-x86_64-3.4.9-gentoo


However, strangely enough, the behavior doesn't change. When I boot, first the grub menu flashes and then I got dumped into the Grub2 menu. I don't understand how this can be given I uninstalled grub and removed the directory. Really banging my head against a wall here. Any other ideas?

Also noticed that now if I select Windows in Grub it brings me to the Win Boot Manager so same behavior but order flipped.
Back to top
View user's profile Send private message
Fitzcarraldo
Guru
Guru


Joined: 30 Aug 2008
Posts: 511
Location: United Kingdom

PostPosted: Tue Oct 23, 2012 2:34 pm    Post subject: Reply with quote

Did you by any chance use EasyBCD to set up Windows Boot Manager? If you did, download the latest version and run it to set up the Windows BCD so that it vectors to GRUB 2, not GRUB Legacy. N.B. Make sure you download EasyBCD 2.2.0.182 a.k.a. 'EasyBCD 2.2 Final'.

http://neosmart.net/forums/showthread.php?t=642

Also, check in the directory /boot/grub2/ and its subdirectories to see if you have any GRUB Legacy files lying around.
_________________
Fitzcarraldo's blog
Back to top
View user's profile Send private message
Budoka
Guru
Guru


Joined: 03 Jun 2012
Posts: 358
Location: Tokyo, Japan

PostPosted: Thu Oct 25, 2012 2:46 am    Post subject: Reply with quote

Fitzcarraldo wrote:
Did you by any chance use EasyBCD to set up Windows Boot Manager? If you did, download the latest version and run it to set up the Windows BCD so that it vectors to GRUB 2, not GRUB Legacy. N.B. Make sure you download EasyBCD 2.2.0.182 a.k.a. 'EasyBCD 2.2 Final'.

http://neosmart.net/forums/showthread.php?t=642

Also, check in the directory /boot/grub2/ and its subdirectories to see if you have any GRUB Legacy files lying around.


Yes I did! But I did so after I had the problem I was writing about in this thread based on a wiki I had found.

I confirmed that it is using Grub2 (Auto locate) and not Grub Legacy and the behavior hasn't changed.

Is there a way I can rollback and start from scratch? I suspect that the wiki I used to "Update Grub to Grub2" may be part of the reason I am having all these problems.

What I find really confusing is that, as best I can tell, I have gotten rid of all the Grub stuff, but the Grub menu still flashes before the Grub2 menu. SO clearly it is living someplace I am missing.

Thanks again for the help.
Back to top
View user's profile Send private message
Budoka
Guru
Guru


Joined: 03 Jun 2012
Posts: 358
Location: Tokyo, Japan

PostPosted: Tue Nov 06, 2012 2:39 pm    Post subject: Reply with quote

OK. After much trial and error, and banging my head against the wall, I discovered that I need grub2 to have "real_root=/dev/mapper/vg-root crypt_root=/dev/sda2 dolvm ro " but I am not sure how to pass that to grub2 config.

If I manually edit the boot at boot it will work. There is another problem but I'll save that for another thread. How do I add it permanently to my grub2 config file? The header in grun2 config states don't edit this file.
Back to top
View user's profile Send private message
Fitzcarraldo
Guru
Guru


Joined: 30 Aug 2008
Posts: 511
Location: United Kingdom

PostPosted: Tue Nov 06, 2012 5:02 pm    Post subject: Reply with quote

Edit the file /etc/default/grub and look for the variable GRUB_CMDLINE_LINUX (add it if it doesn't already exist) and specify the kernel boot parameters in that:

Code:
GRUB_CMDLINE_LINUX="put kernel boot parameters here"


then use the following command to recreate the grub.cfg file:

Code:
grub2-mkconfig -o /boot/grub2/grub.cfg


If /boot is on a separate partition, make sure it is mounted first, of course. And don't forget to create a backup of grub.cfg first in case you need to revert to that for any reason:

Code:
cp /boot/grub2/grub.cfg /boot/grub2/grub2.cfg.bak


Just for an example, here's what mine looks like:

Code:
GRUB_CMDLINE_LINUX="BOOT_IMAGE=/kernel-genkernel-x86_64-3.6.1-gentoo root=/dev/ram0 ramdisk=8192 real_root=/dev/sda6 init=/linuxrc splash=silent,theme:Emergance console=tty1 quiet resume=swap:/dev/sda5 real_resume=/dev/sda5 intel_iommu=off"

_________________
Fitzcarraldo's blog
Back to top
View user's profile Send private message
Budoka
Guru
Guru


Joined: 03 Jun 2012
Posts: 358
Location: Tokyo, Japan

PostPosted: Wed Nov 07, 2012 3:57 am    Post subject: Reply with quote

Fitzcarraldo wrote:
Edit the file /etc/default/grub and look for the variable GRUB_CMDLINE_LINUX (add it if it doesn't already exist) and specify the kernel boot parameters in that:

Code:
GRUB_CMDLINE_LINUX="put kernel boot parameters here"


then use the following command to recreate the grub.cfg file:

Code:
grub2-mkconfig -o /boot/grub2/grub.cfg


If /boot is on a separate partition, make sure it is mounted first, of course. And don't forget to create a backup of grub.cfg first in case you need to revert to that for any reason:

Code:
cp /boot/grub2/grub.cfg /boot/grub2/grub2.cfg.bak


Just for an example, here's what mine looks like:

Code:
GRUB_CMDLINE_LINUX="BOOT_IMAGE=/kernel-genkernel-x86_64-3.6.1-gentoo root=/dev/ram0 ramdisk=8192 real_root=/dev/sda6 init=/linuxrc splash=silent,theme:Emergance console=tty1 quiet resume=swap:/dev/sda5 real_resume=/dev/sda5 intel_iommu=off"


Thanks this did the trick for me. I had to also uncomment

Code:
# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true


otherwise it would place root=blahblah before my parameters preventing a successful boot.
I apologize because I inadvertently derailed this thread.
Back to top
View user's profile Send private message
Budoka
Guru
Guru


Joined: 03 Jun 2012
Posts: 358
Location: Tokyo, Japan

PostPosted: Wed Nov 07, 2012 4:02 am    Post subject: Reply with quote

But, I still have the original problem of GRUB flashing first, then the GRUB2 menu coming up. This is baffling because as best I can tell I have gotten rid of all legacy GRUB stuff.

Now, thanks to everyone help, if I select Gentoo it will actually boot but if I select Windows it will still bring me to the Win Bootloader to select Windows again.

Really driving me nuts. Anymore ideas? This is my first Gentoo install so am happy that I have even gotten this far but would love to be able to clean this up.
Back to top
View user's profile Send private message
Fitzcarraldo
Guru
Guru


Joined: 30 Aug 2008
Posts: 511
Location: United Kingdom

PostPosted: Wed Nov 07, 2012 8:12 pm    Post subject: Reply with quote

Budoka wrote:
if I select Windows [from the GRUB 2 menu] it will still bring me to the Win Bootloader to select Windows again.

That is what it is expected to do if you use Windows Boot Manager to chainload GRUB (be it Legacy or 2). The sequence is as follows when you chainload GRUB 2:

1. You switch on the PC, the BIOS runs and jumps to the code in the MBR.
2. The boot code for Windows in the MBR runs.
3. That boot code in the MBR launches the Windows Boot Manager, which displays its menu.
4. If you select 'Linux' in the Windows Boot Manager's menu, Windows Boot Manager looks in the Windows BCD and finds a pointer to /boot/grub2/i386/core.img (a GRUB 2 file)*, so it jumps to core.img and GRUB 2 displays its menu. (Of course, if you instead select 'Windows' in Windows Boot Manager's menu then Windows is launched instead.)
5. If you select 'Windows' in the GRUB 2 menu, it will correctly jump to the MBR because that is where the boot code for Windows resides, so go to Step 2 above. (Of course, if you instead select 'Linux' in the GRUB 2 menu then Linux is launched instead.)

* If you told EasyBCD you are using GRUB 2, EasyBCD sets up the Windows BCD to point to /boot/grub2/i386/core.img directly, rather than to the GRUB 2 code in the boot sector of the /boot partition. If, on the other hand, you told EasyBCD you are using GRUB Legacy, EasyBCD sets up the Windows BCD to point to the GRUB first-stage code in the boot sector of the /boot partition (which then jumps to /boot/grub2/i386/core.img if you installed GRUB 2, or jumps to the relevant GRUB Legacy file in /boot/grub/ if you installed GRUB Legacy instead of GRUB 2). Just to confuse you further, you could do the latter even if you are using GRUB 2 (I've done it myself) providing Linux and Windows are on the same drive.

You might ask why go to all this trouble of leaving the factory-installed Windows boot code in the MBR and using EasyBCD to edit the Windows BCD to chainload GRUB 2. After all, some folk who dual boot just install GRUB 2 directly in the MBR and don't use the Windows Boot Manager at all. Basically it's because, if anything gets broken in Linux, the Windows installation (including the MBR and the rest of the Windows Boot Manager) are untouched and Windows can still be booted. There are a couple of other reasons too (see the explanation in The best way to dual boot Linux and Windows).

Budoka wrote:
I still have the original problem of GRUB flashing first, then the GRUB2 menu coming up.

What exactly is being displayed during "GRUB flashing first"? In a normal GRUB 2 boot sequence it is normal to see some text very briefly on screen before the GRUB 2 menu appears. Therefore what you are reporting could in actual fact be normal behaviour. Is the "flashing GRUB" text displayed long enough for you to see what it says, and can you tell us what that is? If not, can you take a photo of it or video it and look at that after to see what is displayed? I can't find a GRUB 2 Version 2.00 boot video in YouTube just now, but take a look at this video of GRUB 2 Version 1.99 booting for Slackware. It is not set up to chainload, so, after the BIOS menu is displayed, you very briefly see a GRUB 2 message and then the GRUB 2 menu appears. I'm using GRUB 2 Version 2.00, but the fact remains that, after I select 'Linux' from the Windows Boot Manager's menu, the screen clears and some GRUB 2 text appears briefly before the GRUB 2 menu itself is displayed. The text displayed briefly in my case is longer that that shown in the Slackware video. There is nothing wrong with that. Is that the sort of thing you're seeing? Because if it is, you have nothing to worry about.
_________________
Fitzcarraldo's blog
Back to top
View user's profile Send private message
Budoka
Guru
Guru


Joined: 03 Jun 2012
Posts: 358
Location: Tokyo, Japan

PostPosted: Thu Nov 08, 2012 6:04 am    Post subject: Reply with quote

Fitzcarraldo wrote:
Budoka wrote:
if I select Windows [from the GRUB 2 menu] it will still bring me to the Win Bootloader to select Windows again.


Budoka wrote:
I still have the original problem of GRUB flashing first, then the GRUB2 menu coming up.

What exactly is being displayed during "GRUB flashing first"? In a normal GRUB 2 boot sequence it is normal to see some text very briefly on screen before the GRUB 2 menu appears. Therefore what you are reporting could in actual fact be normal behaviour. Is the "flashing GRUB" text displayed long enough for you to see what it says, and can you tell us what that is? If not, can you take a photo of it or video it and look at that after to see what is displayed? I can't find a GRUB 2 Version 2.00 boot video in YouTube just now, but take a look at this video of GRUB 2 Version 1.99 booting for Slackware. It is not set up to chainload, so, after the BIOS menu is displayed, you very briefly see a GRUB 2 message and then the GRUB 2 menu appears. I'm using GRUB 2 Version 2.00, but the fact remains that, after I select 'Linux' from the Windows Boot Manager's menu, the screen clears and some GRUB 2 text appears briefly before the GRUB 2 menu itself is displayed. The text displayed briefly in my case is longer that that shown in the Slackware video. There is nothing wrong with that. Is that the sort of thing you're seeing? Because if it is, you have nothing to worry about.


It flashes
Quote:
Grub Loading.
Welcome to GRUB!


Based on your video it looks like that is the normal, albeit annoying, behavior. Thanks.
Back to top
View user's profile Send private message
Fitzcarraldo
Guru
Guru


Joined: 30 Aug 2008
Posts: 511
Location: United Kingdom

PostPosted: Thu Nov 08, 2012 6:38 am    Post subject: Reply with quote

Budoka wrote:
It flashes
Quote:
Grub Loading.
Welcome to GRUB!

Based on your video it looks like that is the normal, albeit annoying, behavior. Thanks.

It's normal. You're 'good to go'. Have fun. (I suggest that you edit your first post in this thread and append "[Solved]" to the Subject.)
_________________
Fitzcarraldo's blog
Back to top
View user's profile Send private message
Budoka
Guru
Guru


Joined: 03 Jun 2012
Posts: 358
Location: Tokyo, Japan

PostPosted: Thu Nov 08, 2012 6:43 am    Post subject: Reply with quote

Fitzcarraldo wrote:
Budoka wrote:
It flashes
Quote:
Grub Loading.
Welcome to GRUB!

Based on your video it looks like that is the normal, albeit annoying, behavior. Thanks.

It's normal. You're 'good to go'. Have fun.

Thanks for info/help. Still trying to sort out and digest EasyBCD stuff but is it possible to roll back on grub installations? Based on the link you provided I rather not have the win boot loader depending on grub but rather have Linux use the win boot loader.

I don't expect to be able to get back my F4 recovery key because I overwrote mbr but would still like to keep my win installation as isolated from Linux as possible.

Wish I saw that wiki before using guide. Thanks.
Back to top
View user's profile Send private message
Fitzcarraldo
Guru
Guru


Joined: 30 Aug 2008
Posts: 511
Location: United Kingdom

PostPosted: Fri Nov 09, 2012 10:22 am    Post subject: Reply with quote

No, it's not possible to roll back on GRUB installations. To revert to a previous situation you would need to re-install the previous software. If you follow the procedure I gave in the blog post I mentioned in an earlier post, you will have effectively isolated Windows from Linux and GRUB (GRUB 2, to be precise, in your case). As you have correctly deduced, the fact that you previously overwrote the MBR with GRUB probably means that pressing your F4 key at boot will no longer work (you indicated that, on your machine, F4 boots the Windows factory restore partition software), but that is not the end of the World, as you can still create a Windows 'system repair disc' (see e.g. Create a system repair disc). Anyway, now you know what to do if you want to configure another PC to dual boot with Windows! Let's hope that the developer of EasyBCD adds support for EFI/UEFI, as it currently only supports the traditional PC BIOS which I expect will become obsolete in new hardware quite soon.
_________________
Fitzcarraldo's blog
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum