Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Pacchetto mascherato da EAPI 5
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
stifler83
Apprentice
Apprentice


Joined: 22 Oct 2010
Posts: 158
Location: Rome

PostPosted: Mon Nov 05, 2012 6:35 pm    Post subject: Pacchetto mascherato da EAPI 5 Reply with quote

Salve ragazzi, questo è il problema?

Code:
!!! The following update has been skipped due to unsatisfied dependencies:

dev-db/mongodb:0

!!! All ebuilds that could satisfy ">=dev-libs/boost-1.50" have been masked.
!!! One of the following masked packages is required to complete your request:
- dev-libs/boost-1.51.0-r1001::gentoo (masked by: EAPI 5-progress)
- dev-libs/boost-1.51.0-r1::gentoo (masked by: EAPI 5)

The current version of portage supports EAPI '4'. You must upgrade to a
newer version of portage before EAPI masked packages can be installed.
(dependency required by "dev-db/mongodb-2.2.1" [ebuild])
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.


Idee?
Back to top
View user's profile Send private message
Onip
Advocate
Advocate


Joined: 02 Sep 2004
Posts: 2893
Location: Parma (Italy)

PostPosted: Mon Nov 05, 2012 7:44 pm    Post subject: Re: Pacchetto mascherato da EAPI 5 Reply with quote

stifler83 wrote:
Idee?


portage wrote:

The current version of portage supports EAPI '4'. You must upgrade to a
newer version of portage before EAPI masked packages can be installed.
(dependency required by "dev-db/mongodb-2.2.1" [ebuild])
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.


Ipse dixit. :wink:

EDIT:
aggiungo che, secondo me, non ne vale la pena.
_________________
Linux Registered User n. 373835

Titus Lucretius Carus, De Rerum Natura - Tantum religio potuit suadere malorum
Back to top
View user's profile Send private message
stifler83
Apprentice
Apprentice


Joined: 22 Oct 2010
Posts: 158
Location: Rome

PostPosted: Mon Nov 05, 2012 8:04 pm    Post subject: Re: Pacchetto mascherato da EAPI 5 Reply with quote

Onip wrote:
stifler83 wrote:
Idee?


portage wrote:

The current version of portage supports EAPI '4'. You must upgrade to a
newer version of portage before EAPI masked packages can be installed.
(dependency required by "dev-db/mongodb-2.2.1" [ebuild])
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.


Ipse dixit. :wink:

EDIT:
aggiungo che, secondo me, non ne vale la pena.


Forse sono stato troppo minimalista nel messaggio, comunque oltre alla risoluzione e quindi come volevi farmi notare leggere quello che veniva scritto sotto e l'ho fatto (pure prima di postare la domanda :D), mi serviva proprio un consiglio pratico sulla fattibilità e le implicazioni che comporta una soluzione di questo tipo. Grazie :)
Back to top
View user's profile Send private message
Onip
Advocate
Advocate


Joined: 02 Sep 2004
Posts: 2893
Location: Parma (Italy)

PostPosted: Mon Nov 05, 2012 8:44 pm    Post subject: Reply with quote

elaboro un pochino la mia risposta:

Code:

$ eix -e portage
[I] sys-apps/portage
     Available versions:  [M]2.1.6.7_p1 2.1.11.9{tbz2} ~2.1.11.31 ~*2.2.0_alpha120 ~*2.2.0_alpha142 **9999 {{build doc epydoc +ipc less linguas_pl pypy1_9 python2 python3 selinux xattr}}
     Installed versions:  2.1.11.9{tbz2}(10:34:32 10/08/2012)(ipc -build -doc -epydoc -linguas_pl -pypy1_9 -python2 -python3 -selinux -xattr)
     Homepage:            http://www.gentoo.org/proj/en/portage/index.xml
     Description:         Portage is the package management and distribution system for Gentoo


Attualmente abbiamo una versione di portage in testing e un paio di alpha hardmasked. Considerando che il package manager (portage in questo caso, immagino che la situazione degli altri, se esistono ancora, sia paragonabile) è uno dei componenti fondamentali di una distribuzione linux secondo me l'upgrade da 2.2.0 a 2.2.1 di mongodb (cioè la micro-versione) non giustifica il passaggio ad una versione instabile di portage, ancora peggio se il requisito è una delle versioni hardmasked: non so quale sia quella che implementa EAPI 5.

In caso questo upgrade fosse, per te, fondamentale (non so a che titolo utilizzi mongodb) allora è chiaro che il discorso cambierebbe, ma dovresti essere ben consapevole che ti stai assumendo un pochino di "rischio" con l'aggiornamento di portage e documentarti bene sulle nuove funzionalità e sulle modifiche a quelle esistenti, nonchè ai problemi noti.
_________________
Linux Registered User n. 373835

Titus Lucretius Carus, De Rerum Natura - Tantum religio potuit suadere malorum
Back to top
View user's profile Send private message
stifler83
Apprentice
Apprentice


Joined: 22 Oct 2010
Posts: 158
Location: Rome

PostPosted: Mon Nov 05, 2012 9:30 pm    Post subject: Reply with quote

ti ringrazio, sei stato molto chiaro :)
Back to top
View user's profile Send private message
ago
Developer
Developer


Joined: 01 Mar 2008
Posts: 1486
Location: Cosenza, Italy

PostPosted: Tue Nov 06, 2012 11:05 am    Post subject: Reply with quote

Portage è ora stabile per amd64, quindi non dovresti ricevere warning se fai un sync.
_________________
Contattami se vuoi contribuire in:
-Arch tester
-Chromium tester
-Traduzione doc. it
-Security
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum