Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Solved] I skipped to add sound, now I need it.
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
xsi
n00b
n00b


Joined: 23 Dec 2011
Posts: 47
Location: Ukraine, Kiev, russian language

PostPosted: Wed Oct 31, 2012 9:15 am    Post subject: [Solved] I skipped to add sound, now I need it. Reply with quote

All including sound, is buitin, not to break temporary concept, that all is built in (why should 1 exception be).
alsaconf :
No supported PnP or PCI card found
Probe legacy - no legacy.

Code:
make menuconfig
Device Drivers > Sound card support * >
Preclaim OSS device numbers *
<*>   Advanced Linux Sound Architecture  --->

<*>   OSS Mixer API                                                         │ │ 
  │ │      <*>   OSS PCM (digital audio) API                                           │ │ 
  │ │      [*]     OSS PCM (digital audio) API - Include plugin system

 [*]   PCI sound devices  --->
<*>   (Creative) Ensoniq AudioPCI 1371/1373


What to set inside
Code:
< >   Intel HD Audio  --->
│ │      (64)  Pre-allocated buffer size for HD-audio driver (NEW)                   │ │ 
  │ │      [ ]   Build hwdep interface for HD-audio driver (NEW)                       │ │ 
  │ │      [ ]   Support digital beep via input layer (NEW)                            │ │ 
  │ │      [ ]   Support jack plugging notification via input layer (NEW)              │ │ 
  │ │      [ ]   Support initialization patch loading for HD-audio (NEW)               │ │ 
  │ │      [*]   Build Realtek HD-audio codec support (NEW)                            │ │ 
  │ │      [*]     Build static quirks for Realtek codecs (NEW)                        │ │ 
  │ │      [*]   Build Analog Device HD-audio codec support (NEW)                      │ │ 
  │ │      [*]   Build IDT/Sigmatel HD-audio codec support (NEW)                       │ │ 
  │ │      [*]   Build VIA HD-audio codec support (NEW)                                │ │ 
  │ │      [*]   Build HDMI/DisplayPort HD-audio codec support (NEW)                   │ │ 
  │ │      [*]   Build Cirrus Logic codec support (NEW)                                │ │ 
  │ │      [*]   Build Conexant HD-audio codec support (NEW)                           │ │ 
  │ │      [*]   Build Creative CA0110-IBG codec support (NEW)                         │ │ 
  │ │      [*]   Build Creative CA0132 codec support (NEW)                             │ │ 
  │ │      [*]   Build C-Media HD-audio codec support (NEW)                            │ │ 
  │ │      [*]   Build Silicon Labs 3054 HD-modem codec support (NEW)                  │ │ 
  │ │      [*]   Enable generic HD-audio codec parser (NEW)   

And where is PnP - it is not supported by emerged alsa

localhost xi # emerge --info | wgetpaste
Your paste can be seen here: http://bpaste.net/show/54833/
localhost xi # lspci -v | grep -i audio | wgetpaste
Your paste can be seen here: http://bpaste.net/show/54835/
localhost xi # cat /usr/src/linux/.config | wgetpaste
Your paste can be seen here: http://bpaste.net/show/54836/

:oops:
Happy Halloween!
http://goo.gl/a0yy1
_________________
Phenom X2 560
16 GB RAM
USB 3.0 SATA 3.0
SSD Crucial M4 64GB
GeForce 8400 GS
Ensoniq ES1371 audio


Last edited by xsi on Mon Nov 05, 2012 8:51 am; edited 2 times in total
Back to top
View user's profile Send private message
John R. Graham
Administrator
Administrator


Joined: 08 Mar 2005
Posts: 7713
Location: Somewhere over Atlanta, Georgia

PostPosted: Wed Oct 31, 2012 10:54 am    Post subject: Reply with quote

Probably best for you to work through the Gentoo Linux ALSA Guide first and then report any issues you're encountering. Typically the sound system support is build as modules rather than being built-in.

- John
_________________
This space intentionally left blank.
Back to top
View user's profile Send private message
xsi
n00b
n00b


Joined: 23 Dec 2011
Posts: 47
Location: Ukraine, Kiev, russian language

PostPosted: Mon Nov 05, 2012 8:33 am    Post subject: Reply with quote

I just don't know, when I wrote I was doing by ALSA manual.

speaker-test works - it generates noise, when i connect 3.5 to my separate card

The written above remains +

Code:
xi@localhost ~ $ aplay police_s.wav
ALSA lib confmisc.c:768:(parse_card) cannot find card '0'
ALSA lib conf.c:4241:(_snd_config_evaluate) function snd_func_card_driver returned error: No such file or directory
ALSA lib confmisc.c:392:(snd_func_concat) error evaluating strings
ALSA lib conf.c:4241:(_snd_config_evaluate) function snd_func_concat returned error: No such file or directory
ALSA lib confmisc.c:1251:(snd_func_refer) error evaluating name
ALSA lib conf.c:4241:(_snd_config_evaluate) function snd_func_refer returned error: No such file or directory
ALSA lib conf.c:4720:(snd_config_expand) Evaluate error: No such file or directory
ALSA lib pcm.c:2217:(snd_pcm_open_noupdate) Unknown PCM default
aplay: main:682: audio open error: No such file or directory


Continuing to search and solving this problem...
_________________
Phenom X2 560
16 GB RAM
USB 3.0 SATA 3.0
SSD Crucial M4 64GB
GeForce 8400 GS
Ensoniq ES1371 audio
Back to top
View user's profile Send private message
xsi
n00b
n00b


Joined: 23 Dec 2011
Posts: 47
Location: Ukraine, Kiev, russian language

PostPosted: Mon Nov 05, 2012 8:50 am    Post subject: Reply with quote

Okay all is working, but only when I launch under root (seamonkey).
_________________
Phenom X2 560
16 GB RAM
USB 3.0 SATA 3.0
SSD Crucial M4 64GB
GeForce 8400 GS
Ensoniq ES1371 audio
Back to top
View user's profile Send private message
Chiitoo
l33t
l33t


Joined: 28 Feb 2010
Posts: 848
Location: Here and Away Again

PostPosted: Tue Nov 06, 2012 6:09 pm    Post subject: ><)))°€ Reply with quote

Teegrins, xcislav!

xcislav wrote:
Okay all is working, but only when I launch under root (seamonkey).

This makes me think of the Audio Group section at:
    http://www.gentoo.org/doc/en/alsa-guide.xml#doc_chap3
Gentoo Linux ALSA Guide wrote:
Before we move on to testing, there's one last important thing that needs to be setup. Rule of thumb in a *nix OS: Do not run as root unless needed. This applies here as well ;) How? Well, most of the times you should be logged in as a user and would like to listen to music or access your soundcard. For that to happen, you need to be in the "audio" group. At this point, we'll add users to the audio group, so that they won't have any issues when they want to access sound devices. We'll use gpasswd here and you need to be logged in as root for this to work.

Code:
Code Listing 3.4: Adding users to the audio group
(Substitute <username> with your user)
# gpasswd -a <username> audio
Adding user <username> to group audio

I hope this helps!

Good luck~
_________________
Kind Regards,
~ The Noob Unlimited ~

Sore wa sore, kore wa kore.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum