Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
libattica impede execucao do KDE
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Portuguese
View previous topic :: View next topic  
Author Message
miltinho
n00b
n00b


Joined: 09 Aug 2012
Posts: 6
Location: Ibaiti - Paraná - Brasil

PostPosted: Wed Aug 15, 2012 7:29 pm    Post subject: libattica impede execucao do KDE Reply with quote

Este problema apareceu durante o processo de atualizacao da biblioteca libattica para 0.4, quando os programas do KDE e ate mesmo o login grafico nao iniciou mais(neste caso o kdm), ao temtar iniciar qualuer programa baseado em kde o resultado e o mesmo, ele indica a falta do arquivo libattica.so.0.3.
A primeira tentativa de resolver foi reinstalando os programas do KDE, comecei com o konqueror, mas ocorreu um erro na compilacao do programa, indica que nao definido algumas funcoes, como se os headers da biblioteca libattica nao estivessem la.
Criei um link para o arquivo libattica.so.0.4 com o nome libattica.so.0.3, nao testei todo o sistema, mas pelo menos o konqueror e o konsole estao funcionando, mas nao sei se essa solucao e segura.

Dei uma olhada rapida em algumas postagens (estou sem tempo para procurar melhor), e para eles a reinstala;'ao funcionou.

Desculpem pela falta de acentos, eles ainda nao funcionam fora do kde.
_________________
São 4 tipos de usuários de computador, escravos, piratas, desbravadores e colonos
Back to top
View user's profile Send private message
BaYGoN
Tux's lil' helper
Tux's lil' helper


Joined: 21 Sep 2004
Posts: 109
Location: Brasília - DF (Brasil)

PostPosted: Thu Nov 01, 2012 1:59 pm    Post subject: Reply with quote

Não uso mais o KDE desde o 3.5, mas pelo que você descreveu, você deve estar com um problema simples de se resolver.
O que ocorre é que, os novos pacotes do KDE que você atualizou, estão linkados com a libattica versão 0.3, porém a libattica foi atualizada para 0.4.

Você precisa então re-linkar os programas para que eles usem a nova versão da libattica.

Para isso você precisa instalar o pacote gentoolkit:

Code:
emerge gentoolkit


No processo de atualização eu sempre utilizo esta sequência de comandos. Eles não falham comigo mais desde 2005:

Code:
emerge --sync
emerge -uDN world
emerge --depclean
revdep-rebuild


Na pior das hipóteses, se estes comandos de atualização não resolverem o seu problema, você pode tentar re-emergir o sistema inteiro. Mas isso leva tempo, por mais poderosa que seja sua máquina.

Code:
emerge -e world


No meu notebook com CPU i7 de 2GHz, este comando leva em torno de 12 horas para finalizar. Depende também de quantos programas você tem instalados.

Boa sorte!
_________________
Linux User #433896
HP DV6-6190US / Linux 3.4.6-pf #1 SMP PREEMPT Fri Aug 10 13:19:26 BRT 2012 x86_64 Intel(R) Core(TM) i7-2630QM CPU @ 2.00GHz GenuineIntel GNU/Linux
"The destiny of every guru is to be a noob for eternity"
Back to top
View user's profile Send private message
miltinho
n00b
n00b


Joined: 09 Aug 2012
Posts: 6
Location: Ibaiti - Paraná - Brasil

PostPosted: Sun Dec 02, 2012 9:54 pm    Post subject: Os problemas contiam ... Reply with quote

Agradeço muito pela ajuda, realmnte um simples revdep-rebuild resolveu tudo.

Resolvi instalar o gentoo no meu computador pessoal, quando dei de dc cara com um probleman a respeito do nepomuk e o use "semantic-desktop" que desabilitei e tentei recompilar o sistema aproiveitando para atualizar com "--update --deep --newuse" mas toda vez que tento fazer isso o pacote xf86-video-mach64 dá erro na compilação.

Sei que este pacote que dá erro é para placas de vídeo ati, mas a minha é uma placa nvidia onboard, ou seja este pacote é totalmente desnecessário, mesmo assim as dependencias obrigam a instalação do pacote.
_________________
São 4 tipos de usuários de computador, escravos, piratas, desbravadores e colonos
Back to top
View user's profile Send private message
BaYGoN
Tux's lil' helper
Tux's lil' helper


Joined: 21 Sep 2004
Posts: 109
Location: Brasília - DF (Brasil)

PostPosted: Wed Dec 05, 2012 11:38 pm    Post subject: Reply with quote

Se este pacote está sendo "puxado" por dependências (e a única dependência deste pacote é o xorg-drivers), então você não configurou a variável VIDEO_CARDS no seu make.conf
Ou seja, você está baixando e instalando TODOS os drivers de video opensource que existem.

Seguindo a filosofia Gentoo, a de que você quer seu sistema suportando apenas o hardware que você de fato tem, recomendo você configurar a variável VIDEO_CARDS no seu /etc/make.conf com o valor nouveau:

Quote:
VIDEO_CARDS=nouveau


Sendo assim, acredito que isso também vale para o seu áudio, onde existe a variável ALSA_CARDS. Você deve ter todos os drivers de áudio existentes instalados. Dê uma olhada também na variável INPUT_DEVICES. Com certeza você não precisa instalar tudo o quê há lá. Minha variável INPUT_DEVICES, por exemplo, tem apenas evdev.
_________________
Linux User #433896
HP DV6-6190US / Linux 3.4.6-pf #1 SMP PREEMPT Fri Aug 10 13:19:26 BRT 2012 x86_64 Intel(R) Core(TM) i7-2630QM CPU @ 2.00GHz GenuineIntel GNU/Linux
"The destiny of every guru is to be a noob for eternity"
Back to top
View user's profile Send private message
miltinho
n00b
n00b


Joined: 09 Aug 2012
Posts: 6
Location: Ibaiti - Paraná - Brasil

PostPosted: Fri Dec 07, 2012 7:10 am    Post subject: EEEEEE agora foi Reply with quote

Muito obrigado, caro amigo, eu realmente nao tinha pensado em olhar as useflags do pacote Xorg-drivers.
_________________
São 4 tipos de usuários de computador, escravos, piratas, desbravadores e colonos
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portuguese All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum