Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Canon Immagerunner ir2525i setup question
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
szensz-siempre
Tux's lil' helper
Tux's lil' helper


Joined: 04 Dec 2006
Posts: 103
Location: South Africa

PostPosted: Mon May 28, 2012 10:44 am    Post subject: Canon Immagerunner ir2525i setup question Reply with quote

Hi,

At the office we have an Canon ir2525i to which everyone on my floor prints. They all use Windows and out IT department set up their machines to print over the network. Seeing as I have chosen to run on Gentoo they cannot help me.

I have tried with my limited knowledge to do it myself. Using the CUPS administration page the printer was detected without a problem, then I tried to install using a PPD file I got from the Canon website. However, when I enter the Admin/Printers page the printer is idle with the following error message: "
Quote:
Idle - "/usr/libexec/cups/filter/foomatic-rip failed"


** Edit ** After changing the ppd file to cel-ir2525-ps-en.ppd.gz rather than cel-ir2525-pxl-en.ppd.gz I no longer get the error message. The log shows my job as having being completed, but nothing happens at the printer.

I next tried to install CQue2.0-3 from http://software.canon-europe.com/software/0042573.asp by running the setup script.

It fails with a missing libpng12.so.0 library, which is a problem as libpng-1.2.44 is no longer in portage.

Can anyone help me install and use this printer over the network?

Any help is appreciated.
Back to top
View user's profile Send private message
ShadowCat8
Tux's lil' helper
Tux's lil' helper


Joined: 07 Oct 2008
Posts: 136
Location: Arcadia, CA, USA

PostPosted: Tue May 29, 2012 4:16 pm    Post subject: Reply with quote

Greetings,

At our office here, we have an imageCLASS MF7470 and I use the imageRunner 330s Foomatic driver to be able to print to it. It works quite well. You may want to give that a shot and see if you can get a test page printed from that.

As far as the libpng12 issue, have you run 'revdep-rebuild' yet?

HTH. Let us know.
_________________
------
"There is no value to explaining sanity to an insane person, just as there is no value of explaining rabies to a rabid dog... They will both bite you for your effort."
-- oldbitman
Back to top
View user's profile Send private message
szensz-siempre
Tux's lil' helper
Tux's lil' helper


Joined: 04 Dec 2006
Posts: 103
Location: South Africa

PostPosted: Thu Oct 25, 2012 10:53 am    Post subject: Reply with quote

Hi ShadowCat8, still no resolution here and no-one seems able to help me (I asked one of the canon techies that came for routine maintenance).

It seems like I have CUPS happy with the printer now, but I still cannot print to it as I still can't install CQue (To manage the Dept. ID Management Password feature on the printer). Revdep-rebuild finds no packages that need to be emerged.

Has anyone gotten CQue working that could give me some guidance?
Back to top
View user's profile Send private message
szensz-siempre
Tux's lil' helper
Tux's lil' helper


Joined: 04 Dec 2006
Posts: 103
Location: South Africa

PostPosted: Wed Jan 16, 2013 8:48 am    Post subject: Please help with QCue Reply with quote

:cry:

It's been almost half a year and I am still struggling with this problem. Here is what I have done

CQue is now at version 2.0-4 but running the setup script still gave me the following error:
Code:
./setup: error while loading shared libraries: libpng12.so.0: cannot open shared object file: No such file or directory


So I tried copying the file from my /usr/lib32 to /usr/lib64 folder
Now when I ran the setup script I ended up with:
Code:
./setup: error while loading shared libraries: libpng12.so.0: wrong ELF class: ELFCLASS32


So I installed libpng1.2 into a slot
Quote:
emerge -av libpng:1.2


Some progress, now I needed libjpeg.so.62 so I run:
Code:
emerge =media-libs/jpeg-6b-r9


Now when I run the setup script I get the following error:
Code:
/bin/cp: cannot stat 'cque.pp': No such file or directory


Now I have no idea where to go from here. I'm stumped.
Back to top
View user's profile Send private message
ShadowCat8
Tux's lil' helper
Tux's lil' helper


Joined: 07 Oct 2008
Posts: 136
Location: Arcadia, CA, USA

PostPosted: Mon Mar 25, 2013 7:20 pm    Post subject: Reply with quote

Greetings,

Sorry I missed the fact that you had responded on this thread. :-/

With regards to your issue, it looks like the setup script lost track of where it was getting some of the files it needs... In particular, it doesn't know where to copy the "cque.pp" file from. You may have to look directly at the script to see what it is trying to do and see if you can "help" it along, like I had to with the UFR II driver package from Canon. Do you know where that file is in the CQue source code?

I have noticed that there are some issues with the way that Canon seems to be doing their driver packages, and while I am unfamiliar with CQue, I am now fairly well versed in building and installing the Linux_UFRII_PrinterDriver_V250_u[s,k]_EN package. :? Unfortunately, I have found that after doing all the adjustments that I managed to find (including running "WANT_AUTOMAKE=1.11 autoreconf -f --install" on every source directory with a configure.[in,ac] script in it as was recommended in this post on these forums) on how to get it to build and install, there still seem to be issues when you are using one of the UFR II drivers; nothing happens at the printer and CUPS reports the job as stopped. Checking /var/log/cups/error_log showed the following:
Code:
...<snip>...
W [25/Mar/2013:09:47:18 -0700] [CGI] Missing Product in /usr/share/cups/model/CNCUPSIRADV4051ZK.ppd!
E [25/Mar/2013:10:18:50 -0700] Canon_MF7400_Series_: File "/usr/libexec/cups/filter/pstoufr2cpca" not available: No such file or directory
E [25/Mar/2013:10:19:06 -0700] Canon_MF7400_Series_: File "/usr/libexec/cups/filter/pstoufr2cpca" not available: No such file or directory
E [25/Mar/2013:10:19:06 -0700] [Job 60] Unable to start filter "pstoufr2cpca" - No such file or directory.
E [25/Mar/2013:10:19:06 -0700] [Job 60] Stopping job because the scheduler could not execute a filter.
E [25/Mar/2013:10:20:10 -0700] Canon_MF7400_Series_: File "/usr/libexec/cups/filter/pstoufr2cpca" not available: No such file or directory
E [25/Mar/2013:10:20:10 -0700] [Job 60] Unable to start filter "pstoufr2cpca" - No such file or directory.
E [25/Mar/2013:10:20:10 -0700] [Job 60] Stopping job because the scheduler could not execute a filter.
E [25/Mar/2013:10:24:07 -0700] [Job 60] Stopping unresponsive job!

So, having seen that, I look into the build directories and find the following:
Code:
tech8 Linux_UFRII_PrinterDriver_V250_uk_EN # find . -iname "*pstoufr2cpca*" -print
./Sources/cndrvcups-lb-2.50/pstoufr2cpca
./Sources/cndrvcups-lb-2.50/pstoufr2cpca/filter/.deps/pstoufr2cpca.Po
./Sources/cndrvcups-lb-2.50/pstoufr2cpca/filter/pstoufr2cpca.o
./Sources/cndrvcups-lb-2.50/pstoufr2cpca/filter/pstoufr2cpca
./Sources/cndrvcups-lb-2.50/pstoufr2cpca/filter/pstoufr2cpca.c
tech8 Linux_UFRII_PrinterDriver_V250_uk_EN #

So, after I copy the "pstoufr2cpca" filter to /usr/libexec/cups/filter/, I try another test print and it seems to go through, but all I get on the page is an error message saying "**** Unable to open initial device, quitting." and no output in the error_log. :?

Still running these issues down on my end, but let us know if you find that file.

HTH. TTYL.
_________________
------
"There is no value to explaining sanity to an insane person, just as there is no value of explaining rabies to a rabid dog... They will both bite you for your effort."
-- oldbitman
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum