Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Kerneleinstellungen für VIA-Grafikkarte
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
nowo
n00b
n00b


Joined: 02 Aug 2011
Posts: 15
Location: Potsdam

PostPosted: Sun Oct 21, 2012 4:53 pm    Post subject: Kerneleinstellungen für VIA-Grafikkarte Reply with quote

Moin ihrs! Ich bin grad nach sämtlichen Standardmethoden, die bislang immer funktioniert haben, am Verzweifeln. Wenn ich die Live-CD für amd64 vom 21. Juni 2012 boote, kommt eine schön hohe Auflösung und der Pinguin oben. lspci -k sagt mir dann auch, welche Grafikkarte ich habe:
Code:
01:00.0 VGA compatible controller: VIA Technologies, Inc. K8M890CE/K8N890CE [Chrome 9] (rev 01)
    Subsystem: Fujitsu Technology Solutions Device 10d9

Unter lsmod taucht nirgendwo der Begriff viafb auf. Ist das ein Anzeichen dafür, dass die Anzeige nicht mit Framebuffer-Treiber umgesetzt wird, was auch immer das genau heißt?

Auf dem installierten System jedenfalls erscheint die Konsole (bei X bin ich noch gar nicht) in der klassischen Du-hast-deinen-Kernel-in-Bezug-auf-deine-Grafikkarte-nicht-richtig-konfiguriert-Auflösung. Ich habe laut Handbuch meinen Kernel folgendermaßen konfiguriert:
Code:

Device Drivers
--> Graphics support
    --> [*] /dev/agpgart (AGP Support)
        --> [ ] AMD
            [ ] Intel
            [ ] SiS
            [*] VIA
        -*- VGA Arbitration
        (16) Maximum number of GPUs
        [*] Laptop Hybrid Graphics
        [ ] Direct Rendering Manager
        [*] Intel GMA500 Stub Driver
        -*- Lowlevel video output switch controls
        [*] Support for framebuffer devices
        --> [ ] alles ausgeknipst
        [*] Exynos Video driver support
        [*] Backlight & LCD device support
        --> [*] Lowlevel LCD controls
            -*- Lowlevel Backlight controls
            [*] Generic (aka Sharp Corgi) Backlight Driver
            [ ] sonst alles ausgeknipst
    --> Console display driver support
        -*- VGA text console
        [*] Enable Scrollback Buffer in System RAM
        [*] Framebuffer Console support
        [*]   Map the console to the primary display device
        [ ] sonst alles ausgeknipst
    [ ] Bootup logo

Außerdem hab ich [ ] Enable loadable module support ausgeschaltet. Kann es was damit zu tun haben?
dmesg gibt mir unter anderem Folgendes aus, was eventuell was damit zu tun haben könnte:
Code:

...
[    0.000000] Command line: root=/dev/sda4
...
[    0.000000] DMI present.
[    0.000000] DMI: FUJITSU SIEMENS AMILO La1703/E25, BIOS 6.00-0020-M004       01/26/2007
[    0.000000] e820 update range: 0000000000000000 - 0000000000010000 (usable) ==> (reserved)
[    0.000000] e820 remove range: 00000000000a0000 - 0000000000100000 (usable)
[    0.000000] AGP bridge at 00:00:00
[    0.000000] Aperture from AGP @ d0000000 old size 32 MB
[    0.000000] Aperture from AGP @ d0000000 size 128 MB (APSIZE f20)
...
[    0.000000] Checking aperture...
[    0.000000] AGP bridge at 00:00:00
[    0.000000] Aperture from AGP @ d0000000 old size 32 MB
[    0.000000] Aperture from AGP @ d0000000 size 128 MB (APSIZE f20)
[    0.000000] Node 0: aperture @ d0000000 size 128 MB
[    0.000000] Memory: 953016k/981568k available (4913k kernel code, 460k absent, 28092k reserved, 3834k data, 424k init)
[    0.000000] SLUB: Genslabs=15, HWalign=64, Order=0-3, MinObjects=0, CPUs=1, Nodes=1
[    0.000000] NR_IRQS:4352 nr_irqs:256 16
[    0.000000] Console: colour VGA+ 80x25
[    0.000000] console [tty0] enabled
[    0.000000] Fast TSC calibration using PIT
[    0.000000] Detected 2000.111 MHz processor.
[    0.003001] Calibrating delay loop (skipped), value calculated using timer frequency.. 4000.22 BogoMIPS (lpj=2000111)
...
[    0.256025] vgaarb: device added: PCI:0000:01:00.0,decodes=io+mem,owns=io+mem,locks=none
[    0.256161] vgaarb: loaded
[    0.256243] vgaarb: bridge control possible 0000:01:00.0
[    0.256477] SCSI subsystem initialized
[    0.256663] libata version 3.00 loaded.
[    0.256731] usbcore: registered new interface driver usbfs
[    0.256854] usbcore: registered new interface driver hub
[    0.256980] usbcore: registered new device driver usb
[    0.257264] wmi: Mapper loaded
[    0.257384] Advanced Linux Sound Architecture Driver Version 1.0.25.
[    0.257472] PCI: Using ACPI for IRQ routing
[    0.257559] PCI: pci_cache_line_size set to 64 bytes
[    0.257570] pci 0000:00:00.0: address space collision: [mem 0xd0000000-0xd7ffffff pref] conflicts with GART [mem 0xd0000000-0xd7ffffff]
[    0.257709] ------------[ cut here ]------------
[    0.257797] WARNING: at arch/x86/pci/i386.c:60 pcibios_fwaddrmap_lookup+0x1d/0x60()
[    0.257929] Hardware name: AMILO La1703
[    0.257969] Pid: 1, comm: swapper Not tainted 3.4.9-gentoo #7
[    0.257969] Call Trace:
[    0.257969]  [<ffffffff81030405>] warn_slowpath_common+0x75/0xb0
[    0.257969]  [<ffffffff81030505>] warn_slowpath_null+0x15/0x20
[    0.257969]  [<ffffffff813bb62d>] pcibios_fwaddrmap_lookup+0x1d/0x60
[    0.257969]  [<ffffffff818b793c>] pcibios_allocate_resources+0xb8/0x1ee
[    0.257969]  [<ffffffff818b8ab6>] ? pci_legacy_init+0x3e/0x3e
[    0.257969]  [<ffffffff818b7a89>] pcibios_resource_survey+0x17/0x2d
[    0.257969]  [<ffffffff818b944f>] pcibios_init+0x28/0x3a
[    0.257969]  [<ffffffff818b8afd>] pci_subsys_init+0x47/0x4d
[    0.257969]  [<ffffffff8188db2c>] do_one_initcall+0x78/0x126
[    0.257969]  [<ffffffff8188dcee>] kernel_init+0x114/0x1a5
[    0.257969]  [<ffffffff8188d504>] ? loglevel+0x31/0x31
[    0.257969]  [<ffffffff814c9b44>] kernel_thread_helper+0x4/0x10
[    0.257969]  [<ffffffff8188dbda>] ? do_one_initcall+0x126/0x126
[    0.257969]  [<ffffffff814c9b40>] ? gs_change+0xb/0xb
[    0.257969] ---[ end trace 85a103187464d49a ]---
...
[    0.271917] pci 0000:01:00.0: BAR 6: can't assign mem pref (size 0x10000)
[    0.271917] ------------[ cut here ]------------
[    0.271917] WARNING: at arch/x86/pci/i386.c:60 pcibios_fwaddrmap_lookup+0x1d/0x60()
[    0.272001] Hardware name: AMILO La1703
[    0.272085] Pid: 1, comm: swapper Tainted: G        W    3.4.9-gentoo #7
[    0.272156] Call Trace:
[    0.272156]  [<ffffffff81030405>] warn_slowpath_common+0x75/0xb0
[    0.272156]  [<ffffffff81030505>] warn_slowpath_null+0x15/0x20
[    0.272156]  [<ffffffff813bb62d>] pcibios_fwaddrmap_lookup+0x1d/0x60
[    0.272156]  [<ffffffff813bb68c>] pcibios_retrieve_fw_addr+0x1c/0x40
[    0.272156]  [<ffffffff8123e303>] pci_assign_resource+0x133/0x260
[    0.272156]  [<ffffffff81246d93>] assign_requested_resources_sorted+0x63/0xe0
[    0.272156]  [<ffffffff81246e9c>] __assign_resources_sorted+0x8c/0x360
[    0.272156]  [<ffffffff810e854c>] ? kfree+0x2c/0x100
[    0.272156]  [<ffffffff814be3d1>] __pci_bus_assign_resources+0x61/0x110
[    0.272156]  [<ffffffff814be430>] __pci_bus_assign_resources+0xc0/0x110
[    0.272156]  [<ffffffff818ab0d3>] pci_assign_unassigned_resources+0xd4/0x219
[    0.272156]  [<ffffffff818b77a3>] ? pcibios_allocate_bus_resources+0x9c/0x9c
[    0.272156]  [<ffffffff818b781a>] pcibios_assign_resources+0x77/0xe1
[    0.272156]  [<ffffffff818b4c49>] ? init_acpi_pm_clocksource+0xda/0xe2
[    0.272156]  [<ffffffff818b77a3>] ? pcibios_allocate_bus_resources+0x9c/0x9c
[    0.272156]  [<ffffffff8188db2c>] do_one_initcall+0x78/0x126
[    0.272156]  [<ffffffff8188dcee>] kernel_init+0x114/0x1a5
[    0.272156]  [<ffffffff8188d504>] ? loglevel+0x31/0x31
[    0.272156]  [<ffffffff814c9b44>] kernel_thread_helper+0x4/0x10
[    0.272156]  [<ffffffff8188dbda>] ? do_one_initcall+0x126/0x126
[    0.272156]  [<ffffffff814c9b40>] ? gs_change+0xb/0xb
[    0.272156] ---[ end trace 85a103187464d49b ]---
...
[    0.286195] Linux agpgart interface v0.103
...
[    0.352733] input: Video Bus as /devices/LNXSYSTM:00/device:00/PNP0A03:00/device:14/LNXVIDEO:00/input/input4
[    0.352870] ACPI: Video Device [VGA] (multi-head: yes  rom: no  post: no)
...

Letztlich werd ich sowieso hauptsächlich X am Laufen haben, aber ich will diesmal endlich ein System haben, wo von Anfang an alles so halbwegs stimmt. Wenn das geht, dass die Fähigkeiten der Grafikkarte wie auf der Live-CD genutzt werden, dann möchte ich das möglichst auch so haben.
Back to top
View user's profile Send private message
Max Steel
Veteran
Veteran


Joined: 12 Feb 2007
Posts: 1952
Location: My own world! I and Gentoo!

PostPosted: Sun Oct 21, 2012 5:20 pm    Post subject: Reply with quote

Du hast garkeine framebuffer-Treiber in deinem KErnel. Also wie soll der framebuffer denn funktionieren? Auch via-Modesetting gibt es meines Wissens nicht. (viafb funktioniert auch als builtin im Kernel)

Und das bootup-Logo ist auch ganz nice, kannste also auch anschalten ^^
_________________
mfg
Steel
___________________
Big sorry for my bad English.

Heim-PC: AMD Phenom II X4 3,2GHz, 16GB RAM, gentoo-sources-3.10.7, NV GTX 780
Laptop: Intel Celeron 1,7GHz, 512MB Ram, tuxonice-sources-3.7.1, SIS Graphic

Version 0.4
Back to top
View user's profile Send private message
nowo
n00b
n00b


Joined: 02 Aug 2011
Posts: 15
Location: Potsdam

PostPosted: Sun Oct 21, 2012 5:48 pm    Post subject: Reply with quote

Es ist nicht so, dass ich das Framebufferthema verstanden hätte und wüsste, wovon ich rede. Aber die Handbücher lesen sich so, als würde von allem, was mit Framebuffer zu tun hat, abgeraten. Bezieht sich das nur auf Nvidia und Radeon? Soll ich den Framebuffer-Treiber einkompilieren?
Das Bootup-Logo is mir nüscht. ;o)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum