Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
instalacion oracle xe 10g
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Spanish
View previous topic :: View next topic  
Author Message
Theasker
l33t
l33t


Joined: 18 Nov 2006
Posts: 636
Location: Zaragoza (Spain)

PostPosted: Sat Oct 20, 2012 12:46 pm    Post subject: instalacion oracle xe 10g Reply with quote

Estoy intentando instalar esto desde hace mas de una semana y no hay manera. Con el 11g sin problemas pero con este nada.

Buscando y buscando he conseguido el rpm para instalarlo y un ebuild en este overlay pero después de instalarlo me dice:

Code:
 * The Oracle 10g Express Edition Database has been installed.
 *
 * You have to run
 *   ebuild /var/db/pkg/dev-db/oracle-xe-10.2.0.1_p1/oracle-xe-10.2.0.1_p1.ebuild config
 * to adjust kernel parameters and
 *   /usr/lib/oracle/xe/app/oracle/product/10.2.0/server/bin/oracle_configure.sh
 * to configure oracle-xe before first use!


pero al hacer la configuración con oracle_configure.sh me tira un montón de errores:

Code:

# /usr/lib/oracle/xe/app/oracle/product/10.2.0/server/bin/oracle_configure.sh

Oracle Database 10g Express Edition Configuration
-------------------------------------------------
This will configure on-boot properties of Oracle Database 10g Express
Edition.  The following questions will determine whether the database should
be starting upon system boot, the ports it will use, and the passwords that
will be used for database accounts.  Press <Enter> to accept the defaults.
Ctrl-C will abort.

Specify the HTTP port that will be used for HTML DB [8080]:

Specify a port that will be used for the database listener [1521]:

Port 1521 appears to be in use by another application. Please specify a different port.
Specify a port that will be used for the database listener [1521]:1522

Specify a password to be used for database accounts.  Note that the same
password will be used for SYS, SYSTEM and FLOWS_020100.  Oracle recommends
the use of different passwords for each database account.  This can be done
after initial configuration:
Confirm the password:
Configuring Database...

oracleXE: error while loading shared libraries: libaio.so.1: cannot open shared object file: No such file or directory
ERROR:
ORA-12547: TNS:lost contact


oracleXE: error while loading shared libraries: libaio.so.1: cannot open shared object file: No such file or directory
oracleXE: error while loading shared libraries: libaio.so.1: cannot open shared object file: No such file or directory
ORA-12547: TNS:lost contact
SP2-0640: Not connected
SP2-0640: Not connected
SP2-0640: Not connected
oracleXE: error while loading shared libraries: libaio.so.1: cannot open shared object file: No such file or directory
ERROR:
ORA-12547: TNS:lost contact


SP2-0640: Not connected
SP2-0640: Not connected
SP2-0641: "EXECUTE" requires connection to server
oracleXE: error while loading shared libraries: libaio.so.1: cannot open shared object file: No such file or directory
oracleXE: error while loading shared libraries: libaio.so.1: cannot open shared object file: No such file or directory
ORA-12547: TNS:lost contact
oracleXE: error while loading shared libraries: libaio.so.1: cannot open shared object file: No such file or directory
oracleXE: error while loading shared libraries: libaio.so.1: cannot open shared object file: No such file or directory
ORA-12547: TNS:lost contact
SP2-0640: Not connected
SP2-0640: Not connected
SP2-0640: Not connected
SP2-0640: Not connected
SP2-0640: Not connected
SP2-0640: Not connected
SP2-0640: Not connected
SP2-0640: Not connected
SP2-0640: Not connected
SP2-0640: Not connected
SP2-0640: Not connected
SP2-0640: Not connected
SP2-0640: Not connected
oracleXE: error while loading shared libraries: libaio.so.1: cannot open shared object file: No such file or directory
ERROR:
ORA-12547: TNS:lost contact


SP2-0640: Not connected
SP2-0640: Not connected
SP2-0640: Not connected
oracleXE: error while loading shared libraries: libaio.so.1: cannot open shared object file: No such file or directory
ERROR:
ORA-12547: TNS:lost contact


SP2-0640: Not connected
SP2-0641: "EXECUTE" requires connection to server
SP2-0640: Not connected
oracleXE: error while loading shared libraries: libaio.so.1: cannot open shared object file: No such file or directory
ERROR:
ORA-12547: TNS:lost contact


oracleXE: error while loading shared libraries: libaio.so.1: cannot open shared object file: No such file or directory
ERROR:
ORA-12547: TNS:lost contact


SP2-0640: Not connected
SP2-0640: Not connected
oracleXE: error while loading shared libraries: libaio.so.1: cannot open shared object file: No such file or directory
oracleXE: error while loading shared libraries: libaio.so.1: cannot open shared object file: No such file or directory
ORA-12547: TNS:lost contact
oracleXE: error while loading shared libraries: libaio.so.1: cannot open shared object file: No such file or directory
ERROR:
ORA-12547: TNS:lost contact


oracleXE: error while loading shared libraries: libaio.so.1: cannot open shared object file: No such file or directory
oracleXE: error while loading shared libraries: libaio.so.1: cannot open shared object file: No such file or directory
ORA-12547: TNS:lost contact
SP2-0640: Not connected
SP2-0640: Not connected
SP2-0641: "EXECUTE" requires connection to server
SP2-0640: Not connected
SP2-0640: Not connected
SP2-0640: Not connected
SP2-0640: Not connected
SP2-0640: Not connected
SP2-0640: Not connected
SP2-0640: Not connected
oracleXE: error while loading shared libraries: libaio.so.1: cannot open shared object file: No such file or directory
ERROR:
ORA-12547: TNS:lost contact


SP2-0306: Invalid option.
Usage: CONN[ECT] [logon] [AS {SYSDBA|SYSOPER}]
where <logon>  ::= <username>[/<password>][@<connect_identifier>] | /
oracleXE: error while loading shared libraries: libaio.so.1: cannot open shared object file: No such file or directory
ERROR:
ORA-12547: TNS:lost contact


SP2-0306: Invalid option.
Usage: CONN[ECT] [logon] [AS {SYSDBA|SYSOPER}]
where <logon>  ::= <username>[/<password>][@<connect_identifier>] | /
oracleXE: error while loading shared libraries: libaio.so.1: cannot open shared object file: No such file or directory
ERROR:
ORA-12547: TNS:lost contact


SP2-0306: Invalid option.
Usage: CONN[ECT] [logon] [AS {SYSDBA|SYSOPER}]
where <logon>  ::= <username>[/<password>][@<connect_identifier>] | /
oracleXE: error while loading shared libraries: libaio.so.1: cannot open shared object file: No such file or directory
ERROR:
ORA-12547: TNS:lost contact


SP2-0306: Invalid option.
Usage: CONN[ECT] [logon] [AS {SYSDBA|SYSOPER}]
where <logon>  ::= <username>[/<password>][@<connect_identifier>] | /
oracleXE: error while loading shared libraries: libaio.so.1: cannot open shared object file: No such file or directory
ERROR:
ORA-12547: TNS:lost contact


SP2-0306: Invalid option.
Usage: CONN[ECT] [logon] [AS {SYSDBA|SYSOPER}]
where <logon>  ::= <username>[/<password>][@<connect_identifier>] | /
oracleXE: error while loading shared libraries: libaio.so.1: cannot open shared object file: No such file or directory
ERROR:
ORA-12547: TNS:lost contact


oracleXE: error while loading shared libraries: libaio.so.1: cannot open shared object file: No such file or directory
oracleXE: error while loading shared libraries: libaio.so.1: cannot open shared object file: No such file or directory
ORA-12547: TNS:lost contact
Done.

To start oracle-xe, run:
/etc/init.d/oracle-xe start
and point your Browser to:
http://localhost:8080/apex/

Log in using username system and the password you supplied...


También he probado con el ebuild que hay aqui

a ver si alguien lo ha conseguido o ... me podéis echar un cable.

Gracias anticipadas a tod@s
_________________
"Oigo y olvido. Veo y recuerdo. Hago y comprendo"
Back to top
View user's profile Send private message
Arctic
Apprentice
Apprentice


Joined: 04 Jul 2011
Posts: 178

PostPosted: Sat Oct 20, 2012 4:36 pm    Post subject: Reply with quote

Te faltan las dependencias ,por eso no te deja continuar.
Para solucionarlo solo basta con que leas las exigencias del paquete que estas instalando y las instales con portage (seguramente estarán dentro del arbol) ,sino las encuentras googleas con cada librería que te esta dando error y te dirá de que paquete depende.

Salu2
_________________
ln -s /user/artic /user/arctic
Back to top
View user's profile Send private message
Theasker
l33t
l33t


Joined: 18 Nov 2006
Posts: 636
Location: Zaragoza (Spain)

PostPosted: Sat Oct 20, 2012 4:40 pm    Post subject: Reply with quote

todos los errores son por libio, pero he hecho un revdep y detecta las librerías rotas de la instalación de oracle pero dice que no puede asociarlas con ninguna de las instaladas.
_________________
"Oigo y olvido. Veo y recuerdo. Hago y comprendo"
Back to top
View user's profile Send private message
gringo
Advocate
Advocate


Joined: 27 Apr 2003
Posts: 3744

PostPosted: Mon Oct 29, 2012 11:35 am    Post subject: Reply with quote

Theasker wrote:
todos los errores son por libio, pero he hecho un revdep y detecta las librerías rotas de la instalación de oracle pero dice que no puede asociarlas con ninguna de las instaladas.


... porque estás ejecutando un paquete binario que fue compilado usando una serie de librerías, al no encontrarlas el programa informa de que no encuentra esas dependencias.
El único warning que veo es sobre libaio, en portage hay varias versiones disponibles, prueba con la mas vieja disponible e igual cuela.

saluetes
Back to top
View user's profile Send private message
Theasker
l33t
l33t


Joined: 18 Nov 2006
Posts: 636
Location: Zaragoza (Spain)

PostPosted: Mon Oct 29, 2012 12:14 pm    Post subject: Reply with quote

¿y ... no me cargaré nada al hacer un downgrade de esa librería?, de todas formas lo intentaré a ver si me funciona.

Una vez más de tantas, gracias por tu ayuda e interés Gringo :), lo pruebo esta noche en casa y .... cuento los resultados
_________________
"Oigo y olvido. Veo y recuerdo. Hago y comprendo"
Back to top
View user's profile Send private message
gringo
Advocate
Advocate


Joined: 27 Apr 2003
Posts: 3744

PostPosted: Mon Oct 29, 2012 2:11 pm    Post subject: Reply with quote

Quote:
¿y ... no me cargaré nada al hacer un downgrade de esa librería?


equery te dirá que paquetes dependen de esa librería, en mi sistema actual solo qemu depende de libaio asi que *supongo* que no harás un gran estropicio si instalas una versión inferior.

suerte y saluetes ;-)
Back to top
View user's profile Send private message
Theasker
l33t
l33t


Joined: 18 Nov 2006
Posts: 636
Location: Zaragoza (Spain)

PostPosted: Mon Oct 29, 2012 9:26 pm    Post subject: Reply with quote

He eliminado los paquetes que dependían de esa librería hasta poder eliminarla, pero al intentar instalarla hay un bloqueo con man-pages

Code:
# emerge -va =dev-libs/libaio-0.3.107

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N     ] dev-libs/libaio-0.3.107  51 kB
[blocks B      ] <dev-libs/libaio-0.3.109-r2 ("<dev-libs/libaio-0.3.109-r2" is blocking sys-apps/man-pages-3.42)

Total: 1 package (1 new), Size of downloads: 51 kB
Conflict: 1 block (1 unsatisfied)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (dev-libs/libaio-0.3.107::gentoo, ebuild scheduled for merge) pulled in by
    =dev-libs/libaio-0.3.107

  (sys-apps/man-pages-3.42::gentoo, installed) pulled in by
    sys-apps/man-pages required by @system


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked


¿Y si lo instalase con configure, make, make install para la versión que necesita oracle-xe 10g?, ya se que es una chapucería para gentoo, pero ... ¿habría algún problema? ¿luego para desinstalarlo ... dejaría basura?
_________________
"Oigo y olvido. Veo y recuerdo. Hago y comprendo"
Back to top
View user's profile Send private message
gringo
Advocate
Advocate


Joined: 27 Apr 2003
Posts: 3744

PostPosted: Tue Oct 30, 2012 12:10 pm    Post subject: Reply with quote

Quote:
pero al intentar instalarla hay un bloqueo con man-pages


yo de ti primero miraría que versión necesita este software extactamente, no vaya a ser que trabajes para nada.
Si luego de verdad necesitas esta versión, supongo que con instalar otra versión inferior de man-pages llegará.

Quote:
Y si lo instalase con configure, make, make install para la versión que necesita oracle-xe 10g?


si es un paquete binario es irrelevante porque no se compila ni se enlaza nada, se instalan binarios, algún script y poco mas.

Quote:
¿habría algún problema? ¿luego para desinstalarlo ... dejaría basura?


puedes tener problemas si el paquete instala algo mas que binarios propios del paquete (que no parece el caso).
Si p.ej. te instala alguna libreria y te machaca la que tu tienes en el sistema pues puedes liarla.
Para desinstalar, realmente depende del software que use el paquete pero normalmente hay un make uninstall o similar. Si no hay algo obvio mira en el paquete del software, normalmente hay un archivo INSTALL o README con mas detalles.

saluetes
Back to top
View user's profile Send private message
Theasker
l33t
l33t


Joined: 18 Nov 2006
Posts: 636
Location: Zaragoza (Spain)

PostPosted: Tue Oct 30, 2012 12:35 pm    Post subject: Reply with quote

Quote:
yo de ti primero miraría que versión necesita este software extactamente, no vaya a ser que trabajes para nada.
Si luego de verdad necesitas esta versión, supongo que con instalar otra versión inferior de man-pages llegará.

La versión requerida de libaio sengún esta página es la 107, pero según la wiki de gentoo es la 96, por lo que intentaré instalar la versión más baja que haya en el portage haciendo un downgrade de man-pages.

Al hacer la limpia de qemu, y gparted que usaban la librería, ha desaparecido de mi sistema. Entonces, ¿porqué me la bloquea man-pages si no la instala?

Si no la tengo ya instalada en mi sistema, ¿podría instalarla sin problemas desde un binario rpm? y .... si lo hiciera así, ¿habría problemas si instalara después algún paquete como otra vez gparted?

Saludicos
_________________
"Oigo y olvido. Veo y recuerdo. Hago y comprendo"
Back to top
View user's profile Send private message
gringo
Advocate
Advocate


Joined: 27 Apr 2003
Posts: 3744

PostPosted: Tue Oct 30, 2012 2:33 pm    Post subject: Reply with quote

Quote:
La versión requerida de libaio sengún esta página es la 107, pero según la wiki de gentoo es la 96, por lo que intentaré instalar la versión más baja que haya en el portage haciendo un downgrade de man-pages.


el primer enlace es del 2011 y el segundo del 2008, asi que yo me guiaria por el primero.

Quote:
¿porqué me la bloquea man-pages si no la instala?


porque le estás diciendo que instale una versión concreta de libaio:

Code:
emerge -va =dev-libs/libaio-0.3.107


Quote:
¿podría instalarla sin problemas desde un binario rpm?


por poder, desde luego que puedes, rpm está disponible para gentoo.

Quote:
¿habría problemas si instalara después algún paquete como otra vez gparted?


probablemente, pero es lógico que asi sea si usas 2 gestores de software que no saben de la existencia el uno del otro.

saluetes
Back to top
View user's profile Send private message
Theasker
l33t
l33t


Joined: 18 Nov 2006
Posts: 636
Location: Zaragoza (Spain)

PostPosted: Tue Oct 30, 2012 7:46 pm    Post subject: Reply with quote

He conseguido instalar la versión 107 pero sigue dando los mismos fallos de libaio, por lo que intentaré instalar el rpm para saber si realmente es la versión el problema y si es eso buscaré un ebuild de esa versión de libaio.
_________________
"Oigo y olvido. Veo y recuerdo. Hago y comprendo"
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Spanish All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum