Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
vgc-lv180me desktop sin audio
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Spanish
View previous topic :: View next topic  
Author Message
paynalton
Tux's lil' helper
Tux's lil' helper


Joined: 24 Jun 2006
Posts: 106
Location: Mexico

PostPosted: Thu Sep 20, 2012 1:19 pm    Post subject: vgc-lv180me desktop sin audio Reply with quote

Hola, he decidido escribirles despues de tanto llorar.

tengo un equipo VGC-lv180ME desktop de sony con problemas de audio. Anteriormente estos problemas los había solucionado siguiendo este post:

http://forums.gentoo.org/viewtopic-t-824869-start-0.html

Pero ahora ya no funciona.

Actualmente tengo audio solamente en la salida de audífonos, pero no en las bocinas integradas.

Esta es la salida de lspci

Code:
00:00.0 Host bridge: Intel Corporation 4 Series Chipset DRAM Controller (rev 03)
00:01.0 PCI bridge: Intel Corporation 4 Series Chipset PCI Express Root Port (rev 03)
00:03.0 Communication controller: Intel Corporation 4 Series Chipset HECI Controller (rev 03)
00:19.0 Ethernet controller: Intel Corporation 82567V-2 Gigabit Network Connection
00:1a.0 USB controller: Intel Corporation 82801JI (ICH10 Family) USB UHCI Controller #4
00:1a.1 USB controller: Intel Corporation 82801JI (ICH10 Family) USB UHCI Controller #5
00:1a.2 USB controller: Intel Corporation 82801JI (ICH10 Family) USB UHCI Controller #6
00:1a.7 USB controller: Intel Corporation 82801JI (ICH10 Family) USB2 EHCI Controller #2
00:1b.0 Audio device: Intel Corporation 82801JI (ICH10 Family) HD Audio Controller
00:1c.0 PCI bridge: Intel Corporation 82801JI (ICH10 Family) PCI Express Root Port 1
00:1c.1 PCI bridge: Intel Corporation 82801JI (ICH10 Family) PCI Express Port 2
00:1c.4 PCI bridge: Intel Corporation 82801JI (ICH10 Family) PCI Express Root Port 5
00:1d.0 USB controller: Intel Corporation 82801JI (ICH10 Family) USB UHCI Controller #1
00:1d.1 USB controller: Intel Corporation 82801JI (ICH10 Family) USB UHCI Controller #2
00:1d.2 USB controller: Intel Corporation 82801JI (ICH10 Family) USB UHCI Controller #3
00:1d.7 USB controller: Intel Corporation 82801JI (ICH10 Family) USB2 EHCI Controller #1
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev 90)
00:1f.0 ISA bridge: Intel Corporation 82801JIB (ICH10) LPC Interface Controller
00:1f.2 IDE interface: Intel Corporation 82801JI (ICH10 Family) 4 port SATA IDE Controller #1
00:1f.3 SMBus: Intel Corporation 82801JI (ICH10 Family) SMBus Controller
01:00.0 VGA compatible controller: nVidia Corporation G98 [GeForce 9300M GS] (rev a1)
02:00.0 Network controller: Atheros Communications Inc. AR928X Wireless Network Adapter (PCI-Express) (rev 01)
03:00.0 Multimedia video controller: NEC Corporation Device 0165 (rev 0b)
07:03.0 FireWire (IEEE 1394): Ricoh Co Ltd R5C832 IEEE 1394 Controller (rev 05)
07:03.1 SD Host controller: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter (rev 22)
07:03.2 System peripheral: Ricoh Co Ltd R5C592 Memory Stick Bus Host Adapter (rev 12)


alsamixer muestra esto:
Code:

 Card: HDA Intel                                                                                             
│ Chip: Realtek ALC889                                                                                           
│ View: F3:[Playback] F4: Capture  F5: All                                                                         
│ Item: Master [dB gain: -15,00]


y en /etc/modprobe.d/alsa.conf tengo esto:

Code:

 alias /dev/dsp snd-pcm-oss
alias /dev/midi snd-seq-oss

# Set this to the correct number of cards.

# --- BEGIN: Generated by ALSACONF, do not edit. ---
# --- ALSACONF version 1.0.25 ---
alias char-major-116 snd
alias char-major-14 soundcore
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss
alias snd-card-0 snd-hda-intel
alias sound-slot-0 snd-hda-intel
# --- END: Generated by ALSACONF, do not edit. ---
options snd-hda-intel model=auto

_________________
"Si un ave no rompe su huevo morirá antes de nacer.... Nosotros somos el ave y el mundo es nuestro huevo. POR LA REVOLUCION DEL MUNDO!!!!" Utena
Back to top
View user's profile Send private message
gringo
Advocate
Advocate


Joined: 27 Apr 2003
Posts: 3748

PostPosted: Fri Sep 28, 2012 9:16 am    Post subject: Reply with quote

solo un par de comentarios, no creo que te ayuden a solucionar el problema pero :

1- hay un ebuild disponible aqui -> http://git.flokli.de/flokli-overlay/plain/media-sound/hda-verb
2- en la web del Tikashi Iwai ( desarollador de alsa) se ve que la última versión de este software data del 2010.
3- alsaconf creo que está obsoleto. Desde luego las entradas -oss son irrelevantes a menos que vayas a usar oss o la emulación.

una prueba que puedes hacer :

cat /proc/asound/card0/codec#* | grep Codec

eso te sacará al menos una entrada, te vas a http://www.kernel.org/doc/Documentation/sound/alsa/HD-Audio-Models.txt y miras ahi si aparece como soportado.
Si aparece como soportado creo que lo del hwdep sobra y el único problema que tienes es un problema de configuración de alsa.

No usas nada como pulseaudio o similar, no ?

saluetes
Back to top
View user's profile Send private message
paynalton
Tux's lil' helper
Tux's lil' helper


Joined: 24 Jun 2006
Posts: 106
Location: Mexico

PostPosted: Fri Oct 05, 2012 2:01 pm    Post subject: Reply with quote

mmm, he probado ya varios modelos de la lista que coinciden con alc889 pero nada.

El ebuild para hda-verb creo que es para la arquitectura amd64...

no, no uso pulseaudio ni nada parecido, usando mpg123 o aplay da los mismos resultados...

mmmm, que podría hacer?


agrego la salida de amixer:

Code:
amixer
Simple mixer control 'Master',0
  Capabilities: pvolume pvolume-joined pswitch pswitch-joined penum
  Playback channels: Mono
  Limits: Playback 0 - 64
  Mono: Playback 64 [100%] [0.00dB] [on]
Simple mixer control 'Headphone',0
  Capabilities: pvolume pswitch penum
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 64
  Mono:
  Front Left: Playback 62 [97%] [0.00dB] [on]
  Front Right: Playback 62 [97%] [0.00dB] [on]
Simple mixer control 'Speaker',0
  Capabilities: pvolume pswitch penum
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 64
  Mono:
  Front Left: Playback 62 [97%] [0.00dB] [on]
  Front Right: Playback 62 [97%] [0.00dB] [on]
Simple mixer control 'PCM',0
  Capabilities: pvolume penum
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 255
  Mono:
  Front Left: Playback 254 [100%] [0.20dB]
  Front Right: Playback 254 [100%] [0.20dB]
Simple mixer control 'Surround',0
  Capabilities: pvolume pswitch penum
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 64
  Mono:
  Front Left: Playback 62 [97%] [0.00dB] [on]
  Front Right: Playback 62 [97%] [0.00dB] [on]
Simple mixer control 'Center',0
  Capabilities: pvolume pvolume-joined pswitch pswitch-joined penum
  Playback channels: Mono
  Limits: Playback 0 - 64
  Mono: Playback 62 [97%] [0.00dB] [on]
Simple mixer control 'LFE',0
  Capabilities: pvolume pvolume-joined pswitch pswitch-joined penum
  Playback channels: Mono
  Limits: Playback 0 - 64
  Mono: Playback 62 [97%] [0.00dB] [on]
Simple mixer control 'Line',0
  Capabilities: pvolume pswitch penum
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Mono:
  Front Left: Playback 23 [74%] [0.00dB] [on]
  Front Right: Playback 23 [74%] [0.00dB] [on]
Simple mixer control 'Mic',0
  Capabilities: pvolume pswitch penum
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Mono:
  Front Left: Playback 31 [100%] [12.00dB] [on]
  Front Right: Playback 31 [100%] [12.00dB] [on]
Simple mixer control 'Mic Boost',0
  Capabilities: volume penum
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: 0 - 3
  Front Left: 3 [100%] [30.00dB]
  Front Right: 3 [100%] [30.00dB]
Simple mixer control 'IEC958',0
  Capabilities: pswitch pswitch-joined penum
  Playback channels: Mono
  Mono: Playback [on]
Simple mixer control 'IEC958 Default PCM',0
  Capabilities: pswitch pswitch-joined penum
  Playback channels: Mono
  Mono: Playback [on]
Simple mixer control 'Beep',0
  Capabilities: pvolume pswitch penum
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Mono:
  Front Left: Playback 26 [84%] [4.50dB] [on]
  Front Right: Playback 26 [84%] [4.50dB] [on]
Simple mixer control 'Capture',0
  Capabilities: cvolume cswitch penum
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 46
  Front Left: Capture 45 [98%] [29.00dB] [on]
  Front Right: Capture 45 [98%] [29.00dB] [on]
Simple mixer control 'Auto-Mute Mode',0
  Capabilities: enum
  Items: 'Disabled' 'Enabled'
  Item0: 'Disabled'
Simple mixer control 'Channel Mode',0
  Capabilities: enum
  Items: '2ch' '4ch' '6ch'
  Item0: '6ch'
Simple mixer control 'Digital',0
  Capabilities: cvolume penum
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 120
  Front Left: Capture 90 [75%] [15.00dB]
  Front Right: Capture 90 [75%] [15.00dB]
Simple mixer control 'Input Source',0
  Capabilities: cenum
  Items: 'Internal Mic' 'Mic' 'Line'
  Item0: 'Mic'

_________________
"Si un ave no rompe su huevo morirá antes de nacer.... Nosotros somos el ave y el mundo es nuestro huevo. POR LA REVOLUCION DEL MUNDO!!!!" Utena
Back to top
View user's profile Send private message
quilosaq
l33t
l33t


Joined: 22 Dec 2009
Posts: 872

PostPosted: Fri Oct 05, 2012 10:29 pm    Post subject: Reply with quote

Mira qué dice
Code:
alsa-info
Back to top
View user's profile Send private message
paynalton
Tux's lil' helper
Tux's lil' helper


Joined: 24 Jun 2006
Posts: 106
Location: Mexico

PostPosted: Fri Oct 05, 2012 10:42 pm    Post subject: Reply with quote

mandó mucha info, la he puesto aca:

http://pastebin.ca/2240071
_________________
"Si un ave no rompe su huevo morirá antes de nacer.... Nosotros somos el ave y el mundo es nuestro huevo. POR LA REVOLUCION DEL MUNDO!!!!" Utena
Back to top
View user's profile Send private message
quilosaq
l33t
l33t


Joined: 22 Dec 2009
Posts: 872

PostPosted: Fri Oct 05, 2012 11:44 pm    Post subject: Reply with quote

paynalton wrote:
...no uso pulseaudio ni nada parecido..

Según la salida de alsa-info si que usas pulseaudio. Comprueba que tu usuario está en el grupo audio.
Back to top
View user's profile Send private message
paynalton
Tux's lil' helper
Tux's lil' helper


Joined: 24 Jun 2006
Posts: 106
Location: Mexico

PostPosted: Fri Oct 05, 2012 11:46 pm    Post subject: Reply with quote

Code:

paynalton@carlos ~ $ groups
wheel audio video games apache vboxusers kvm paynalton vmnet


mmm, puede que sea un problema con pulse audio entonces??? voy a buscarle por alli.
_________________
"Si un ave no rompe su huevo morirá antes de nacer.... Nosotros somos el ave y el mundo es nuestro huevo. POR LA REVOLUCION DEL MUNDO!!!!" Utena
Back to top
View user's profile Send private message
quilosaq
l33t
l33t


Joined: 22 Dec 2009
Posts: 872

PostPosted: Sat Oct 06, 2012 12:06 am    Post subject: Reply with quote

Puedes mirar en la wiki de gentoo (en inglés):
http://en.gentoo-wiki.com/wiki/PulseAudio
Back to top
View user's profile Send private message
Arctic
Apprentice
Apprentice


Joined: 04 Jul 2011
Posts: 178

PostPosted: Sat Oct 13, 2012 11:18 pm    Post subject: Reply with quote

Pulseaudio provoca mas problemas que los que soluciona, esto ya comienza a ser veridico ,que escritorio estas utilizando ??????

Salu2
_________________
ln -s /user/artic /user/arctic
Back to top
View user's profile Send private message
paynalton
Tux's lil' helper
Tux's lil' helper


Joined: 24 Jun 2006
Posts: 106
Location: Mexico

PostPosted: Mon Oct 15, 2012 2:59 pm    Post subject: Reply with quote

pues no, segun esto pulse audio está trabajando correctamente y detecta bien la tarjeta de sonido pero no hay cambio alguno.... si acaso ahora tengo un extraño ruido de fondo en los audífonos.


Para eliminar pulseaudio basta con quitar el useflag y vorver a emerger los paquetes que lo implementen???
_________________
"Si un ave no rompe su huevo morirá antes de nacer.... Nosotros somos el ave y el mundo es nuestro huevo. POR LA REVOLUCION DEL MUNDO!!!!" Utena
Back to top
View user's profile Send private message
Arctic
Apprentice
Apprentice


Joined: 04 Jul 2011
Posts: 178

PostPosted: Tue Oct 16, 2012 1:45 pm    Post subject: Reply with quote

paynalton wrote:
pues no, segun esto pulse audio está trabajando correctamente y detecta bien la tarjeta de sonido pero no hay cambio alguno.... si acaso ahora tengo un extraño ruido de fondo en los audífonos.


Para eliminar pulseaudio basta con quitar el useflag y vorver a emerger los paquetes que lo implementen???


Efectivamente , elimina la flag y recompila ,puedes usar gentoolkit para facilitar el proceso.

Pulseaudio da muchos problemas con fuentes DTS hasta hace muy poco ni se podian reproducir frecuancias muy altas, en algunos reproductores provoca Lag por no hablar de que a mucha gente la configuracion inicial le provoca mutes en el mezclador, la idea es buena pero aun le queda camino que recorrer.

Salu2
_________________
ln -s /user/artic /user/arctic
Back to top
View user's profile Send private message
paynalton
Tux's lil' helper
Tux's lil' helper


Joined: 24 Jun 2006
Posts: 106
Location: Mexico

PostPosted: Wed Oct 17, 2012 9:36 pm    Post subject: Reply with quote

Bueno, ya desinstale pulseaudio por completo, incluyendo el server y pavucontrol.

cambie el valor de modprobe.d/alsa al valor "auto" y corride revdep-rebuild

El problema continua casi igual:

Se ha ido ese ruido extraño.

Cuando desconecto los audífonos KDE arroja el siguiente mensaje:

Quote:
El dispositivo reproductor de audio HDA Intel, ALC889 Digital (IEC958 (S/PDIF) Digital Audio Output) no funciona.
Se recurre a HDA Intel (ALC889 Analog)

_________________
"Si un ave no rompe su huevo morirá antes de nacer.... Nosotros somos el ave y el mundo es nuestro huevo. POR LA REVOLUCION DEL MUNDO!!!!" Utena
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Spanish All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum