Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
sys-kernel/geek-sources-3.5.3
View unanswered posts
View posts from last 24 hours

Goto page 1, 2, 3, 4, 5, 6, 7, 8, 9, 10  Next  
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
init_6
Apprentice
Apprentice


Joined: 22 Jun 2008
Posts: 166

PostPosted: Fri Sep 07, 2012 3:10 pm    Post subject: sys-kernel/geek-sources-3.5.3 Reply with quote

Big Fat Warning
USE AT YOUR OWN RISK.


At the moment sys-kernel/geek-sources-3.5.3 supports:
(USE flags some feature)

  • aufs AnotherUnionFS url
  • bfq Budget Fair Queueing Budget I/O Scheduler url
  • bld Alternate CPU load distribution technique for Linux kernel scheduler url
  • branding CONFIG_FONT_ISO_LATIN_1_8x16 CONFIG_LOGO_LARRY_CLUT224
  • ck Con Kolivas' high performance patchset url
  • deblob Remove binary blobs from kernel sources to provide libre license compliance url
  • fbcondecor Spock's fbsplash patch url
  • fedora Fedora patches url patch list
  • grsecurity grsecurity patches url url patch list
  • ice TuxOnIce patches url
  • mageia Mandriva/Mageia patches url patch list
  • reiser4 Reiser 4 url
  • rt Ingo Molnar's realtime preempt patches url
  • suse OpenSuSE patches url patch list
  • uksm Ultra Kernel Samepage Merging patches url
  • vserver VServer patches url
  • zfs ZFS patches url


And all this you can use individually or together in any combination. But you must remember that:
Uncle Ben wrote:
Remember, with great power, comes great responsibility.


And you need to know that any conflicting patch in sys-kernel/geek-sources are automatically skipped. And there are no any checks for conflicting patches/USE flags in sys-kernel/geek-sources.

sys-kernel/geek-sources are available in the overlay init6

Code:
layman -a init6


Each version of the geek-sources I'm testing and using with the use USE flags:
Code:
>  emerge sys-kernel/geek-sources -pv

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] sys-kernel/geek-sources-3.5.3::init6  USE="aufs bfq bld branding ck deblob fedora ice mageia suse uksm -fbcondecor -grsecurity -reiser4 -rt -vserver -zfs" 0 kB

Total: 1 package (1 reinstall), Size of downloads: 0 kB


I build all the kernels with install_kernel and use it with initramfs (look branches).

So
Code:
> uname -a
Linux nemesis 3.5.3-geek-gnu #2 SMP Thu Sep 6 12:34:49 EEST 2012 x86_64 Intel(R) Pentium(R) Dual CPU T3200 @ 2.00GHz GenuineIntel GNU/Linux


Any help, patches are welcome. Live long and prosper.
Back to top
View user's profile Send private message
Gordex
n00b
n00b


Joined: 10 Jul 2008
Posts: 19

PostPosted: Fri Sep 14, 2012 5:58 pm    Post subject: Reply with quote

tried it.. works awesome for me.. thanks for your work :)
Back to top
View user's profile Send private message
init_6
Apprentice
Apprentice


Joined: 22 Jun 2008
Posts: 166

PostPosted: Mon Sep 17, 2012 10:19 am    Post subject: sys-kernel/geek-sources-3.5.4 Reply with quote

sys-kernel/geek-sources-3.5.3 -> sys-kernel/geek-sources-3.5.4 for now bump only kernel (patch-3.5.4.xz), mageia and vserver all other from 3.5.3
Back to top
View user's profile Send private message
khayyam
Advocate
Advocate


Joined: 07 Jun 2012
Posts: 2173

PostPosted: Mon Sep 17, 2012 3:58 pm    Post subject: Reply with quote

init6 ...

both 3.5.3 and now 3.5.4 have issues with the manifest for deblob-check.

best ... khay
Back to top
View user's profile Send private message
init_6
Apprentice
Apprentice


Joined: 22 Jun 2008
Posts: 166

PostPosted: Mon Sep 17, 2012 6:26 pm    Post subject: Reply with quote

khayyam wrote:
init6 ...

both 3.5.3 and now 3.5.4 have issues with the manifest for deblob-check.

best ... khay


Thanks for the report. Fixed. In these cases use generate_manifest

How much has been done and what remains to be… So scripts deblob * need to download again because they can vary even within the same version. Still need to fix reading from a file in the function kernel-geek_ApplyPatch… there is terribly realized
Back to top
View user's profile Send private message
haven
Tux's lil' helper
Tux's lil' helper


Joined: 19 Nov 2003
Posts: 141
Location: Belfast, Uk

PostPosted: Tue Sep 18, 2012 10:35 am    Post subject: Reply with quote

Real time patch needs updating to:

rt_ver="3.4.11-rt19"

Patches fine without errors.
Back to top
View user's profile Send private message
bingyuan
n00b
n00b


Joined: 20 Feb 2011
Posts: 13

PostPosted: Fri Sep 21, 2012 4:38 pm    Post subject: Reply with quote

reiser4 patch for Linux 3.5.3 is here: http://sourceforge.net/projects/reiser4/files/reiser4-for-linux-3.x/
please merge it into the newest geek-sources
Back to top
View user's profile Send private message
init_6
Apprentice
Apprentice


Joined: 22 Jun 2008
Posts: 166

PostPosted: Sat Sep 22, 2012 7:44 am    Post subject: Reply with quote

haven wrote:
Real time patch needs updating to:

rt_ver="3.4.11-rt19"

Patches fine without errors.

Done
Back to top
View user's profile Send private message
init_6
Apprentice
Apprentice


Joined: 22 Jun 2008
Posts: 166

PostPosted: Sat Sep 22, 2012 7:47 am    Post subject: Reply with quote

bingyuan wrote:
reiser4 patch for Linux 3.5.3 is here: http://sourceforge.net/projects/reiser4/files/reiser4-for-linux-3.x/
please merge it into the newest geek-sources


He is already there. :wink:
Code:
USE="reiser4" emerge =sys-kernel/geek-sources-3.5.4
Back to top
View user's profile Send private message
bingyuan
n00b
n00b


Joined: 20 Feb 2011
Posts: 13

PostPosted: Sun Sep 23, 2012 3:50 am    Post subject: Reply with quote

init_6 wrote:
bingyuan wrote:
reiser4 patch for Linux 3.5.3 is here: http://sourceforge.net/projects/reiser4/files/reiser4-for-linux-3.x/
please merge it into the newest geek-sources


He is already there. :wink:
Code:
USE="reiser4" emerge =sys-kernel/geek-sources-3.5.4


Quote:
* Reiser4 - http://sourceforge.net/projects/reiser4
* Applying reiser4-for-3.5.4.patch.gz ...
* Patch /dev/shm/portage/sys-kernel/geek-sources-3.5.4/distdir/reiser4-for-3.5.4.patch.gz does not exist.


There is not reiser4-for-3.5.4.patch.gz, only reiser4-for-3.5.3.patch.gz.
Back to top
View user's profile Send private message
init_6
Apprentice
Apprentice


Joined: 22 Jun 2008
Posts: 166

PostPosted: Sun Sep 23, 2012 6:37 am    Post subject: Reply with quote

bingyuan wrote:
Quote:
* Reiser4 - http://sourceforge.net/projects/reiser4
* Applying reiser4-for-3.5.4.patch.gz ...
* Patch /dev/shm/portage/sys-kernel/geek-sources-3.5.4/distdir/reiser4-for-3.5.4.patch.gz does not exist.


There is not reiser4-for-3.5.4.patch.gz, only reiser4-for-3.5.3.patch.gz.


done

Code:
 USE="-aufs -bfq -bld -branding -ck -deblob -fedora -ice -mageia -suse -uksm -fbcondecor -grsecurity reiser4 -rt -vserver -zfs" emerge -1 =sys-kernel/geek-sources-3.5.4

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] sys-kernel/geek-sources-3.5.4::init6  USE="reiser4* -aufs* -bfq* -bld* -branding* -ck* -deblob* -fbcondecor -fedora* -grsecurity -ice* -mageia* -rt -suse* -uksm* -vserver -zfs" 0 kB

Total: 1 package (1 reinstall), Size of downloads: 0 kB


>>> Verifying ebuild manifests

>>> Emerging (1 of 1) sys-kernel/geek-sources-3.5.4 from init6
 * linux-3.5.tar.xz SHA256 SHA512 WHIRLPOOL size ;-) ...                                                               [ ok ]
 * patch-3.5.4.xz SHA256 SHA512 WHIRLPOOL size ;-) ...                                                                 [ ok ]
 * reiser4-for-3.5.3.patch.gz SHA256 SHA512 WHIRLPOOL size ;-) ...                                                     [ ok ]
>>> Unpacking source...
 * Extract the sources ...                                                                                             [ ok ]

 * Update to latest upstream ...
 * Applying patch-3.5.4.xz ...                                                                                         [ ok ]
>>> Source unpacked in /var/tmp/portage/sys-kernel/geek-sources-3.5.4/work
>>> Preparing source in /var/tmp/portage/sys-kernel/geek-sources-3.5.4/work/linux-3.5.4-geek ...
 * QA Notice: The 'hasq' function is deprecated (replaced by 'has')
 * QA Notice: USE Flag 'imq' not in IUSE for sys-kernel/geek-sources-3.5.4

 * Reiser4 - http://sourceforge.net/projects/reiser4
 * Applying reiser4-for-3.5.3.patch.gz ...                                                                             [ ok ]
 * QA Notice: USE Flag 'pardus' not in IUSE for sys-kernel/geek-sources-3.5.4
 * QA Notice: USE Flag 'pld' not in IUSE for sys-kernel/geek-sources-3.5.4

 * Oops: ACPI: EC: input buffer is not empty, aborting transaction - 2.6.32 regression https://bugzilla.kernel.org/show_bug.cgi?id=14733#c41
 * Applying acpi-ec-add-delay-before-write.patch ...                                                                   [ ok ]

 * Oops: lpc_ich: Resource conflict(s) found affecting iTCO_wdt https://bugzilla.kernel.org/show_bug.cgi?id=44991
 * Applying lpc_ich_3.5.1.patch ...                                                                                    [ ok ]

 * Live long and prosper.

 * Set extraversion in Makefile
 * Copy current config from /proc
 * Kernel config file already exist.
 * I will NOT overwrite that.
 * Cleanup backups after patching
>>> Source prepared.
>>> Configuring source in /var/tmp/portage/sys-kernel/geek-sources-3.5.4/work/linux-3.5.4-geek ...
>>> Source configured.
>>> Compiling source in /var/tmp/portage/sys-kernel/geek-sources-3.5.4/work/linux-3.5.4-geek ...
>>> Source compiled.
>>> Test phase [not enabled]: sys-kernel/geek-sources-3.5.4

>>> Install geek-sources-3.5.4 into /var/tmp/portage/sys-kernel/geek-sources-3.5.4/image/ category sys-kernel
>>> Copying sources ...
>>> Completed installing geek-sources-3.5.4 into /var/tmp/portage/sys-kernel/geek-sources-3.5.4/image/
Back to top
View user's profile Send private message
Gibbo_07
n00b
n00b


Joined: 15 Nov 2009
Posts: 29
Location: Brisbane, AU

PostPosted: Tue Oct 09, 2012 8:32 am    Post subject: Reply with quote

Hi init,

This project interests me for personal use; since the zen project appears to have been shelved.

Unfortunately I can't build the deps for geek-sources, apparently due to my current kernel being too new?

Code:

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N     ] sys-kernel/spl-0.6.0_rc11  USE="-custom-cflags -debug" 0 kB
[ebuild  N     ] sys-fs/zfs-kmod-0.6.0_rc11  USE="rootfs -custom-cflags -debug" 0 kB
[ebuild  N     ] sys-fs/zfs-0.6.0_rc11  USE="rootfs -custom-cflags (-kernel-builtin) -static-libs -test-suite" 0 kB
[ebuild  N     ] sys-kernel/geek-sources-3.5.5::init6  USE="bfq bld branding reiser4 zfs -aufs -deblob -fbcondecor -fedora -grsecurity -ice -mageia -rt -suse -uksm" 54,166 kB

Total: 4 packages (4 new), Size of downloads: 54,166 kB

Would you like to merge these packages? [Yes/No] y

>>> Verifying ebuild manifests

>>> Starting parallel fetch

>>> Emerging (1 of 4) sys-kernel/spl-0.6.0_rc11
 * spl-0.6.0-rc11.tar.gz SHA256 SHA512 WHIRLPOOL size ;-) ...                                                                                                                                                 [ ok ]
 * Determining the location of the kernel source code
 * Found kernel source directory:
 *     /usr/src/linux
 * Found kernel object directory:
 *     /usr/src/linux-3.6.0-gentoo
 * Found sources for kernel version:
 *     3.6.0-gentoo
 * ERROR: sys-kernel/spl-0.6.0_rc11 failed (setup phase):
 *   Linux 3.5 is the latest supported version.
 *
 * Call stack:
 *               ebuild.sh, line  89:  Called pkg_setup
 *   spl-0.6.0_rc11.ebuild, line  48:  Called die
 * The specific snippet of code:
 *      [ ${PV} != "9999" ] && \
 *              { kernel_is le 3 5 || die "Linux 3.5 is the latest supported version."; }
 *
 * If you need support, post the output of `emerge --info '=sys-kernel/spl-0.6.0_rc11'`,
 * the complete build log and the output of `emerge -pqv '=sys-kernel/spl-0.6.0_rc11'`.
 * The complete build log is located at '/var/tmp/portage/sys-kernel/spl-0.6.0_rc11/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/sys-kernel/spl-0.6.0_rc11/temp/die.env'.
 * Working directory: '/var/tmp/portage/sys-kernel/spl-0.6.0_rc11'
 * S: '/var/tmp/portage/sys-kernel/spl-0.6.0_rc11/work/spl-0.6.0-rc11'


I tried merging an older gentoo-sources and linking to it, this gets me further in the build process but still not past spl. Im left to think I need to be _running_ an older kernel just to merge yours?

Any advice on this be appreciated, keen to try it out.

Cheers
Back to top
View user's profile Send private message
init_6
Apprentice
Apprentice


Joined: 22 Jun 2008
Posts: 166

PostPosted: Tue Oct 09, 2012 3:01 pm    Post subject: Reply with quote

Gibbo_07 wrote:
I tried merging an older gentoo-sources and linking to it, this gets me further in the build process but still not past spl. Im left to think I need to be _running_ an older kernel just to merge yours?

Any advice on this be appreciated, keen to try it out.

Cheers


ZFS is a pain for me. Interestingly of course but I do that with him just experimenting. But I'll try to fix it.
Back to top
View user's profile Send private message
init_6
Apprentice
Apprentice


Joined: 22 Jun 2008
Posts: 166

PostPosted: Tue Oct 09, 2012 6:28 pm    Post subject: Reply with quote

For full zfs support you need sys-kernel/spl+sys-fs/zfs+patch for kernel which is applied when using the USE flag zfs

Gibbo_07 wrote:

Code:

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N     ] sys-kernel/spl-0.6.0_rc11  USE="-custom-cflags -debug" 0 kB
[ebuild  N     ] sys-fs/zfs-kmod-0.6.0_rc11  USE="rootfs -custom-cflags -debug" 0 kB
[ebuild  N     ] sys-fs/zfs-0.6.0_rc11  USE="rootfs -custom-cflags (-kernel-builtin) -static-libs -test-suite" 0 kB
[ebuild  N     ] sys-kernel/geek-sources-3.5.5::init6  USE="bfq bld branding reiser4 zfs -aufs -deblob -fbcondecor -fedora -grsecurity -ice -mageia -rt -suse -uksm" 54,166 kB

Total: 4 packages (4 new), Size of downloads: 54,166 kB

Would you like to merge these packages? [Yes/No] y


next step install all dep.

Gibbo_07 wrote:

Code:

>>> Emerging (1 of 4) sys-kernel/spl-0.6.0_rc11
 * spl-0.6.0-rc11.tar.gz SHA256 SHA512 WHIRLPOOL size ;-) ...                                                                                                                                                 [ ok ]
 * Determining the location of the kernel source code
 * Found kernel source directory:
 *     /usr/src/linux
 * Found kernel object directory:
 *     /usr/src/linux-3.6.0-gentoo
 * Found sources for kernel version:
 *     3.6.0-gentoo
 * ERROR: sys-kernel/spl-0.6.0_rc11 failed (setup phase):
 *   Linux 3.5 is the latest supported version.


your current kernel source version 3.6.0 but
Quote:
Linux 3.5 is the latest supported version.
so? So Install the kernel source version 3.5. * and make oldconfig && make prepare
after checking the version in sys-kernel/spl should in theory pass. Do you even read what you wrote a portage?
Back to top
View user's profile Send private message
Gibbo_07
n00b
n00b


Joined: 15 Nov 2009
Posts: 29
Location: Brisbane, AU

PostPosted: Wed Oct 10, 2012 5:19 am    Post subject: Reply with quote

Quote:

your current kernel source version 3.6.0 but
Quote:
Linux 3.5 is the latest supported version.
so? So Install the kernel source version 3.5. * and make oldconfig && make prepare
after checking the version in sys-kernel/spl should in theory pass. Do you even read what you wrote a portage?


Well as I did mention, I merged an older kernel, prepared and linked to it (due to the latest supported version message you pointed out) however that doesn't get me much further into the build - as shown below.

Code:

checking kernel source directory... /usr/src/linux
checking kernel build directory... /usr/src/linux
checking kernel source version... 3.4.11-gentoo
checking kernel file name for module symbols... configure: error:
        *** Please make sure the kernel devel package for your distribution
        *** is installed.  If your building with a custom kernel make sure the
        *** kernel is configured, built, and the '--with-linux=PATH' configure
        *** option refers to the location of the kernel source.

!!! Please attach the following file when seeking support:
!!! /var/tmp/portage/sys-kernel/spl-0.6.0_rc11/work/spl-0.6.0-rc11/config.log
 * ERROR: sys-kernel/spl-0.6.0_rc11 failed (configure phase):
 *   econf failed
 *
 * Call stack:
 *          ebuild.sh, line   89:  Called src_configure
 *        environment, line 4422:  Called autotools-utils_src_configure
 *        environment, line  740:  Called econf '--docdir=/usr/share/doc/spl-0.6.0_rc11' '--bindir=/bin' '--sbindir=/sbin' '--with-config=all' '--with-linux=/usr/src/linux' '--with-linux-obj=/usr/src/linux' '--disable-debug'
 *   phase-helpers.sh, line  501:  Called die
 * The specific snippet of code:
 *                      die "econf failed"
 *
 * If you need support, post the output of `emerge --info '=sys-kernel/spl-0.6.0_rc11'`,
 * the complete build log and the output of `emerge -pqv '=sys-kernel/spl-0.6.0_rc11'`.
 * The complete build log is located at '/var/tmp/portage/sys-kernel/spl-0.6.0_rc11/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/sys-kernel/spl-0.6.0_rc11/temp/environment'.
 * Working directory: '/var/tmp/portage/sys-kernel/spl-0.6.0_rc11/work/spl-0.6.0-rc11'
 * S: '/var/tmp/portage/sys-kernel/spl-0.6.0_rc11/work/spl-0.6.0-rc11'


Yes ofcourse I read the output, the problem is that I find the need to revert to an old kernel (actually configuring, compiling and booting into it) before merging a new one kinda counter productive. I was hoping there was a way around it.

Anyway it woulda been nice to build with +zfs however it was more so for testing purposes than a mission critical inclusion. Currently merging geek-sources (-zfs), maybe one day I can get it to work.

Cheers for the reply, and the kernel.
Back to top
View user's profile Send private message
init_6
Apprentice
Apprentice


Joined: 22 Jun 2008
Posts: 166

PostPosted: Wed Oct 10, 2012 12:38 pm    Post subject: sys-kernel/geek-sources-3.6.1 Reply with quote

sys-kernel/geek-sources-3.6.1 now is unmask.
At the moment sys-kernel/geek-sources-3.6.1 supports:
(USE flags some feature)

bad news:
  • bld, ck, grsecurity, reiser4, rt, zfs It is currently not available under 3.6.*
  • Current mageia - 3.5.5/0.rc1.1.mga3

good news:
  • All missing patches will be added as they become available ;) stay tuned
  • From this time you are free to not only choices between different patches but also change the order of their patching in geek-sources.

Little bit about it. Let's say you want all patches have been applied in alphabetical order.
Code:
echo 'GEEKSOURCES_PATCHING_ORDER="aufs bfq bld branding ck fbcondecor fedora grsecurity ice imq mageia pardus pld reiser4 rt suse uksm vserver zfs"' > /etc/portage/kernel.conf

If the file /etc/portage/kernel.conf does not exist will use the default value of GEEKSOURCES_PATCHING_ORDER.
Default patching order is
Code:
GEEKSOURCES_PATCHING_ORDER="vserver bfq ck fbcondecor grsecurity ice imq reiser4 rt bld uksm aufs mageia fedora suse pardus pld zfs branding"


So
Code:
>emerge sys-kernel/geek-sources -pv

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] sys-kernel/geek-sources-3.6.1::init6  USE="aufs bfq branding fedora ice mageia suse -deblob -fbcondecor -vserver" 67,078 kB

Total: 1 package (1 reinstall), Size of downloads: 67,078 kB
> uname -a
Linux nemesis 3.6.1-geek #5 SMP Wed Oct 10 15:04:09 EEST 2012 x86_64 Intel(R) Pentium(R) Dual CPU T3200 @ 2.00GHz GenuineIntel GNU/Linux


Any help, patches are welcome.

PS:
I got couple warnings and oops on sys-kernel/geek-sources-3.6.1 with USE="deblob" and net-wireless/broadcom-sta-5.100.82.112-r2
Now with USE="-deblob", b43 works fine for me.
Back to top
View user's profile Send private message
haven
Tux's lil' helper
Tux's lil' helper


Joined: 19 Nov 2003
Posts: 141
Location: Belfast, Uk

PostPosted: Thu Oct 11, 2012 2:49 pm    Post subject: Reply with quote

So far 3.6.1-geek is running very smoothly on all my tests, thanks for the good work :)
Back to top
View user's profile Send private message
haven
Tux's lil' helper
Tux's lil' helper


Joined: 19 Nov 2003
Posts: 141
Location: Belfast, Uk

PostPosted: Thu Oct 11, 2012 7:31 pm    Post subject: Reply with quote

Spoke too soon, hit a zram allocation issue (its a generic issue with 3.6.1 so not due to anything in the geek-sources). May be worth throwing this patch into the mix as well until it makes it upstream:

http://code.google.com/p/compcache/issues/detail?id=102
Back to top
View user's profile Send private message
init_6
Apprentice
Apprentice


Joined: 22 Jun 2008
Posts: 166

PostPosted: Fri Oct 12, 2012 7:32 am    Post subject: Reply with quote

haven wrote:
Spoke too soon, hit a zram allocation issue (its a generic issue with 3.6.1 so not due to anything in the geek-sources). May be worth throwing this patch into the mix as well until it makes it upstream:

http://code.google.com/p/compcache/issues/detail?id=102


Done.
Back to top
View user's profile Send private message
init_6
Apprentice
Apprentice


Joined: 22 Jun 2008
Posts: 166

PostPosted: Fri Oct 12, 2012 12:53 pm    Post subject: Reply with quote

sys-kernel/geek-sources-3.6.1 now with: grsecurity patch list, rt url
vserver and fbcondecor look bad.
Back to top
View user's profile Send private message
LiamOS
n00b
n00b


Joined: 06 Jun 2012
Posts: 56
Location: Kerry/Dublin, Ireland

PostPosted: Fri Oct 12, 2012 2:41 pm    Post subject: Reply with quote

Compiling now. :D
_________________
CFLAGS=" -O999999"
Back to top
View user's profile Send private message
init_6
Apprentice
Apprentice


Joined: 22 Jun 2008
Posts: 166

PostPosted: Sat Oct 13, 2012 8:49 am    Post subject: Reply with quote

Bump sys-kernel/geek-sources-3.6.2 + uksm url
Back to top
View user's profile Send private message
LiamOS
n00b
n00b


Joined: 06 Jun 2012
Posts: 56
Location: Kerry/Dublin, Ireland

PostPosted: Sun Oct 14, 2012 4:45 pm    Post subject: Reply with quote

If it's trivial to do, would it be possible to get a USE flag for BFS?
EDIT: Just git pulled...I see a ck use flag... You may be ahead of me
_________________
CFLAGS=" -O999999"
Back to top
View user's profile Send private message
PM17E5
Apprentice
Apprentice


Joined: 10 Feb 2009
Posts: 230

PostPosted: Sun Oct 14, 2012 10:20 pm    Post subject: Reply with quote

I've decided to check this out and I'm curious why it's skipping the rt patch?

Code:
 * Budget Fair Queueing Budget I/O Scheduler - http://algo.ing.unimo.it/people/paolo/disk_sched/
 * Applying 0001-block-cgroups-kconfig-build-bits-for-BFQ-v5-3.6.patch ...                                                                                                                     [ ok ]
 * Applying 0002-block-introduce-the-BFQ-v5-I-O-sched-for-3.6.patch ...                                                                                                                        [ ok ]

 * Con Kolivas high performance patchset - http://users.on.net/~ckolivas/kernel
 * Applying patch-3.6-ck1.bz2 ...                                                                                                                                                              [ ok ]

 * Ingo Molnar's realtime preempt patches - http://www.kernel.org/pub/linux/kernel/projects/rt
 * Applying patch-3.6.1-rt1.patch.xz ...
 * Skipping patch --> patch-3.6.1-rt1.patch.xz                                                                                                                                                 [ ok ]

 * Oops: ACPI: EC: input buffer is not empty, aborting transaction - 2.6.32 regression https://bugzilla.kernel.org/show_bug.cgi?id=14733#c41
 * Applying acpi-ec-add-delay-before-write.patch ...                                                                                                                                           [ ok ]

 * gpio-ich: Share ownership of GPIO groups http://git.kernel.org/?p=linux/kernel/git/torvalds/linux.git;a=patch;h=4f600ada70beeb1dfe08e11e871bf31015aa0a3d
 * Applying gpio-ich_share_ownership_of_GPIO_groups_3.6.patch ...                                                                                                                              [ ok ]

 * zram pagealloc fix http://code.google.com/p/compcache/issues/detail?id=102
 * Applying zram_pagealloc_fix.patch ...
Back to top
View user's profile Send private message
init_6
Apprentice
Apprentice


Joined: 22 Jun 2008
Posts: 166

PostPosted: Mon Oct 15, 2012 6:03 am    Post subject: Reply with quote

PM17E5 wrote:
I've decided to check this out and I'm curious why it's skipping the rt patch?


Turn off all the USE flags except "rt". Or put rt in first place in the variable GEEKSOURCES_PATCHING_ORDER:

Code:
echo 'GEEKSOURCES_PATCHING_ORDER="rt aufs bfq bld branding ck fbcondecor fedora grsecurity ice imq mageia pardus pld reiser4 suse uksm vserver zfs"' > /etc/portage/kernel.conf


In general, the answer in the first message

Quote:
And you need to know that any conflicting patch in sys-kernel/geek-sources are automatically skipped. And there are no any checks for conflicting patches/USE flags in sys-kernel/geek-sources.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page 1, 2, 3, 4, 5, 6, 7, 8, 9, 10  Next
Page 1 of 10

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum