Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Troubles with E-17
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
rpil
Apprentice
Apprentice


Joined: 23 May 2008
Posts: 288

PostPosted: Sat Sep 22, 2012 10:15 pm    Post subject: [SOLVED] Troubles with E-17 Reply with quote

I try to install E-17. I followed the instructions from Gentoo wiki, but I have some issues.
This was the result of eix-sync:
Code:
# eix-update
Reading Portage settings ..
Building database (/var/cache/eix/portage.eix) ..
[0] "gentoo" /usr/portage/ (cache: metadata-md5-or-flat)
     Reading category 156|156 (100%) Finished             
[1] "enlightenment" /var/lib/layman/enlightenment (cache: parse|ebuild*#metadata-md5#metadata-flat#assign)
     Reading category  42|156 ( 26%): dev-python .. * ERROR: dev-python/python-e_dbus-9999 failed (depend phase):
 *   Invalid syntax of PYTHON_DEPEND: Unrecognized minimal version '2.4'
 *
 * Call stack:
 *                   ebuild.sh, line 541:  Called source '/var/lib/layman/enlightenment/dev-python/python-e_dbus/python-e_dbus-9999.ebuild'
 *   python-e_dbus-9999.ebuild, line  12:  Called inherit 'enlightenment'
 *                   ebuild.sh, line 283:  Called qa_source '/usr/portage//eclass/enlightenment.eclass'
 *                   ebuild.sh, line  72:  Called source '/usr/portage//eclass/enlightenment.eclass'
 *        enlightenment.eclass, line  68:  Called inherit 'python'
 *                   ebuild.sh, line 283:  Called qa_source '/usr/portage//eclass/python.eclass'
 *                   ebuild.sh, line  72:  Called source '/usr/portage//eclass/python.eclass'
 *               python.eclass, line 553:  Called _python_parse_dependencies_in_old_EAPIs 'PYTHON_DEPEND' 'DEPEND RDEPEND'
 *               python.eclass, line 346:  Called _python_parse_versions_range '2:2.4' 'PYTHON_DEPEND' '_PYTHON_ATOMS'
 *               python.eclass, line 267:  Called die
 * The specific snippet of code:
 *                              die "Invalid syntax of ${input_variable}: Unrecognized minimal version '${minimal_version}'"
 *
 * If you need support, post the output of `emerge --info '=dev-python/python-e_dbus-9999'`,
 * the complete build log and the output of `emerge -pqv '=dev-python/python-e_dbus-9999'`.
 * This ebuild is from an overlay: '/var/lib/layman/enlightenment/'
 * Working directory: '/home/rpil'
 * S: '/python-e_dbus-9999'

Ebuild failed with status 1
     Reading category  42|156 ( 26%): dev-python ..
Could not properly execute /var/lib/layman/enlightenment/dev-python/python-e_dbus/python-e_dbus-9999.ebuild
     Reading category  42|156 ( 26%): dev-python .. * ERROR: dev-python/python-ecore-9999 failed (depend phase):
 *   Invalid syntax of PYTHON_DEPEND: Unrecognized minimal version '2.4'
 *
 * Call stack:
 *                  ebuild.sh, line 541:  Called source '/var/lib/layman/enlightenment/dev-python/python-ecore/python-ecore-9999.ebuild'
 *   python-ecore-9999.ebuild, line  13:  Called inherit 'enlightenment'
 *                  ebuild.sh, line 283:  Called qa_source '/usr/portage//eclass/enlightenment.eclass'
 *                  ebuild.sh, line  72:  Called source '/usr/portage//eclass/enlightenment.eclass'
 *       enlightenment.eclass, line  68:  Called inherit 'python'
 *                  ebuild.sh, line 283:  Called qa_source '/usr/portage//eclass/python.eclass'
 *                  ebuild.sh, line  72:  Called source '/usr/portage//eclass/python.eclass'
 *              python.eclass, line 553:  Called _python_parse_dependencies_in_old_EAPIs 'PYTHON_DEPEND' 'DEPEND RDEPEND'
 *              python.eclass, line 346:  Called _python_parse_versions_range '2:2.4' 'PYTHON_DEPEND' '_PYTHON_ATOMS'
 *              python.eclass, line 267:  Called die
 * The specific snippet of code:
 *                              die "Invalid syntax of ${input_variable}: Unrecognized minimal version '${minimal_version}'"
 *
 * If you need support, post the output of `emerge --info '=dev-python/python-ecore-9999'`,
 * the complete build log and the output of `emerge -pqv '=dev-python/python-ecore-9999'`.
 * This ebuild is from an overlay: '/var/lib/layman/enlightenment/'
 * Working directory: '/home/rpil'
 * S: '/python-ecore-9999'

Ebuild failed with status 1
     Reading category  42|156 ( 26%): dev-python ..
Could not properly execute /var/lib/layman/enlightenment/dev-python/python-ecore/python-ecore-9999.ebuild
     Reading category  42|156 ( 26%): dev-python .. * ERROR: dev-python/python-edje-9999 failed (depend phase):
 *   Invalid syntax of PYTHON_DEPEND: Unrecognized minimal version '2.4'
 *
 * Call stack:
 *                 ebuild.sh, line 541:  Called source '/var/lib/layman/enlightenment/dev-python/python-edje/python-edje-9999.ebuild'
 *   python-edje-9999.ebuild, line  13:  Called inherit 'enlightenment'
 *                 ebuild.sh, line 283:  Called qa_source '/usr/portage//eclass/enlightenment.eclass'
 *                 ebuild.sh, line  72:  Called source '/usr/portage//eclass/enlightenment.eclass'
 *      enlightenment.eclass, line  68:  Called inherit 'python'
 *                 ebuild.sh, line 283:  Called qa_source '/usr/portage//eclass/python.eclass'
 *                 ebuild.sh, line  72:  Called source '/usr/portage//eclass/python.eclass'
 *             python.eclass, line 553:  Called _python_parse_dependencies_in_old_EAPIs 'PYTHON_DEPEND' 'DEPEND RDEPEND'
 *             python.eclass, line 346:  Called _python_parse_versions_range '2:2.4' 'PYTHON_DEPEND' '_PYTHON_ATOMS'
 *             python.eclass, line 267:  Called die
 * The specific snippet of code:
 *                              die "Invalid syntax of ${input_variable}: Unrecognized minimal version '${minimal_version}'"
 *
 * If you need support, post the output of `emerge --info '=dev-python/python-edje-9999'`,
 * the complete build log and the output of `emerge -pqv '=dev-python/python-edje-9999'`.
 * This ebuild is from an overlay: '/var/lib/layman/enlightenment/'
 * Working directory: '/home/rpil'
 * S: '/python-edje-9999'

Ebuild failed with status 1
     Reading category  42|156 ( 26%): dev-python ..
Could not properly execute /var/lib/layman/enlightenment/dev-python/python-edje/python-edje-9999.ebuild
     Reading category  42|156 ( 26%): dev-python .. * ERROR: dev-python/python-elementary-9999 failed (depend phase):
 *   Invalid syntax of PYTHON_DEPEND: Unrecognized minimal version '2.4'
 *
 * Call stack:
 *                       ebuild.sh, line 541:  Called source '/var/lib/layman/enlightenment/dev-python/python-elementary/python-elementary-9999.ebuild'
 *   python-elementary-9999.ebuild, line  13:  Called inherit 'enlightenment'
 *                       ebuild.sh, line 283:  Called qa_source '/usr/portage//eclass/enlightenment.eclass'
 *                       ebuild.sh, line  72:  Called source '/usr/portage//eclass/enlightenment.eclass'
 *            enlightenment.eclass, line  68:  Called inherit 'python'
 *                       ebuild.sh, line 283:  Called qa_source '/usr/portage//eclass/python.eclass'
 *                       ebuild.sh, line  72:  Called source '/usr/portage//eclass/python.eclass'
 *                   python.eclass, line 553:  Called _python_parse_dependencies_in_old_EAPIs 'PYTHON_DEPEND' 'DEPEND RDEPEND'
 *                   python.eclass, line 346:  Called _python_parse_versions_range '2:2.4' 'PYTHON_DEPEND' '_PYTHON_ATOMS'
 *                   python.eclass, line 267:  Called die
 * The specific snippet of code:
 *                              die "Invalid syntax of ${input_variable}: Unrecognized minimal version '${minimal_version}'"
 *
 * If you need support, post the output of `emerge --info '=dev-python/python-elementary-9999'`,
 * the complete build log and the output of `emerge -pqv '=dev-python/python-elementary-9999'`.
 * This ebuild is from an overlay: '/var/lib/layman/enlightenment/'
 * Working directory: '/home/rpil'
 * S: '/python-elementary-9999'

Ebuild failed with status 1
     Reading category  42|156 ( 26%): dev-python ..
Could not properly execute /var/lib/layman/enlightenment/dev-python/python-elementary/python-elementary-9999.ebuild
     Reading category  42|156 ( 26%): dev-python .. * ERROR: dev-python/python-evas-9999 failed (depend phase):
 *   Invalid syntax of PYTHON_DEPEND: Unrecognized minimal version '2.4'
 *
 * Call stack:
 *                 ebuild.sh, line 541:  Called source '/var/lib/layman/enlightenment/dev-python/python-evas/python-evas-9999.ebuild'
 *   python-evas-9999.ebuild, line  13:  Called inherit 'enlightenment'
 *                 ebuild.sh, line 283:  Called qa_source '/usr/portage//eclass/enlightenment.eclass'
 *                 ebuild.sh, line  72:  Called source '/usr/portage//eclass/enlightenment.eclass'
 *      enlightenment.eclass, line  68:  Called inherit 'python'
 *                 ebuild.sh, line 283:  Called qa_source '/usr/portage//eclass/python.eclass'
 *                 ebuild.sh, line  72:  Called source '/usr/portage//eclass/python.eclass'
 *             python.eclass, line 553:  Called _python_parse_dependencies_in_old_EAPIs 'PYTHON_DEPEND' 'DEPEND RDEPEND'
 *             python.eclass, line 346:  Called _python_parse_versions_range '2:2.4' 'PYTHON_DEPEND' '_PYTHON_ATOMS'
 *             python.eclass, line 267:  Called die
 * The specific snippet of code:
 *                              die "Invalid syntax of ${input_variable}: Unrecognized minimal version '${minimal_version}'"
 *
 * If you need support, post the output of `emerge --info '=dev-python/python-evas-9999'`,
 * the complete build log and the output of `emerge -pqv '=dev-python/python-evas-9999'`.
 * This ebuild is from an overlay: '/var/lib/layman/enlightenment/'
 * Working directory: '/home/rpil'
 * S: '/python-evas-9999'

Ebuild failed with status 1
     Reading category  42|156 ( 26%): dev-python ..
Could not properly execute /var/lib/layman/enlightenment/dev-python/python-evas/python-evas-9999.ebuild
     Reading category 149|156 ( 95%): x11-misc .. * ERROR: x11-misc/shellementary-9999 failed (depend phase):
 *   Invalid syntax of PYTHON_DEPEND: Unrecognized minimal version '2.4'
 *
 * Call stack:
 *                   ebuild.sh, line 541:  Called source '/var/lib/layman/enlightenment/x11-misc/shellementary/shellementary-9999.ebuild'
 *   shellementary-9999.ebuild, line  13:  Called inherit 'enlightenment'
 *                   ebuild.sh, line 283:  Called qa_source '/usr/portage//eclass/enlightenment.eclass'
 *                   ebuild.sh, line  72:  Called source '/usr/portage//eclass/enlightenment.eclass'
 *        enlightenment.eclass, line  68:  Called inherit 'python'
 *                   ebuild.sh, line 283:  Called qa_source '/usr/portage//eclass/python.eclass'
 *                   ebuild.sh, line  72:  Called source '/usr/portage//eclass/python.eclass'
 *               python.eclass, line 553:  Called _python_parse_dependencies_in_old_EAPIs 'PYTHON_DEPEND' 'DEPEND RDEPEND'
 *               python.eclass, line 346:  Called _python_parse_versions_range '2:2.4' 'PYTHON_DEPEND' '_PYTHON_ATOMS'
 *               python.eclass, line 267:  Called die
 * The specific snippet of code:
 *                              die "Invalid syntax of ${input_variable}: Unrecognized minimal version '${minimal_version}'"
 *
 * If you need support, post the output of `emerge --info '=x11-misc/shellementary-9999'`,
 * the complete build log and the output of `emerge -pqv '=x11-misc/shellementary-9999'`.
 * This ebuild is from an overlay: '/var/lib/layman/enlightenment/'
 * Working directory: '/home/rpil'
 * S: '/shellementary-9999'

Ebuild failed with status 1
     Reading category 149|156 ( 95%): x11-misc ..
Could not properly execute /var/lib/layman/enlightenment/x11-misc/shellementary/shellementary-9999.ebuild
     Reading category 156|156 (100%) Finished       
Applying masks ..
Calculating hash tables ..
Writing database file /var/cache/eix/portage.eix ..
Database contains 16196 packages in 156 categories.


I checked for the missing packages:
Code:
# eix dev-python/python-e_dbus
* dev-python/python-e_dbus [1]
     Available versions:  (**)9999 {{static-libs}}
     Description:         Python bindings for E_DBUS library

[1] "enlightenment" /var/lib/layman/enlightenment
# eix dev-python/python-ecore
* dev-python/python-ecore [1]
     Available versions:  (**)9999 {{X evas static-libs}}
     Description:         Python bindings for ecore

[1] "enlightenment" /var/lib/layman/enlightenment
# eix dev-python/python-edje
* dev-python/python-edje [1]
     Available versions:  (**)9999 {{static-libs}}
     Description:         Python bindings for edje

[1] "enlightenment" /var/lib/layman/enlightenment
# eix dev-python/python-elementary
* dev-python/python-elementary [1]
     Available versions:  (**)9999 {{static-libs}}
     Homepage:            http://www.enlightenment.org/
     Description:         Python bindings for elementary library

[1] "enlightenment" /var/lib/layman/enlightenment
# eix dev-python/python-evas
* dev-python/python-evas [1]
     Available versions:  (**)9999 {{static-libs}}
     Homepage:            http://www.enlightenment.org/
     Description:         Python bindings for EVAS library

[1] "enlightenment" /var/lib/layman/enlightenment
# eix x11-misc/shellementary
* x11-misc/shellementary [1]
     Available versions:  (**)9999 {{static-libs}}
     Description:         Tool to display Elementary dialogs from the command line and shell scripts


and for Entrance DM:
Code:
[1] "enlightenment" /var/lib/layman/enlightenment
# eix x11-misc/entrance
No matches found.


Also:
Code:
# eix esmart
No matches found.


Any ideas?


Last edited by rpil on Thu Oct 11, 2012 10:56 pm; edited 1 time in total
Back to top
View user's profile Send private message
Ant P.
Advocate
Advocate


Joined: 18 Apr 2009
Posts: 2363
Location: UK

PostPosted: Sun Sep 23, 2012 2:31 am    Post subject: Reply with quote

Yeah, the overlay has pretty broken code and there's some missing ebuilds. The error spam's even worse in paludis. You should be able to install the rest no problem though.
Back to top
View user's profile Send private message
rpil
Apprentice
Apprentice


Joined: 23 May 2008
Posts: 288

PostPosted: Sun Sep 23, 2012 3:57 pm    Post subject: Reply with quote

So, do you think that I can use Enlightenment without all these packages?
Please, tell me, how can I enter my E-17 session from Slim (I have a Fluxbox session as default).
Back to top
View user's profile Send private message
Ant P.
Advocate
Advocate


Joined: 18 Apr 2009
Posts: 2363
Location: UK

PostPosted: Sun Sep 23, 2012 4:10 pm    Post subject: Reply with quote

Use a .xinitrc containing `exec enlightenment_start`
Back to top
View user's profile Send private message
rpil
Apprentice
Apprentice


Joined: 23 May 2008
Posts: 288

PostPosted: Tue Oct 09, 2012 6:34 am    Post subject: Reply with quote

I have this message when I try to compile enlightenment-0.16.9999:
Code:
rmdir: failed to remove '/var/tmp/portage/x11-wm/enlightenment-0.16.9999/image//usr/share/doc/e16': No such file or directory
 * ERROR: x11-wm/enlightenment-0.16.9999 failed (install phase):
 *   (no error message)
 *
 * Call stack:
 *     ebuild.sh, line  85:  Called src_install
 *   environment, line 2860:  Called die
 * The specific snippet of code:
 *       rmdir "${D}"/usr/share/doc/e16 || die;
 *
 * If you need support, post the output of `emerge --info '=x11-wm/enlightenment-0.16.9999'`,
 * the complete build log and the output of `emerge -pqv '=x11-wm/enlightenment-0.16.9999'`.
 * The complete build log is located at '/var/tmp/portage/x11-wm/enlightenment-0.16.9999/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/x11-wm/enlightenment-0.16.9999/temp/environment'.
 * Working directory: '/var/tmp/portage/x11-wm/enlightenment-0.16.9999/work/e16/e'
 * S: '/var/tmp/portage/x11-wm/enlightenment-0.16.9999/work/e16/e'


This is the emerge -pqv '=x11-wm/enlightenment-0.16.9999':
Code:
# emerge -pqv '=x11-wm/enlightenment-0.16.9999'
[ebuild     UD] x11-wm/enlightenment-0.16.9999 [1.0.10] USE="dbus nls pango xinerama -doc -pulseaudio -xcomposite -xrandr"


"Failed to remove /var/tmp/portage/x11-wm/enlightenment-0.16.9999/image//usr/share/doc/e16?

/usr/share/ contains a folder named e16 but not inside /doc. There is no /doc.
What kind of message is this and why emerge fails?

I have Portage 2.1.11.9.
In Gentoo wiki says about "sets" folder and other things, which are only available with Portage edition 2.2 or greater. Do I have to unmask the latest Portage version, in order to have a normal compile and install of E17?

And last, but not least, if E17 emerges, E16 will be lost? I would like to have both on my machine.
Back to top
View user's profile Send private message
ppurka
Advocate
Advocate


Joined: 26 Dec 2004
Posts: 3205

PostPosted: Tue Oct 09, 2012 8:41 am    Post subject: Reply with quote

1. If you want to use the e17 WM, all you need is enlightenment-9999 and its dependencies. You don't even need any of the e_modules; in fact many of them are unstable and not recommended for use by upstream. Similarly, you don't need any of the python-* packages from the overlay.

2. If you want to use e16, then stick to using the released 1.0.x versions instead of the live version.

3. For using with slim you can add the file /etc/X11/Sessions/enlightenment (make sure it is executable)
Code:
/etc/X11/Sessions» cat enlightenment
#!/bin/sh
exec /usr/bin/enlightenment_start

Then, in slim provide the sessions variable with all the sessions you want from that directory /etc/X11/Sessions like so
Code:
sessions             enlightenment,Xsession
You can switch between different WMs in slim by pressing F1 before login.

4. You can have both e17 and e16 installed at the same time since they don't clash.
_________________
emerge --quiet redefined | E17 vids: I, II
Back to top
View user's profile Send private message
rpil
Apprentice
Apprentice


Joined: 23 May 2008
Posts: 288

PostPosted: Tue Oct 09, 2012 10:26 am    Post subject: Reply with quote

First of all, thanks fore the response, my friend.
I use gdm instead of slim, as it recognized from the first time both wm installed, which are fluxbox and e16.
How can I emerge this enlightenment-9999 with all its depencies?
Why does emerge enlightenment-0.16.9999 (is this the E17?) fails?
Do I must to pass to Portage 2.2 which is masked?
And, finally, what do you mean by:
Quote:
4. You can have both e17 and e16 installed at the same time since they don't clash.


Thanks in advance. :wink:
Back to top
View user's profile Send private message
ppurka
Advocate
Advocate


Joined: 26 Dec 2004
Posts: 3205

PostPosted: Tue Oct 09, 2012 12:57 pm    Post subject: Reply with quote

rpil wrote:
First of all, thanks fore the response, my friend.
I use gdm instead of slim, as it recognized from the first time both wm installed, which are fluxbox and e16.
How can I emerge this enlightenment-9999 with all its depencies?
You emerge it by
Code:
emerge -av "=enlightenment-9999"

Quote:
Why does emerge enlightenment-0.16.9999 (is this the E17?) fails?
Going by the slot it is in in portage (look at the output of "eix enlightenment"), it is e16 and not e17. That's why I asked you to emerge the 1.0.x version of e16 and not this version.
Quote:
Do I must to pass to Portage 2.2 which is masked?
2.2 is not needed.
Quote:
And, finally, what do you mean by:
Quote:
4. You can have both e17 and e16 installed at the same time since they don't clash.


Thanks in advance. :wink:
e16 is in slot 0 while e17 is in slot 0.17, so you can have both installed at the same time.
_________________
emerge --quiet redefined | E17 vids: I, II
Back to top
View user's profile Send private message
rpil
Apprentice
Apprentice


Joined: 23 May 2008
Posts: 288

PostPosted: Tue Oct 09, 2012 7:48 pm    Post subject: Reply with quote

And now, what?
Code:
# emerge -av "=enlightenment-9999"

These are the packages that would be merged, in order:

Calculating dependencies... done!

emerge: there are no ebuilds to satisfy "=enlightenment-9999".


:?
Back to top
View user's profile Send private message
ppurka
Advocate
Advocate


Joined: 26 Dec 2004
Posts: 3205

PostPosted: Tue Oct 09, 2012 10:33 pm    Post subject: Reply with quote

Don't know what kind of a system you have. It works here.
Code:

~» emerge -av "=enlightenment-9999"
This action requires superuser access...
Would you like to add --pretend to options? [Yes/No] y

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   *] x11-wm/enlightenment-9999::enlightenment  USE="e_modules_backlight e_modules_battery e_modules_clock e_modules_comp e_modules_conf-applications e_modules_conf-dialogs e_modules_conf-display e_modules_conf-edgebindings e_modules_conf-interaction e_modules_conf-intl e_modules_conf-keybindings e_modules_conf-menus e_modules_conf-paths e_modules_conf-performance e_modules_conf-randr e_modules_conf-shelves e_modules_conf-theme e_modules_conf-wallpaper2 e_modules_conf-window-manipulation e_modules_conf-window-remembers e_modules_cpufreq e_modules_dropshadow e_modules_everything e_modules_fileman e_modules_fileman-opinfo e_modules_gadman e_modules_ibar e_modules_ibox e_modules_illume2 e_modules_mixer
e_modules_msgbus e_modules_notification e_modules_pager e_modules_quickaccess e_modules_shot e_modules_start e_modules_syscon e_modules_systray e_modules_tasks
e_modules_temperature e_modules_tiling e_modules_winlist e_modules_wizard e_modules_xkbswitch nls pam spell udev -bluetooth -doc -e_modules_access -e_modules_connman -e_modules_ofono -e_modules_physics -exchange -static-libs -ukit" 0 kB

Total: 1 package (1 reinstall), Size of downloads: 0 kB
~» emerge -pv "=x11-wm/enlightenment-9999"

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   *] x11-wm/enlightenment-9999::enlightenment  USE="e_modules_backlight e_modules_battery e_modules_clock e_modules_comp e_modules_conf-applications e_modules_conf-dialogs e_modules_conf-display e_modules_conf-edgebindings e_modules_conf-interaction e_modules_conf-intl e_modules_conf-keybindings e_modules_conf-menus e_modules_conf-paths e_modules_conf-performance e_modules_conf-randr e_modules_conf-shelves e_modules_conf-theme e_modules_conf-wallpaper2 e_modules_conf-window-manipulation e_modules_conf-window-remembers e_modules_cpufreq e_modules_dropshadow e_modules_everything e_modules_fileman e_modules_fileman-opinfo e_modules_gadman e_modules_ibar e_modules_ibox e_modules_illume2 e_modules_mixer
e_modules_msgbus e_modules_notification e_modules_pager e_modules_quickaccess e_modules_shot e_modules_start e_modules_syscon e_modules_systray e_modules_tasks
e_modules_temperature e_modules_tiling e_modules_winlist e_modules_wizard e_modules_xkbswitch nls pam spell udev -bluetooth -doc -e_modules_access -e_modules_connman -e_modules_ofono -e_modules_physics -exchange -static-libs -ukit" 0 kB

Total: 1 package (1 reinstall), Size of downloads: 0 kB

_________________
emerge --quiet redefined | E17 vids: I, II
Back to top
View user's profile Send private message
rpil
Apprentice
Apprentice


Joined: 23 May 2008
Posts: 288

PostPosted: Tue Oct 09, 2012 10:46 pm    Post subject: Reply with quote

Is there some particular packages that I must emerge before e17?
There must be an explanation why my portage cannot build the package.
I have an AMD Athlon (tm) 64x2 Dual Core 4200+.
Back to top
View user's profile Send private message
rpil
Apprentice
Apprentice


Joined: 23 May 2008
Posts: 288

PostPosted: Wed Oct 10, 2012 6:10 am    Post subject: Reply with quote

Well, this is my emerge --info:
Code:
# emerge --info
Portage 2.1.11.9 (default/linux/x86/10.0/desktop, gcc-4.5.4, glibc-2.15-r2, 3.3.8-gentoo i686)
=================================================================
System uname: Linux-3.3.8-gentoo-i686-AMD_Athlon-tm-_Processor-with-gentoo-2.1
Timestamp of tree: Tue, 09 Oct 2012 06:45:01 +0000
app-shells/bash:          4.2_p37
dev-lang/python:          2.7.3-r2, 3.2.3
dev-util/cmake:           2.8.9
dev-util/pkgconfig:       0.27.1
sys-apps/baselayout:      2.1-r1
sys-apps/openrc:          0.9.8.4
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.11.6
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.5.4
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r3
sys-kernel/linux-headers: 3.1 (virtual/os-headers)
sys-libs/glibc:           2.15-r2
Repositories: gentoo
ACCEPT_KEYWORDS="x86"
ACCEPT_LICENSE="*"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=i686 -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -march=i686 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -march=i686 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles news parallel-fetch parse-eapi-ebuild-head protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -march=i686 -pipe"
GENTOO_MIRRORS="ftp://files.gentoo.gr ftp://ftp.ntua.gr/pub/linux/gentoo/"
LANG="C"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync.gr.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa berkdb bluetooth bmp branding bzip2 cairo cdda cdr cli consolekit cracklib crypt cups cxx dbus dri dts dvd dvdr emboss encode exif fam firefox flac fortran gdbm gif gnome gpm iconv imlib ipv6 jpeg jpg kde lcms ldap libnotify mad mng modules mp3 mp4 mpeg mudflap ncurses nls nptl ogg opengl openmp pam pango pcre pdf png policykit ppds pppd qt3support qt4 readline sdl session spell ssl startup-notification static-libs svg tcpd tiff truetype udev udisks unicode upower usb vorbis wxwidgets x264 x86 xcb xinerama xml xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" PHP_TARGETS="php5-3" PYTHON_TARGETS="python3_2 python2_7" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="radeon" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, LINGUAS, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON


And these are the -so far- moves that I've made:

Code:
# emerge layman
# layman -fa enlightenment
# layman -S


Created the folder /etc/portage/package.keywords where I putted the package.keywords.file and made:

Code:
# cd /etc/portage/package.keywords
# ln -s /var/lib/layman/enlightenment/scripts/package.keywords.livecvs enlightenment


I created a /etc/portage/package.use folder where I putted the enlightenment.use file with the following content:

Code:
dev-libs/e_dbus X
media-libs/evas X jpeg png svg xpm fontconfig
dev-libs/ecore X curl


And then:

Code:
# emerge subversion
# emerge -pv x11-wm/enlightenment
# emerge -av --keep-going x11-wm/enlightenment
# emerge -av eina eet evas ecore efreet embryo edje eeze e_dbus enlightenment


Also (despite Wiki says that this is only available for Portage 2.2):
Code:
mkdir /etc/portage/sets

where I created a file titled "enlightment-live" and added:
Code:
=dev-libs/eina-9999
=dev-libs/eet-9999
=media-libs/evas-9999
=dev-libs/ecore-9999
=dev-libs/embryo-9999
=media-libs/edje-9999
=dev-libs/efreet-9999
=dev-libs/e_dbus-9999
=dev-libs/eeze-9999
=x11-wm/enlightenment-9999


Code:
# layman -S
* Running... # /usr/bin/svn up /var/lib/layman/enlightenment
At revision 790.
*
* Success:
* ------
*
* Successfully synchronized overlay "enlightenment".



Is there something missing? Do I forgot something important? With all these moves, I 'm in E16. What is left to do, so I can emerge E17?
Back to top
View user's profile Send private message
rpil
Apprentice
Apprentice


Joined: 23 May 2008
Posts: 288

PostPosted: Wed Oct 10, 2012 8:59 am    Post subject: Reply with quote

I emerged git and added the niifaq overlay to layman:

Code:
# layman -o 'http://git.niifaq.ru/enlightenment-niifaq/plain/Documentation/layman/enlightenment-niifaq.xml' -f -k -a enlightenment-niifaq
* Running... # /usr/bin/git clone git://vcs.niifaq.ru/e17 /var/lib/layman/enlightenment-niifaq
Cloning into '/var/lib/layman/enlightenment-niifaq'...
remote: Counting objects: 10087, done.
remote: Compressing objects: 100% (6225/6225), done.
remote: Total 10087 (delta 5510), reused 6617 (delta 3249)
Receiving objects: 100% (10087/10087), 1.37 MiB | 1.03 MiB/s, done.
Resolving deltas: 100% (5510/5510), done.
* Successfully added overlay "enlightenment-niifaq".


I synced layman again:
Code:
 # layman -S
* Running... # /usr/bin/svn up /var/lib/layman/enlightenment
At revision 790.
* Running... # ( cd /var/lib/layman/enlightenment-niifaq  && /usr/bin/git pull )
Already up-to-date.
*
* Success:
* ------
*
* Successfully synchronized overlay "enlightenment".
* Successfully synchronized overlay "enlightenment-niifaq".
*
* Warnings:
* ------
*
* Overlay "enlightenment-niifaq" could not be found in the remote lists.
* Please check if it has been renamed and re-add if necessary.


I found a German site where there was a similar report, I added the following line in /etc/layman.layman.cfg:
Code:
http://git.niifaq.ru/enlightenment-niifaq/plain/Documentation/layman/enlightenment-niifaq.xml

but the message remains and also the "no ebuilds" message...
Help! :cry:
Back to top
View user's profile Send private message
ppurka
Advocate
Advocate


Joined: 26 Dec 2004
Posts: 3205

PostPosted: Wed Oct 10, 2012 9:40 am    Post subject: Reply with quote

What are the outputs of
Code:
ls -lR /var/lib/layman/enlightenment/x11-wm
grep -rHi enlightenment /etc/portage/*/* /etc/portage/*

Also, keep only one overlay, not both. You will run into problems otherwise.
_________________
emerge --quiet redefined | E17 vids: I, II
Back to top
View user's profile Send private message
rpil
Apprentice
Apprentice


Joined: 23 May 2008
Posts: 288

PostPosted: Wed Oct 10, 2012 10:03 am    Post subject: Reply with quote

Code:
# ls -lR /var/lib/layman/enlightenment/x11-wm
/var/lib/layman/enlightenment/x11-wm:
total 8
drwxr-xr-x 3 root root 4096 Oct  7 01:21 ecomp
drwxr-xr-x 4 root root 4096 Oct  7 01:21 enlightenment

/var/lib/layman/enlightenment/x11-wm/ecomp:
total 16
-rw-r--r-- 1 root root 318 Oct  7 01:21 ChangeLog
-rw-r--r-- 1 root root 931 Oct  7 01:21 Manifest
-rw-r--r-- 1 root root 582 Oct  7 01:21 ecomp-9999.ebuild
-rw-r--r-- 1 root root 316 Oct  7 01:21 metadata.xml

/var/lib/layman/enlightenment/x11-wm/enlightenment:
total 24
-rw-r--r-- 1 root root 2323 Oct  7 01:21 ChangeLog
-rw-r--r-- 1 root root 2235 Oct  7 01:21 Manifest
-rw-r--r-- 1 root root 2396 Oct  7 01:21 enlightenment-9999.ebuild
drwxr-xr-x 3 root root 4096 Oct  7 01:21 files
-rw-r--r-- 1 root root 4664 Oct  7 01:21 metadata.xml

/var/lib/layman/enlightenment/x11-wm/enlightenment/files:
total 8
-rw-r--r-- 1 root root 3056 Oct  7 01:21 gentoo-sysactions.conf
-rw-r--r-- 1 root root  474 Oct  7 01:21 quickstart.diff


and:
Code:
# grep -rHi enlightenment /etc/portage/*/* /etc/portage/*
/etc/portage/package.keywords/enlightenment:#   /var/lib/layman/enlightenment/scripts/package.keywords.livecvs \
/etc/portage/package.keywords/enlightenment:#   /etc/portage/package.keywords/enlightenment
/etc/portage/package.keywords/enlightenment:x11-wm/enlightenment * ~* **
/etc/portage/package.keywords/enlightenment-niifaq:=x11-wm/enlightenment-9999 **
/etc/portage/sets/enlightenment-live:=x11-wm/enlightenment-9999
/etc/portage/package.unmask:=x11-wm/enlightenment-9999
/etc/portage/sets/enlightenment-live:=x11-wm/enlightenment-9999


Which one overlay do you suggest me to keep? And how can I delete the other?
Back to top
View user's profile Send private message
ppurka
Advocate
Advocate


Joined: 26 Dec 2004
Posts: 3205

PostPosted: Wed Oct 10, 2012 11:57 am    Post subject: Reply with quote

Everything seems fine. I don't know what else to test. Maybe ask in #gentoo and some portage guru can help you.

As for the overlay, I personally use only enlightenment because it is maintained by both upstream e developer, and gentoo developer.
_________________
emerge --quiet redefined | E17 vids: I, II
Back to top
View user's profile Send private message
rpil
Apprentice
Apprentice


Joined: 23 May 2008
Posts: 288

PostPosted: Thu Oct 11, 2012 10:50 pm    Post subject: Reply with quote

Finally, I MADE IT!
I tried some actions and they worked! Don't know exactly which of all was the right, but the result is success!
First of all, I erased the niifaq overlay.

In my /etc/portage/make.conf:
I changed my ACCEPT_KEYWORDS from x86 to ~x86.
I added the line
Code:
source /var/lib/layman/make.conf


In /etc/portage/package.use/enlightenment.use, I added:
Code:
=x11-wm/enlightenment-9999


In /etc/portage.package.keywords/keywords.file:
Code:
x11-wm/enlightenment-9999::gentoo


I made:
Code:
layman -S
(there was an error about enlightenment-niifaq - somewhere he is hiding!)
AND:
Code:
# emerge -av enlightenment:0.17

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U *] dev-libs/eina-9999::enlightenment [1.7.0::gentoo] USE="mempool-chained mempool-pass-through nls static-libs (-altivec) -debug -default-mempool -doc -mempool-buddy -mempool-ememoa-fixed% -mempool-ememoa-unknown% -mempool-fixed-bitmap -mmx -sse -sse2 -test" 0 kB
[ebuild  N    *] dev-libs/eobj-9999::enlightenment  USE="nls static-libs -doc" 0 kB
[ebuild     U *] dev-libs/eet-9999::enlightenment [1.7.0::gentoo] USE="nls ssl static-libs -debug -doc -examples -gnutls -test" 0 kB
[ebuild     U *] dev-libs/embryo-9999::enlightenment [1.7.0::gentoo] USE="nls static-libs -doc" 0 kB
[ebuild     U *] media-libs/evas-9999::enlightenment [1.7.0::gentoo] USE="X bmp eet fontconfig gif ico jpeg nls opengl png ppm psd sdl%* static-libs svg threads tiff xcb xpm (-altivec) -bidi -directfb -doc -fbcon -gles -mmx -sse -sse3 -tga -wayland%" 0 kB
[ebuild     U *] dev-libs/ecore-9999::enlightenment [1.7.0::gentoo] USE="X curl evas inotify ipv6 nls opengl sdl ssl static-libs threads xcb xinerama -ares -directfb -doc -fbcon -glib -gnutls -test -tslib -xprint -xscreensaver" 0 kB
[ebuild  N    *] dev-libs/eio-9999::enlightenment  USE="nls static-libs threads -doc" 0 kB
[ebuild     U *] dev-libs/eeze-9999::enlightenment [1.7.0::gentoo] USE="nls static-libs -doc -utilities" 0 kB
[ebuild     U *] media-libs/edje-9999::enlightenment [1.7.0::gentoo] USE="cache nls static-libs -debug -doc -vim-syntax" 0 kB
[ebuild     U *] dev-libs/e_dbus-9999::enlightenment [1.7.0::gentoo] USE="bluetooth connman libnotify nls static-libs udev -doc -ofono -test-binaries" 0 kB
[ebuild     U *] dev-libs/efreet-9999::enlightenment [1.7.0::gentoo] USE="nls static-libs -doc" 0 kB
[ebuild  NS   *] x11-wm/enlightenment-9999::enlightenment [1.0.10::gentoo] USE="bluetooth e_modules_backlight e_modules_battery e_modules_clock e_modules_comp e_modules_conf-applications e_modules_conf-dialogs e_modules_conf-display e_modules_conf-edgebindings e_modules_conf-interaction e_modules_conf-intl e_modules_conf-keybindings e_modules_conf-menus e_modules_conf-paths e_modules_conf-performance e_modules_conf-randr e_modules_conf-shelves e_modules_conf-theme e_modules_conf-wallpaper2 e_modules_conf-window-manipulation e_modules_conf-window-remembers e_modules_connman e_modules_cpufreq e_modules_dropshadow e_modules_everything e_modules_fileman e_modules_fileman-opinfo e_modules_gadman e_modules_ibar e_modules_ibox e_modules_illume2 e_modules_mixer e_modules_msgbus e_modules_notification e_modules_pager e_modules_quickaccess e_modules_shot e_modules_start e_modules_syscon e_modules_systray e_modules_tasks e_modules_temperature e_modules_tiling e_modules_winlist e_modules_wizard e_modules_xkbswitch nls pam spell static-libs udev -doc -e_modules_access -e_modules_ofono -e_modules_physics -exchange -ukit" 0 kB

Total: 12 packages (9 upgrades, 2 new, 1 in new slot), Size of downloads: 0 kB

Would you like to merge these packages? [Yes/No] y


Now, lets see on reboot...
Back to top
View user's profile Send private message
rpil
Apprentice
Apprentice


Joined: 23 May 2008
Posts: 288

PostPosted: Thu Oct 11, 2012 10:56 pm    Post subject: Reply with quote

UP AND RUNNING!!!!
I'm very happy! Thanks, guys! :D
Back to top
View user's profile Send private message
rpil
Apprentice
Apprentice


Joined: 23 May 2008
Posts: 288

PostPosted: Fri Oct 12, 2012 6:37 am    Post subject: Reply with quote

After erasing enlightenment-niifaq overlay, I get this message from layman:
Code:
# layman -S
* Running... # /usr/bin/svn up /var/lib/layman/enlightenment
At revision 793.
* Running... # ( cd /var/lib/layman/enlightenment-niifaq  && /usr/bin/git pull )
*
* Success:
* ------
*
* Successfully synchronized overlay "enlightenment".
*
* Warnings:
* ------
*
* Overlay "enlightenment-niifaq" could not be found in the remote lists.
* Please check if it has been renamed and re-add if necessary.
*
*
* Errors:
* ------
*
* Failed to sync overlay "enlightenment-niifaq".
* Error was: [Errno 2] No such file or directory: '/var/lib/layman/enlightenment-niifaq'
*


Where else is enlightenment-niifaq and how I can completely erase it and have no error message?
Back to top
View user's profile Send private message
ppurka
Advocate
Advocate


Joined: 26 Dec 2004
Posts: 3205

PostPosted: Fri Oct 12, 2012 1:19 pm    Post subject: Reply with quote

You probably deleted enlightenment-niifaq by hand instead of using layman to delete it. One way would be to force sync enlightenment-niifaq (if it's possible with layman) and then delete it properly.
_________________
emerge --quiet redefined | E17 vids: I, II
Back to top
View user's profile Send private message
rpil
Apprentice
Apprentice


Joined: 23 May 2008
Posts: 288

PostPosted: Fri Oct 12, 2012 11:04 pm    Post subject: Reply with quote

It's ok now:

Code:
# layman -d enlightenment-niifaq
* Directory /var/lib/layman/enlightenment-niifaq did not exist, no files deleted.
* Successfully deleted overlay "enlightenment-niifaq".

Code:

# layman -S
* Running... # /usr/bin/svn up /var/lib/layman/enlightenment
At revision 793.
*
* Success:
* ------
*
* Successfully synchronized overlay "enlightenment".
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum