Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
gnome 3.4
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
sobhan
n00b
n00b


Joined: 05 Jul 2012
Posts: 17
Location: Tehran,Iran

PostPosted: Mon Aug 06, 2012 5:41 pm    Post subject: gnome 3.4 Reply with quote

when i want to emerge -uavDN @world to update from gnome 3.2 to 3.4 from the gnome overlay it Tell's me
Code:
These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U ~] sys-libs/zlib-1.2.7 [1.2.5.1-r2] USE="-minizip -static-libs" 0 kB
[ebuild     U ~] app-crypt/p11-kit-0.13 [0.12] USE="-debug" 0 kB
[ebuild     U  ] dev-libs/icu-49.1.2 [49.1.1-r1] USE="-debug -doc -examples -static-libs" 0 kB
[ebuild  N     ] dev-libs/libyaml-0.1.4  USE="-doc -examples -static-libs -test" 0 kB
[ebuild     U  ] sys-devel/gcc-config-1.7.3 [1.6] 0 kB
[ebuild     U ~] dev-libs/gobject-introspection-common-1.33.3::gnome [1.32.1::gentoo] 0 kB
[ebuild     U ~] net-misc/mobile-broadband-provider-info-20120614 [20110511] 72 kB
[ebuild     U ~] x11-libs/gnome-pty-helper-0.32.2 [0.28.1] USE="hardened%*" 0 kB
[ebuild     U  ] media-libs/libjpeg-turbo-1.2.1 [1.2.0-r1] USE="-java -static-libs" 0 kB
[ebuild     U  ] app-emulation/emul-linux-x86-baselibs-20120520 [20120127] USE="-development" 0 kB
[ebuild     U  ] sys-apps/ed-1.6 [1.4] 0 kB
[ebuild     U  ] dev-libs/libevent-2.0.19 [2.0.18] USE="ssl -static-libs -test" 0 kB
[ebuild     U  ] sys-apps/debianutils-4.3.2 [3.4.4] USE="-static" 0 kB
[ebuild     U  ] sys-kernel/linux-headers-3.4-r2 [3.4] 0 kB
[ebuild     U  ] media-libs/libv4l-0.8.8 [0.8.5] 0 kB
[ebuild     U  ] dev-db/sqlite-3.7.13 [3.7.12.1] USE="extensions fts3 readline threadsafe -debug -doc -icu -secure-delete -soundex -tcl -test -unlock-notify" 0 kB
[ebuild     U ~] dev-lang/orc-0.4.16 [0.4.11] USE="-examples -static-libs" 653 kB
[ebuild   R    ] dev-libs/nettle-2.4  USE="gmp (-ssl%*)" 0 kB
[ebuild  N     ] dev-util/ragel-6.7-r1  USE="-vim-syntax" 0 kB
[ebuild  N    ~] sys-apps/hwids-20120730  360 kB
[uninstall     ] sys-apps/usbutils-004  USE="zlib -network-cron -python"
[blocks b      ] <sys-apps/usbutils-005-r1 ("<sys-apps/usbutils-005-r1" is blocking sys-apps/hwids-20120730)
[ebuild     U  ] sys-apps/sed-4.2.1-r1 [4.2.1] USE="acl nls (-selinux) -static" 0 kB
[ebuild   R    ] dev-libs/libgpg-error-1.10  USE="nls static-libs* -common-lisp" 0 kB
[ebuild   R    ] dev-libs/popt-1.16-r1  USE="nls static-libs*" 687 kB
[ebuild     U  ] sys-apps/grep-2.12 [2.9] USE="nls pcre" 0 kB
[ebuild   R    ] app-text/hunspell-1.3.2-r3  USE="ncurses nls readline -static-libs" LINGUAS="-af -bg -ca -cs -cy -da -de -el -en -eo -es -et -fo -fr -ga -gl -he -hr -hu -ia -id -is% -it -km% -ku -lt -lv -mk -ms -nb -nl -nn -pl -pt -pt_BR% -ro -ru -sk -sl -sq -sv -sw -tn -uk -zu" 0 kB
[ebuild   R    ] dev-libs/libgcrypt-1.5.0-r2  USE="static-libs*" 0 kB
[ebuild     U ~] media-video/gnome-video-effects-0.4.0 [0.3.0] 140 kB
[ebuild  N     ] sys-apps/gptfdisk-0.8.4  179 kB
[ebuild  N     ] app-admin/eselect-ruby-20100603  0 kB
[ebuild     U  ] app-admin/eselect-xvmc-0.3 [0.2] 0 kB
[ebuild  N     ] dev-lang/ruby-1.8.7_p357  USE="berkdb gdbm ncurses readline ssl -debug -doc -examples -ipv6 -libedit -rubytests -socks5 -threads -tk -xemacs" 0 kB
[ebuild     U ~] dev-libs/glib-2.33.6::gnome [2.32.3::gentoo] USE="-debug -doc (-fam) (-selinux) -static-libs -systemtap -test -utils -xattr" 0 kB
[ebuild   R    ] net-misc/curl-7.25.0-r1  USE="ldap ssl -ares -idn -ipv6 -kerberos -ssh -static-libs -test -threads" CURL_SSL="nss -axtls -gnutls -openssl -polarssl (-cyassl%)" 0 kB
[ebuild     U ~] x11-themes/gnome-icon-theme-3.4.0 [3.2.1.2] USE="branding" 14,388 kB
[ebuild     U ~] net-libs/gnutls-2.12.20 [2.12.18] USE="cxx nettle nls zlib -bindist -doc -examples -guile -lzo -pkcs11 -static-libs -test" 7,062 kB
[ebuild     U  ] media-libs/libexif-0.6.21 [0.6.20] USE="nls -doc -static-libs" 0 kB
[ebuild     U ~] media-fonts/cantarell-0.0.9 [0.0.8] USE="X" 306 kB
[ebuild     U ~] dev-cpp/glibmm-2.32.1 [2.32.0] USE="-debug -doc -examples -test" 0 kB
[ebuild     U ~] dev-libs/gobject-introspection-1.33.3::gnome [1.32.1::gentoo] USE="-doc -doctool -test" 0 kB
[ebuild     U ~] dev-util/itstool-1.2.0 [1.1.2] 81 kB
[ebuild     U ~] dev-libs/atk-2.5.3::gnome [2.4.0::gentoo] USE="introspection nls -doc" 0 kB
[ebuild     U ~] net-libs/libnice-0.1.2 [0.1.0] USE="gstreamer -upnp" 656 kB
[ebuild  N    ~] net-libs/farstream-0.1.2-r1  USE="introspection -msn -python -test -upnp" 0 kB
[ebuild     U ~] dev-util/gdbus-codegen-2.33.6::gnome [2.30.3::gentoo] PYTHON_TARGETS="python2_7%* python3_2%* -python2_5% -python2_6% -python3_1%" 0 kB
[ebuild     U ~] dev-python/pygobject-3.2.2 [3.0.4] USE="cairo threads -examples -test" 0 kB
[ebuild     U ~] dev-python/pygobject-2.28.6-r52 [2.28.6-r51] USE="introspection -doc -examples -libffi -test" 0 kB
[ebuild  N     ] dev-lang/ruby-1.9.3_p194-r1  USE="berkdb gdbm ncurses rdoc readline ssl yaml -debug -doc -examples -ipv6 -rubytests -socks5 -tk -xemacs" 0 kB
[ebuild  N     ] dev-ruby/rubygems-1.8.24  USE="-server -test" RUBY_TARGETS="ruby18 ruby19 -jruby -ree18" 0 kB
[ebuild  N     ] virtual/rubygems-4  RUBY_TARGETS="(ruby19)" 0 kB
[ebuild  N     ] virtual/rubygems-1  RUBY_TARGETS="(ruby18)" 0 kB
[ebuild  N     ] dev-ruby/rake-0.8.7-r6  USE="-bash-completion -doc -test" RUBY_TARGETS="ruby18 ruby19 -jruby -ree18" 0 kB
[ebuild  N     ] dev-ruby/racc-1.4.6-r1  USE="-test" RUBY_TARGETS="ruby18 ruby19 -jruby -ree18" 0 kB
[ebuild  N     ] dev-ruby/json-1.6.7  USE="-doc -test" RUBY_TARGETS="ruby18 ruby19 -jruby -ree18" 0 kB
[ebuild  N     ] dev-ruby/rdoc-3.12  USE="-doc -test" RUBY_TARGETS="ruby18 ruby19 -jruby -ree18" 0 kB
[ebuild  N    ~] sys-apps/kmod-9-r3  USE="tools zlib -debug -doc -lzma -static-libs" 1,097 kB
[uninstall     ] sys-apps/module-init-tools-3.16-r1  USE="-static"
[blocks b      ] sys-apps/kmod ("sys-apps/kmod" is blocking sys-apps/module-init-tools-3.16-r1)
[blocks b      ] sys-apps/module-init-tools ("sys-apps/module-init-tools" is blocking sys-apps/kmod-9-r3)
[ebuild     U  ] sys-apps/dbus-1.6.2 [1.4.20] USE="X -debug -doc (-selinux) -static-libs -systemd% -test" 0 kB
[ebuild     U ~] x11-libs/gtk+-2.24.11-r1 [2.24.10-r1] USE="introspection (-aqua) -cups* -debug -doc -examples -test -vim-syntax -xinerama" 0 kB
[ebuild     U  ] dev-libs/dbus-glib-0.100 [0.98] USE="-debug -doc -static-libs -test" 0 kB
[ebuild     U #] gnome-base/libgnome-keyring-3.4.1 [3.2.2] USE="introspection%* -debug -doc -test" 0 kB
[ebuild     U #] app-accessibility/at-spi2-core-2.4.2 [2.2.3] USE="introspection -doc" 0 kB
[ebuild   R    ] app-text/ghostscript-gpl-9.05-r1  USE="X dbus gtk -bindist -cups* -djvu -idn -jpeg2k -static-libs" LINGUAS="-ja -ko -zh_CN -zh_TW" 0 kB
[ebuild     U ~] net-dns/avahi-0.6.30-r3 [0.6.30-r1] USE="dbus gdbm gtk introspection qt4 -autoipd -bookmarks -doc -gtk3 -howl-compat -ipv6 -mdnsresponder-compat -mono -python -test -utils" 0 kB
[ebuild  N    ~] app-accessibility/at-spi2-atk-2.5.4::gnome  USE="-test" 0 kB
[ebuild     U  ] dev-python/dbus-python-1.1.1 [1.0.0] USE="-doc -examples -test" 0 kB
[ebuild     U ~] www-client/firefox-14.0.1 [10.0.5] USE="alsa dbus gstreamer%* ipc jit%* libnotify minimal startup-notification webm -bindist -custom-cflags -custom-optimization -debug -pgo (-selinux) -system-sqlite -wifi (-crashreporter%*)" LINGUAS="-af -ak -ar -as -ast -be -bg -bn_BD -bn_IN -br -bs -ca -cs -csb -cy -da -de -el -en_GB -en_ZA -eo -es_AR -es_CL -es_ES -es_MX -et -eu -fa -fi -fr -fy_NL -ga_IE -gd -gl -gu_IN -he -hi_IN -hr -hu -hy_AM -id -is -it -ja -kk -km% -kn -ko -ku -lg -lt -lv -mai -mk -ml -mr -nb_NO -nl -nn_NO -nso -or -pa_IN -pl -pt_BR -pt_PT -rm -ro -ru -si -sk -sl -son -sq -sr -sv_SE -ta -ta_LK -te -th -tr -uk -vi -zh_CN -zh_TW -zu" 0 kB
[ebuild     U ~] net-im/telepathy-logger-0.4.0 [0.2.12-r1] USE="introspection -doc -test" 0 kB
[ebuild     U #] dev-python/pyatspi-2.4.0 [2.2.1] USE="-test" 0 kB
[ebuild     U #] net-libs/telepathy-farstream-0.4.0 [0.1.2] USE="-examples -python" 0 kB
[ebuild   R    ] x11-libs/qt-gui-4.8.2  USE="accessibility dbus exceptions gif glib mng qt3support tiff xv (-aqua) (-c++0x) -cups* -debug -egl -gtkstyle -nas -nis -pch (-qpa) -trace -xinerama" 0 kB
[ebuild     U ~] sys-auth/polkit-0.107 [0.104-r1] USE="gtk introspection nls pam -examples -kde (-selinux) -systemd (-debug%) (-doc%)" 1,351 kB
[ebuild     U ~] net-libs/glib-networking-2.32.3 [2.30.2] USE="gnome libproxy ssl -smartcard% -test%" 325 kB
[ebuild     U ~] net-libs/libsoup-2.39.4.1-r1::gnome [2.38.1::gentoo] USE="introspection ssl -debug -doc -samba -test" 0 kB
[ebuild     U ~] net-libs/libsoup-gnome-2.39.4.1::gnome [2.38.1::gentoo] USE="introspection -debug -doc" 0 kB
[ebuild     U ~] net-voip/telepathy-gabble-0.16.1 [0.14.1] USE="jingle -test (-debug%)" 2,584 kB
[ebuild     U #] dev-libs/libgdata-0.12.0 [0.10.2] USE="gnome introspection -debug -doc -static-libs" 0 kB
[ebuild     U #] gnome-extra/sushi-0.4.1 [0.2.1] 0 kB
[ebuild     U ~] x11-libs/gtk+-3.5.8::gnome [3.4.3-r1::gentoo] USE="X colord introspection -accessibility% (-aqua) -cups* -debug -doc -examples (-packagekit) -test -vim-syntax (-wayland) -xinerama" 0 kB
[ebuild     U ~] gnome-base/gconf-3.2.5 [2.32.4] USE="introspection ldap policykit -debug -doc -orbit%" 1,490 kB
[ebuild     U #] gnome-base/libgnomekbd-3.4.0.2 [3.2.0-r1] USE="introspection -test" 0 kB
[ebuild     U ~] gnome-base/dconf-0.12.1 [0.10.0] USE="X -doc (-vala%)" 198 kB
[ebuild     U ~] net-libs/webkit-gtk-1.9.4-r300::gnome [1.6.3-r300::gentoo] USE="geoloc%* gstreamer introspection jit spell webgl* (-aqua) -coverage -debug -doc -test" 0 kB
[ebuild     U ~] x11-themes/gnome-themes-standard-3.5.4::gnome [3.4.2::gentoo] USE="gtk3%*" 0 kB
[ebuild     U #] gnome-base/gnome-menus-3.4.2 [3.2.0.1-r1] USE="introspection python -debug -test" 0 kB
[ebuild     U #] x11-libs/libwnck-3.4.2 [3.2.1] USE="introspection startup-notification -doc -tools%" 0 kB
[ebuild     U #] gnome-base/gnome-session-3.4.2.1 [3.2.1-r1] USE="-debug% -doc -ipv6 -systemd%" 0 kB
[ebuild     U #] net-libs/gnome-online-accounts-3.4.2 [3.2.1] USE="gnome introspection -debug -doc" 0 kB
[ebuild     U ~] gnome-extra/zenity-3.4.0 [2.32.1] USE="libnotify webkit%* -debug (-compat%*)" 3,537 kB
[ebuild     U #] gnome-extra/evolution-data-server-3.4.3 [3.2.3-r2] USE="gnome-online-accounts introspection ldap weather -doc -ipv6 -kerberos -test -vala" 0 kB
[ebuild     U #] gnome-base/nautilus-3.4.2 [3.2.1-r1] USE="exif gnome introspection previewer -doc (-packagekit) -sendto -test -tracker -xmp" 0 kB
[ebuild     U ~] sys-apps/util-linux-2.21.2 [2.20.1-r2] USE="cramfs crypt ncurses nls static-libs* udev%* unicode -ddate -loop-aes -old-linux -perl (-selinux) -slang (-uclibc)" 2,916 kB
[ebuild     U ~] sys-fs/udev-187-r1 [171-r6] USE="gudev hwdb keymap openrc%* static-libs%* -doc% -introspection (-selinux) (-action_modeswitch%) (-build%) (-debug%) (-edd%) (-extras%*) (-floppy%) (-rule_generator%*) (-test%)" 1,312 kB
[blocks b      ] <sys-fs/udev-186 ("<sys-fs/udev-186" is blocking sys-fs/udev-init-scripts-14)
[ebuild  N    ~] sys-fs/udev-init-scripts-14  5 kB
[ebuild     U ~] x11-misc/colord-0.1.21 [0.1.18] USE="gtk%* gusb introspection udev -doc -examples -scanner -vala" 541 kB
[ebuild     U ~] net-misc/networkmanager-0.9.4.0-r5 [0.9.4.0-r4] USE="dhcpcd introspection nss ppp wext -avahi -bluetooth -connection-sharing -dhclient -doc -gnutls -modemmanager -resolvconf -systemd -wimax" 0 kB
[ebuild   R    ] media-sound/pulseaudio-1.1-r1  USE="X alsa asyncns caps dbus gdbm glib gnome orc ssl tcpd udev -avahi -bluetooth* -doc -equalizer -ipv6 -jack -libsamplerate -lirc (-oss) -realtime (-system-wide) -test" 0 kB
[ebuild  N     ] sys-fs/cryptsetup-1.4.1  USE="nls static (-selinux)" 755 kB
[ebuild     U ~] media-libs/libcanberra-0.29 [0.28-r5] USE="alsa gnome gstreamer gtk gtk3 pulseaudio sound udev -oss -tdb" 309 kB
[ebuild     U ~] net-im/telepathy-mission-control-5.12.1 [5.10.1] USE="gnome-keyring networkmanager upower -connman% -debug%" 0 kB
[ebuild  NS   ~] sys-fs/udisks-1.99.0 [1.0.4-r2] USE="crypt gptfdisk introspection -debug -systemd" 713 kB
[ebuild     U  ] media-libs/libsdl-1.2.15-r2 [1.2.15] USE="X alsa audio joystick opengl pulseaudio video xv -aalib -custom-cflags -dga -directfb -fbcon -ggi -libcaca -nas -oss (-ps3) -static-libs (-svga) -tslib -xinerama" 0 kB
[ebuild     U #] x11-wm/metacity-2.34.3 [2.34.1] USE="-test -xinerama" 0 kB
[ebuild     U #] dev-libs/folks-0.6.9 [0.6.6] USE="eds socialweb -debug -test -tracker -utils -vala" 0 kB
[ebuild     U ~] gnome-base/gvfs-1.12.3 [1.10.1] USE="cdda gnome-keyring http udev udisks%* -afp -archive -avahi -bluetooth* -bluray -doc -fuse -gdu* -gphoto2 -ios -samba" 1,331 kB
[ebuild     U #] gnome-extra/gnome-tweak-tool-3.4.0.1 [3.2.2-r2] 0 kB
[blocks B      ] <sys-apps/pciutils-3.1.9-r2 ("<sys-apps/pciutils-3.1.9-r2" is blocking sys-apps/hwids-20120730)
[blocks B      ] net-libs/farsight2 ("net-libs/farsight2" is blocking net-libs/farstream-0.1.2-r1)
[blocks B      ] <sys-apps/openrc-0.9.9 ("<sys-apps/openrc-0.9.9" is blocking sys-fs/udev-187-r1)

Total: 104 packages (75 upgrades, 19 new, 1 in new slot, 9 reinstalls, 2 uninstalls), Size of downloads: 43,036 kB
Conflict: 7 blocks (3 unsatisfied)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (net-libs/farsight2-0.0.29::gentoo, installed) pulled in by
    net-libs/farsight2[python] required by (dev-python/papyon-0.5.6::gentoo, installed)

  (sys-apps/openrc-0.9.8.4::gentoo, installed) pulled in by
    sys-apps/openrc required by (sys-apps/baselayout-2.1-r1::gentoo, installed)
    sys-apps/openrc required by (sys-fs/udev-init-scripts-14::gentoo, ebuild scheduled for merge)

  (sys-fs/udev-187-r1::gentoo, ebuild scheduled for merge) pulled in by
    sys-fs/udev required by (sys-apps/util-linux-2.21.2::gentoo, ebuild scheduled for merge)
    >=sys-fs/udev-171-r5[gudev] required by (sys-power/upower-0.9.16::gentoo, installed)
    sys-fs/udev[gudev] required by (gnome-base/gnome-settings-daemon-3.4.2::gentoo, installed)
    >=sys-fs/udev-146-r1 required by (sys-auth/consolekit-0.4.5_p20120320::gentoo, installed)
    >=sys-fs/udev-171[gudev] required by (gnome-base/gvfs-1.12.3::gentoo, ebuild scheduled for merge)
    >=sys-fs/udev-187 required by (sys-fs/udev-init-scripts-14::gentoo, ebuild scheduled for merge)
    sys-fs/udev[gudev] required by (dev-libs/libgusb-0.1.3::gentoo, installed)
    >=sys-fs/udev-143 required by (dev-libs/libatasmart-0.19::gentoo, installed)
    >=sys-fs/udev-151-r4 required by (sys-fs/lvm2-2.02.88::gentoo, installed)
    >=sys-fs/udev-160 required by (media-libs/libcanberra-0.29::gentoo, ebuild scheduled for merge)
    >=sys-fs/udev-150 required by (x11-base/xorg-server-1.12.2::gentoo, installed)
    >=sys-fs/udev-171[hwdb] required by (media-sound/pulseaudio-1.1-r1::gentoo, ebuild scheduled for merge)
    >=sys-fs/udev-124 required by (sys-fs/cryptsetup-1.4.1::gentoo, ebuild scheduled for merge)
    >=sys-fs/udev-171[gudev] required by (media-video/cheese-3.4.2::gentoo, installed)
    sys-fs/udev required by (virtual/dev-manager-0::gentoo, installed)
    sys-fs/udev[gudev] required by (x11-misc/colord-0.1.21::gentoo, ebuild scheduled for merge)
    >=sys-fs/udev-182[static-libs] required by (sys-fs/cryptsetup-1.4.1::gentoo, ebuild scheduled for merge)
    >=sys-fs/udev-180[gudev,hwdb] required by (sys-fs/udisks-1.99.0::gentoo, ebuild scheduled for merge)
    >=sys-fs/udev-171[gudev] required by (net-misc/networkmanager-0.9.4.0-r5::gentoo, ebuild scheduled for merge)

  (net-libs/farstream-0.1.2-r1::gentoo, ebuild scheduled for merge) pulled in by
    >=net-libs/farstream-0.1.0 required by (net-libs/telepathy-farstream-0.4.0::gentoo, ebuild scheduled for merge)
    net-libs/farstream required by (net-im/pidgin-2.10.4::gentoo, installed)

  (sys-apps/pciutils-3.1.9-r1::gentoo, installed) pulled in by
    sys-apps/pciutils required by (media-sound/alsa-utils-1.0.25-r1::gentoo, installed)
    sys-apps/pciutils required by (app-laptop/radeontool-1.5-r3::gentoo, installed)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked

,i was obligated to remove the cpus use to
and my make.conf
Code:
# These settings were set by the catalyst build script that automatically
# built this stage.
# Please consult /usr/share/portage/config/make.conf.example for a more
# detailed example.
CFLAGS="-march=native -O2 -pipe"
CXXFLAGS="${CFLAGS}"
# WARNING: Changing your CHOST is not something that should be done lightly.
# Please consult http://www.gentoo.org/doc/en/change-chost.xml before changing.
CHOST="x86_64-pc-linux-gnu"
# These are the USE flags that were used in addition to what is provided by the
# profile used for building.
USE="-cups mmx sse sse2 sna networkmanager dhcpcd -qt -kde -KDE -bluetooth -ipv6"
VIDEO_CARDS="intel radeon"
INPUT_DEVICES="evdev synaptics"
MAKEOPTS="-j6"
linguas="fa en us"

my package.accept_keywords
http://bpaste.net/show/38713/
my package.use
http://bpaste.net/show/38714/
my package.unmask http://bpaste.net/show/38715/
and 1 last ting i use gnome desktop profile
any one got an idea :?:
Back to top
View user's profile Send private message
m_lan
n00b
n00b


Joined: 29 Mar 2012
Posts: 16
Location: Poland, Warsaw

PostPosted: Thu Aug 09, 2012 7:21 pm    Post subject: Reply with quote

Hi sobhan

I don't think you need both farstream and farsight2. I had similar problems with them - the simplest solution was to remove farstream (and all connected applications)

As for udev and openrc - maybe try downgrading? I have udev-171-r6 and openrc-0.9.8.4 and they work fine together

The same goes for pciutils - maybe downgrading will help

hope this helps,

cheers
m_lan
Back to top
View user's profile Send private message
Master_d
Apprentice
Apprentice


Joined: 12 Oct 2003
Posts: 152
Location: Milwaukee

PostPosted: Thu Sep 13, 2012 4:29 am    Post subject: Reply with quote

m_lan wrote:
Hi sobhan

I don't think you need both farstream and farsight2. I had similar problems with them - the simplest solution was to remove farstream (and all connected applications)

As for udev and openrc - maybe try downgrading? I have udev-171-r6 and openrc-0.9.8.4 and they work fine together

The same goes for pciutils - maybe downgrading will help

hope this helps,

cheers
m_lan

I'm suffering from this same issue.
how do you find out which packages are dependent on farstream?
_________________
お前の常識知ったこっちゃねえ!
Back to top
View user's profile Send private message
m_lan
n00b
n00b


Joined: 29 Mar 2012
Posts: 16
Location: Poland, Warsaw

PostPosted: Thu Sep 13, 2012 8:31 am    Post subject: Reply with quote

One of the ways to see what depends on farstream is to use
Code:
emerge --depclean -v farstream

It should say that it can't remove selected package beacause some other packages depend on it.

Unfortunately problem with farstream and farsight2 returs very often. Both packages are a part of net-im/empathy; net-im/empathy is a part of gnome-core-apps, a subpackage of gnome. Last time it reappeared after another system update, I just installed gnome-light instead of original gnome. That way you can remove net-im/empathy and some other packages that you don't need.
The guide is here: http://forums.gentoo.org/viewtopic-t-921876-start-0.html
Back to top
View user's profile Send private message
moneycat
n00b
n00b


Joined: 23 May 2007
Posts: 21

PostPosted: Thu Sep 13, 2012 9:15 am    Post subject: Reply with quote

With the packages.keywords from git overlay, and unmask bluez, I still got these Blocks.

Is there any idea to solved this? The openrc seems the main block packages...

Quote:
[blocks B ] <sys-apps/pciutils-3.1.9-r2 ("<sys-apps/pciutils-3.1.9-r2" is blocking sys-apps/hwids-20120831)
[blocks B ] <sys-kernel/genkernel-3.4.25 ("<sys-kernel/genkernel-3.4.25" is blocking sys-fs/udev-189)
[blocks B ] <sys-apps/openrc-0.9.9 ("<sys-apps/openrc-0.9.9" is blocking sys-fs/udev-189)

Total: 132 packages (93 upgrades, 34 new, 2 in new slots, 3 reinstalls, 5 uninstalls), Size of downloads: 239,361 kB
Conflict: 13 blocks (3 unsatisfied)

* Error: The above package list contains packages which cannot be
* installed at the same time on the same system.

(sys-apps/pciutils-3.1.9-r1::gentoo, installed) pulled in by
sys-apps/pciutils required by (media-sound/alsa-utils-1.0.25-r1::gentoo, installed)
sys-apps/pciutils required by (app-laptop/radeontool-1.5-r3::gentoo, installed)

(sys-kernel/genkernel-3.4.24_p2::gentoo, installed) pulled in by
sys-kernel/genkernel required by @selected

(sys-fs/udev-189::gentoo, ebuild scheduled for merge) pulled in by
>=sys-fs/udev-169 required by (net-wireless/bluez-4.101-r3::gentoo, ebuild scheduled for merge)
>=sys-fs/udev-171-r5[gudev] required by (sys-power/upower-0.9.16::gentoo, installed)
>=sys-fs/udev-171[gudev] required by (media-gfx/shotwell-0.12.3::gentoo, installed)
>=sys-fs/udev-171[gudev] required by (gnome-base/gvfs-1.12.3::gentoo, ebuild scheduled for merge)
>=sys-fs/udev-164-r2 required by (app-admin/system-config-printer-common-1.3.11-r1::gentoo, ebuild scheduled for merge)
>=sys-fs/udev-180[gudev,hwdb] required by (sys-fs/udisks-1.99.0-r1::gentoo, ebuild scheduled for merge)
sys-fs/udev[gudev] required by (x11-misc/colord-0.1.22::gentoo, ebuild scheduled for merge)
sys-fs/udev[gudev] required by (net-im/empathy-3.4.2.3::gentoo, ebuild scheduled for merge)
>=sys-fs/udev-146-r1 required by (sys-auth/consolekit-0.4.5_p20120320::gentoo, installed)
>=sys-fs/udev-151-r4 required by (sys-fs/lvm2-2.02.88::gentoo, installed)
>=sys-fs/udev-160 required by (media-libs/libcanberra-0.29::gentoo, ebuild scheduled for merge)
sys-fs/udev required by (sys-apps/util-linux-2.21.2::gentoo, ebuild scheduled for merge)
>=sys-fs/udev-187 required by (sys-fs/udev-init-scripts-16::gentoo, ebuild scheduled for merge)
>=sys-fs/udev-171[hwdb] required by (media-sound/pulseaudio-1.1-r1::gentoo, installed)
>=sys-fs/udev-143 required by (dev-libs/libatasmart-0.19::gentoo, installed)
>=sys-fs/udev-124 required by (sys-fs/cryptsetup-1.4.1::gentoo, ebuild scheduled for merge)
>=sys-fs/udev-171[gudev] required by (media-video/cheese-3.4.2::gentoo, ebuild scheduled for merge)
sys-fs/udev required by (net-wireless/gnome-bluetooth-3.4.2::gentoo, ebuild scheduled for merge)
sys-fs/udev[gudev] required by (dev-libs/libgusb-0.1.3::gentoo, installed)
sys-fs/udev[gudev] required by (gnome-base/gnome-settings-daemon-3.4.2::gentoo, ebuild scheduled for merge)
>=sys-fs/udev-171[gudev] required by (net-misc/networkmanager-0.9.4.0-r7::gentoo, ebuild scheduled for merge)
sys-fs/udev required by (virtual/dev-manager-0::gentoo, installed)
>=sys-fs/udev-150 required by (x11-base/xorg-server-1.12.2::gentoo, installed)
>=sys-fs/udev-182[static-libs] required by (sys-fs/cryptsetup-1.4.1::gentoo, ebuild scheduled for merge)

(sys-apps/openrc-0.9.8.4::gentoo, installed) pulled in by
sys-apps/openrc required by (sys-apps/baselayout-2.1-r1::gentoo, installed)
sys-apps/openrc required by (sys-fs/udev-init-scripts-16::gentoo, ebuild scheduled for merge)
sys-apps/openrc required by (app-admin/openrc-settingsd-1.0.1::gentoo, ebuild scheduled for merge)
Back to top
View user's profile Send private message
m_lan
n00b
n00b


Joined: 29 Mar 2012
Posts: 16
Location: Poland, Warsaw

PostPosted: Thu Sep 13, 2012 9:30 am    Post subject: Reply with quote

This is the reason I resigned from gnome overlay as soon as there was gnome 3 on gentoo overlay. To much hustle :?
Beside downgrading openrc, I don't know what more I can advice you.
Back to top
View user's profile Send private message
moneycat
n00b
n00b


Joined: 23 May 2007
Posts: 21

PostPosted: Fri Oct 12, 2012 6:40 am    Post subject: Reply with quote

The blocks seems eliminated now. Today I use
Code:
emerge --autounmask-write =gnome-3.4.2 =gnome-shell-3.4.1
and accept all suggestions, I only encounter
Code:
!<shadow-4.1.5-r1
from pambase. After unmask of shadow-4.1.5.1, the
Code:
emerge -uDNpv world
seems works.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum