Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
tinyproxy says it starts, but doesn't
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
tsftd
n00b
n00b


Joined: 21 May 2011
Posts: 19
Location: Here

PostPosted: Fri Oct 12, 2012 12:35 am    Post subject: tinyproxy says it starts, but doesn't Reply with quote

Another little glitch, I have installed and configured tinyproxy as per http://markus.revti.com/2009/10/installing-tinyproxy-as-squid-proxy-server-alternative/ and http://controlpanelblog.com/general/how-to-install-and-configure-tinyproxy.html . /etc/init.d/tinyproxy start emits no errors, the tinyproxy log shows no errors ( http://pastebin.com/fw39bdcX ) -- however, htop does not show any tinyproxy processes, or any processes started by that username (which I confirmed was created). More tellingly, trying to stop or restart the service yields:
Code:
[censored] ~ # /etc/init.d/tinyproxy restart
 * Stopping tinyproxy ...
 * start-stop-daemon: no matching processes found                         [ ok ]
 * Starting tinyproxy ...                                                 [ ok ]


I have also tried changing the username it runs under to root, thinking it may be a permission error, to no avail (username has been reset to tinyproxy). One thing slightly different from the tutorial is that the conf file is /etc/tinyproxy.conf instead of /etc/tinyproxy/tinyproxy.conf -- but since the log confirms that it's pulling settings from the conf file, that shouldn't be an issue.

Obviously, trying to connect through the proxy gives an error (from firefox):
Code:
The proxy server is refusing connections
          Firefox is configured to use a proxy server that is refusing connections.
  Check the proxy settings to make sure that they are correct.
  Contact your network administrator to make sure the proxy server is working.


Any ideas?
Back to top
View user's profile Send private message
Hu
Watchman
Watchman


Joined: 06 Mar 2007
Posts: 9009

PostPosted: Fri Oct 12, 2012 1:36 am    Post subject: Reply with quote

Does the process fail to start or does it start and immediately exit? What does strace report?
Back to top
View user's profile Send private message
tsftd
n00b
n00b


Joined: 21 May 2011
Posts: 19
Location: Here

PostPosted: Fri Oct 12, 2012 3:05 am    Post subject: Reply with quote

it starts and then fails, after a fair number of errors -- mostly related to files not being found: http://pastebin.com/hWLqbbB8
Back to top
View user's profile Send private message
adsmol
n00b
n00b


Joined: 26 Nov 2012
Posts: 1

PostPosted: Mon Nov 26, 2012 9:58 am    Post subject: Reply with quote

At my site it started to start again after:

mkdir /run/tinyproxy && chown tinyproxy:tinyproxy /run/tinyproxy
Back to top
View user's profile Send private message
ToeiRei
Veteran
Veteran


Joined: 03 Jan 2005
Posts: 1156
Location: Austria

PostPosted: Mon Dec 10, 2012 11:15 pm    Post subject: Reply with quote

added those two lines to the init script...
_________________
Blog | btrfs | Please stand by - The mailer daemon is busy burning your messages in hell...
Back to top
View user's profile Send private message
gr650
n00b
n00b


Joined: 07 Jan 2005
Posts: 42
Location: Uzwil, Switzerland

PostPosted: Tue Feb 26, 2013 10:28 am    Post subject: Reply with quote

Ah, thanks for the one-/twoliner. Added that one to the init script and now tinyproxy at least starts as a daemon.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum