Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
emerge failed with trace stack
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
toralf
Advocate
Advocate


Joined: 01 Feb 2004
Posts: 2614
Location: Hamburg/Germany

PostPosted: Thu Oct 11, 2012 3:40 pm    Post subject: emerge failed with trace stack Reply with quote

An
Code:
time ionice -n 3 eix-sync -q && emerge --update @world --ask
gave today :
Code:
These are the packages that would be merged, in reverse order:

Calculating dependencies  ... done!
Traceback (most recent call last):
  File "/usr/bin/emerge", line 50, in <module>
    retval = emerge_main()
  File "/usr/lib/portage/pym/_emerge/main.py", line 2071, in emerge_main
    myopts, myaction, myfiles, spinner)
  File "/usr/lib/portage/pym/_emerge/actions.py", line 302, in action_build
    settings, trees, myopts, myparams, myaction, myfiles, spinner)
  File "/usr/lib/portage/pym/_emerge/depgraph.py", line 7319, in backtrack_depgraph
    myaction, myfiles, spinner)
  File "/usr/lib/portage/pym/_emerge/depgraph.py", line 7351, in _backtrack_depgraph
    success, favorites = mydepgraph.select_files(myfiles)
  File "/usr/lib/portage/pym/_emerge/depgraph.py", line 2249, in select_files
    self._load_vdb()
  File "/usr/lib/portage/pym/_emerge/depgraph.py", line 546, in _load_vdb
    fake_vartree.sync()
  File "/usr/lib/portage/pym/_emerge/FakeVartree.py", line 177, in sync
    self._real_vardb.lock()
  File "/usr/lib/portage/pym/portage/dbapi/vartree.py", line 221, in lock
    self._lock = lockdir(self._dbroot)
  File "/usr/lib/portage/pym/portage/locks.py", line 53, in lockdir
    return lockfile(mydir, wantnewlockfile=1, flags=flags)
  File "/usr/lib/portage/pym/portage/locks.py", line 103, in lockfile
    myfd = os.open(lockfilename, os.O_CREAT|os.O_RDWR, 0o660)
  File "/usr/lib/portage/pym/portage/__init__.py", line 230, in __call__
    rval = self._func(*wrapped_args, **wrapped_kwargs)
OSError: [Errno 5] Input/output error: '/var/db/.pkg.portage_lockfile'
The same call again however worked fine.
Anybody else saw this before ? (stable Gentoo, portage 2.1.11.9)
Back to top
View user's profile Send private message
eccerr0r
Advocate
Advocate


Joined: 01 Jul 2004
Posts: 3601
Location: USA

PostPosted: Thu Oct 11, 2012 4:05 pm    Post subject: Reply with quote

I would pin this to unstable hardware...
_________________
Intel Core i7 2700K@ 4.1GHz/HD3000 graphics/8GB DDR3/180GB SSD
What am I supposed to be advocating?
Back to top
View user's profile Send private message
toralf
Advocate
Advocate


Joined: 01 Feb 2004
Posts: 2614
Location: Hamburg/Germany

PostPosted: Thu Oct 11, 2012 4:13 pm    Post subject: Reply with quote

eccerr0r wrote:
I would pin this to unstable hardware...
Well - the system is at an external USB drive ...
Back to top
View user's profile Send private message
eccerr0r
Advocate
Advocate


Joined: 01 Jul 2004
Posts: 3601
Location: USA

PostPosted: Thu Oct 11, 2012 4:52 pm    Post subject: Reply with quote

I have used gentoo-on-root-on-external USB2 HDD... it should/does work fine...
_________________
Intel Core i7 2700K@ 4.1GHz/HD3000 graphics/8GB DDR3/180GB SSD
What am I supposed to be advocating?
Back to top
View user's profile Send private message
toralf
Advocate
Advocate


Joined: 01 Feb 2004
Posts: 2614
Location: Hamburg/Germany

PostPosted: Thu Oct 11, 2012 5:00 pm    Post subject: Reply with quote

eccerr0r wrote:
I have used gentoo-on-root-on-external USB2 HDD... it should/does work fine...
yep - it is an USB 2.0 drive here too (ext4).
Back to top
View user's profile Send private message
eccerr0r
Advocate
Advocate


Joined: 01 Jul 2004
Posts: 3601
Location: USA

PostPosted: Thu Oct 11, 2012 5:06 pm    Post subject: Reply with quote

What host USB adaptor is it? Hope not made by VIA?
_________________
Intel Core i7 2700K@ 4.1GHz/HD3000 graphics/8GB DDR3/180GB SSD
What am I supposed to be advocating?
Back to top
View user's profile Send private message
toralf
Advocate
Advocate


Joined: 01 Feb 2004
Posts: 2614
Location: Hamburg/Germany

PostPosted: Thu Oct 11, 2012 5:15 pm    Post subject: Reply with quote

eccerr0r wrote:
What host USB adaptor is it? Hope not made by VIA?
No, it is ThinkPad :
Code:
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 003: ID 1bcf:0c31 Sunplus Innovation Technology Inc. SPIF30x Serial-ATA bridge
Bus 001 Device 004: ID 0a5c:217f Broadcom Corp. Bluetooth Controller
Bus 001 Device 005: ID 04f2:b221 Chicony Electronics Co., Ltd integrated camera
Bus 002 Device 003: ID 05e3:0608 Genesys Logic, Inc. USB-2.0 4-Port HUB
Bus 002 Device 004: ID 17ef:1003 Lenovo Integrated Smart Card Reader
Bus 002 Device 005: ID 046d:c062 Logitech, Inc. LS1 Laser Mouse, corded
Bus 002 Device 006: ID 043d:0078 Lexmark International, Inc. InkJet Color Printer
Bus 002 Device 007: ID 046a:0023 Cherry GmbH CyMotion Master Linux Keyboard
the HD (180 GB partition of a 750GiB drive) is the "Sunplus Innovation Technology Inc. SPIF30x Serial-ATA bridge"


Well, and this was in the syslog :
Code:
2012-10-11T17:33:13.065+02:00 n22 kernel: EXT4-fs error (device sdb3) in ext4_new_inode:936: IO failure
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum