Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
emerging Virtualbox fails due to "WSDLParseException"
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
psychedup
n00b
n00b


Joined: 02 Oct 2012
Posts: 3
Location: Bremerton, WA, US

PostPosted: Tue Oct 02, 2012 10:02 pm    Post subject: emerging Virtualbox fails due to "WSDLParseException&qu Reply with quote

I've got 2 gentoo boxes that have had Virtualbox running just fine for quite some time, and I use the vboxwebsrv to manage the virtualbox guests remotely. I recently started messing with some apache settings on one machine and the vboxwebsrv page quit working (although Virtualbox itself still worked fine if I ran it under Gnome or Xfce).

In attempting to get it working again I uninstalled & tried re-emerging Virtualbox but I keep running into this error. I also attempted to re-emerge Virtualbox on my other machine (the one that wasn't having any problems) and hit the same error message, so now I'm not sure if the root problem was my messing with apache or not at all.

The main error message is here:

Code:
Exception in thread "main" com.sun.tools.internal.ws.util.WSDLParseException: Encountered error in wsdl. Check namespace of element <message>
        at com.sun.tools.internal.ws.util.xml.XmlUtil.matchesTagNS(XmlUtil.java:58)
        at com.sun.tools.internal.ws.wsdl.parser.WSDLParser.parseDefinitionsNoImport(WSDLParser.java:292)
        at com.sun.tools.internal.ws.wsdl.parser.WSDLParser.processImports(WSDLParser.java:237)
        at com.sun.tools.internal.ws.wsdl.parser.WSDLParser.parseDefinitions(WSDLParser.java:212)
        at com.sun.tools.internal.ws.wsdl.parser.WSDLParser.buildWSDLDocument(WSDLParser.java:188)
        at com.sun.tools.internal.ws.wsdl.parser.WSDLParser.parse(WSDLParser.java:155)
        at com.sun.tools.internal.ws.processor.modeler.wsdl.WSDLModeler.buildModel(WSDLModeler.java:115)
        at com.sun.tools.internal.ws.wscompile.WsimportTool.run(WsimportTool.java:172)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
        at java.lang.reflect.Method.invoke(Method.java:616)
        at com.sun.tools.internal.ws.Invoker.invoke(Invoker.java:105)
        at com.sun.tools.internal.ws.WsImport.main(WsImport.java:41)


emerge --info:
Code:
Portage 2.1.11.9 (default/linux/amd64/10.0/desktop, gcc-4.5.4, glibc-2.15-r2, 3.0.6-gentoo x86_64)
=================================================================
System uname: Linux-3.0.6-gentoo-x86_64-AMD_Athlon-tm-_64_Processor_3200+-with-gentoo-2.1
Timestamp of tree: Tue, 02 Oct 2012 14:45:01 +0000
ccache version 3.1.7 [enabled]
app-shells/bash:          4.2_p37
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.3-r2, 3.1.4-r3, 3.2.3
dev-util/ccache:          3.1.7
dev-util/cmake:           2.8.7-r5
dev-util/pkgconfig:       0.27.1
sys-apps/baselayout:      2.1-r1
sys-apps/openrc:          0.9.8.4
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.9.6-r3, 1.11.6
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.5.4
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r3
sys-kernel/linux-headers: 3.4-r2 (virtual/os-headers)
sys-libs/glibc:           2.15-r2
Repositories: gentoo
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe -march=athlon64"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt /usr/share/openvpn/easy-rsa"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.4/ext-active/ /etc/php/cgi-php5.4/ext-active/ /etc/php/cli-php5.4/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -pipe -march=athlon64"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs ccache config-protect-if-modified distlocks ebuild-locks fixlafiles news parallel-fetch parse-eapi-ebuild-head protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://gentoo.osuosl.org/ ftp://distro.ibiblio.org/pub/linux/distributions/gentoo/ http://distro.ibiblio.org/pub/linux/distributions/gentoo/ ftp://ftp.gtlib.gatech.edu/pub/gentoo http://www.gtlib.gatech.edu/pub/gentoo ftp://mirror.iawnet.sandia.gov/pub/gentoo/ ftp://ftp.ussg.iu.edu/pub/linux/gentoo ftp://ftp.ucsb.edu/pub/mirrors/linux/gentoo/ http://ftp.ucsb.edu/pub/mirrors/linux/gentoo/ http://cudlug.cudenver.edu/gentoo/ http://gentoo.mirrors.pair.com/ ftp://gentoo.mirrors.pair.com/ http://gentoo.mirrors.tds.net/gentoo ftp://gentoo.mirrors.tds.net/gentoo http://gentoo.netnitco.net ftp://gentoo.netnitco.net/pub/mirrors/gentoo/source/ http://open-systems.ufl.edu/mirrors/gentoo http://gentoo.llarian.net/ ftp://gentoo.llarian.net/pub/gentoo http://gentoo.binarycompass.org http://mirror.datapipe.net/gentoo ftp://mirror.datapipe.net/gentoo http://mirrors.cs.wmich.edu/gentoo http://mirror.usu.edu/mirrors/gentoo/ http://mirror.mcs.anl.gov/pub/gentoo/ ftp://mirror.mcs.anl.gov/pub/gentoo/ http://gentoo.mirrors.easynews.com/linux/gentoo/ http://gentoo.cites.uiuc.edu/pub/gentoo/ ftp://gentoo.cites.uiuc.edu/pub/gentoo/ ftp://ftp.wallawalla.edu/pub/mirrors/ftp.gentoo.org http://gentoo.chem.wisc.edu/gentoo/ ftp://gentoo.chem.wisc.edu/gentoo/ http://lug.mtu.edu/gentoo/ ftp://lug.mtu.edu/gentoo/ http://gentoo.mirrors.hoobly.com/ http://chi-10g-1-mirror.fastsoft.net/pub/linux/gentoo/gentoo-distfiles/ ftp://chi-10g-1-mirror.fastsoft.net/pub/linux/gentoo/gentoo-distfiles/ http://mirror.its.uidaho.edu/pub/gentoo/ ftp://mirror.its.uidaho.edu/gentoo/ http://www.cyberuse.com/gentoo/ "
LANG="en_US"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en en_US"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync.namerica.gentoo.org/gentoo-portage"
USE="X a52 aac aalib acl acpi alsa amd64 apache2 aspell avahi berkdb branding bzip2 cairo cdda cdparanoia cdr cdrkit cli consolekit cracklib crypt cups curl cxx dbus dri dts dv dvd dvdr emboss encode exif fam fbcon ffmpeg firefox flac fortran fuse gd gdbm gif gimp gnome gnutls gphoto2 gpm gtk gtk3 iconv id3tag ipv6 java jpeg lame lcms ldap libnotify lock mad melt mmx mng modules mp3 mp4 mpeg mudflap multilib mysql ncurses nls nptl nsplugin ogg opengl openmp pam pango parport pcre pdf png policykit ppds pppd python python3 qt3 qt3support qt4 quicktime readline samba scanner sdl semantic-desktop session spell sql sse sse2 ssl startup-notification svg swat taglib tcl tcpd threads thunar tiff tk truetype udev udisks unicode upower usb vcd vhosts vorbis wav webkit wma wmf wxwidgets x264 xcb xinerama xml xscreensaver xulrunner xv xvfb xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en en_US" PHP_TARGETS="php5-3" PYTHON_TARGETS="python3_2 python2_7" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="radeon" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON


Code:
!!! When you file a bug report, please include the following information:
GENTOO_VM=icedtea-bin-6  CLASSPATH="" JAVA_HOME="/opt/icedtea-bin-6.1.11.4"
JAVACFLAGS="-source 1.6 -target 1.6" COMPILER=""


Has anyone else run into this problem? Do you think I'm doing something wrong or is it a bug?

Thanks,
Chris
Back to top
View user's profile Send private message
rad_scorpion
n00b
n00b


Joined: 24 Jun 2010
Posts: 8

PostPosted: Thu Oct 04, 2012 2:24 pm    Post subject: Reply with quote

Yes, I had the same problem a few minutes ago. I just turned the web service use flag off, and everything compiled fine. Judging by the google answers, it's not the problem in the virtualbox itself. But switching the web completely may be not the solution you want, in this case I can't help, sorry. ;)
Back to top
View user's profile Send private message
psychedup
n00b
n00b


Joined: 02 Oct 2012
Posts: 3
Location: Bremerton, WA, US

PostPosted: Thu Oct 04, 2012 2:58 pm    Post subject: Reply with quote

Thanks for conifirming that it wasn't just me :)

I also tried it yesterday without the vboxwebsrv flag and it compiled just fine. I really love that feature but I guess I'll have to live without it for a while. I'm going to open a bug so hopefully it can be fixed.

Chris
Back to top
View user's profile Send private message
qcaze
n00b
n00b


Joined: 26 May 2004
Posts: 8

PostPosted: Wed Oct 10, 2012 8:34 pm    Post subject: Reply with quote

Having vboxwebsrv off also works for me. Same for virtualbox-4.2.0-r1 btw.
Even tried with Sun's java (sun-jdk-1.6) instead of icedtea6-bin but no luck.
Any news on this?

.morten
Back to top
View user's profile Send private message
badm4n
n00b
n00b


Joined: 12 Oct 2012
Posts: 2
Location: Pennsylvania

PostPosted: Sat Oct 13, 2012 1:59 am    Post subject: Reply with quote

I have been beating my head against a wall all night trying to fix this. I think I found what is causing the error, but I do not know enough about XSLT to be able to fix it. Whatever is creating:
Code:
./work/VirtualBox-4.2.0/out/arch/release/bin/sdk/bindings/webservice/vboxweb.wsdl
is putting an empty xmlns (xmlns="") attribute for all <message> and <operation> tags beginning around line 15880. If I manually remove these tags, the WSDL parsing command will succeed.

Anyone out there have the knowledge to figure out what is missing to cause this empty namespace attribute or where to start looking to try and get this fixed?
_________________
[ badm4n ]
Back to top
View user's profile Send private message
psychedup
n00b
n00b


Joined: 02 Oct 2012
Posts: 3
Location: Bremerton, WA, US

PostPosted: Sat Oct 13, 2012 2:41 am    Post subject: Reply with quote

I opened bug #437192 a few days ago and several other users have joined it. It sounds like a patch from bug #436246 may be what broke it for us.
Back to top
View user's profile Send private message
Snaketails
n00b
n00b


Joined: 01 Jul 2003
Posts: 62
Location: Boronia.Vic.Oz.Au

PostPosted: Sun Oct 14, 2012 9:42 am    Post subject: Reply with quote

Thank you for the solution to the problem I have with virtualbox installing, removing vboxwebsrv from the use flags allowed me to install virtualbox :)

I tried the -bin install, but I couldn't get a headless install, with that option removed.

Now I can run asterisk inside the virtualbox once again :)
Back to top
View user's profile Send private message
muhsinzubeir
l33t
l33t


Joined: 29 Sep 2007
Posts: 937
Location: /home/muhsin

PostPosted: Mon Oct 29, 2012 10:28 pm    Post subject: Reply with quote

Thanks guys turning off this vboxwebsrv also did the trick here :)
_________________
~x86
p5k-se
Intel Core 2 Duo
Nvidia GT200
http://www.zanbytes.com
Back to top
View user's profile Send private message
drutten
Tux's lil' helper
Tux's lil' helper


Joined: 31 Dec 2003
Posts: 103
Location: Umeå, Sweden

PostPosted: Wed Oct 31, 2012 6:27 pm    Post subject: Reply with quote

Thanks, solved it for me too. Now I hope someone solves the problem with vboxwebsrv.
Back to top
View user's profile Send private message
Mustela
n00b
n00b


Joined: 22 Nov 2009
Posts: 42

PostPosted: Sun Nov 04, 2012 5:04 pm    Post subject: Reply with quote

Hello. The version 4.2.2 have the same bug.
Back to top
View user's profile Send private message
dewke
Tux's lil' helper
Tux's lil' helper


Joined: 01 Jun 2004
Posts: 75
Location: back in the black hole

PostPosted: Thu Nov 15, 2012 3:53 pm    Post subject: Reply with quote

Mustela wrote:
Hello. The version 4.2.2 have the same bug.


If you downgrade libxslt to 1.1.26 you can install virtualbox with the vboxwebsrv use flag.
_________________
Oderint dum metuant
-Caligula
Back to top
View user's profile Send private message
Mustela
n00b
n00b


Joined: 22 Nov 2009
Posts: 42

PostPosted: Thu Nov 15, 2012 4:26 pm    Post subject: Reply with quote

dewke wrote:
Mustela wrote:
Hello. The version 4.2.2 have the same bug.


If you downgrade libxslt to 1.1.26 you can install virtualbox with the vboxwebsrv use flag.
Thanks, Dewke. In 2-3 hours I check it. :)
_________________
Highest updated PentiumII-233MHz laptop con 128MB de RAM y Gentoo :)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum