Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
net-libs/farsight2 is blocking net-libs/farstream [solved]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
shallpion
Guru
Guru


Joined: 29 Sep 2008
Posts: 331

PostPosted: Sat Sep 29, 2012 2:43 am    Post subject: net-libs/farsight2 is blocking net-libs/farstream [solved] Reply with quote

Hi. During a recent update, I noticed that

Quote:
[blocks B ] net-libs/farsight2 ("net-libs/farsight2" is blocking net-libs/farstream-0.1.2-r1)


(net-libs/farsight2-0.0.31::gentoo, installed) pulled in by
net-libs/farsight2[python] required by (dev-python/papyon-0.5.6::gentoo, installed)

(net-libs/farstream-0.1.2-r1::gentoo, ebuild scheduled for merge) pulled in by
>=net-libs/farstream-0.1.0 required by (net-libs/telepathy-farstream-0.4.0::gentoo, ebuild scheduled for merge)
net-libs/farstream required by (net-im/empathy-3.4.2.3::gentoo, ebuild scheduled for merge)



The only way I could get around this dependency conflict is to mask farstream. Is there a correct way to deal with this problem? Thanks.


Last edited by shallpion on Tue Nov 06, 2012 5:50 am; edited 1 time in total
Back to top
View user's profile Send private message
t0dbld
n00b
n00b


Joined: 23 Jun 2011
Posts: 34

PostPosted: Fri Oct 05, 2012 6:03 am    Post subject: Re: net-libs/farsight2 is blocking net-libs/farstream Reply with quote

shallpion wrote:
Hi. During a recent update, I noticed that

Quote:
[blocks B ] net-libs/farsight2 ("net-libs/farsight2" is blocking net-libs/farstream-0.1.2-r1)


(net-libs/farsight2-0.0.31::gentoo, installed) pulled in by
net-libs/farsight2[python] required by (dev-python/papyon-0.5.6::gentoo, installed)

(net-libs/farstream-0.1.2-r1::gentoo, ebuild scheduled for merge) pulled in by
>=net-libs/farstream-0.1.0 required by (net-libs/telepathy-farstream-0.4.0::gentoo, ebuild scheduled for merge)
net-libs/farstream required by (net-im/empathy-3.4.2.3::gentoo, ebuild scheduled for merge)



The only way I could get around this dependency conflict is to mask farstream. Is there a correct way to deal with this problem? Thanks.


Same issue you ever find anything out ?
Back to top
View user's profile Send private message
shallpion
Guru
Guru


Joined: 29 Sep 2008
Posts: 331

PostPosted: Fri Oct 05, 2012 6:05 am    Post subject: Reply with quote

nope :( still waiting for a miracle after next update
Back to top
View user's profile Send private message
paulj
Guru
Guru


Joined: 30 Sep 2004
Posts: 342
Location: Wales, UK

PostPosted: Sun Oct 07, 2012 4:17 pm    Post subject: Reply with quote

I came across this problem, and on investigation identified that farstream is basically superseding farsight. I un-merged net-libs/farsight2 and net-libs/telepathy-farsight, and then merged net-libs/farstream and net-libs/telepathy-farstream. I re-emerged the programs which used the older packages, and they reverted to using the later version. I didn't need to mask anything.

I apologise if this sounds slightly vague, but I recently removed Gnome from my system, and none of these files are required are longer, so they have all gone.
Back to top
View user's profile Send private message
vootey
n00b
n00b


Joined: 24 Jul 2010
Posts: 29
Location: Austria

PostPosted: Wed Oct 10, 2012 3:34 pm    Post subject: Reply with quote

same here.
ktp-call-ui requires farstream and papyon and pidgin require farsight2.
farsight2 and farstream are blocking each other.

any news?
Back to top
View user's profile Send private message
paulj
Guru
Guru


Joined: 30 Sep 2004
Posts: 342
Location: Wales, UK

PostPosted: Wed Oct 10, 2012 4:10 pm    Post subject: Reply with quote

vootey wrote:
same here.
ktp-call-ui requires farstream and papyon and pidgin require farsight2.
farsight2 and farstream are blocking each other.

any news?


Actually, from what I can see in the latest ebuilds, ktp-call-ui requires farstream, papyon requires farsight2, but pidgin will work with which ever is installed.

I suggest you push the developers upstream to consider moving to farstream, or better still allowing either to be used, as pidgin does. Seeing which packages you are struggling with explains why I didn't have a problem in the end - clearly whatever wanted access to these libraries was configured to use which ever was available.
Back to top
View user's profile Send private message
shallpion
Guru
Guru


Joined: 29 Sep 2008
Posts: 331

PostPosted: Tue Nov 06, 2012 5:48 am    Post subject: Reply with quote

I manually deleted all packages depending farsight2 and all packages depending on them, and go on until the dependencies were cleaned. Then re-emerge the world and it succeeded. I don't know why depclean would not remove these packages...
Back to top
View user's profile Send private message
cami
n00b
n00b


Joined: 15 Jan 2005
Posts: 17

PostPosted: Sat Dec 29, 2012 2:42 pm    Post subject: Reply with quote

Depclean will never remove packages that are in @system, @world or (possibly deep) dependencies of those. If you want to remove a subtree, you need to obsolete it first by removing the packages that require it (check with equery depends atom). Only when no more packages require the subtree, depclean will unmerge it. Note that if a dependency can be satisfied by different packages, like "farsight | farstream", a package that could be safely removed might still be considered "needed" by depclean, because it does not know which of the two packages satisfied the dependency at compile time.

Some packages still depend on farsight, even though they would work with farstream as well. This is kind of a bug and should be reported to the package maintainer when needed. Papyon seems to need a bit of patching for the migration, haven't tested that yet.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum