Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
cannot emerge gv-3.7.3-r1
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
GungHo
Apprentice
Apprentice


Joined: 27 Aug 2004
Posts: 254

PostPosted: Wed Oct 10, 2012 7:42 am    Post subject: cannot emerge gv-3.7.3-r1 Reply with quote

Hi all,

on my box is app-text/gv-3.7.1-r1 installed. When trying to do an emerge -u --deep world all is running well, but when it comes to ghostview emerge stops with

Code:

 * Messages for package app-text/gv-3.7.3-r1:

 * ERROR: app-text/gv-3.7.3-r1 failed (configure phase):
 *   econf failed
 *
 * Call stack:
 *          ebuild.sh, line   85:  Called src_configure
 *        environment, line 2331:  Called econf '--enable-scrollbar-code' '--disable-international'
 *   phase-helpers.sh, line  467:  Called die
 * The specific snippet of code:
 *            die "econf failed"
 *
 * If you need support, post the output of `emerge --info '=app-text/gv-3.7.3-r1'`,
 * the complete build log and the output of `emerge -pqv '=app-text/gv-3.7.3-r1'`.
 * The complete build log is located at '/var/tmp/portage/app-text/gv-3.7.3-r1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/app-text/gv-3.7.3-r1/temp/environment'.
 * Working directory: '/var/tmp/portage/app-text/gv-3.7.3-r1/work/gv-3.7.3'
 * S: '/var/tmp/portage/app-text/gv-3.7.3-r1/work/gv-3.7.3'


Scrolling a bit back I can see

Code:
checking for XawInitializeWidgetSet in -lXaw3d... no
configure: error: Unable to find a valid Xaw3d library. Please install it and rerun configure.


But libxaw3d is installed in the recent version:

Code:
# qlist -ICv libXaw
x11-libs/libXaw-1.0.11
x11-libs/libXaw3d-1.6.2


and there are also some files in /usr/X11R6/lib

Code:
# ls -l libXaw*
lrwxrwxrwx 1 root root     10 Jul  1 18:45 libXaw.so -> libXaw7.so
lrwxrwxrwx 1 root root     12 Jul  1 18:45 libXaw.so.6 -> libXaw6.so.6
lrwxrwxrwx 1 root root     12 Jul  1 18:45 libXaw.so.7 -> libXaw7.so.7
-rw-r--r-- 1 root root 506432 Oct 10 09:02 libXaw3d.a
lrwxrwxrwx 1 root root     17 Oct 10 09:02 libXaw3d.so -> libXaw3d.so.8.0.0
lrwxrwxrwx 1 root root     17 Oct 10 09:02 libXaw3d.so.8 -> libXaw3d.so.8.0.0
-rwxr-xr-x 1 root root 330664 Oct 10 09:02 libXaw3d.so.8.0.0
-rw-r--r-- 1 root root 521392 Jul  1 18:45 libXaw6.a
lrwxrwxrwx 1 root root     16 Jul  1 18:45 libXaw6.so -> libXaw6.so.6.0.1
lrwxrwxrwx 1 root root     16 Jul  1 18:45 libXaw6.so.6 -> libXaw6.so.6.0.1
-rwxr-xr-x 1 root root 340048 Jul  1 18:45 libXaw6.so.6.0.1
-rw-r--r-- 1 root root 719972 Jul  1 18:45 libXaw7.a
lrwxrwxrwx 1 root root     16 Jul  1 18:45 libXaw7.so -> libXaw7.so.7.0.0
lrwxrwxrwx 1 root root     16 Jul  1 18:45 libXaw7.so.7 -> libXaw7.so.7.0.0
-rwxr-xr-x 1 root root 467808 Jul  1 18:45 libXaw7.so.7.0.0


So what's wrong ?

This is the output of emerge --info '=app-text/gv-3.7.3-r1'
Code:

Portage 2.1.11.9 (default/linux/amd64/10.0, gcc-4.5.4, glibc-2.15-r2, 3.4.9-gentoo x86_64)
=================================================================
                        System Settings
=================================================================
System uname: Linux-3.4.9-gentoo-x86_64-AMD_Athlon-tm-_II_X4_640_Processor-with-gentoo-2.1
Timestamp of tree: Wed, 10 Oct 2012 05:30:01 +0000
app-shells/bash:          4.2_p37
dev-java/java-config:     1.3.7-r1, 2.1.11-r3
dev-lang/python:          2.6.6-r2, 2.7.3-r2, 3.1.4-r3, 3.2.3
dev-util/cmake:           2.8.7-r5
dev-util/pkgconfig:       0.27.1
sys-apps/baselayout:      2.1-r1
sys-apps/openrc:          0.9.8.4
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.10.3, 1.11.6
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.4.5, 4.5.4
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r3
sys-kernel/linux-headers: 3.4-r2 (virtual/os-headers)
sys-libs/glibc:           2.15-r2
Repositories: gentoo x-portage
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -march=k8 -pipe -fomit-frame-pointer"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -march=k8 -pipe -fomit-frame-pointer"
DISTDIR="/opt/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs collision-protect config-protect-if-modified distlocks ebuild-locks fixlafiles news parallel-fetch parse-eapi-ebuild-head protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://mirror.bytemark.co.uk/gentoo/ http://212.219.56.135/sites/www.ibiblio.org/gentoo/ http://212.219.56.153/sites/www.ibiblio.org/gentoo/ http://mirror.pacific.net.au/linux/Gentoo http://212.219.56.134/sites/www.ibiblio.org/gentoo/"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en en_gb de"
MAKEOPTS="-j5"
PKGDIR="/opt/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext X a52 aac acl alsa amd64 avi berkdb bzip2 cairo cdparanoia cdr cli consolekit cracklib crypt cups cxx dbus device-mapper dga directfb dlloader dri dvb dvd dvdr dvdread encode fam fat flac fontconfig fts3 gcdmaster gdbm gdu gif gnutls gphoto2 gpm gtk hwdb iconv imap imlib ipv6 java jpeg ldap link mmx mmxext modules mpeg mplayer mudflap multilib musepack ncurses nls nocardbus nptl nptlonly nsplugin ntfs nvidia ogg opengl openmp pam pcre pda pdf pdflib perl png policykit ppd pppd rar readline rtc ruby sdl session smp sox sqlite sse sse2 ssl static-libs subtitles svg tcpd threads tiff truetype udev usb v4l v4l2 vorbis xfs xv xvid zlib" ALSA_CARDS="hda_intel emu10k1" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en en_gb de" PHP_TARGETS="php5-3" PYTHON_TARGETS="python3_2 python2_7" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="nv vesa nvidia nuveau" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON


who can help ?

Thanks in advance.
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 5618

PostPosted: Thu Oct 11, 2012 2:31 pm    Post subject: Reply with quote

Pastebin config.log.
Back to top
View user's profile Send private message
GungHo
Apprentice
Apprentice


Joined: 27 Aug 2004
Posts: 254

PostPosted: Fri Oct 12, 2012 10:12 am    Post subject: Reply with quote

Hi VoidMage,

thanks for your reply :D

Throwing an eye into config.log I can see

Code:
configure:13409: checking for XawInitializeWidgetSet in -lXaw3d
configure:13434: x86_64-pc-linux-gnu-gcc -o conftest -O2 -march=k8 -pipe -fomit-frame-pointer  -DXAW_GRAY_BLKWHT_STIPPLES -DXAW_ARROW_SCROLLBARS   -Wl,-O1 -Wl,--as-needed conftest.c -lXaw3d  -lXpm -lXmu -lXt -lXext -lSM -lICE -lX11 -lfl -lm  >&5
/usr/lib/gcc/x86_64-pc-linux-gnu/4.5.4/../../../../lib64/libXaw3d.so: undefined reference to `multiSinkObjectClass'
/usr/lib/gcc/x86_64-pc-linux-gnu/4.5.4/../../../../lib64/libXaw3d.so: undefined reference to `multiSrcObjectClass'
collect2: ld returned 1 exit status
configure:13434: $? = 1
configure: failed program was:
| /* confdefs.h */
| #define PACKAGE_NAME ""
| #define PACKAGE_TARNAME ""
| #define PACKAGE_VERSION ""
| #define PACKAGE_STRING ""
| #define PACKAGE_BUGREPORT ""
| #define PACKAGE_URL ""
| #define PACKAGE "gv"
| #define VERSION "3.7.3"
| #define STDC_HEADERS 1
| #define HAVE_SYS_TYPES_H 1


and a lot more #defines following. But I cannot identify the prob.

It's in http://pastebin.com/VLBdC1uN

cheers
Back to top
View user's profile Send private message
megabaks
Apprentice
Apprentice


Joined: 22 Jan 2012
Posts: 253
Location: Russia && Saint-Petersburg

PostPosted: Fri Oct 12, 2012 12:02 pm    Post subject: Reply with quote

revdep-rebuild
Back to top
View user's profile Send private message
GungHo
Apprentice
Apprentice


Joined: 27 Aug 2004
Posts: 254

PostPosted: Fri Oct 12, 2012 4:04 pm    Post subject: Reply with quote

Hi megabaks,

thanks for your reply :D .

But no luck :( .

It's not that easy.

cheers
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 5618

PostPosted: Fri Oct 12, 2012 4:17 pm    Post subject: Reply with quote

Just a guess - you might need it rebuilt with 'unicode' useflag (API separation in this lib was done quite poorly).
Back to top
View user's profile Send private message
GungHo
Apprentice
Apprentice


Joined: 27 Aug 2004
Posts: 254

PostPosted: Sun Oct 14, 2012 1:37 pm    Post subject: Reply with quote

Hi VoidMage,

success :D . That did it.

Now the use-flags of this 2 packages are pretty weird, but at least this is a workaround about the bad API separation:

Code:
# equery uses app-text/gv     
[ Legend : U - final flag setting for installation]
[        : I - package is installed with flag     ]
[ Colors : set, unset                             ]
 * Found these USE flags for app-text/gv-3.7.3-r1:
 U I
 - - unicode  : Adds support for Unicode
 - - xinerama : Add support for the xinerama X11 extension, which is mandatory
                if you work in multiple monitors setup
# equery uses x11-libs/libXaw3d
[ Legend : U - final flag setting for installation]
[        : I - package is installed with flag     ]
[ Colors : set, unset                             ]
 * Found these USE flags for x11-libs/libXaw3d-1.6.2:
 U I
 + + static-libs : Build static libraries
 + + unicode     : Adds support for Unicode


Thanks a lot for your assistence.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum