Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Login stops when number one is pressed [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo
View previous topic :: View next topic  
Author Message
stu_rat
n00b
n00b


Joined: 17 Jan 2011
Posts: 39
Location: UK

PostPosted: Mon Oct 08, 2012 8:06 pm    Post subject: Login stops when number one is pressed [SOLVED] Reply with quote

I did a world update yesterday and I now have a strange login problem. One of the characters in my password is the number 1. When I enter this character, the screen goes blank and the cursor jumps to the top of the screen. No further input is accepted, but if I press Alt+F1 I can return to the console and enter the remaining characters of my password to login successfully. The same thing happens if I enter a username that contains a number 1. It's only the number 1 that causes this behaviour, other numbers are fine.

What could be the cause of this problem?


Last edited by stu_rat on Tue Oct 09, 2012 8:16 pm; edited 1 time in total
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 6593
Location: Goose Creek SC

PostPosted: Mon Oct 08, 2012 9:35 pm    Post subject: Reply with quote

http://www.gentoo.org/doc/en/guide-localization.xml

nano -w /etc/conf.d/keymaps
Take special care with the keymap variable. If you select the wrong keymap, you will get weird results when typing on your keyboard.

When you're finished configuring /etc/conf.d/keymaps, save and exit.

Gentoo uses /etc/conf.d/hwclock to set clock options. Edit it according to your needs.
_________________
Defund the FCC.
Back to top
View user's profile Send private message
stu_rat
n00b
n00b


Joined: 17 Jan 2011
Posts: 39
Location: UK

PostPosted: Tue Oct 09, 2012 7:35 pm    Post subject: Reply with quote

DONAHUE wrote:
http://www.gentoo.org/doc/en/guide-localization.xml

nano -w /etc/conf.d/keymaps
Take special care with the keymap variable. If you select the wrong keymap, you will get weird results when typing on your keyboard.



I checked that file and it's the same as it was when I first installed Gentoo. And even then the only change I made to it was to change the keymap from "us" to "uk".

I feel it is something to do with keymaps however, as I have another strange symptom - whenever I type the letter "a" within a desktop application, I get "a." i.e. the letter plus a dot. And if I hold down the "a" key, I don't get a series of letters, but a series of dots.
Back to top
View user's profile Send private message
Jaglover
Advocate
Advocate


Joined: 29 May 2005
Posts: 4658
Location: Saint Amant, Acadiana

PostPosted: Tue Oct 09, 2012 7:54 pm    Post subject: Reply with quote

Do you get same behavior when booting some Linux CD?
_________________
Please learn how to denote units correctly!
Back to top
View user's profile Send private message
stu_rat
n00b
n00b


Joined: 17 Jan 2011
Posts: 39
Location: UK

PostPosted: Tue Oct 09, 2012 8:15 pm    Post subject: Reply with quote

Jaglover wrote:
Do you get same behavior when booting some Linux CD?


Yes, but not if I boot into Windows.

I've change my keyboard and that has fixed it.

Thanks for the question. That prompted me to try a different keyboard.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum