Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] Libreoffice requires "xhost +"
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Circuitsoft
Tux's lil' helper
Tux's lil' helper


Joined: 14 Jul 2004
Posts: 112

PostPosted: Mon Oct 08, 2012 3:40 pm    Post subject: [solved] Libreoffice requires "xhost +" Reply with quote

I find that I cannot start Libreoffice without disabling X11 access control. I have no problems with any other installed apps, so I don't know what the issue here is.

Code:
alex@alex-thinks ~/Downloads $ lowriter Doc1.doc
XDM authorization key matches an existing client!/usr/lib64/libreoffice/program/soffice.bin X11 error: Can't open display:
   Set DISPLAY environment variable, use -display option
   or check permissions of your X-Server
   (See "man X" resp. "man xhost" for details)
alex@alex-thinks ~/Downloads $ pgrep soffi
alex@alex-thinks ~/Downloads $ xhost +
access control disabled, clients can connect from any host
alex@alex-thinks ~/Downloads $ lowriter Doc1.doc
alex@alex-thinks ~/Downloads $ xhost -
access control enabled, only authorized clients can connect
alex@alex-thinks ~/Downloads $ lowriter Doc1.doc
XDM authorization key matches an existing client!/usr/lib64/libreoffice/program/soffice.bin X11 error: Can't open display:
   Set DISPLAY environment variable, use -display option
   or check permissions of your X-Server
   (See "man X" resp. "man xhost" for details)
alex@alex-thinks ~/Downloads $ lowriter --version
LibreOffice 3.5

alex@alex-thinks ~/Downloads $ X -version

X.Org X Server 1.12.2
Release Date: 2012-05-29
X Protocol Version 11, Revision 0
Build Operating System: Linux 3.2.1-gentoo-r2 x86_64 Gentoo
Current Operating System: Linux alex-thinks 3.4.9-gentoo #2 SMP Mon Aug 27 18:09:05 CDT 2012 x86_64
Kernel command line: root=/dev/sda4 rootfstype=ext4 acpi_osi=Linux BOOT_IMAGE=/boot/vmlinuz-3.4.9-gentoo
Build Date: 30 July 2012  04:48:43AM
 
Current version of pixman: 0.26.0
        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.


Oddly enough, it does work sometimes. After a bit of reading elsewhere, it would appear to be a race condition involving a fork and a failure to close the X connection in the parent process.


Last edited by Circuitsoft on Mon Oct 08, 2012 7:13 pm; edited 1 time in total
Back to top
View user's profile Send private message
eccerr0r
Advocate
Advocate


Joined: 01 Jul 2004
Posts: 4015
Location: USA

PostPosted: Mon Oct 08, 2012 4:31 pm    Post subject: Reply with quote

What desktop environment are you using?

Does running other X11 applications have the same problem (if started at the same command line?)
_________________
Intel Core i7 2700K@ 4.1GHz/HD3000 graphics/8GB DDR3/180GB SSD
What am I supposed to be advocating?
Back to top
View user's profile Send private message
Circuitsoft
Tux's lil' helper
Tux's lil' helper


Joined: 14 Jul 2004
Posts: 112

PostPosted: Mon Oct 08, 2012 4:47 pm    Post subject: Reply with quote

Openbox with XDM. I've had no problems with other apps.
Back to top
View user's profile Send private message
Circuitsoft
Tux's lil' helper
Tux's lil' helper


Joined: 14 Jul 2004
Posts: 112

PostPosted: Mon Oct 08, 2012 4:51 pm    Post subject: Reply with quote

So, the fix seems to be to add
Code:
DisplayManager*authName:        MIT-MAGIC-COOKIE-1
to /etc/X11/xdm/xdm-config
Back to top
View user's profile Send private message
toralf
Advocate
Advocate


Joined: 01 Feb 2004
Posts: 2717
Location: Hamburg/Germany

PostPosted: Mon Oct 08, 2012 5:05 pm    Post subject: Reply with quote

Circuitsoft wrote:
So, the fix seems to be to add
Code:
DisplayManager*authName:        MIT-MAGIC-COOKIE-1
to /etc/X11/xdm/xdm-config
/me wonders whether you checked before w/o xdm (simply by startx or xinit) or not ...
Back to top
View user's profile Send private message
Circuitsoft
Tux's lil' helper
Tux's lil' helper


Joined: 14 Jul 2004
Posts: 112

PostPosted: Mon Oct 08, 2012 5:08 pm    Post subject: Reply with quote

No, I didn't, but after some reading, it appears that xdm sets some extra security cookies that other DMs don't, and the setting above disables them.
Back to top
View user's profile Send private message
toralf
Advocate
Advocate


Joined: 01 Feb 2004
Posts: 2717
Location: Hamburg/Germany

PostPosted: Mon Oct 08, 2012 5:24 pm    Post subject: Reply with quote

Circuitsoft wrote:
No, I didn't, but after some reading, it appears that xdm sets some extra security cookies that other DMs don't, and the setting above disables them.
Ah - thx for the info.
BTW you might now put a "[solved]" in front of the topic :-)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum