Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
mythtv: increase live tv buffer?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
danomac
l33t
l33t


Joined: 06 Nov 2004
Posts: 817
Location: Vancouver, BC

PostPosted: Mon Oct 08, 2012 1:12 am    Post subject: mythtv: increase live tv buffer? Reply with quote

My mythtv frontend skips video and audio and sometimes stops with a buffer error.

I just discovered that rewinding right after starting live TV fixes it - I have been watching live TV for over 45 minutes and no skips or crashing with a buffer error.

I have done some looking but I don't see anything in the fronend. Is there a way to do this?
Back to top
View user's profile Send private message
Jaglover
Advocate
Advocate


Joined: 29 May 2005
Posts: 4560
Location: Saint Amant, Acadiana

PostPosted: Mon Oct 08, 2012 1:19 am    Post subject: Reply with quote

This was common with early 0.25, what version you are using?
_________________
Please learn how to denote units correctly!
Back to top
View user's profile Send private message
danomac
l33t
l33t


Joined: 06 Nov 2004
Posts: 817
Location: Vancouver, BC

PostPosted: Mon Oct 08, 2012 1:54 am    Post subject: Reply with quote

Code:

 $ sudo equery list mythtv
 * Searching for mythtv ...
[I-O] [  ] media-tv/mythtv-0.25.1_p20120622:0


I upgraded to that version as I read some fixes were in it for livetv, but my setup is still doing it. 1 backend, 3 frontends. I only use one frontend at a time.

Today I accidentally discovered rewinding live TV once so there's ~15 seconds in the queue fixes all the problems! Figures.

Edit: I see 0.26 is keyworded:

Code:

[ebuild     U  ] media-tv/mythtv-0.26_pre20120706::mythtv [0.25.1_p20120622::mythtv]


I do use my install to watch tv, so I don't want to upgrade until it's stabilized... :?
Back to top
View user's profile Send private message
Jaglover
Advocate
Advocate


Joined: 29 May 2005
Posts: 4560
Location: Saint Amant, Acadiana

PostPosted: Mon Oct 08, 2012 2:00 am    Post subject: Reply with quote

I'd give a shot to (~)0.25.2_p20120825.
_________________
Please learn how to denote units correctly!
Back to top
View user's profile Send private message
danomac
l33t
l33t


Joined: 06 Nov 2004
Posts: 817
Location: Vancouver, BC

PostPosted: Mon Oct 08, 2012 2:04 am    Post subject: Reply with quote

I think I'll try that tomorrow or Tuesday. I didn't even think to look to see if there were other versions masked in the mythtv overlay.
Back to top
View user's profile Send private message
Jaglover
Advocate
Advocate


Joined: 29 May 2005
Posts: 4560
Location: Saint Amant, Acadiana

PostPosted: Mon Oct 08, 2012 2:06 am    Post subject: Reply with quote

It's not in an overlay, it's in main tree.
_________________
Please learn how to denote units correctly!
Back to top
View user's profile Send private message
danomac
l33t
l33t


Joined: 06 Nov 2004
Posts: 817
Location: Vancouver, BC

PostPosted: Wed Oct 10, 2012 3:07 pm    Post subject: Reply with quote

I've been reading that 0.27 is the development branch and 0.26 is considered stable, so I guess I'll try to install 0.26 later today. I thought 0.26 was still considered the development branch.
Back to top
View user's profile Send private message
danomac
l33t
l33t


Joined: 06 Nov 2004
Posts: 817
Location: Vancouver, BC

PostPosted: Wed Oct 10, 2012 7:41 pm    Post subject: Reply with quote

So I've updated my backend and all my frontends. I watched about 10 minutes of live tv with no issues. I'll do a longer test, but I think it's solved. Live tv always kicked me in the butt. It just hates me. :?
Back to top
View user's profile Send private message
danomac
l33t
l33t


Joined: 06 Nov 2004
Posts: 817
Location: Vancouver, BC

PostPosted: Fri Oct 12, 2012 12:44 am    Post subject: Reply with quote

It's still doing it with 0.26.

Again, rewinding it 5 or 10 seconds fixes it.
Back to top
View user's profile Send private message
fuzzybee
Apprentice
Apprentice


Joined: 09 May 2005
Posts: 155

PostPosted: Wed Nov 21, 2012 12:33 pm    Post subject: Reply with quote

For some reason, .26 doesn't show up at all when I sync. Any ideas why?

Code:
# eix -s myth
* app-text/mythes
     Available versions:  1.2.3 {{static-libs}}
     Homepage:            http://hunspell.sourceforge.net/
     Description:         A simple thesaurus for Libreoffice

* media-libs/gmyth
     Available versions:  [M]0.7 {{debug}}
     Homepage:            http://gmyth.sourceforge.net/
     Description:         GObject based library to access mythtv backends

* media-plugins/gst-plugins-mythtv
     Available versions:  (0.10) [M]0.10.19^t [M]0.10.21^t [M]0.10.22^t
     Homepage:            http://gstreamer.freedesktop.org/
     Description:         plugin for gstreamer

[I] media-plugins/mythplugins
     Available versions:  (~)0.25.2_p20120716 (~)0.25.2_p20120825 {{cdda cdr exif fftw mytharchive mythbrowser mythgallery mythgame mythmusic mythnetvision mythnews mythweather raw}}
     Installed versions:  0.25.2_p20120825(07:15:05 09/05/12)(cdda cdr fftw mythbrowser mythmusic mythnetvision mythweather -exif -mytharchive -mythgallery -mythgame -mythnews -raw)
     Homepage:            http://www.mythtv.org
     Description:         Official MythTV plugins

[I] media-tv/mythtv
     Available versions:  (~)0.25.2_p20120716 (~)0.25.2_p20120825 {{alsa altivec autostart bluray cec crystalhd debug dvb dvd egl fftw +hls ieee1394 input_devices_joystick jack lcd libass lirc perl pulseaudio python raop +theora vaapi vdpau +vorbis +xml xmltv +xvid}}
     Installed versions:  0.25.2_p20120825(07:08:36 09/05/12)(alsa fftw hls python theora vdpau vorbis xml xvid -altivec -autostart -bluray -cec -crystalhd -debug -dvb -dvd -egl -ieee1394 -input_devices_joystick -jack -lcd -libass -lirc -perl -pulseaudio -raop -vaapi -xmltv)
     Homepage:            http://www.mythtv.org
     Description:         Homebrew PVR project

* media-tv/mythtv-status
     Available versions:  ~0.10.1
     Homepage:            http://www.etc.gen.nz/projects/mythtv/mythtv-status.html
     Description:         Displays the current status of MythTV at the command prompt

[I] www-apps/mythweb
     Available versions:  (0.25.2) (~)0.25.2
        {{vhosts}}
     Installed versions:  0.25.2(0.25.2)(07:03:40 08/20/12)(-vhosts)
     Homepage:            http://www.mythtv.org
     Description:         PHP scripts intended to manage MythTV from a web browser.
Back to top
View user's profile Send private message
danomac
l33t
l33t


Joined: 06 Nov 2004
Posts: 817
Location: Vancouver, BC

PostPosted: Wed Nov 21, 2012 3:42 pm    Post subject: Reply with quote

I'm using the overlay here.
Back to top
View user's profile Send private message
fuzzybee
Apprentice
Apprentice


Joined: 09 May 2005
Posts: 155

PostPosted: Thu Nov 22, 2012 2:52 am    Post subject: Reply with quote

Hmm - I went away from the overlay when I discovered an ebuild for .25. May be time to return.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum