Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Cannot use numeric keyboard after xorg-serve upgrade
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
BlackBelt
Guru
Guru


Joined: 27 Nov 2004
Posts: 369
Location: Messina/Pisa

PostPosted: Sun Oct 07, 2012 10:56 am    Post subject: Cannot use numeric keyboard after xorg-serve upgrade Reply with quote

Hello guys, after upgrading xorg-xserver to 1.13 I am unable to use the numeric keys - the numeric keys below the F-ONE keys - on my laptop.

in th xorg.con file, the input device is:

Code:
Section "InputDevice"
        Identifier "Keyboard0"
        Driver     "kbd"
        Option     "Protocol" "Standard"
        Option     "XkbRules" "xorg"
        Option     "XkbLayout" "us"
        Option     "XkbModel" "latitude"
EndSection


any hint?
_________________
"Sulla strada per l'inferno c'e' sempre un sacco di gente,
ma è comunque una via che si percorre in solitudine."

Charles Bukowski
Back to top
View user's profile Send private message
krinn
Advocate
Advocate


Joined: 02 May 2003
Posts: 3937

PostPosted: Sun Oct 07, 2012 11:07 am    Post subject: Reply with quote

kdb driver has been deprecated for a long time, i suppose they might have move from deprecated to dead status.
http://www.gentoo.org/proj/en/desktop/x/x11/xorg-server-1.8-upgrade-guide.xml
Back to top
View user's profile Send private message
BlackBelt
Guru
Guru


Joined: 27 Nov 2004
Posts: 369
Location: Messina/Pisa

PostPosted: Sun Oct 07, 2012 11:48 am    Post subject: Reply with quote

krinn wrote:
kdb driver has been deprecated for a long time, i suppose they might have move from deprecated to dead status.
http://www.gentoo.org/proj/en/desktop/x/x11/xorg-server-1.8-upgrade-guide.xml


thank you. I noticed also that the issue is present using the shell with no X active. So I think the issue is not xorg related, am I wrong?

Can the issue hardware related? I notice that keys does not work also in windows.

I have a dell latitude e6400
_________________
"Sulla strada per l'inferno c'e' sempre un sacco di gente,
ma è comunque una via che si percorre in solitudine."

Charles Bukowski
Back to top
View user's profile Send private message
krinn
Advocate
Advocate


Joined: 02 May 2003
Posts: 3937

PostPosted: Sun Oct 07, 2012 12:41 pm    Post subject: Reply with quote

BlackBelt wrote:

Can the issue hardware related? I notice that keys does not work also in windows.
I have a dell latitude e6400


That's bad news.

The best way to abstract everything is going into your bios and try keys there, nearly all bios use F1.. keys as shortcut to save/load/reboot...
Back to top
View user's profile Send private message
BlackBelt
Guru
Guru


Joined: 27 Nov 2004
Posts: 369
Location: Messina/Pisa

PostPosted: Sun Oct 07, 2012 12:46 pm    Post subject: Reply with quote

krinn wrote:
BlackBelt wrote:

Can the issue hardware related? I notice that keys does not work also in windows.
I have a dell latitude e6400


That's bad news.

The best way to abstract everything is going into your bios and try keys there, nearly all bios use F1.. keys as shortcut to save/load/reboot...


I think I need to change the keyobard.
thank you
_________________
"Sulla strada per l'inferno c'e' sempre un sacco di gente,
ma è comunque una via che si percorre in solitudine."

Charles Bukowski
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum