Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Failed to emerge x11-libs/fox-1.6.45
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
Rolmo
n00b
n00b


Joined: 17 Mar 2012
Posts: 32
Location: Poland

PostPosted: Mon Oct 01, 2012 6:43 pm    Post subject: [SOLVED] Failed to emerge x11-libs/fox-1.6.45 Reply with quote

I made sync and wanted to upgrade world.

Code:
[...]lXi -ldl -lpthread -lrt -ljpeg -lpng -ltiff -lz -lbz2 -lGLU -lGL -L/usr/lib/gcc/x86_64-pc-linux-gnu/4.5.3 -L/usr/lib/gcc/x86_64-pc-linux-gnu/4.5.3/../../../../lib64 -L/lib/../lib64 -L/usr/lib/../lib64 -L/usr/lib/gcc/x86_64-pc-linux-gnu/4.5.3/../../../../x86_64-pc-linux-gnu/lib -L/usr/lib/gcc/x86_64-pc-linux-gnu/4.5.3/../../.. -lstdc++ -lm -lc -lgcc_s /usr/lib/gcc/x86_64-pc-linux-gnu/4.5.3/crtendS.o /usr/lib/gcc/x86_64-pc-linux-gnu/4.5.3/../../../../lib64/crtn.o  -O2 -O2 -Wl,-O1   -Wl,-soname -Wl,libFOX-1.6.so.0 -o .libs/libFOX-1.6.so.0.0.45
/usr/lib/gcc/x86_64-pc-linux-gnu/4.5.3/../../../../x86_64-pc-linux-gnu/bin/ld: cannot find -lGLU
collect2: ld returned 1 exit status
make[1]: *** [libFOX-1.6.la] Error 1
make[1]: Leaving directory `/var/tmp/portage/x11-libs/fox-1.6.45/work/fox-1.6.45/src'
make: *** [all-recursive] Error 1
 * ERROR: x11-libs/fox-1.6.45 failed (compile phase):
 *   emake failed
 *
 * If you need support, post the output of `emerge --info '=x11-libs/fox-1.6.45'`,
 * the complete build log and the output of `emerge -pqv '=x11-libs/fox-1.6.45'`.
 * The complete build log is located at '/var/tmp/portage/x11-libs/fox-1.6.45/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/x11-libs/fox-1.6.45/temp/environment'.
 * Working directory: '/var/tmp/portage/x11-libs/fox-1.6.45/work/fox-1.6.45'
 * S: '/var/tmp/portage/x11-libs/fox-1.6.45/work/fox-1.6.45'


Code:
Portage 2.1.11.23 (default/linux/amd64/10.0/desktop, gcc-4.5.3, glibc-2.15-r3, 3.3.8-gentoo x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-3.3.8-gentoo-x86_64-Intel-R-_Pentium-R-_Dual_CPU_T3200_@_2.00GHz-with-gentoo-2.2
Timestamp of tree: Mon, 01 Oct 2012 15:15:01 +0000
distcc 3.1 x86_64-pc-linux-gnu [disabled]
app-shells/bash:          4.2_p37
dev-java/java-config:     2.1.12
dev-lang/python:          2.7.3-r2, 3.2.3-r1
dev-util/cmake:           2.8.7-r5
dev-util/pkgconfig:       0.27.1
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.9.8.4
sys-apps/sandbox:         2.6
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.11.1, 1.12.4
sys-devel/binutils:       2.22.90
sys-devel/gcc:            4.5.3-r2, 4.6.3
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r3
sys-kernel/linux-headers: 3.6 (virtual/os-headers)
sys-libs/glibc:           2.15-r3
Repositories: gentoo
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://gentoo.prz.rzeszow.pl http://gentoo.po.opole.pl"
LANG="pl_PL.UTF-8"
LC_ALL="pl_PL.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="pl"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync.pl.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa amd64 berkdb bluetooth branding bzip2 cairo cdda cdr cli consolekit cracklib crypt cups cxx dbus dri dts dvd dvdr emboss encode exif fam firefox flac fortran gadu gdbm gif gpm gtk iconv ipv6 jpeg lcms ldap libnotify mad mmx mng modules mp3 mp4 mpeg mudflap multilib ncurses nls nptl nsplugin ogg opengl openmp pam pango pcre pdf png policykit ppds pppd qt3support qt4 readline sdl session spell sse sse2 ssl startup-notification svg tcpd tiff truetype udev udisks unicode upower usb userlocales vorbis wxwidgets x264 xcb xml xmpp xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="pl" PHP_TARGETS="php5-3" PYTHON_TARGETS="python3_2 python2_7" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="nouveau" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON

=================================================================
                        Package Settings
=================================================================
USE="bzip2 jpeg (multilib) opengl png tiff truetype zlib -debug -doc -profile"

x11-libs/fox-1.6.40 was built with the following:
CFLAGS="-march=core2 -mtune=generic -O2 -pipe"
CXXFLAGS="-march=core2 -mtune=generic -O2 -pipe"


Last edited by Rolmo on Wed Oct 10, 2012 9:46 am; edited 1 time in total
Back to top
View user's profile Send private message
Rolmo
n00b
n00b


Joined: 17 Mar 2012
Posts: 32
Location: Poland

PostPosted: Thu Oct 04, 2012 7:05 pm    Post subject: Reply with quote

bump
Back to top
View user's profile Send private message
krinn
Advocate
Advocate


Joined: 02 May 2003
Posts: 3925

PostPosted: Thu Oct 04, 2012 9:30 pm    Post subject: Reply with quote

try re-emerge mesa or check
Code:
readlink /usr/lib64/libGLU.so
Back to top
View user's profile Send private message
Rolmo
n00b
n00b


Joined: 17 Mar 2012
Posts: 32
Location: Poland

PostPosted: Sat Oct 06, 2012 1:52 pm    Post subject: Reply with quote

Code:
readlink /usr/lib64/libGLU.so
/usr/lib64/libGLU.so.1
Back to top
View user's profile Send private message
krinn
Advocate
Advocate


Joined: 02 May 2003
Posts: 3925

PostPosted: Sat Oct 06, 2012 7:12 pm    Post subject: Reply with quote

Code:
ldconfig -p | grep libGLU


or post the config.log of the failing build try.
Back to top
View user's profile Send private message
Rolmo
n00b
n00b


Joined: 17 Mar 2012
Posts: 32
Location: Poland

PostPosted: Sun Oct 07, 2012 7:30 am    Post subject: Reply with quote

Code:
libGLU.so.1 (libc6) => /usr/lib32/libGLU.so.1
libGLU.so (libc6) => /usr/lib32/libGLU.so
Back to top
View user's profile Send private message
krinn
Advocate
Advocate


Joined: 02 May 2003
Posts: 3925

PostPosted: Sun Oct 07, 2012 10:02 am    Post subject: Reply with quote

i'm sorry i'm not familiar with amd64 setup, but your ldconfig is only showing the 32bits version of the library, so any program looking for the 64bits might report it as missing. I don't know the version you are building, but i think the 32bits one should have shown the -m32 cflags, so must be 64bits.

You can check if /usr/lib is symlink to /usr/lib64 and not /usr/lib32 (well, better wait input from an amd64 user to confirm this !)

Or try adding /usr/lib64 to your ldconfig
create a file in /etc/ld.so.conf.d and put /usr/lib64 in it then do ldconfig to rebuild caching and redo your emerge or ldconfig -p | grep libGLU to see if the 64bits version is found now.
Back to top
View user's profile Send private message
marmoras
n00b
n00b


Joined: 12 May 2012
Posts: 14

PostPosted: Tue Oct 09, 2012 1:55 pm    Post subject: Reply with quote

I don't know if it helps. I am on an amd64 'pure' (no-multilib) and switched from an nvidia gpu to the onboard intel HD of a 2600k. Unmerged the drivers, reemerged mesa with the intel flag, switched the opengl, but on the update of xfe it hit with the fox package. Going back to fox, it failed to emerge with the same error about the libGLU.
The problem was solved by explicitly emerging media-libs/glu, then fox (and then xfe). So, it might help if you reemerged the glu package. Somehow in my case it didn't show up in any of the emerge -uD attempts and although the revdep-rebuild showed a breakage with fox it didn't glu, so it failed correcting the breakage.
Back to top
View user's profile Send private message
marmoras
n00b
n00b


Joined: 12 May 2012
Posts: 14

PostPosted: Tue Oct 09, 2012 1:56 pm    Post subject: Reply with quote

I don't know if it helps. I am on an amd64 'pure' (no-multilib) and switched from an nvidia gpu to the onboard intel HD of a 2600k. Unmerged the drivers, reemerged mesa with the intel flag, switched the opengl, but on the update of xfe it hit with the fox package. Going back to fox, it failed to emerge with the same error about the libGLU.
The problem was solved by explicitly emerging media-libs/glu, then fox (and then xfe). So, it might help if you reemerged the glu package. Somehow in my case it didn't show up in any of the emerge -uD attempts and although the revdep-rebuild showed a breakage with fox it didn't glu, so it failed correcting the breakage.
Back to top
View user's profile Send private message
pcfreak85
n00b
n00b


Joined: 11 Feb 2005
Posts: 43

PostPosted: Wed Oct 10, 2012 9:04 am    Post subject: Reply with quote

at first, thanks for the hints!

same issue with all packages using the "opengl" use flag.

re-emerging mesa does not work for me, but the readlink check returned that the link is missing. I've created the link manually and I'm now able to merge all packages without any error.


steps:

1. readlink /usr/lib64/libGLU.so

-> returned nothing but should be a link to libGLU.so.1 which should be a link to libGLU.so.1.3.1

2. ln -s /usr/lib64/libGLU.so.1 /usr/lib64/libGLU.so

3. merging packages works well!

I'm not sure if this is a gentoo related bug or just a signle issue on my system...


Best,
Andreas
_________________
Gentoo is 1337!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum