Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
What's up with "No address associated with hostname"?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
Punchcutter
Apprentice
Apprentice


Joined: 11 Feb 2007
Posts: 233

PostPosted: Mon Sep 10, 2012 9:58 pm    Post subject: What's up with "No address associated with hostname&quo Reply with quote

I've persistently had a problem with portage (by some understanding of what this refers to) not being able to find resources on the web. Until now, this has been restricted to layman, but today I tried to upgrade firefox and thunderbird via portage from the standard tree, and I'm getting something very similar. The core of the problem seems to be reflected in the error "No address associated with hostname".

Code:
Installed /var/tmp/portage/mail-client/thunderbird-15.0/work/comm-release/mozilla/testing/mozbase/mozprofile
Processing dependencies for mozprofile==0.1
Searching for pysqlite
Reading http://pypi.python.org/simple/pysqlite/
Download error: [Errno -5] No address associated with hostname -- Some packages may not be found!
Couldn't find index page for 'pysqlite' (maybe misspelled?)
Scanning index of all packages (this may take a while)
Reading http://pypi.python.org/simple/
Download error: [Errno -5] No address associated with hostname -- Some packages may not be found!
No local packages or download links found for pysqlite
Best match: None
Traceback (most recent call last):
  File "setup.py", line 51, in <module>
    """,
  File "/usr/lib/python2.6/distutils/core.py", line 152, in setup
    dist.run_commands()

The funny thing about these cases is that I can always either ping the "problem" URL/domain, or often even pull it up in my browser, while portage/layman is telling me that the domain has no IP address (at least I think that's what this means). So that indicates to me that this is not a DNS problem or anything related to my provider, although this tends to happen at home. If I take my laptop to my workplace, things tend to work.

I found a hint somewhere once that I should add nameserver 8.8.8.8 (google, right?) to my /etc/resolv.conf, and once or twice that has solved the problem, but today it didn't, for instance. Today the problem is happening on my wife's desktop machine, which much harder to transport to my workplace :(

Can anyone give me the final answer to what this is about and how to fix it once and for all? Thanks.
Back to top
View user's profile Send private message
Hu
Watchman
Watchman


Joined: 06 Mar 2007
Posts: 9120

PostPosted: Tue Sep 11, 2012 2:09 am    Post subject: Reply with quote

When this fails, what is the output of cat -n /etc/resolv.conf ; emerge --info net-misc/wget net-misc/curl ; dig -t a failed-host ; dig -t aaaa failed-host?
Back to top
View user's profile Send private message
Punchcutter
Apprentice
Apprentice


Joined: 11 Feb 2007
Posts: 233

PostPosted: Tue Sep 11, 2012 7:43 am    Post subject: Reply with quote

Thanks for helping, Hu. Here's what I've got:

Code:
# cat -n /etc/resolv.conf ; emerge --info net-misc/wget net-misc/curl ; dig -t a pypi.python.org ; dig -t aaaa pypi.python.org
     1  # Generated by dhcpcd from eth0
     2  # /etc/resolv.conf.head can replace this line
     3  domain hawaiiantel.net
     4  nameserver 192.168.200.1
     5  nameserver 8.8.8.8
     6  # /etc/resolv.conf.tail can replace this line
Portage 2.1.11.9 (default/linux/x86/10.0, gcc-4.5.3, unavailable, 3.2.12-gentoo i686)
=================================================================
                        System Settings
=================================================================
System uname: Linux-3.2.12-gentoo-i686-Intel-R-_Pentium-R-_4_CPU_3.20GHz-with-gentoo-2.0.3
Timestamp of tree: Mon, 10 Sep 2012 19:45:01 +0000
app-shells/bash:          4.1_p9
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.6.6-r2, 3.1.3-r1
dev-util/cmake:           2.8.6-r4
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.0.3
sys-apps/openrc:          0.9.8.4
sys-apps/sandbox:         2.4
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.9.6-r3, 1.11.1
sys-devel/binutils:       2.20.1-r1
sys-devel/gcc:            4.4.5, 4.5.3-r2
sys-devel/gcc-config:     1.5-r2
sys-devel/libtool:        2.2.10
sys-devel/make:           3.81-r2
sys-kernel/linux-headers: 2.6.36.1 (virtual/os-headers)
sys-libs/glibc:           2.15-r2
Repositories: gentoo kde-sunset
ACCEPT_KEYWORDS="x86"
ACCEPT_LICENSE="*"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=i686 -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/hosts /etc/init.d /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /usr/share/X11/xkb"
CXXFLAGS="-O2 -march=i686 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -march=i686 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -march=i686 -pipe"
GENTOO_MIRRORS="ftp://gentoo.cs.utah.edu/gentoo ftp://mirror.usu.edu/gentoo"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en ja"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/kde-sunset"
SYNC="rsync://rsync.namerica.gentoo.org/gentoo-portage"
USE="X acl acpi alsa berkdb bzip2 cjk cli cracklib crypt cxx dbus dri fortran gdbm gnupg gnutls gpm iconv immqt-bc jpeg modules mudflap ncurses nls nptl nptlonly opengl openmp pam pcre pdf png pppd qt3support quicktime readline session ssl tcpd udev unicode v4l2 vim-syntax x86 xscreensaver zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en ja" PHP_TARGETS="php5-3" PYTHON_TARGETS="python3_2 python2_7" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="intel i915 i830" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON

=================================================================
                        Package Settings
=================================================================

net-misc/wget-1.12-r3 was built with the following:
USE="nls ssl -debug -idn -ipv6 -ntlm -static"


net-misc/curl-7.24.0 was built with the following:
USE="gnutls ssl -ares -idn -ipv6 -kerberos -ldap -nss -ssh -static-libs -test -threads"


; <<>> DiG 9.9.1-P2 <<>> -t a pypi.python.org
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 30893
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 4, ADDITIONAL: 4

;; QUESTION SECTION:
;pypi.python.org.               IN      A

;; ANSWER SECTION:
pypi.python.org.        68989   IN      A       140.211.10.73

;; AUTHORITY SECTION:
python.org.             75078   IN      NS      ns3.p11.dynect.net.
python.org.             75078   IN      NS      ns2.p11.dynect.net.
python.org.             75078   IN      NS      ns1.p11.dynect.net.
python.org.             75078   IN      NS      ns4.p11.dynect.net.

;; ADDITIONAL SECTION:
ns4.p11.dynect.net.     41335   IN      A       204.13.251.11
ns3.p11.dynect.net.     41335   IN      A       208.78.71.11
ns2.p11.dynect.net.     41335   IN      A       204.13.250.11
ns1.p11.dynect.net.     41335   IN      A       208.78.70.11

;; Query time: 48 msec
;; SERVER: 192.168.200.1#53(192.168.200.1)
;; WHEN: Mon Sep 10 21:42:54 2012
;; MSG SIZE  rcvd: 199


; <<>> DiG 9.9.1-P2 <<>> -t aaaa pypi.python.org
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 57767
;; flags: qr; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 4096
;; QUESTION SECTION:
;pypi.python.org.               IN      AAAA

;; Query time: 46 msec
;; SERVER: 192.168.200.1#53(192.168.200.1)
;; WHEN: Mon Sep 10 21:42:54 2012
;; MSG SIZE  rcvd: 44

Back to top
View user's profile Send private message
Punchcutter
Apprentice
Apprentice


Joined: 11 Feb 2007
Posts: 233

PostPosted: Fri Oct 05, 2012 11:53 pm    Post subject: Reply with quote

This fell off my radar for quite a while, and other problems intervened. Now I'm back to trying to upgrade Firefox and looking at it again. Same problem is occurring. Here's some additional evidence that this either related to portage or curl, but not to the server site, DNS, or anything else AFAICT. Note that wget succeeds in downloading the page data, but curl does not. Thanks in advance to anyone who can help. If there's no help, I'll try schlepping this desktop machine to my workplace and see if it makes any difference.
Code:
# wget -v http://pypi.python.org/simple/pysqlite
--2012-10-05 13:48:11--  http://pypi.python.org/simple/pysqlite
Resolving pypi.python.org... 140.211.10.73
Connecting to pypi.python.org|140.211.10.73|:80... connected.
HTTP request sent, awaiting response... 301 Moved Permanently
Location: /simple/pysqlite/ [following]
--2012-10-05 13:48:11--  http://pypi.python.org/simple/pysqlite/
Connecting to pypi.python.org|140.211.10.73|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 1469 (1.4K) [text/html]
Saving to: `pysqlite.2'

     0K .                                                     100%  616K=0.002s

2012-10-05 13:48:12 (616 KB/s) - `pysqlite.2' saved [1469/1469]
Code:

# curl -v http://pypi.python.org/simple/pysqlite
* About to connect() to pypi.python.org port 80 (#0)
*   Trying 140.211.10.73...
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0* connected
* Connected to pypi.python.org (140.211.10.73) port 80 (#0)
> GET /simple/pysqlite HTTP/1.1
> User-Agent: curl/7.26.0
> Host: pypi.python.org
> Accept: */*
>
< HTTP/1.1 301 Moved Permanently
< Server: nginx/1.1.19
< Date: Fri, 05 Oct 2012 23:45:15 GMT
< Transfer-Encoding: chunked
< Connection: keep-alive
< Location: /simple/pysqlite/
<
{ [data not shown]
  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
* Connection #0 to host pypi.python.org left intact
* Closing connection #0
Back to top
View user's profile Send private message
Hu
Watchman
Watchman


Joined: 06 Mar 2007
Posts: 9120

PostPosted: Sat Oct 06, 2012 1:11 am    Post subject: Reply with quote

The build output from the first post looks quite strange. It looks like the Thunderbird upstream build system is trying to download packages in the middle of the build. This is very wrong. Packages must not assume network access during the build. If I am correct, and the package is fixed not to do that, then your problem may become irrelevant.
Back to top
View user's profile Send private message
Punchcutter
Apprentice
Apprentice


Joined: 11 Feb 2007
Posts: 233

PostPosted: Sat Oct 06, 2012 1:54 am    Post subject: Reply with quote

That certainly looks like what's happening. Is it really a violation of the ebuild development model? Of course I have no expectation of my ability to convince anyone to change their ebuild, esp. of such big, important packages :roll: But you'd think that maintainers of such packages would be well-versed in best practices. Anyway... doesn't look like a fix is coming, so... I'll try bringing the machine to work. If that works, I might have to talk to my home internet provider and see what they think...
Back to top
View user's profile Send private message
Hu
Watchman
Watchman


Joined: 06 Mar 2007
Posts: 9120

PostPosted: Sat Oct 06, 2012 3:19 am    Post subject: Reply with quote

If I am right (which is still not proven), then it is not the Gentoo maintainer who has done something bad, but rather the Thunderbird developers. The only thing I would say that the Gentoo developer could be expected to do would be to disable the download attempt, which may or may not be easy to do. I would be interested to see if this package can be built successfully on a machine which has no Internet access.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum