Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
No CDRom under PcManFm ...
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
Mordillo98
n00b
n00b


Joined: 28 Mar 2012
Posts: 15

PostPosted: Fri Oct 05, 2012 3:46 pm    Post subject: No CDRom under PcManFm ... Reply with quote

I have Gentoo 3.3.8 with OpenBox only.

I have no problem mounting it through terminal. It just doesn't appear in PcManFm.

The folder /mnt/cdrom exists.

I will see under PcManFm a USB key if I insert one, and I can browse through it no problem.


~/.xinitrc

exec ck-launch-session dbus-launch openbox-session

fstab
------
/dev/sda1 /boot ext2 defaults,noatime 1 2
/dev/sda3 / ext3 noatime 0 1
/dev/sda2 none swap sw 0 0
/dev/cdrom /mnt/cdrom auto noauto,ro 0 1

proc /proc proc defaults 0 0
shm /dev/shm tmpfs nodev,nosuid,noexec 0 0


lspci
------
00:00.0 Host bridge: Intel Corporation Core Processor DRAM Controller (rev 18)
00:01.0 PCI bridge: Intel Corporation Core Processor PCI Express x16 Root Port (rev 18)
00:16.0 Communication controller: Intel Corporation 5 Series/3400 Series Chipset HECI Controller (rev 06)
00:1a.0 USB controller: Intel Corporation 5 Series/3400 Series Chipset USB2 Enhanced Host Controller (rev 06)
00:1b.0 Audio device: Intel Corporation 5 Series/3400 Series Chipset High Definition Audio (rev 06)
00:1c.0 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 1 (rev 06)
00:1c.1 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 2 (rev 06)
00:1c.2 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 3 (rev 06)
00:1c.3 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 4 (rev 06)
00:1c.4 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 5 (rev 06)
00:1d.0 USB controller: Intel Corporation 5 Series/3400 Series Chipset USB2 Enhanced Host Controller (rev 06)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev a6)
00:1f.0 ISA bridge: Intel Corporation Mobile 5 Series Chipset LPC Interface Controller (rev 06)
00:1f.2 SATA controller: Intel Corporation 5 Series/3400 Series Chipset 6 port SATA AHCI Controller (rev 06)
00:1f.3 SMBus: Intel Corporation 5 Series/3400 Series Chipset SMBus Controller (rev 06)
00:1f.6 Signal processing controller: Intel Corporation 5 Series/3400 Series Chipset Thermal Subsystem (rev 06)
01:00.0 VGA compatible controller: NVIDIA Corporation GT216 [GeForce GT 330M] (rev a2)
01:00.1 Audio device: NVIDIA Corporation High Definition Audio Controller (rev a1)
12:00.0 Network controller: Broadcom Corporation BCM4313 802.11b/g/n Wireless LAN Controller (rev 01)
13:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 03)
14:00.0 SD Host controller: Ricoh Co Ltd MMC/SD Host Controller (rev 01)
14:00.1 System peripheral: Ricoh Co Ltd R5U2xx (R5U230 / R5U231 / R5U241) [Memory Stick Host Controller] (rev 01)
14:00.2 System peripheral: Ricoh Co Ltd PCIe xD-Picture Card Controller (rev 01)
14:00.3 FireWire (IEEE 1394): Ricoh Co Ltd R5C832 PCIe IEEE 1394 Controller (rev 01)
ff:00.0 Host bridge: Intel Corporation Core Processor QuickPath Architecture Generic Non-core Registers (rev 05)
ff:00.1 Host bridge: Intel Corporation Core Processor QuickPath Architecture System Address Decoder (rev 05)
ff:02.0 Host bridge: Intel Corporation Core Processor QPI Link 0 (rev 05)
ff:02.1 Host bridge: Intel Corporation Core Processor QPI Physical 0 (rev 05)
ff:02.2 Host bridge: Intel Corporation Core Processor Reserved (rev 05)
ff:02.3 Host bridge: Intel Corporation Core Processor Reserved (rev 05)

rc-update show

bootmisc | boot
cupsd | default
devfs | sysinit
dmesg | sysinit
fsck | boot
hostname | boot
hwclock | boot
keymaps | boot
killprocs | shutdown
local | default
localmount | boot
modules | boot
mount-ro | shutdown
mtab | boot
net.lo | boot
netmount | default
procfs | boot
root | boot
savecache | shutdown
swap | boot
sysctl | boot
syslog-ng | default
termencoding | boot
udev | sysinit
udev-postmount | default
urandom | boot
vixie-cron | default
wicd | boot


Any help would be really appreciated. :)
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 5396

PostPosted: Fri Oct 05, 2012 4:19 pm    Post subject: Reply with quote

It depends on how you start pcmanfm, but in my case I've noticed that on going from x11-libs/libfm-0.1.17 to >=1.0 I needed to prefix that call with explicit 'dbus-launch --exit-with-session' (that parameter is likely optional).
Back to top
View user's profile Send private message
Mordillo98
n00b
n00b


Joined: 28 Mar 2012
Posts: 15

PostPosted: Fri Oct 05, 2012 6:17 pm    Post subject: Reply with quote

Tried it, same thing.

Forgot to include my /etc/group

root:x:0:root
bin:x:1:root,bin,daemon
daemon:x:2:root,bin,daemon
sys:x:3:root,bin,adm
adm:x:4:root,adm,daemon
tty:x:5:
disk:x:6:root,adm,mfilion
lp:x:7:lp
mem:x:8:
kmem:x:9:
wheel:x:10:root,mfilion
floppy:x:11:root,mfilion
news:x:13:news
uucp:x:14:uucp
console:x:17:
audio:x:18:mfilion
cdrom:x:19:mfilion
tape:x:26:root
video:x:27:root,mfilion
cdrw:x:80:
usb:x:85:mfilion
users:x:100:mfilion
portage:x:250:portage,mfilion
utmp:x:406:
nogroup:x:65533:
nobody:x:65534:
man:x:15:
sshd:x:22:
cron:x:16:
mail:x:12:
postmaster:x:249:
ssmtp:x:248:
crontab:x:247:
locate:x:246:
ldap:x:439:
messagebus:x:245:
lpadmin:x:106:
mfilion:x:1000:
transmission:x:105:
hsqldb:x:104:
Back to top
View user's profile Send private message
Mordillo98
n00b
n00b


Joined: 28 Mar 2012
Posts: 15

PostPosted: Tue Oct 09, 2012 3:01 pm    Post subject: Reply with quote

Anybody else could help me on this one? That would be greatly appreciated. :cry:
Back to top
View user's profile Send private message
Mordillo98
n00b
n00b


Joined: 28 Mar 2012
Posts: 15

PostPosted: Mon Nov 12, 2012 5:16 pm    Post subject: Reply with quote

... I am still having this issue. I even redid Gentoo and used genkernel to boot still same issue.

Anybody?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum